Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

pulseaudio-dlna

Alles rund um das Thema Multimedia unter Linux

Moderator: Moderatoren

Antworten
Benutzeravatar
McFlyers
Newbie
Newbie
Beiträge: 2
Registriert: 1. Mai 2021, 04:58

pulseaudio-dlna

Beitrag von McFlyers »

Hallo @ll,

ich verzichte mal auf einen Querverweis auf ein anderes Forum....bin dort nicht mehr...

OS: Leap 15.2 (Standardkernel)
Plasma 5

pulseaudio-dlna merckert mit mir:
[

Code: Alles auswählen

achim@enterprise:~> pulseaudio-dlna 
Traceback (most recent call last):
  File "/usr/bin/pulseaudio-dlna", line 6, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 3123, in <module>
    @_call_aside
  File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 3107, in _call_aside
    f(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 3136, in _initialize_master_working_set
    working_set = WorkingSet._build_master()
  File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 578, in _build_master
    ws.require(__requires__)
  File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 895, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 781, in resolve
    raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'dbus-python>=1.0.0' distribution was not found and is required by pulseaudio-dlna

Code: Alles auswählen

achim@enterprise:~> zypper se -si pulseaudio-dlna dbus-python
Repository-Daten werden geladen...
Installierte Pakete werden gelesen...

S  | Name                | Type  | Version                             | Arch   | Repository
---+---------------------+-------+-------------------------------------+--------+-------------------
i+ | pulseaudio-dlna     | Paket | 0.6.0+git20190209.b0db813-pm152.1.3 | noarch | Packman Repository
i+ | python3-dbus-python | Paket | 1.2.4-lp152.6.7                     | x86_64 | Haupt-Repository

Code: Alles auswählen

achim@enterprise:~> zypper lr -d
#  | Alias                                | Name                                                    | Enabled   | GPG Check       | Refresh        | Priority  | Type   | URI                                                                                                       | Serv->
---+--------------------------------------+---------------------------------------------------------+-----------+-----------------+----------------+-----------+--------+-----------------------------------------------------------------------------------------------------------+-------
 1 | NVIDIA                               | NVIDIA                                                  | Ja        | (r ) Ja         | Ja             |   90      | rpm-md | https://download.nvidia.com/opensuse/leap/15.2                                                            | 
 2 | Packman Repository                   | Packman Repository                                      | Ja        | (r ) Ja         | Ja             |   20      | rpm-md | http://ftp.gwdg.de/pub/linux/packman/suse/openSUSE_Leap_15.2/                                             | 
 3 | https-download.opensuse.org-c28a7c29 | games                                                   | Ja        | (r ) Ja         | Ja             |  110      | rpm-md | https://download.opensuse.org/repositories/games/openSUSE_Leap_15.2/                                      | 
 4 | openSUSE_Leap_15.2                   | Mozilla                                                 | Ja        | (r ) Ja         | Ja             |   80      | rpm-md | http://download.opensuse.org/repositories/mozilla/openSUSE_Leap_15.2/                                     | 
 5 | openSUSE_Leap_15.2_1                 | Sauerland                                               | Ja        | (r ) Ja         | Ja             |  120      | rpm-md | https://download.opensuse.org/repositories/home:/Sauerland:/branches:/home:/Sauerland/openSUSE_Leap_15.2/ | 
 6 | opensuse-guide.org-repo              | Libdvdcss Repository                                    | Ja        | (r ) Ja         | Ja             |   99      | rpm-md | http://opensuse-guide.org/repo/openSUSE_Leap_15.2/                                                        | 
 7 | repo-non-oss                         | Non-OSS Repository                                      | Ja        | (r ) Ja         | Ja             |   99      | rpm-md | http://download.opensuse.org/distribution/leap/15.2/repo/non-oss/                                         | 
 8 | repo-oss                             | Haupt-Repository                                        | Ja        | (r ) Ja         | Ja             |   99      | rpm-md | http://download.opensuse.org/distribution/leap/15.2/repo/oss/                                             | 
 9 | repo-update                          | Hauptaktualisierungs-Repository                         | Ja        | (r ) Ja         | Ja             |   90      | rpm-md | http://download.opensuse.org/update/leap/15.2/oss                                                         | 
10 | repo-update-non-oss                  | Aktualisierungs-Repository (Nicht-Open-Source-Software) | Ja        | (r ) Ja         | Ja             |   90      | rpm-md | http://download.opensuse.org/update/leap/15.2/non-oss/     
Hat wer eine Idee?

Danke im vorraus
Benutzeravatar
tomm.fa
Moderator
Moderator
Beiträge: 5552
Registriert: 21. Jan 2006, 17:18
Wohnort: OWL - Kreis Gütersloh
Kontaktdaten:

Re: pulseaudio-dlna

Beitrag von tomm.fa »

Nur mal gerade was auf die Schnelle ausprobiert.
PackMan-Repo deaktiviert:

Code: Alles auswählen

zypper mr -d http://ftp.halifax.rwth-aachen.de/packman/suse/openSUSE_Leap_15.2/
(Die URL ist entsprechend anzupassen, oder man nimmt den Alias.)

Installation von pulseaudio-dlna und der passenden Version von python3-PyChromecast:

Code: Alles auswählen

zypper -p https://download.opensuse.org/repositories/home:Simmphonie/openSUSE_Leap_15.2/ -p https://download.opensuse.org/repositories/devel:languages:python/openSUSE_Leap_15.2/ in pulseaudio-dlna                    
Retrieving repository 'https://download.opensuse.org/repositories/home:Simmphonie/openSUSE_Leap_15.2/' metadata -----------------------------------------------------------------------------------------------------------------------------------------[\]

New repository or package signing key received:

  Repository:       https://download.opensuse.org/repositories/home:Simmphonie/openSUSE_Leap_15.2/
  Key Name:         home:Simmphonie OBS Project <home:Simmphonie@build.opensuse.org>
  Key Fingerprint:  EE89E97E E2713D3B 0734A3B9 6810CF9E 04F01D79
  Key Created:      Wed Jan  1 04:51:50 2020
  Key Expires:      Fri Mar 11 04:51:50 2022
  Rpm Name:         gpg-pubkey-04f01d79-5e0c1756


Do you want to reject the key, trust temporarily, or trust always? [r/t/a/?] (r): t
Retrieving repository 'https://download.opensuse.org/repositories/home:Simmphonie/openSUSE_Leap_15.2/' metadata ......................................................................................................................................[done]
Building repository 'https://download.opensuse.org/repositories/home:Simmphonie/openSUSE_Leap_15.2/' cache ...........................................................................................................................................[done]
Retrieving repository 'https://download.opensuse.org/repositories/devel:languages:python/openSUSE_Leap_15.2/' metadata ----------------------------------------------------------------------------------------------------------------------------------[/]

New repository or package signing key received:

  Repository:       https://download.opensuse.org/repositories/devel:languages:python/openSUSE_Leap_15.2/
  Key Name:         devel:languages:python OBS Project <devel:languages:python@build.opensuse.org>
  Key Fingerprint:  172CCD6B 0CF49B73 88F1C611 27163A4E EDF0D733
  Key Created:      Wed Apr 10 19:54:44 2019
  Key Expires:      Fri Jun 18 19:54:44 2021 (expires in 47 days)
  Rpm Name:         gpg-pubkey-edf0d733-5cae2de4


Do you want to reject the key, trust temporarily, or trust always? [r/t/a/?] (r): t
Retrieving repository 'https://download.opensuse.org/repositories/devel:languages:python/openSUSE_Leap_15.2/' metadata ...............................................................................................................................[done]
Building repository 'https://download.opensuse.org/repositories/devel:languages:python/openSUSE_Leap_15.2/' cache ....................................................................................................................................[done]
Loading repository data...
Reading installed packages...
Resolving package dependencies...

The following 14 NEW packages are going to be installed:
  opus-tools pulseaudio-dlna python3-PyChromecast python3-casttube python3-cssselect python3-docopt python3-ifaddr python3-lxml python3-notify2 python3-protobuf python3-pycairo python3-pyroute2 python3-setproctitle python3-zeroconf

14 new packages to install.
Overall download size: 3.6 MiB. Already cached: 0 B. After the operation, additional 17.3 MiB will be used.
Continue? [y/n/v/...? shows all options] (y): 
Retrieving package opus-tools-0.1.10-lp152.3.6.x86_64                                                                                                                                                                 (1/14),  77.7 KiB (193.6 KiB unpacked)
Retrieving: opus-tools-0.1.10-lp152.3.6.x86_64.rpm ...................................................................................................................................................................................................[done]
[…]
PackMan-Repo wieder aktiviert:

Code: Alles auswählen

zypper mr -e http://ftp.halifax.rwth-aachen.de/packman/suse/openSUSE_Leap_15.2/

Mein AV-Receiver (Onkyo TX-NR575E) wird erkannt und ich kann vom Desktop-PC den Ton dort übertragen lassen (DLNA oder Chromecast). Funktionieren tut puleaudio-dlna also prinzipiell noch.
Müsste dann mal jemand bei PackMan Bescheid geben, dass deren Paket angepasst wird, ich benötige es nicht.
Linupedia - Wiki des Linux-Club.
Rechner 1: openSUSE Leap 15.3 mit KDE/Plasma, Kernel 5.14.*
Rechner 2: openSUSE Leap 15.3 mit Fluxbox 1.3.7 und Kernel 5.13.*
Rechner 3: openSUSE Leap 15.3, GNOME 3.34 mit Wayland
Rechner 4: PineTab mit Arch Linux
Benutzeravatar
McFlyers
Newbie
Newbie
Beiträge: 2
Registriert: 1. Mai 2021, 04:58

Re: pulseaudio-dlna

Beitrag von McFlyers »

Nach langer Zeit mal eine Rückmeldung.

Problem besteht unter Leap 15.3 (bzw. Packman-Repo) auch (bzw. immer noch), aber der liebe Sauerland hat mir ein Packetchen mit einem Workaround gebastelt.
An dieser Stelle noch ein Dankeschön an Sauerland.
Antworten