Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[Gelöst] Upgrade von openSUSE Leap 15.1 auf 15.2

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Benutzeravatar
egweber1
Newbie
Newbie
Beiträge: 22
Registriert: 17. Feb 2020, 16:34
Wohnort: Schwarzenbach am Wald, Bayern
Kontaktdaten:

[Gelöst] Upgrade von openSUSE Leap 15.1 auf 15.2

Beitrag von egweber1 » 27. Jun 2020, 16:26

Hallo,
nächste Woche soll ja Leap 15.2 erscheinen.
Wie bekomme ich ein Update mit Yast am einfachsten hin?
Mögliche Lösung:
Alle Repositories bis auf openSUSE-Leap-15.1-OSS und penSUSE-Leap-15.1-Update auf nicht Aktiv schalten.
Diese beiden dann auf 15.2 setzen und ein Softwareupdate durchführen.
Danach alle anderen auf 15.2 setzen, wieder aktivieren und erneut updaten.
Ist dieses Vorgehen durchführbar oder andere Vorschläge?
Danke vorab. ;)
Zuletzt geändert von egweber1 am 5. Jul 2020, 11:00, insgesamt 5-mal geändert.
Rechner: AMD Ryzen 7 2700X mit 16 GB RAM Grafik: AMD RX570 8GB
Festplatten: 2 x SSD NVME 256GB, eine für Windows 10 und eine OpenSuse 15.2
Sowie 3x HDD je 1 TB

Werbung:
mojo
Member
Member
Beiträge: 182
Registriert: 7. Jul 2007, 11:04

Re: Upgrade von openSUSE Leap 15.1 auf 15.2

Beitrag von mojo » 27. Jun 2020, 17:27

Ein anderer Vorschlag wäre:
  • Leap 15.2 .iso runterladen.
  • Iso mittels Suse Imagewriter (ggfs. über Yast nachinstallieren) auf einen USB Stick schreiben (Imagewriter macht den automatisch bootfähig)
  • Von diesem USB-Stick booten
  • Anstatt Installation Update der vorhandenen Installation auswählen.

mojo

Benutzeravatar
tomm.fa
Moderator
Moderator
Beiträge: 5386
Registriert: 21. Jan 2006, 17:18
Wohnort: OWL - Kreis Gütersloh
Kontaktdaten:

Re: Upgrade von openSUSE Leap 15.1 auf 15.2

Beitrag von tomm.fa » 27. Jun 2020, 18:28

Ich würde es abhängig von den verwendeten Drittrepositorien und eventuell von den installierten Pakete machen. Bei deinem Weg, egweber1, würde ich einfach bei allen Repositorien die Eins von 15.1 zu einer Zwei ändern und dann ein zypper -vv dup --allow-vendor-change ausführen; dieses jedoch, nur wenn die vier Standardrepositorien und das von PackMan vorhanden sind, eventuell noch das von Mozilla.
Den Weg von mojo würde ich nur wählen, wenn der PC nicht am Internet hängt und die vier Standardrepositorien vorhanden sind.
Ich selbst führe, wegen meiner (vielen) Drittrepositorien, meistens eine Neuinstallation aus, ist danach dann auch wieder alles schön aufgeräumt.
Linupedia - Wiki des Linux-Club.
Keine Unterstützung/Hilfestellung per PN!

HarryMalaria
Member
Member
Beiträge: 215
Registriert: 17. Nov 2005, 18:24

Re: Upgrade von openSUSE Leap 15.1 auf 15.2

Beitrag von HarryMalaria » 30. Jun 2020, 21:41

ich will auch auf 15.2 updaten, hab keine großartigen fremdpackete drauf, außer mozilla und den nividiatreiber, den man ja nachinstallieren kann. ich hab allerdings qemu und was dazugehört drauf, werden die auch automatisch upgedatet oder muß man die dann wieder gesondert updaten. den nvidiatreiber werde ich dann erst nachträglich installieren, hatte da mal probleme.

Benutzeravatar
tomm.fa
Moderator
Moderator
Beiträge: 5386
Registriert: 21. Jan 2006, 17:18
Wohnort: OWL - Kreis Gütersloh
Kontaktdaten:

Re: Upgrade von openSUSE Leap 15.1 auf 15.2

Beitrag von tomm.fa » 30. Jun 2020, 22:15

Nvidia-Treiber deinstallieren und danach dieses Repositorium deaktivieren - Rechner neu starten. Alle Repositorien auf Leap 15.2 umstellen und ein

Code: Alles auswählen

zypper -vv dup --allow-vendor-change
ausführen, auch die Qemu-Pakete sollten aktualisiert werden.
Rechner neu starten, Nvidia-Repositorium wieder aktivieren und die zu deiner Karte passenden Pakete/Treiber installieren; Rechner neu starten und (hoffentlich) glücklich sein.

Ich gehe bei der Anleitung von deinen wenig informativen Angaben aus und demnach dürftest du nur sechs Repositorien (OSS, Non-OSS, Update-OSS, Update-Non-OSS, Mozilla und Nvidia) eingebunden haben.
Ob deine unbekannte Grafikkarte was mit den vorhandenen Treibern im Nvidia-Repositorium (https://download.nvidia.com/opensuse/leap/15.2/x86_64/) anfangen kann, kann ich auch nicht beurteilen, daher ist meine Anleitung/mein Beitrag ohne Gewähr.
Linupedia - Wiki des Linux-Club.
Keine Unterstützung/Hilfestellung per PN!

HarryMalaria
Member
Member
Beiträge: 215
Registriert: 17. Nov 2005, 18:24

Re: Upgrade von openSUSE Leap 15.1 auf 15.2

Beitrag von HarryMalaria » 2. Jul 2020, 11:35

Nicht ganz, hab auch noch packman, wegen den Videolibs. Die Grafikkarte ist eine 1030 nvidia, dafür wird momentan in 15.1 der Nvidiatreiber G04 benutzt, der nouveau ist leider kaum benutzbar. Aber Packman und Mozilla kann man ja nachträglich problemlos umstellen. Der Grafiktreiber ist immer das Hauptproblem.

Benutzeravatar
tomm.fa
Moderator
Moderator
Beiträge: 5386
Registriert: 21. Jan 2006, 17:18
Wohnort: OWL - Kreis Gütersloh
Kontaktdaten:

Re: Upgrade von openSUSE Leap 15.1 auf 15.2

Beitrag von tomm.fa » 2. Jul 2020, 11:56

PackMan ist ebenfalls für ein allgemeines zypper dist-upgrade (dup) geeignet und kann wie Mozilla zusammen mit den Standardrepositorien umgestellt und deren Pakete gemeinsam hochgestuft/umgestellt werden.
HarryMalaria hat geschrieben:
2. Jul 2020, 11:35
Die Grafikkarte ist eine 1030 nvidia, dafür wird momentan in 15.1 der Nvidiatreiber G04 benutzt, …
Da hier schon wieder vernünftige Angaben fehlen und man sich was aus den bereitgestellten selbst was zusammenfrickeln muss, gibt es noch einen Hinweis und dann bin ich aus dem Thema raus, zumindest was Beiträge von egweber1 und HarryMalaria betrifft.
Da deine Grafikkarte wahrscheinlich den 440.100er-Treiber verwendet, sollten es unter openSUSE Leap 15.2 die G05er-Pakete aus dem Nvidia-Repositorium sein.
Linupedia - Wiki des Linux-Club.
Keine Unterstützung/Hilfestellung per PN!

HarryMalaria
Member
Member
Beiträge: 215
Registriert: 17. Nov 2005, 18:24

Re: Upgrade von openSUSE Leap 15.1 auf 15.2

Beitrag von HarryMalaria » 2. Jul 2020, 16:02

Nein! Die Karte verwendet in 15.1 den Treiber: 390.138.lp.151.7.1 das letzte Update war vor ein paar Tagen.

HarryMalaria
Member
Member
Beiträge: 215
Registriert: 17. Nov 2005, 18:24

Re: Upgrade von openSUSE Leap 15.1 auf 15.2

Beitrag von HarryMalaria » 2. Jul 2020, 17:38

So, hab das Upgrade grade durchgeführt hat alles wunderbar gepasst. Danke nochmal für den Tipp mit repos packman und mozilla. Nach dem Upgrade konnte ich sofort weitermachen, wie davor, keinerlei Probleme. Ich hab nur noch den nvidiatreiber nachinstalliert bei einer 1030 hab ich den G04 Treiber verwandt, wie bei 151 läuft auch, alles wunderbar.

Benutzeravatar
egweber1
Newbie
Newbie
Beiträge: 22
Registriert: 17. Feb 2020, 16:34
Wohnort: Schwarzenbach am Wald, Bayern
Kontaktdaten:

Re: Upgrade von openSUSE Leap 15.1 auf 15.2

Beitrag von egweber1 » 2. Jul 2020, 22:39

Habe jetzt doch Neuinstallation gemacht. Läuft! Home und andere Platten in ihrem Zustand gelassen und Benutzer übernommen. Nur noch eins: Wie kann ich mp4 Dateien in Firefox mit vlc abspielen?
Habe vlc.ymp für 15.2 probiert, aber:
Ein Fehler trat auf, während der Initialisierung des Software-Repositorys.
Details:
http-download.videolan.org-7b6cf506: [http-download.videolan.org-7b6cf506|http://download.videolan.org/openSUSE.o ... /standard/] Keine gültigen Metadaten bei dem festgelegten URL gefunden
Verlauf:
- [http-download.videolan.org-7b6cf506|http://download.videolan.org/openSUSE.o ... /standard/] Repository type can't be determined.
Wie kann ich die Dateien abspielen? Bei Version 15.1 ging es wunderbar.
Rechner: AMD Ryzen 7 2700X mit 16 GB RAM Grafik: AMD RX570 8GB
Festplatten: 2 x SSD NVME 256GB, eine für Windows 10 und eine OpenSuse 15.2
Sowie 3x HDD je 1 TB

Benutzeravatar
susejunky
Hacker
Hacker
Beiträge: 690
Registriert: 19. Sep 2014, 18:22

Re: Upgrade von openSUSE Leap 15.1 auf 15.2

Beitrag von susejunky » 3. Jul 2020, 12:28

Hallo egweber1,
egweber1 hat geschrieben:
2. Jul 2020, 22:39
... Wie kann ich mp4 Dateien in Firefox mit vlc abspielen?
Eine .mp4-Datei ist ein Container (https://de.wikipedia.org/wiki/Containerdatei) und was man benötigt, um den Inhalt eines Containers wiederzugeben hängt vom Inhalt (codec, https://de.wikipedia.org/wiki/Codec) ab.

VLC kann sehr viele Codecs wiedergeben, sodass VLC wahrscheinlich die richtige Wahl für Deine .mp4-Datei ist.
egweber1 hat geschrieben:
2. Jul 2020, 22:39
...
Ein Fehler trat auf, während der Initialisierung des Software-Repositorys.
Details:
http-download.videolan.org-7b6cf506: [http-download.videolan.org-7b6cf506|http://download.videolan.org/openSUSE.o ... /standard/] Keine gültigen Metadaten bei dem festgelegten URL gefunden
Verlauf:
- [http-download.videolan.org-7b6cf506|http://download.videolan.org/openSUSE.o ... /standard/] Repository type can't be determined.
Ich schließe mich da tomm.fa an und empfehle Dir alle Multimedia Anwendungen und Codecs aus dem Packman-Repository zu beziehen.

Wenn Du libdvdcss benötigst, kann Du https://download.videolan.org/pub/video ... x86_64.rpm als einzelnes Paket herunterladen und mit zypper installieren.

Viele Grüße

susejunky

Benutzeravatar
egweber1
Newbie
Newbie
Beiträge: 22
Registriert: 17. Feb 2020, 16:34
Wohnort: Schwarzenbach am Wald, Bayern
Kontaktdaten:

Re: Upgrade von openSUSE Leap 15.1 auf 15.2

Beitrag von egweber1 » 4. Jul 2020, 12:48

Habe probiert:
localhost:~ # zypper install libdvdcss2-1.4.2-1.3.x86_64.rpm
Specified local path does not exist or is not accessible.
Problem retrieving the specified RPM file:
Malformed URI:
Please check whether the file is accessible.
Problem with the RPM file specified as 'libdvdcss2-1.4.2-1.3.x86_64.rpm', skipping.
No valid arguments specified.
Es kann nur eine mp4 Datei abgespielt werden, danach öffnet vlc nicht mehr. Muss mich dann abmelden und neu anmelden.
Oder ich gebe vlc in der Konsole ein:
VLC media player 3.0.10 Vetinari (revision 3.0.10-0-g7f145afa84)
[00005600815c3bc0] main libvlc: VLC wird mit dem Standard-Interface ausgeführt. Benutzen Sie 'cvlc', um VLC ohne Interface zu verwenden.
[00005600815be350] main playlist: playlist is empty
[flv @ 0x7ff130c048a0] Packet mismatch 155713536 2376 2376
libva info: VA-API version 1.5.0
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib64/dri/radeonsi_drv_video.so
libva info: Found init function __vaDriverInit_1_5
mesa: for the --simplifycfg-sink-common option: may only occur zero or one times!
mesa: for the --global-isel-abort option: may only occur zero or one times!
libva info: va_openDriver() returns 0
[00007ff114001f60] glconv_vaapi_x11 gl error: vaDeriveImage: operation failed
[00007ff12c001ff0] main video output error: video output creation failed
[00007ff130c18140] main decoder error: failed to create video output
mesa: for the --simplifycfg-sink-common option: may only occur zero or one times!
mesa: for the --global-isel-abort option: may only occur zero or one times!
[00007ff130c18140] avcodec decoder: Using G3DVL VDPAU Driver Shared Library version 1.0 for hardware decoding
Danach kann ich zwar Dateien abspielen, aber in Firefox keine Videos. Die muss ich erst herunterladen.
Unter Anwendungen>Multimedia>vlc steht als Befehl
/usr/bin/vlc --started-from-file %U
Rechner: AMD Ryzen 7 2700X mit 16 GB RAM Grafik: AMD RX570 8GB
Festplatten: 2 x SSD NVME 256GB, eine für Windows 10 und eine OpenSuse 15.2
Sowie 3x HDD je 1 TB

Benutzeravatar
tomm.fa
Moderator
Moderator
Beiträge: 5386
Registriert: 21. Jan 2006, 17:18
Wohnort: OWL - Kreis Gütersloh
Kontaktdaten:

Re: Upgrade von openSUSE Leap 15.1 auf 15.2

Beitrag von tomm.fa » 4. Jul 2020, 13:53

Bezüglich libdvdc*:
Du solltest schon den kompletten Pfad eingeben.
Alternative (als Root/su):

Code: Alles auswählen

zypper ar -f -n "opensuse-guide.org"  http://opensuse-guide.org/repo/openSUSE_Leap_15.2/ libdvdc*

Code: Alles auswählen

zypper in libdvdc*
Die durch das * markierte Stellen müssen noch entsprechend angepasst werden.

Bezüglich VLC:
Ausgaben von

Code: Alles auswählen

zypper lr -d

Code: Alles auswählen

zypper se -si vlc gst ffmpeg
vorführen.
Linupedia - Wiki des Linux-Club.
Keine Unterstützung/Hilfestellung per PN!

Benutzeravatar
egweber1
Newbie
Newbie
Beiträge: 22
Registriert: 17. Feb 2020, 16:34
Wohnort: Schwarzenbach am Wald, Bayern
Kontaktdaten:

Re: Upgrade von openSUSE Leap 15.1 auf 15.2

Beitrag von egweber1 » 4. Jul 2020, 14:53

zypper lr -d

Code: Alles auswählen

#  | Alias                                | Name                                                    | Aktiviert | GPG-Überprüfung | Aktualisierung | Priorität | Typ    | URI                                                                                | Dienst
---+--------------------------------------+---------------------------------------------------------+-----------+-----------------+----------------+-----------+--------+------------------------------------------------------------------------------------+-------
 1 | http-download.opensuse.org-f75bc362  | openSUSE:Leap:15.2:Update                               | Ja        | (r ) Ja         | Ja             |   99      | rpm-md | http://download.opensuse.org/update/leap/15.2/oss/                                 | 
 2 | http-download.videolan.org-42213ec6  | SuSE                                                    | Ja        | (r ) Ja         | Ja             |   99      | rpm-md | http://download.videolan.org/SuSE/Leap_15.2/                                       | 
 3 | https-download.opensuse.org-48d834c9 | multimedia:apps                                         | Ja        | (r ) Ja         | Ja             |   99      | rpm-md | https://download.opensuse.org/repositories/multimedia:/apps/openSUSE_Leap_15.2/    | 
 4 | https-download.opensuse.org-558ab253 | multimedia:libs                                         | Ja        | (r ) Ja         | Ja             |   99      | rpm-md | https://download.opensuse.org/repositories/multimedia:/libs/openSUSE_Leap_15.2/    | 
 5 | openSUSE-Leap-15.2-1                 | openSUSE-Leap-15.2-1                                    | Ja        | (r ) Ja         | Ja             |   99      | rpm-md | cd:/?devices=/dev/disk/by-id/ata-DRW-24D5MT_KMGJ8TE5922                            | 
 6 | openSUSE_Leap_15.2                   | Packman-Repository                                      | Ja        | (r ) Ja         | Ja             |   89      | rpm-md | http://packman.inode.at/suse/openSUSE_Leap_15.2/                                   | 
 7 | openSUSE_Leap_15.2_1                 | Libre-Office                                            | Ja        | (r ) Ja         | Ja             |   95      | rpm-md | http://download.opensuse.org/repositories/LibreOffice:/Factory/openSUSE_Leap_15.2/ | 
 8 | openSUSE_Leap_15.2_10                | libdvdcss Repository                                    | Ja        | (r ) Ja         | Ja             |   99      | rpm-md | http://opensuse-guide.org/repo/openSUSE_Leap_15.2                                  | 
 9 | openSUSE_Leap_15.2_11                | Wine                                                    | Nein      | ----            | ----           |   99      | rpm-md | http://download.opensuse.org/repositories/Emulators:/Wine/openSUSE_Leap_15.2/      | 
10 | openSUSE_Leap_15.2_2                 | Apps Multimedia                                         | Ja        | (r ) Ja         | Ja             |   96      | rpm-md | http://download.opensuse.org/repositories/multimedia:/apps/openSUSE_Leap_15.2/     | 
11 | openSUSE_Leap_15.2_3                 | Libs Multimedia                                         | Ja        | (r ) Ja         | Ja             |   97      | rpm-md | http://download.opensuse.org/repositories/multimedia:/libs/openSUSE_Leap_15.2/     | 
12 | openSUSE_Leap_15.2_4                 | Wissenschaft                                            | Ja        | (r ) Ja         | Ja             |   98      | rpm-md | http://download.opensuse.org/repositories/science/openSUSE_Leap_15.2/              | 
13 | openSUSE_Leap_15.2_5                 | Games                                                   | Ja        | (r ) Ja         | Ja             |   99      | rpm-md | http://download.opensuse.org/repositories/games/openSUSE_Leap_15.2/                | 
14 | openSUSE_Leap_15.2_6                 | Erziehung und Bildung                                   | Ja        | (r ) Ja         | Ja             |   99      | rpm-md | http://download.opensuse.org/repositories/Education/openSUSE_Leap_15.2/            | 
15 | openSUSE_Leap_15.2_7                 | Drucken                                                 | Ja        | (r ) Ja         | Ja             |   99      | rpm-md | http://download.opensuse.org/repositories/Printing/openSUSE_Leap_15.2/             | 
16 | openSUSE_Leap_15.2_8                 | Grafik                                                  | Ja        | (r ) Ja         | Ja             |   99      | rpm-md | http://download.opensuse.org/repositories/graphics/openSUSE_Leap_15.2/             | 
17 | openSUSE_Leap_15.2_9                 | Mozilla                                                 | Ja        | (r ) Ja         | Ja             |   99      | rpm-md | http://download.opensuse.org/repositories/mozilla/openSUSE_Leap_15.2/              | 
18 | repo-debug                           | Debug Repository                                        | Ja        | (r ) Ja         | Ja             |   99      | rpm-md | http://download.opensuse.org/debug/distribution/leap/15.2/repo/oss/                | 
19 | repo-debug-non-oss                   | Debug Repository (Non-OSS)                              | Ja        | (r ) Ja         | Ja             |   99      | rpm-md | http://download.opensuse.org/debug/distribution/leap/15.2/repo/non-oss/            | 
20 | repo-debug-update                    | Aktualisierungs-Repository (Debug)                      | Ja        | (r ) Ja         | Ja             |   99      | rpm-md | http://download.opensuse.org/debug/update/leap/15.2/oss                            | 
21 | repo-debug-update-non-oss            | Update Repository (Debug, Non-OSS)                      | Ja        | (r ) Ja         | Ja             |   99      | rpm-md | http://download.opensuse.org/debug/update/leap/15.2/non-oss/                       | 
22 | repo-non-oss                         | Non-OSS Repository                                      | Ja        | (r ) Ja         | Ja             |   88      | rpm-md | http://download.opensuse.org/distribution/leap/15.2/repo/non-oss/                  | 
23 | repo-oss                             | Haupt-Repository (OSS)                                  | Ja        | (r ) Ja         | Ja             |   87      | rpm-md | http://download.opensuse.org/distribution/leap/15.2/repo/oss/                      | 
24 | repo-source                          | Source-Repository(OSS)                                  | Ja        | (r ) Ja         | Ja             |   91      | rpm-md | http://download.opensuse.org/source/distribution/leap/15.2/repo/oss/               | 
25 | repo-source-non-oss                  | Source Repository (Non-OSS)                             | Ja        | (r ) Ja         | Ja             |   92      | rpm-md | http://download.opensuse.org/source/distribution/leap/15.2/repo/non-oss/           | 
26 | repo-update                          | Hauptaktualisierungs-Repository                         | Ja        | (r ) Ja         | Ja             |   93      | rpm-md | http://download.opensuse.org/update/leap/15.2/oss                                  | 
27 | repo-update-non-oss                  | Aktualisierungs-Repository (Nicht-Open-Source-Software) | Ja        | (r ) Ja         | Ja             |   94      | rpm-md | http://download.opensuse.org/update/leap/15.2/non-oss/                             | 
28 | skype-stable                         | skype (stable)                                          | Ja        | ( p) Ja         | Ja             |   99      | rpm-md | https://repo.skype.com/rpm/stable/                                                 | 
zypper se -si vlc gst ffmpeg

Code: Alles auswählen

  | Name                              | Typ   | Version                 | Arch   | Repository
---+-----------------------------------+-------+-------------------------+--------+-----------------------
i+ | PackageKit-gstreamer-plugin       | Paket | 1.1.13-lp152.2.3        | x86_64 | Haupt-Repository (OSS)
i+ | PackageKit-gstreamer-plugin       | Paket | 1.1.13-lp152.2.3        | x86_64 | openSUSE-Leap-15.2-1
i+ | chromium-ffmpeg-extra             | Paket | 69.0.3497.100-pm152.2.6 | x86_64 | Packman-Repository
i+ | ffmpeg-3                          | Paket | 3.4.4-pm152.5.2         | x86_64 | Packman-Repository
i  | ffmpegthumbs                      | Paket | 20.04.2-lp152.1.1       | x86_64 | Haupt-Repository (OSS)
i  | ffmpegthumbs                      | Paket | 20.04.2-lp152.1.1       | x86_64 | openSUSE-Leap-15.2-1
i  | ffmpegthumbs-lang                 | Paket | 20.04.2-lp152.1.1       | noarch | Haupt-Repository (OSS)
i  | ffmpegthumbs-lang                 | Paket | 20.04.2-lp152.1.1       | noarch | openSUSE-Leap-15.2-1
i  | gstreamer                         | Paket | 1.16.2-lp152.1.7        | x86_64 | Haupt-Repository (OSS)
i  | gstreamer                         | Paket | 1.16.2-lp152.1.7        | x86_64 | openSUSE-Leap-15.2-1
i  | gstreamer-lang                    | Paket | 1.16.2-lp152.1.7        | noarch | Haupt-Repository (OSS)
i  | gstreamer-lang                    | Paket | 1.16.2-lp152.1.7        | noarch | openSUSE-Leap-15.2-1
i  | gstreamer-libnice                 | Paket | 0.1.14-lp152.3.7        | x86_64 | Haupt-Repository (OSS)
i  | gstreamer-libnice                 | Paket | 0.1.14-lp152.3.7        | x86_64 | openSUSE-Leap-15.2-1
i  | gstreamer-plugin-cluttergst3      | Paket | 3.0.26-lp152.3.7        | x86_64 | Haupt-Repository (OSS)
i  | gstreamer-plugin-cluttergst3      | Paket | 3.0.26-lp152.3.7        | x86_64 | openSUSE-Leap-15.2-1
i+ | gstreamer-plugins-bad             | Paket | 1.16.2-lp152.2.17       | x86_64 | Haupt-Repository (OSS)
i+ | gstreamer-plugins-bad             | Paket | 1.16.2-lp152.2.17       | x86_64 | openSUSE-Leap-15.2-1
i  | gstreamer-plugins-bad-lang        | Paket | 1.16.2-lp152.2.17       | noarch | Haupt-Repository (OSS)
i  | gstreamer-plugins-bad-lang        | Paket | 1.16.2-lp152.2.17       | noarch | openSUSE-Leap-15.2-1
i  | gstreamer-plugins-base            | Paket | 1.16.2-lp152.2.16       | x86_64 | Haupt-Repository (OSS)
i  | gstreamer-plugins-base            | Paket | 1.16.2-lp152.2.16       | x86_64 | openSUSE-Leap-15.2-1
i  | gstreamer-plugins-base-lang       | Paket | 1.16.2-lp152.2.16       | noarch | Haupt-Repository (OSS)
i  | gstreamer-plugins-base-lang       | Paket | 1.16.2-lp152.2.16       | noarch | openSUSE-Leap-15.2-1
i  | gstreamer-plugins-cogl            | Paket | 1.22.2-lp152.4.10       | x86_64 | Haupt-Repository (OSS)
i  | gstreamer-plugins-cogl            | Paket | 1.22.2-lp152.4.10       | x86_64 | openSUSE-Leap-15.2-1
i  | gstreamer-plugins-good            | Paket | 1.16.2-lp152.1.7        | x86_64 | Haupt-Repository (OSS)
i  | gstreamer-plugins-good            | Paket | 1.16.2-lp152.1.7        | x86_64 | openSUSE-Leap-15.2-1
i  | gstreamer-plugins-good-gtk        | Paket | 1.16.2-lp152.1.7        | x86_64 | Haupt-Repository (OSS)
i  | gstreamer-plugins-good-gtk        | Paket | 1.16.2-lp152.1.7        | x86_64 | openSUSE-Leap-15.2-1
i  | gstreamer-plugins-good-lang       | Paket | 1.16.2-lp152.1.7        | noarch | Haupt-Repository (OSS)
i  | gstreamer-plugins-good-lang       | Paket | 1.16.2-lp152.1.7        | noarch | openSUSE-Leap-15.2-1
i+ | gstreamer-plugins-ugly            | Paket | 1.16.2-lp152.1.4        | x86_64 | Haupt-Repository (OSS)
i+ | gstreamer-plugins-ugly            | Paket | 1.16.2-lp152.1.4        | x86_64 | openSUSE-Leap-15.2-1
i  | gstreamer-plugins-ugly-lang       | Paket | 1.16.2-lp152.1.4        | noarch | Haupt-Repository (OSS)
i  | gstreamer-plugins-ugly-lang       | Paket | 1.16.2-lp152.1.4        | noarch | openSUSE-Leap-15.2-1
i  | libclutter-gst-3_0-0              | Paket | 3.0.26-lp152.3.7        | x86_64 | Haupt-Repository (OSS)
i  | libclutter-gst-3_0-0              | Paket | 3.0.26-lp152.3.7        | x86_64 | openSUSE-Leap-15.2-1
i  | libgstadaptivedemux-1_0-0         | Paket | 1.16.2-lp152.2.17       | x86_64 | Haupt-Repository (OSS)
i  | libgstadaptivedemux-1_0-0         | Paket | 1.16.2-lp152.2.17       | x86_64 | openSUSE-Leap-15.2-1
i  | libgstallocators-1_0-0            | Paket | 1.16.2-lp152.2.16       | x86_64 | Haupt-Repository (OSS)
i  | libgstallocators-1_0-0            | Paket | 1.16.2-lp152.2.16       | x86_64 | openSUSE-Leap-15.2-1
i  | libgstapp-1_0-0                   | Paket | 1.16.2-lp152.2.16       | x86_64 | Haupt-Repository (OSS)
i  | libgstapp-1_0-0                   | Paket | 1.16.2-lp152.2.16       | x86_64 | openSUSE-Leap-15.2-1
i  | libgstaudio-1_0-0                 | Paket | 1.16.2-lp152.2.16       | x86_64 | Haupt-Repository (OSS)
i  | libgstaudio-1_0-0                 | Paket | 1.16.2-lp152.2.16       | x86_64 | openSUSE-Leap-15.2-1
i  | libgstbadaudio-1_0-0              | Paket | 1.16.2-lp152.2.17       | x86_64 | Haupt-Repository (OSS)
i  | libgstbadaudio-1_0-0              | Paket | 1.16.2-lp152.2.17       | x86_64 | openSUSE-Leap-15.2-1
i  | libgstbasecamerabinsrc-1_0-0      | Paket | 1.16.2-lp152.2.17       | x86_64 | Haupt-Repository (OSS)
i  | libgstbasecamerabinsrc-1_0-0      | Paket | 1.16.2-lp152.2.17       | x86_64 | openSUSE-Leap-15.2-1
i  | libgstcodecparsers-1_0-0          | Paket | 1.16.2-lp152.2.17       | x86_64 | Haupt-Repository (OSS)
i  | libgstcodecparsers-1_0-0          | Paket | 1.16.2-lp152.2.17       | x86_64 | openSUSE-Leap-15.2-1
i  | libgstfft-1_0-0                   | Paket | 1.16.2-lp152.2.16       | x86_64 | Haupt-Repository (OSS)
i  | libgstfft-1_0-0                   | Paket | 1.16.2-lp152.2.16       | x86_64 | openSUSE-Leap-15.2-1
i  | libgstgl-1_0-0                    | Paket | 1.16.2-lp152.2.16       | x86_64 | Haupt-Repository (OSS)
i  | libgstgl-1_0-0                    | Paket | 1.16.2-lp152.2.16       | x86_64 | openSUSE-Leap-15.2-1
i  | libgstisoff-1_0-0                 | Paket | 1.16.2-lp152.2.17       | x86_64 | Haupt-Repository (OSS)
i  | libgstisoff-1_0-0                 | Paket | 1.16.2-lp152.2.17       | x86_64 | openSUSE-Leap-15.2-1
i  | libgstmpegts-1_0-0                | Paket | 1.16.2-lp152.2.17       | x86_64 | Haupt-Repository (OSS)
i  | libgstmpegts-1_0-0                | Paket | 1.16.2-lp152.2.17       | x86_64 | openSUSE-Leap-15.2-1
i  | libgstpbutils-1_0-0               | Paket | 1.16.2-lp152.2.16       | x86_64 | Haupt-Repository (OSS)
i  | libgstpbutils-1_0-0               | Paket | 1.16.2-lp152.2.16       | x86_64 | openSUSE-Leap-15.2-1
i  | libgstphotography-1_0-0           | Paket | 1.16.2-lp152.2.17       | x86_64 | Haupt-Repository (OSS)
i  | libgstphotography-1_0-0           | Paket | 1.16.2-lp152.2.17       | x86_64 | openSUSE-Leap-15.2-1
i  | libgstreamer-1_0-0                | Paket | 1.16.2-lp152.1.7        | x86_64 | Haupt-Repository (OSS)
i  | libgstreamer-1_0-0                | Paket | 1.16.2-lp152.1.7        | x86_64 | openSUSE-Leap-15.2-1
i  | libgstriff-1_0-0                  | Paket | 1.16.2-lp152.2.16       | x86_64 | Haupt-Repository (OSS)
i  | libgstriff-1_0-0                  | Paket | 1.16.2-lp152.2.16       | x86_64 | openSUSE-Leap-15.2-1
i  | libgstrtp-1_0-0                   | Paket | 1.16.2-lp152.2.16       | x86_64 | Haupt-Repository (OSS)
i  | libgstrtp-1_0-0                   | Paket | 1.16.2-lp152.2.16       | x86_64 | openSUSE-Leap-15.2-1
i  | libgstrtsp-1_0-0                  | Paket | 1.16.2-lp152.2.16       | x86_64 | Haupt-Repository (OSS)
i  | libgstrtsp-1_0-0                  | Paket | 1.16.2-lp152.2.16       | x86_64 | openSUSE-Leap-15.2-1
i  | libgstsctp-1_0-0                  | Paket | 1.16.2-lp152.2.17       | x86_64 | Haupt-Repository (OSS)
i  | libgstsctp-1_0-0                  | Paket | 1.16.2-lp152.2.17       | x86_64 | openSUSE-Leap-15.2-1
i  | libgstsdp-1_0-0                   | Paket | 1.16.2-lp152.2.16       | x86_64 | Haupt-Repository (OSS)
i  | libgstsdp-1_0-0                   | Paket | 1.16.2-lp152.2.16       | x86_64 | openSUSE-Leap-15.2-1
i  | libgsttag-1_0-0                   | Paket | 1.16.2-lp152.2.16       | x86_64 | Haupt-Repository (OSS)
i  | libgsttag-1_0-0                   | Paket | 1.16.2-lp152.2.16       | x86_64 | openSUSE-Leap-15.2-1
i  | libgsturidownloader-1_0-0         | Paket | 1.16.2-lp152.2.17       | x86_64 | Haupt-Repository (OSS)
i  | libgsturidownloader-1_0-0         | Paket | 1.16.2-lp152.2.17       | x86_64 | openSUSE-Leap-15.2-1
i  | libgstvideo-1_0-0                 | Paket | 1.16.2-lp152.2.16       | x86_64 | Haupt-Repository (OSS)
i  | libgstvideo-1_0-0                 | Paket | 1.16.2-lp152.2.16       | x86_64 | openSUSE-Leap-15.2-1
i  | libgstwayland-1_0-0               | Paket | 1.16.2-lp152.2.17       | x86_64 | Haupt-Repository (OSS)
i  | libgstwayland-1_0-0               | Paket | 1.16.2-lp152.2.17       | x86_64 | openSUSE-Leap-15.2-1
i  | libgstwebrtc-1_0-0                | Paket | 1.16.2-lp152.2.17       | x86_64 | Haupt-Repository (OSS)
i  | libgstwebrtc-1_0-0                | Paket | 1.16.2-lp152.2.17       | x86_64 | openSUSE-Leap-15.2-1
i  | libvlc5                           | Paket | 3.0.10-lp152.1.2        | x86_64 | Haupt-Repository (OSS)
i  | libvlc5                           | Paket | 3.0.10-lp152.1.2        | x86_64 | openSUSE-Leap-15.2-1
i  | libvlccore9                       | Paket | 3.0.10-lp152.1.2        | x86_64 | Haupt-Repository (OSS)
i  | libvlccore9                       | Paket | 3.0.10-lp152.1.2        | x86_64 | openSUSE-Leap-15.2-1
i  | phonon-backend-gstreamer          | Paket | 4.9.1-lp152.1.3         | x86_64 | Haupt-Repository (OSS)
i  | phonon-backend-gstreamer          | Paket | 4.9.1-lp152.1.3         | x86_64 | openSUSE-Leap-15.2-1
i  | phonon4qt5-backend-gstreamer      | Paket | 4.10.0-lp152.1.7        | x86_64 | Haupt-Repository (OSS)
i  | phonon4qt5-backend-gstreamer      | Paket | 4.10.0-lp152.1.7        | x86_64 | openSUSE-Leap-15.2-1
i  | phonon4qt5-backend-gstreamer-lang | Paket | 4.10.0-lp152.1.7        | noarch | Haupt-Repository (OSS)
i  | phonon4qt5-backend-gstreamer-lang | Paket | 4.10.0-lp152.1.7        | noarch | openSUSE-Leap-15.2-1
i+ | vlc                               | Paket | 3.0.10-lp152.1.2        | x86_64 | Haupt-Repository (OSS)
i+ | vlc                               | Paket | 3.0.10-lp152.1.2        | x86_64 | openSUSE-Leap-15.2-1
i  | vlc-codec-gstreamer               | Paket | 3.0.10-lp152.1.2        | x86_64 | Haupt-Repository (OSS)
i  | vlc-codec-gstreamer               | Paket | 3.0.10-lp152.1.2        | x86_64 | openSUSE-Leap-15.2-1
i+ | vlc-codecs                        | Paket | 3.0.10-pm152.2.3        | x86_64 | Packman-Repository
i  | vlc-lang                          | Paket | 3.0.10-lp152.1.2        | noarch | Haupt-Repository (OSS)
i  | vlc-lang                          | Paket | 3.0.10-lp152.1.2        | noarch | openSUSE-Leap-15.2-1
i  | vlc-noX                           | Paket | 3.0.10-lp152.1.2        | x86_64 | Haupt-Repository (OSS)
i  | vlc-noX                           | Paket | 3.0.10-lp152.1.2        | x86_64 | openSUSE-Leap-15.2-1
i  | vlc-qt                            | Paket | 3.0.10-lp152.1.2        | x86_64 | Haupt-Repository (OSS)
i  | vlc-qt                            | Paket | 3.0.10-lp152.1.2        | x86_64 | openSUSE-Leap-15.2-1
i  | vlc-vdpau                         | Paket | 3.0.10-lp152.1.2        | x86_64 | Haupt-Repository (OSS)
i  | vlc-vdpau                         | Paket | 3.0.10-lp152.1.2        | x86_64 | openSUSE-Leap-15.
Zuletzt geändert von tomm.fa am 4. Jul 2020, 14:57, insgesamt 1-mal geändert.
Grund: CODE-Tags gesetzt.
Rechner: AMD Ryzen 7 2700X mit 16 GB RAM Grafik: AMD RX570 8GB
Festplatten: 2 x SSD NVME 256GB, eine für Windows 10 und eine OpenSuse 15.2
Sowie 3x HDD je 1 TB

Benutzeravatar
egweber1
Newbie
Newbie
Beiträge: 22
Registriert: 17. Feb 2020, 16:34
Wohnort: Schwarzenbach am Wald, Bayern
Kontaktdaten:

Re: Upgrade von openSUSE Leap 15.1 auf 15.2

Beitrag von egweber1 » 4. Jul 2020, 18:03

Nach der Deinstallation vom Codec-Paket vlc-vdpau klappt es wieder mit dem Abspielen von MP4 und flv-Dateien.
Muss auch nicht mehr neu anmelden, da vlc jetzt immer startet.
Einziges problem noch: In Firefox kann ich immer noch nicht mp4-Dateien abspielen.
Rechner: AMD Ryzen 7 2700X mit 16 GB RAM Grafik: AMD RX570 8GB
Festplatten: 2 x SSD NVME 256GB, eine für Windows 10 und eine OpenSuse 15.2
Sowie 3x HDD je 1 TB

Sauerland
Guru
Guru
Beiträge: 3659
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: Upgrade von openSUSE Leap 15.1 auf 15.2

Beitrag von Sauerland » 4. Jul 2020, 21:44

Man kann es nicht oft genug sagen:
Finger weg vom vlc Repo und multimedia:libs Repo wenn das Packman Repo aktiv ist.

Die beissen sich meist.

Und zum Thema Repos:
Weniger ist oft mehr.
Erspart viel Ärger.
Desktop: OpenSUSE Leap 15.1, Nvidia-Grafik Kernel 5.x
Laptop: OpenSUSE Leap 15.1, Intel-Skylake, Kernel 4.12

Benutzeravatar
tomm.fa
Moderator
Moderator
Beiträge: 5386
Registriert: 21. Jan 2006, 17:18
Wohnort: OWL - Kreis Gütersloh
Kontaktdaten:

Re: Upgrade von openSUSE Leap 15.1 auf 15.2

Beitrag von tomm.fa » 4. Jul 2020, 22:29

Und das obligatorische

Code: Alles auswählen

zypper -vv dup --allow-vendor-change --from Packman-Repository
sollte auch noch ausgeführt werden.
Linupedia - Wiki des Linux-Club.
Keine Unterstützung/Hilfestellung per PN!

Benutzeravatar
ralli
Hacker
Hacker
Beiträge: 335
Registriert: 29. Jun 2004, 13:55

Re: Upgrade von openSUSE Leap 15.1 auf 15.2

Beitrag von ralli » 5. Jul 2020, 10:37

Grundsätzlich installiere ich eine neue Major Version seit Jahren immer neu. Der Mehraufwand hält sich in Grenzen. Damit habe ich die allerbesten Erfahrungen gemacht. Um in den Genuß aller erforderlichen Multimedia Anwendungen zu kommen, stelle ich alles auf Packman Repos um. Dabei hat sich folgende Vorgehensweise bewährt und funktioniert bestens:

Code: Alles auswählen

Packman Repo hinzufügen

zypper ar -f http://ftp.halifax.rwth-aachen.de/packman/suse/openSUSE_Leap_15.2/ Packman

Priorität erhöhen

zypper mr -p 20 http://ftp.halifax.rwth-aachen.de/packman/suse/openSUSE_Leap_15.2/

Pakete auf Packman umstellen

zypper dup --from http://ftp.halifax.rwth-aachen.de/packman/suse/openSUSE_Leap_15.2/

Alles mit 1 bestätigen

Alle zusätzlich wichtigen Codecs installieren

zypper install -f libxine2-codecs ffmpeg lame gstreamer-0_10-plugins-good gstreamer-0_10-plugins-bad gstreamer-0_10-plugins-ugly gstreamer-0_10-plugins-good-extra gstreamer-0_10-plugins-ugly-orig-addon gstreamer-0_10-plugins-ffmpeg dvdauthor07 gstreamer-plugins-base gstreamer-plugins-bad gstreamer-plugins-bad-orig-addon gstreamer-plugins-good gstreamer-plugins-ugly gstreamer-plugins-ugly-orig-addon gstreamer-plugins-good-extra gstreamer-fluendo-mp3 k3b-codecs vlc smplayer x264 x265 gstreamer-plugins-libav vlc-codecs gstreamer-0_10-plugins-fluendo_mp3 ogmtools

Status: OK

Gruß ralli
System: openSUSE Leap 15.2 - KDE Desktop - CPU: Intel Core i7-870 - RAM: 16 GB - Graka: AMD 2GB - SSD 128 GB - HD: 1 TB

Benutzeravatar
egweber1
Newbie
Newbie
Beiträge: 22
Registriert: 17. Feb 2020, 16:34
Wohnort: Schwarzenbach am Wald, Bayern
Kontaktdaten:

Re: "Gelöst"Upgrade von openSUSE Leap 15.1 auf 15.2

Beitrag von egweber1 » 5. Jul 2020, 11:01

Danke
Zuletzt geändert von egweber1 am 5. Jul 2020, 11:24, insgesamt 1-mal geändert.
Rechner: AMD Ryzen 7 2700X mit 16 GB RAM Grafik: AMD RX570 8GB
Festplatten: 2 x SSD NVME 256GB, eine für Windows 10 und eine OpenSuse 15.2
Sowie 3x HDD je 1 TB

Benutzeravatar
tomm.fa
Moderator
Moderator
Beiträge: 5386
Registriert: 21. Jan 2006, 17:18
Wohnort: OWL - Kreis Gütersloh
Kontaktdaten:

Re: Upgrade von openSUSE Leap 15.1 auf 15.2

Beitrag von tomm.fa » 5. Jul 2020, 11:03

ralli hat geschrieben:
5. Jul 2020, 10:37
Grundsätzlich installiere ich eine neue Major Version seit Jahren immer neu. Der Mehraufwand hält sich in Grenzen. Damit habe ich die allerbesten Erfahrungen gemacht. Um in den Gnuß aller erforderlichen Multimedia Anwendungen zu kommen, stelle ich alles auf Packman Repos um. Dabei hat sich folgende Vorgehensweise bewährt und funktioniert bestens:

Code: Alles auswählen

zypper dup --from http://ftp.halifax.rwth-aachen.de/packman/suse/openSUSE_Leap_15.2/
Alles mit 1 bestätigen
  1. Das zypper dup würde ich ändern in

    Code: Alles auswählen

    zypper -vv dup --allow-vendor-change --from PackManRepo*
    *PackManRepo ist entsprechend anzupassen.
  2. Dann entfällt auch der nächste Schritt, alles mit 1 zu bestätigen, die Auswahl kann sich zwischen den Abfragen auch ändern.

ralli hat geschrieben:
5. Jul 2020, 10:37
Alle zusätzlich wichtigen Codecs installieren

Code: Alles auswählen

zypper install -f libxine2-codecs ffmpeg lame gstreamer-0_10-plugins-good gstreamer-0_10-plugins-bad gstreamer-0_10-plugins-ugly gstreamer-0_10-plugins-good-extra gstreamer-0_10-plugins-ugly-orig-addon gstreamer-0_10-plugins-ffmpeg dvdauthor07 gstreamer-plugins-base gstreamer-plugins-bad gstreamer-plugins-bad-orig-addon gstreamer-plugins-good gstreamer-plugins-ugly gstreamer-plugins-ugly-orig-addon gstreamer-plugins-good-extra gstreamer-fluendo-mp3 k3b-codecs vlc smplayer x264 x265 gstreamer-plugins-libav vlc-codecs gstreamer-0_10-plugins-fluendo_mp3 ogmtools
Gruß ralli
Du solltest dir diese Liste mal genauer anschauen, einige Pakete gibt es schon länger nicht mehr (gstreamer-fluendo-mp3, alle gstreamer-0_10, dvdauthor07 usw.), libxine2-codecs wird auch kaum noch benötigt.
Linupedia - Wiki des Linux-Club.
Keine Unterstützung/Hilfestellung per PN!

Antworten