Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[gelöst] Verbindungsaufbau zum WLAN braucht sehr lange

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
wbwb
Member
Member
Beiträge: 233
Registriert: 26. Jun 2006, 14:51

[gelöst] Verbindungsaufbau zum WLAN braucht sehr lange

Beitrag von wbwb » 13. Mär 2020, 20:35

Hallo,

auf meinem Laptop mit einer neu installierten Leap 15.1 dauert es nach dem Aufwachen aus dem Suspend oder auch nach einem Login teilweise bis zu ca. 60 Sekunden und länger bevor die "configuring interface" Animation im System Tray endlich Ruhe gibt und die Verbindung von "Available" zu "Active" wechselt. Manchmal sagt mir das System auch währenddessen, dass die Verbindung "deactivated" würde um sie kurz danach dann endgültig zu aktivieren. Wenn die Verbindung erst einmal etabliert ist, erscheint sie völlig stabil.

Ich nutze den NetworkManager mit gespeichertem Passwort. KWallet ist abgeschaltet.

Das Problem hängt nicht ab von einem speziellen WLAN Netzwerk, sondern tritt in allen bisher ausprobierten WIFI Netzen auf.

Auf einem Vergleichssystem, noch mit Leap 42.3 geht der Verbindungsaufbau immer ganz flugs.

Wie kann ich denn feststellen, welche Prozesse hier so ewig brauchen?
Und wie kann ich denen "Beine machen"?
Danke,
wbwb.

PS: Ich weiß nicht welche SysInfos evtl. von Hilfe wären, aber hier ist schon mal
uname -r

Code: Alles auswählen

4.12.14-lp151.28.40-default
lsmod | grep wifi

Code: Alles auswählen

iwlwifi               282624  1 iwlmvm
cfg80211              761856  3 iwlmvm,iwlwifi,mac80211
nmcli g

Code: Alles auswählen

STATE      CONNECTIVITY  WIFI-HW  WIFI     WWAN-HW  WWAN    
connected  full          enabled  enabled  enabled  enabled
lspci

Code: Alles auswählen

04:00.0 Network controller: Intel Corporation Wireless 8260 (rev 3a)
    ...
    Kernel driver in use: iwlwifi
	Kernel modules: iwlwifi
ip

Code: Alles auswählen

wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    link/ether xx:xx:xx:xx:xx:xx brd ff:ff:ff:ff:ff:ff
    inet 192.168.0.104/24 brd 192.168.0.255 scope global noprefixroute dynamic wlan0
       valid_lft 5398sec preferred_lft 5398sec
    inet6 xxxx::xxxx:xxxx:xxxx:dbc0/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever
iw dev wlan0 link

Code: Alles auswählen

Connected to xx:xx:xx:xx:xx:xx (on wlan0)
	SSID: XXXXXXXX
	freq: 5180
	RX: 73762104 bytes (54922 packets)
	TX: 2836544 bytes (24281 packets)
	signal: -43 dBm
	tx bitrate: 180.0 MBit/s MCS 12 40MHz short GI
	bss flags:	short-slot-time
	dtim period:	1
	beacon int:	100
systemctl status NetworkManager

Code: Alles auswählen

● NetworkManager.service - Network Manager
   Loaded: loaded (/usr/lib/systemd/system/NetworkManager.service; enabled; vendor preset: disabled)
  Drop-In: /usr/lib/systemd/system/NetworkManager.service.d
           └─NetworkManager-ovs.conf
   Active: active (running) since Fri 2020-03-13 17:38:06 CET; 2h 47min ago
     Docs: man:NetworkManager(8)
 Main PID: 1163 (NetworkManager)
    Tasks: 4
   CGroup: /system.slice/NetworkManager.service
           ├─1163 /usr/sbin/NetworkManager --no-daemon
           └─3471 /sbin/dhclient -d -q -sf /usr/lib/nm-dhcp-helper -pf /var/run/dhclient-wlan0.pid -lf /var/lib/NetworkManager/dhclient-11fec643-75b2-4cc1-ba3f-642f5514d833-wlan0.lease -cf>
Zuletzt geändert von wbwb am 15. Mär 2020, 11:50, insgesamt 1-mal geändert.

Werbung:
Sauerland
Guru
Guru
Beiträge: 3619
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: Verbindungsaufbau zum WLAN braucht sehr lange

Beitrag von Sauerland » 14. Mär 2020, 07:04

Schalte mal IPV6 aus.
Desktop: OpenSUSE Leap 15.1, Nvidia-Grafik Kernel 5.x
Laptop: OpenSUSE Leap 15.1, Intel-Skylake, Kernel 4.12

wbwb
Member
Member
Beiträge: 233
Registriert: 26. Jun 2006, 14:51

Re: Verbindungsaufbau zum WLAN braucht sehr lange

Beitrag von wbwb » 14. Mär 2020, 10:43

Kannst Du mir bitte kurz erklären was genauer Du da im Visier hast und warum das helfen würde?

Ich frage deshalb, weil im selben Netz, auf identischer Hardware und wie im Post beschrieben, noch eine Leap 42.3 läuft - aber ohne das beschriebene Problem.
Auf dieser Leap 42.3 ist IPV6 ebenfalls "enabled" (die Treiber sind geladen, die wlan0 bekommt eine inet6 Adresse, /proc/net/if_inet6 existiert, es wird auch der NetworkManager genutzt und dessen connection configuration Reiter sieht bei der IPV6 auch praktisch gleich aus wie bei der 15.1)

Was wäre denn auf der Leap 15.1 in der IPV6 Konfiguration anders als auf der Leap 42.3, so dass Du denkst dass es zu dieser ewigen Warterei beim Verbindungsaufbau kommen könnte?

Sauerland
Guru
Guru
Beiträge: 3619
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: Verbindungsaufbau zum WLAN braucht sehr lange

Beitrag von Sauerland » 14. Mär 2020, 13:17

IPV6 war schon bei vielen Problemen der Auslöser, auch bei nicht mehr unterstützten Versionen.

Aber wenn du alles mit IPV6 machst ist das natürlich keine Alternative.

Du kannst es auch mal mit einer festen IP versuchen statt dhcp.
Desktop: OpenSUSE Leap 15.1, Nvidia-Grafik Kernel 5.x
Laptop: OpenSUSE Leap 15.1, Intel-Skylake, Kernel 4.12

spoensche
Moderator
Moderator
Beiträge: 7501
Registriert: 30. Okt 2004, 23:53
Wohnort: Siegen

Re: Verbindungsaufbau zum WLAN braucht sehr lange

Beitrag von spoensche » 14. Mär 2020, 13:46

Für die autom. IPv6 Address Zuweisung benötigst du entweder einen DHCPv6 Server oder einen Routing Advertisement Daemon.

wbwb
Member
Member
Beiträge: 233
Registriert: 26. Jun 2006, 14:51

Re: Verbindungsaufbau zum WLAN braucht sehr lange

Beitrag von wbwb » 14. Mär 2020, 14:20

Ich frage noch mal anders: Welche log-files, oder welche command line tools o.ä., kann ich nutzen um zu sehen was das System genau 'macht', bevor es die Verbindung endlich etabliert hat? So könnte ich wenigstens herausfinden welcher Prozess es ist der da so lange braucht.

Sauerland
Guru
Guru
Beiträge: 3619
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: Verbindungsaufbau zum WLAN braucht sehr lange

Beitrag von Sauerland » 14. Mär 2020, 15:30

Welche log-files,

Code: Alles auswählen

journalctl
Desktop: OpenSUSE Leap 15.1, Nvidia-Grafik Kernel 5.x
Laptop: OpenSUSE Leap 15.1, Intel-Skylake, Kernel 4.12

Gräfin Klara
Hacker
Hacker
Beiträge: 469
Registriert: 23. Jun 2008, 20:51

Re: Verbindungsaufbau zum WLAN braucht sehr lange

Beitrag von Gräfin Klara » 14. Mär 2020, 16:14

wbwb hat geschrieben:
14. Mär 2020, 14:20
.. was das System genau 'macht' ...
Das ist ein umfangreiches Thema.
Eine wlan_karte besteht aus mindestens 2 Komponenten.

wlan? ist das Ethernet auf der Karte, also in Richtung System. Dort kommt auch die IP hin.
phy? ist das Wifi auf der Karte, meist ein Module, an dem die Antennen stecken, also Richtung Access Point. (meist router)

Damit sich die Karte dem System als Ethernet darstellen kann, braucht es eine Software, die eth und phy verbinden.
Das macht der wpa_supplicant, ein wifi supplicant für die Kommunikation zwischen eth <-> phy <-> Cipher <-> Authentifizierung <-> und mehr.

Diesen wpa_supplicant (vorher natürlich stoppen) kannst du per Konsole starten mit:

Code: Alles auswählen

# wpa_supplicant -c /etc/wpa_supplicant/DEIN_CONFIG_FILE.conf -i DEIN_DEVICE (eg. wlan0) -dt
Damit läuft er im Debugmodus und zeigt alle Vorgänge rund um eth und phy. Dann weißt du es ganz genau.
Aber wahrscheinlich bin ich wieder am Thema vorbei.

Gruß
Gräfin Klara

wbwb
Member
Member
Beiträge: 233
Registriert: 26. Jun 2006, 14:51

Re: Verbindungsaufbau zum WLAN braucht sehr lange

Beitrag von wbwb » 15. Mär 2020, 11:49

Danke für Eure Hilfe. Ein Stop auf https://linux-club.de ist immer lehrreich - inklusive solcher Dinge wie
Gräfin Klara hat geschrieben:
14. Mär 2020, 16:14

Code: Alles auswählen

# wpa_supplicant -c /etc/wpa_supplicant/DEIN_CONFIG_FILE.conf -i DEIN_DEVICE (eg. wlan0) -dt
Das kannte ich mal wieder noch gar nicht. Cool ;)

Am Ende war die Lösung dann aber anders: Im NetworkManager log /var/log/NetworkManager gab es diese Einträge

Code: Alles auswählen

localhost NetworkManager[1228]: <warn>  [1584264509.3529] device (wlan0): Activation: (wifi) association took too long, failing activation
Wenn man Dr. Google hier nach einer Diagnose fragt, bekommt man dafür relativ häufig den Hinweis, man sollte die Router-Firmware updaten. Habe ich gemacht und seitdem gab es keinen solchen Eintrag mehr im NetworkManager log und ich habe das Gefühl dass der Verbindungsaufbau wieder "schnell" ist. Ich hoffe das war's. (Warum die alte Router-Firmware bei der Leap 42.3 keine Schwierigkeiten gemacht hat, weiß ich nicht.)

Gesund bleiben, wbwb

Antworten