Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

USB unter Opensuse 15.1 Geräte erkannt, aber nicht eingebunden

Alles rund um Hardware, die unter Linux läuft oder zum Laufen gebracht werden soll

Moderator: Moderatoren

Antworten
Mav
Newbie
Newbie
Beiträge: 35
Registriert: 12. Mär 2005, 12:14

USB unter Opensuse 15.1 Geräte erkannt, aber nicht eingebunden

Beitrag von Mav » 9. Nov 2019, 10:46

Moin zusammen :)

Habe da ein Problem mit meinen USB-Geräten. Die 'normalen' laufen super (also Maus und Tastatur (sogar Gamepad und Kopfhörer) per Logitech Wireless).

Aber seit einiger Zeit funktionieren meine USB-Sticks nicht mehr. Ich stecke die ein, die fangen auch an zu blinken, werden aber wohl nicht richtig eingebunden, blinken also endlos weiter.

Das für mich Unverständliche: Starte ich mit VMWare ein Windows 10 Pro auf dem Linux, und gebe die Ports bzw. Devices der VM frei, funktionieren die einwandfrei im virtuellen Windows.

Auch komisch für mich: Mit 'lsusb' werden die Geräte angezeigt. KDE bietet mir bei einem Speicherstick sogar das Kontextmenü an, passiert aber nix, wenn ich das mit dem Dateimanager öffnen will.

Also erkennen tut das Linux die Sticks wohl, verheddert sich aber irgendwie beim richtig einbinden.

Hat da vielleicht wer eine Idee, woran das liegen könnte?

Updates sollten Alle drauf sein.

Kernel ist: Linux mav-linux 4.12.14-lp151.28.25-default #1 SMP Wed Oct 30 08:39:59 UTC 2019 (54d7657) x86_64 x86_64 x86_64 GNU/Linux

Vielen Dank schonmal für Hinweise, wo ich nach dem Fehler suchen könnte...

LG,
Mav

Werbung:
Benutzeravatar
manzek
Member
Member
Beiträge: 166
Registriert: 20. Mär 2005, 14:21
Wohnort: Oldenburger Land

Re: USB unter Opensuse 15.1 Geräte erkannt, aber nicht eingebunden

Beitrag von manzek » 9. Nov 2019, 11:53

Hast du auch daran gedacht, unter Systemeinstellungen > Wechselmedien > Wechselmedien den Haken bei

Code: Alles auswählen

Automatisches Einhängen von Wechselmedien aktivieren
zu setzen?
So long, Stephan

---
Gigabyte Z77X-D3H * Intel i7-3770K LCS @ 4,2 GHz * 16 GB DDR3 @ 1866 MHz * nVIDIA GeForce RTX 2070 SUPER, 8192 MB * 23,6" - LED @ 1920x1080 * openSUSE Leap 15.1 * KDE 5.12.x

thio
Hacker
Hacker
Beiträge: 454
Registriert: 13. Jan 2006, 12:14

Re: USB unter Opensuse 15.1 Geräte erkannt, aber nicht eingebunden

Beitrag von thio » 9. Nov 2019, 14:39

Habe einen Rechner auf Leap 15.0 zurückgesetzt, funktioniert leider immer noch nicht...
(Unter 15.0 sollte der Drucker früher aber funktioniert haben)
Bin irgendwie ratlos...

Benutzeravatar
manzek
Member
Member
Beiträge: 166
Registriert: 20. Mär 2005, 14:21
Wohnort: Oldenburger Land

Re: USB unter Opensuse 15.1 Geräte erkannt, aber nicht eingebunden

Beitrag von manzek » 9. Nov 2019, 14:50

@thio

Bist du sicher, dass du im richtigen Thread bist?
Ansonsten bitte einen eigenen Thread zu deinem Problem erstellen.
So long, Stephan

---
Gigabyte Z77X-D3H * Intel i7-3770K LCS @ 4,2 GHz * 16 GB DDR3 @ 1866 MHz * nVIDIA GeForce RTX 2070 SUPER, 8192 MB * 23,6" - LED @ 1920x1080 * openSUSE Leap 15.1 * KDE 5.12.x

Benutzeravatar
Heinz-Peter
Guru
Guru
Beiträge: 2080
Registriert: 24. Okt 2005, 14:04

Re: USB unter Opensuse 15.1 Geräte erkannt, aber nicht eingebunden

Beitrag von Heinz-Peter » 9. Nov 2019, 21:04

Mav hat geschrieben:
9. Nov 2019, 10:46
Das für mich Unverständliche: Starte ich mit VMWare ein Windows 10 Pro auf dem Linux, und gebe die Ports bzw. Devices der VM frei, funktionieren die einwandfrei im virtuellen Windows.
Nur so eine Idee. Die USB Speichermedien unter einem Windows Betriebssystem anhängen und dann ordnungsgemäß entfernen.

Gruß

Heinz-Peter
Wir müssen lernen, entweder als Brüder miteinander zu leben oder als Narren unterzugehen.
Mein Betriebssystem: Suse 42.2/42.3, Prozessor: Pentium 4 550 (3,40 GHz, FSB800, Hyper-Threading), Grafikkarte: Nvidia Geforce 6610XL (PCIe)/128MByte.

Mav
Newbie
Newbie
Beiträge: 35
Registriert: 12. Mär 2005, 12:14

Re: USB unter Opensuse 15.1 Geräte erkannt, aber nicht eingebunden

Beitrag von Mav » 10. Nov 2019, 22:05

manzek hat geschrieben:
9. Nov 2019, 11:53
Hast du auch daran gedacht, unter Systemeinstellungen > Wechselmedien > Wechselmedien den Haken bei

Code: Alles auswählen

Automatisches Einhängen von Wechselmedien aktivieren
zu setzen?
Bin ich zu dumm? Systemeinstellungen gibt es bei Windows, mein Yast macht da aber nicht so ganz mit.
Entschuldigung. Ist etwas fies...
Bekomme den Stick aber auch nicht unter Windows 10 eingebunden.
Das hat bisher immer funktioniert.
Sollte vielleicht noch mal bei UEFI nachschauen.

Aber Windows-Einstellungen sind für Linuxe nicht so wirklich hilfreich...

Habe aber trotzdem versucht, die korrekt auszubinden...

Bringt leider nix :(

LG,
Mav

Benutzeravatar
tomm.fa
Moderator
Moderator
Beiträge: 5348
Registriert: 21. Jan 2006, 17:18
Wohnort: OWL - Kreis Gütersloh
Kontaktdaten:

Re: USB unter Opensuse 15.1 Geräte erkannt, aber nicht eingebunden

Beitrag von tomm.fa » 10. Nov 2019, 22:18

Mav hat geschrieben:
10. Nov 2019, 22:05
manzek hat geschrieben:
9. Nov 2019, 11:53
Hast du auch daran gedacht, unter Systemeinstellungen > Wechselmedien > Wechselmedien den Haken bei

Code: Alles auswählen

Automatisches Einhängen von Wechselmedien aktivieren
zu setzen?
Bin ich zu dumm? Systemeinstellungen gibt es bei Windows, mein Yast macht da aber nicht so ganz mit.
Es wurden die KDE-Systemeinstellungen (Systemsettings/systemsettings5) gemeint und nicht YaST2. Diese findest du, falls nach der Installation nichts geändert wurde, im K-Menü unter anderem bei den Favoriten. Ansonsten kannst du diese auch mittels der Tastenkombi Alt+F2 und dann Eingabe von systemsettings5 aufrufen.

Zum USB-Stock:
Konsole starten, als Root/su anmelden,

Code: Alles auswählen

journalctl -f
aufrufen, Stock einstöpseln und Meldungen hier vorführen.
Linupedia - Wiki des Linux-Club.
Keine Unterstützung/Hilfestellung per PN!

Mav
Newbie
Newbie
Beiträge: 35
Registriert: 12. Mär 2005, 12:14

Re: USB unter Opensuse 15.1 Geräte erkannt, aber nicht eingebunden

Beitrag von Mav » 10. Nov 2019, 22:24

Heinz-Peter hat geschrieben:
9. Nov 2019, 21:04
Mav hat geschrieben:
9. Nov 2019, 10:46
Das für mich Unverständliche: Starte ich mit VMWare ein Windows 10 Pro auf dem Linux, und gebe die Ports bzw. Devices der VM frei, funktionieren die einwandfrei im virtuellen Windows.
Nur so eine Idee. Die USB Speichermedien unter einem Windows Betriebssystem anhängen und dann ordnungsgemäß entfernen.

Gruß

Heinz-Peter
Habe ich gemacht. Leider FAIL :(
Und was ich verschwiegen habe:
Ist ein YubiKey bzw. eine Logitech C920.
Der YubiKey funzt unter dem VMWare-Windows 10, aber irgendwie nicht unter Linux :(
Mit lsusb wird er angezeigt, hat aber keine Funktion :(
Ich verstehe es gerade nicht!? Habe sogar in den Repos das YubiKey C Gedöns installiert.
Nach der Webcam sollte ich vielleicht noch mal suchen...
Aber meine Sticks, die halt einfach gemountet wurden, samt Partitionen und verschiedener Formatierungen, werden leider nicht mehr erkannt.

Und Danke für die Idee, aber ich habe die Sticks auch unter Windows 'unmounted'.

Lieben Dank,
Mav

Mav
Newbie
Newbie
Beiträge: 35
Registriert: 12. Mär 2005, 12:14

Re: USB unter Opensuse 15.1 Geräte erkannt, aber nicht eingebunden

Beitrag von Mav » 10. Nov 2019, 22:37

tomm.fa hat geschrieben:
10. Nov 2019, 22:18
Mav hat geschrieben:
10. Nov 2019, 22:05
manzek hat geschrieben:
9. Nov 2019, 11:53
Hast du auch daran gedacht, unter Systemeinstellungen > Wechselmedien > Wechselmedien den Haken bei

Code: Alles auswählen

Automatisches Einhängen von Wechselmedien aktivieren
zu setzen?
Bin ich zu dumm? Systemeinstellungen gibt es bei Windows, mein Yast macht da aber nicht so ganz mit.
Es wurden die KDE-Systemeinstellungen (Systemsettings/systemsettings5) gemeint und nicht YaST2. Diese findest du, falls nach der Installation nichts geändert wurde, im K-Menü unter anderem bei den Favoriten. Ansonsten kannst du diese auch mittels der Tastenkombi Alt+F2 und dann Eingabe von systemsettings5 aufrufen.

Zum USB-Stock:
Konsole starten, als Root/su anmelden,

Code: Alles auswählen

journalctl -f
aufrufen, Stock einstöpseln und Meldungen hier vorführen.
Ja wie genial :)
Das kannte ich noch nicht...
Mache erstmal mit dem Tipp weiter und melde das Ergebnis...

Vielen Dank schonmal...
Mav

Antworten