Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

leap 15.1: firewalld started, blokiert jedoch Samba

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
uhi
Member
Member
Beiträge: 75
Registriert: 17. Feb 2006, 11:40
Wohnort: Nähe München

leap 15.1: firewalld started, blokiert jedoch Samba

Beitrag von uhi » 15. Apr 2019, 14:43

Firewalld startet beim Booten, läßt auch Samba zu. Wenn man jedoch von Windows aus auf den Linux-Rechner zugreifen will, blokiiert firewalld. Ein "systemctl restart firewalld.service" öffnet die Verbindung nicht. Erst nach "Yast -> Sichherheit -> Firewall" mit "neut laden" wird die Verbindung freigegeben.
Was muss ich entweder bei wirewalld.service oder nmb.service ändern, damit ich den mühsame Umweg sparen kann?

Werbung:
marce
Advanced Hacker
Advanced Hacker
Beiträge: 1135
Registriert: 19. Jun 2008, 13:16
Wohnort: Dettenhausen
Kontaktdaten:

Re: leap 15.1: firewalld started, blokiert jedoch Samba

Beitrag von marce » 15. Apr 2019, 14:54


uhi
Member
Member
Beiträge: 75
Registriert: 17. Feb 2006, 11:40
Wohnort: Nähe München

Re: leap 15.1: firewalld started, blokiert jedoch Samba

Beitrag von uhi » 15. Apr 2019, 18:37

firewalled.service startet beim Booten (enabled).
Es muss sich um eine andere Tücke handeln

Sauerland
Guru
Guru
Beiträge: 3417
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: leap 15.1: firewalld started, blokiert jedoch Samba

Beitrag von Sauerland » 15. Apr 2019, 18:58

Eigentlich sollte bei Leap 15.1 ein bugreport eröffnet werden, sodann hast du den Link nicht richtig gelesen?

Poste

Code: Alles auswählen

zypper se -si firewall
Desktop: OpenSUSE Leap 15.0, Nvidia-Grafik Kernel 4.x
Laptop: OpenSUSE Leap 15.0, Intel-Skylake, Kernel 4.12

uhi
Member
Member
Beiträge: 75
Registriert: 17. Feb 2006, 11:40
Wohnort: Nähe München

Re: leap 15.1: firewalld started, blokiert jedoch Samba

Beitrag von uhi » 16. Apr 2019, 14:26

Ich habe den Link schon vor der Fragestellung genau durchgelesen und vermutlich auch verstanden.
Hier das Ergebnis von zypper:

***********

Code: Alles auswählen

Repository-Daten werden geladen...
Warnung: Repository 'Update Repository (Non-Oss)' scheint veraltet zu sein. Ziehen Sie in Erwägung, eine andere Spiegelung oder einen anderen Server zu verwenden.
Installierte Pakete werden gelesen...

S  | Name             | Typ   | Version          | Arch   | Repository     
---+------------------+-------+------------------+--------+----------------
i+ | firewall-macros  | Paket | 0.5.5-lp151.5.1  | noarch | Main Repository
i+ | firewalld        | Paket | 0.5.5-lp151.5.1  | noarch | Main Repository
i+ | firewalld-lang   | Paket | 0.5.5-lp151.5.1  | noarch | Main Repository
i+ | python3-firewall | Paket | 0.5.5-lp151.5.1  | noarch | Main Repository
i+ | yast2-firewall   | Paket | 4.1.11-lp151.1.1 | noarch | Main Repository
************
Mich stört jetzt zusätzlich der Satz "Update Repository (Non-Oss)' scheint veraltet zu sein". Ich benutze das vom Programm vorgesehene Repository http://download.opensuse.org/update/leap/15.1/non-oss/
Zuletzt geändert von tomm.fa am 16. Apr 2019, 19:53, insgesamt 1-mal geändert.
Grund: Code-Tags gesetzt (siehe dazu auch: https://linux-club.de/forum/viewtopic.php?f=92&t=105750).

Sauerland
Guru
Guru
Beiträge: 3417
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: leap 15.1: firewalld started, blokiert jedoch Samba

Beitrag von Sauerland » 16. Apr 2019, 14:33

Bugreport!
Desktop: OpenSUSE Leap 15.0, Nvidia-Grafik Kernel 4.x
Laptop: OpenSUSE Leap 15.0, Intel-Skylake, Kernel 4.12

spoensche
Moderator
Moderator
Beiträge: 7436
Registriert: 30. Okt 2004, 23:53
Wohnort: Siegen

Re: leap 15.1: firewalld started, blokiert jedoch Samba

Beitrag von spoensche » 17. Apr 2019, 21:47

Sauerland hat geschrieben:
16. Apr 2019, 14:33
Bugreport!
Warum direkt einen Bugreport, ohne jemals die Logs gesehen zu haben? Evtl. ist die Ursache auch einfach nur die SMB Version oder ein Berechtigungsproblem.

@uhi:

1. Poste mal bitte die Logs von Firewalld
2. Poste mal die Ausgabe von

Code: Alles auswählen

iptables -L
3. Poste mal die Freigabenkonfiguration die du verwendest
4. Was sagen die Samba Logs.
5. Was für eine Windows Version will auf die Freigabe zugreifen?

Sauerland
Guru
Guru
Beiträge: 3417
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: leap 15.1: firewalld started, blokiert jedoch Samba

Beitrag von Sauerland » 17. Apr 2019, 22:19

Warum direkt einen Bugreport, ohne jemals die Logs gesehen zu haben? Evtl. ist die Ursache auch einfach nur die SMB Version oder ein Berechtigungsproblem.
Weil die Leap 15.1 eine beta ist, die Zeit , falls es ein bug ist, knapp werden könnte um es bis zum Erscheinen in ca. 4 Wochen noch zu fixen???
Wenn es kein bug sein sollte, wird dort auch geholfen.....
Desktop: OpenSUSE Leap 15.0, Nvidia-Grafik Kernel 4.x
Laptop: OpenSUSE Leap 15.0, Intel-Skylake, Kernel 4.12

Benutzeravatar
StephanS
Member
Member
Beiträge: 71
Registriert: 24. Jan 2005, 22:04

Re: leap 15.1: firewalld started, blokiert jedoch Samba

Beitrag von StephanS » 19. Apr 2019, 13:58

Bei mir gab es mal ein Problem mit der Reihenfolge, in der wickedd und firewalld gestartet wurden. Dadurch war dem Netzwerk-Interface die (selbstdefinierte) Zone nicht richtig zugewiesen und firewalld hat die erlaubten Services nicht aufgemacht. Siehe https://bugzilla.opensuse.org/show_bug.cgi?id=1120380. Ein Neustart von firewalld hat - wie bei dir - auch nicht geholfen sondern ein Neustart von wickedd. Wickedd muss nach firewalld starten! Schau mal in /usr/lib/systemd/system/wickedd.service, ob da firewalld unter "After=" steht.

Ansonsten schau mal mit firewall-cmd, was die Firewall so über die aktuelle Konfiguration denk. Als erstes

Code: Alles auswählen

firewall-cmd --get-active-zones
und dann

Code: Alles auswählen

firewall-cmd --list-all --zone=...

uhi
Member
Member
Beiträge: 75
Registriert: 17. Feb 2006, 11:40
Wohnort: Nähe München

Re: leap 15.1: firewalld started, blokiert jedoch Samba

Beitrag von uhi » 1. Mai 2019, 20:43

firewall-cmd --list-all --zone=eth0

Antwort: Error: INVALID_ZONE: eth0
und das obwohl eth0 die einzige zone ist

Benutzeravatar
gehrke
Moderator
Moderator
Beiträge: 1924
Registriert: 10. Nov 2012, 11:00
Wohnort: Münsterland

Re: leap 15.1: firewalld started, blokiert jedoch Samba

Beitrag von gehrke » 1. Mai 2019, 21:00

@uhi: Bitte <code>-Tags benutzen.
Danke.

Benutzeravatar
StephanS
Member
Member
Beiträge: 71
Registriert: 24. Jan 2005, 22:04

Re: leap 15.1: firewalld started, blokiert jedoch Samba

Beitrag von StephanS » 1. Mai 2019, 21:33

uhi hat geschrieben:
1. Mai 2019, 20:43
firewall-cmd --list-all --zone=eth0

Antwort: Error: INVALID_ZONE: eth0
und das obwohl eth0 die einzige zone ist
eth0 ist das Interface. Eine vordefinierte Zone könnte zum Beispiel "public" sein. Aber wenn dein Interface eth0 heißt, dann mach doch mal

Code: Alles auswählen

firewall-cmd --get-zone-of-interface=eth0

und schreib uns die Ausgabe.

uhi
Member
Member
Beiträge: 75
Registriert: 17. Feb 2006, 11:40
Wohnort: Nähe München

Re: leap 15.1: firewalld started, blokiert jedoch Samba

Beitrag von uhi » 8. Mai 2019, 18:59

Nach dem letzten auomatischen Update (von 15.1 auf Tumbleweed) keine Probleme mehr. Das Thema kann meiner Ansicht nach als "gelöst" markiert werden.

Benutzeravatar
gehrke
Moderator
Moderator
Beiträge: 1924
Registriert: 10. Nov 2012, 11:00
Wohnort: Münsterland

Re: leap 15.1: firewalld started, blokiert jedoch Samba

Beitrag von gehrke » 8. Mai 2019, 19:18


Antworten