Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[Gelöst] Firewall startet nicht

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
Benutzeravatar
Uwe.Lü
Hacker
Hacker
Beiträge: 469
Registriert: 7. Nov 2004, 22:21

[Gelöst] Firewall startet nicht

Beitrag von Uwe.Lü » 12. Nov 2018, 13:20

Hallo, meine Firewall strikt. wenn ich versuche sie über Yast zu starten erhalte ich folgende Fehlermeldung:

Code: Alles auswählen

Fehler beim Ausführen des Befehls "[["/usr/bin/firewall-config"]]". 
Abbruch-Code: 1 Fehlerausgabe: Traceback (most recent call last): File "/usr/bin/firewall-config", line 8170, 
in <module> app = FirewallConfig() File "/usr/bin/firewall-config", line 1386, in __init__ self.connection_changed() File "/usr/bin/firewall-config", line 1692, 
in connection_changed self.update_active_zones() File "/usr/bin/firewall-config", line 2465, 
in update_active_zones connection, zone ]) File "/usr/lib64/python3.6/site-packages/gi/overrides/Gtk.py", line 1237, 
in append return self._do_insert(parent, -1, row) File "/usr/lib64/python3.6/site-packages/gi/overrides/Gtk.py", line 1229, 
in _do_insert row, columns = self._convert_row(row) File "/usr/lib64/python3.6/site-packages/gi/overrides/Gtk.py", line 870, 
in _convert_row result.append(self._convert_value(cur_col, value)) File "/usr/lib64/python3.6/site-packages/gi/overrides/Gtk.py", line 888, 
in _convert_value return GObject.Value(self.get_column_type(column), value) File "/usr/lib64/python3.6/site-packages/gi/overrides/GObject.py", line 218, 
in __init__ self.set_value(py_value) File "/usr/lib64/python3.6/site-packages/gi/overrides/GObject.py", line 274, 
in set_value (py_value, type(py_value))) ValueError: Expected string but got False<class 'bool'> 
Auf meinem System läuft Open SuSE Leap 15.0.
Zuletzt geändert von Uwe.Lü am 20. Nov 2018, 12:27, insgesamt 2-mal geändert.
Acer Aspire V17 Nitro - Black Edition, Distribution: openSUSE Leap 15.0 (x86_64), NVIDIA Corporation GM107M (GeForce GTX 860M)
Acer Extensa, Distribution: openSuse Leap 15.0, Kernel-Version: 4.12.14-lp150.11-default

Werbung:
Sauerland
Guru
Guru
Beiträge: 3248
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: Firewall startet nicht

Beitrag von Sauerland » 12. Nov 2018, 16:06

Als root:

Code: Alles auswählen

zypper se -si firewall

Code: Alles auswählen

zypper lr -d
Desktop: OpenSUSE Leap 15.0, Nvidia-Grafik Kernel 4.x
Laptop: OpenSUSE Leap 15.0, Intel-Skylake, Kernel 4.12

Benutzeravatar
Uwe.Lü
Hacker
Hacker
Beiträge: 469
Registriert: 7. Nov 2004, 22:21

Re: Firewall startet nicht

Beitrag von Uwe.Lü » 13. Nov 2018, 14:27

Danke für die schnelle Antwort, hier die Ausgaben:

Code: Alles auswählen

linux1:~ # zypper se -si firewall
Loading repository data...
Reading installed packages...

S  | Name             | Type    | Version            | Arch   | Repository               
---+------------------+---------+--------------------+--------+--------------------------
i+ | firewall-config  | package | 0.5.5-lp150.2.12.1 | noarch | openSUSE-Leap-15.0-Update
i  | firewall-macros  | package | 0.5.5-lp150.2.12.1 | noarch | openSUSE-Leap-15.0-Update
i+ | firewalld        | package | 0.5.5-lp150.2.12.1 | noarch | openSUSE-Leap-15.0-Update
i  | firewalld-lang   | package | 0.5.5-lp150.2.12.1 | noarch | openSUSE-Leap-15.0-Update
i  | python3-firewall | package | 0.5.5-lp150.2.12.1 | noarch | openSUSE-Leap-15.0-Update
i  | yast2-firewall   | package | 4.0.26-lp150.2.3.1 | noarch | openSUSE-Leap-15.0-Update
linux1:~ # zypper lr -d
Repository priorities are without effect. All enabled repositories share the same priority.

#  | Alias                     | Name                                    | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                      | Service
---+---------------------------+-----------------------------------------+---------+-----------+---------+----------+--------+--------------------------------------------------------------------------+--------
 1 | download.nvidia.com-leap  | nVidia Graphics Drivers                 | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | https://download.nvidia.com/opensuse/leap/15.0                           |        
 2 | openSUSE-Leap-15.0-1      | openSUSE-Leap-15.0-1                    | No      | ----      | ----    |   99     | rpm-md | cd:///?devices=/dev/disk/by-id/ata-MATSHITADVD-RAM_UJ8E2Q_H088_317580    |        
 3 | packman.inode.at-suse     | Packman Repository                      | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://packman.inode.at/suse/openSUSE_Leap_15.0/                         |        
 4 | repo-debug                | openSUSE-Leap-15.0-Debug                | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/distribution/leap/15.0/repo/oss/      |        
 5 | repo-debug-non-oss        | openSUSE-Leap-15.0-Debug-Non-Oss        | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/distribution/leap/15.0/repo/non-oss/  |        
 6 | repo-debug-update         | openSUSE-Leap-15.0-Update-Debug         | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/update/leap/15.0/oss/                 |        
 7 | repo-debug-update-non-oss | openSUSE-Leap-15.0-Update-Debug-Non-Oss | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/update/leap/15.0/non-oss/             |        
 8 | repo-non-oss              | openSUSE-Leap-15.0-Non-Oss              | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/distribution/leap/15.0/repo/non-oss/        |        
 9 | repo-oss                  | openSUSE-Leap-15.0-Oss                  | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/distribution/leap/15.0/repo/oss/            |        
10 | repo-source               | openSUSE-Leap-15.0-Source               | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/source/distribution/leap/15.0/repo/oss/     |        
11 | repo-source-non-oss       | openSUSE-Leap-15.0-Source-Non-Oss       | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/source/distribution/leap/15.0/repo/non-oss/ |        
12 | repo-update               | openSUSE-Leap-15.0-Update               | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/15.0/oss/                       |        
13 | repo-update-non-oss       | openSUSE-Leap-15.0-Update-Non-Oss       | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/15.0/non-oss/                   |        
linux1:~ # 
Acer Aspire V17 Nitro - Black Edition, Distribution: openSUSE Leap 15.0 (x86_64), NVIDIA Corporation GM107M (GeForce GTX 860M)
Acer Extensa, Distribution: openSuse Leap 15.0, Kernel-Version: 4.12.14-lp150.11-default

Benutzeravatar
gehrke
Moderator
Moderator
Beiträge: 1855
Registriert: 10. Nov 2012, 11:00
Wohnort: Münsterland

Re: Firewall startet nicht

Beitrag von gehrke » 13. Nov 2018, 19:09

Vermutlich erhöhst Du deine Chancen, Dein Problem zu lösen, wenn Du:
1. versuchsweise den Service Firewall von Hand startet und Dir mal den Status ansiehst
2. das System-Journal zu diesem Zeitpunkt auswertest und hier postest, falls Dich das nicht schon weiter bringt.

Benutzeravatar
Geier0815
Administrator
Administrator
Beiträge: 4291
Registriert: 14. Jun 2004, 09:12

Re: Firewall startet nicht

Beitrag von Geier0815 » 14. Nov 2018, 09:20

Ich weiß nicht ob es in diesem Fall die Ursache ist, aber firewalld und die yast2-firewall scheinen nicht gemeinsam laufen zu können. Zumindest hatte hier jemand vor kurzem erst das Problem das firewalld nach reboot nicht automatisch gestartet wurde, eben aus diesem Grund.
Wenn Windows die Lösung ist...
kann ich dann bitte das Problem zurück haben?

Benutzeravatar
Uwe.Lü
Hacker
Hacker
Beiträge: 469
Registriert: 7. Nov 2004, 22:21

Re: Firewall startet nicht

Beitrag von Uwe.Lü » 14. Nov 2018, 09:29

gehrke hat geschrieben:
13. Nov 2018, 19:09
1. versuchsweise den Service Firewall von Hand startet und Dir mal den Status ansiehst
wie mache ich das?
Acer Aspire V17 Nitro - Black Edition, Distribution: openSUSE Leap 15.0 (x86_64), NVIDIA Corporation GM107M (GeForce GTX 860M)
Acer Extensa, Distribution: openSuse Leap 15.0, Kernel-Version: 4.12.14-lp150.11-default

Benutzeravatar
Geier0815
Administrator
Administrator
Beiträge: 4291
Registriert: 14. Jun 2004, 09:12

Re: Firewall startet nicht

Beitrag von Geier0815 » 14. Nov 2018, 11:45

Code: Alles auswählen

systemctl start firewalld.service
systemctl status firewalld.service
journalctl -u firewalld
Wenn Windows die Lösung ist...
kann ich dann bitte das Problem zurück haben?

Benutzeravatar
Uwe.Lü
Hacker
Hacker
Beiträge: 469
Registriert: 7. Nov 2004, 22:21

Re: Firewall startet nicht

Beitrag von Uwe.Lü » 14. Nov 2018, 16:55

Hier die Ausgaben:

Code: Alles auswählen

linux1:~ # systemctl start firewalld.service
linux1:~ # systemctl status firewalld.service
● firewalld.service - firewalld - dynamic firewall daemon
   Loaded: loaded (/usr/lib/systemd/system/firewalld.service; disabled; vendor preset: disabled)
   Active: active (running) since Wed 2018-11-14 16:52:18 CET; 14s ago
     Docs: man:firewalld(1)
 Main PID: 20350 (firewalld)
    Tasks: 2 (limit: 4915)
   CGroup: /system.slice/firewalld.service
           └─20350 /usr/bin/python3 -Es /usr/sbin/firewalld --nofork --nopid

Nov 14 16:52:18 linux1 systemd[1]: Starting firewalld - dynamic firewall daemon...
Nov 14 16:52:18 linux1 systemd[1]: Started firewalld - dynamic firewall daemon.

Code: Alles auswählen

linux1:~ # journalctl -u firewalld
-- Logs begin at Wed 2018-11-14 14:41:17 CET, end at Wed 2018-11-14 16:52:18 CET. --
Nov 14 16:52:18 linux1 systemd[1]: Starting firewalld - dynamic firewall daemon...
Nov 14 16:52:18 linux1 systemd[1]: Started firewalld - dynamic firewall daemon.
linux1:~ # 
Zuletzt geändert von gehrke am 14. Nov 2018, 18:18, insgesamt 1-mal geändert.
Grund: eigenständige Code-Blöcke
Acer Aspire V17 Nitro - Black Edition, Distribution: openSUSE Leap 15.0 (x86_64), NVIDIA Corporation GM107M (GeForce GTX 860M)
Acer Extensa, Distribution: openSuse Leap 15.0, Kernel-Version: 4.12.14-lp150.11-default

Benutzeravatar
gehrke
Moderator
Moderator
Beiträge: 1855
Registriert: 10. Nov 2012, 11:00
Wohnort: Münsterland

Re: Firewall startet nicht

Beitrag von gehrke » 14. Nov 2018, 18:58

Für mich sieht das nicht nach einem Problem mit firewalld aus, denn dieser Service startet scheinbar fehlerfrei.

Vielmehr scheint es ein Problem mit yast zu geben. Da bin ich als nicht-SUSE-User raus.

Hier noch mal den Hinweis von Geier0815 beachten.
Vermutlich meint er das hier: https://linux-club.de/forum/viewtopic.php?f=90&t=122588

Benutzeravatar
susejunky
Hacker
Hacker
Beiträge: 428
Registriert: 19. Sep 2014, 18:22

Re: Firewall startet nicht

Beitrag von susejunky » 14. Nov 2018, 23:44

Hallo Uwe.Lü,
Uwe.Lü hat geschrieben:
14. Nov 2018, 16:55
Hier die Ausgaben:

Code: Alles auswählen

linux1:~ # systemctl start firewalld.service
linux1:~ # systemctl status firewalld.service
● firewalld.service - firewalld - dynamic firewall daemon
   Loaded: loaded (/usr/lib/systemd/system/firewalld.service; disabled; vendor preset: disabled)
   Active: active (running) since Wed 2018-11-14 16:52:18 CET; 14s ago
     Docs: man:firewalld(1)
 Main PID: 20350 (firewalld)
    Tasks: 2 (limit: 4915)
   CGroup: /system.slice/firewalld.service
           └─20350 /usr/bin/python3 -Es /usr/sbin/firewalld --nofork --nopid

Nov 14 16:52:18 linux1 systemd[1]: Starting firewalld - dynamic firewall daemon...
Nov 14 16:52:18 linux1 systemd[1]: Started firewalld - dynamic firewall daemon.
Die Ausgabe

Code: Alles auswählen

...
Loaded: loaded (/usr/lib/systemd/system/firewalld.service; disabled; vendor preset: disabled)
...
zeigt, dass "firewalld" beim Systemstart nicht automatisch gestartet wird.

Mit dem Befehl (als "root" in einer Konsole)

Code: Alles auswählen

# systemctl enable firewalld
kannst Du das ändern. Danach sollte

Code: Alles auswählen

> systemctl status firewalld
folgendes Ergebnis liefern

Code: Alles auswählen

...
Loaded: loaded (/usr/lib/systemd/system/firewalld.service; enabled; vendor preset: disabled)
...
Möglicherweise ist damit auch das Problem

Code: Alles auswählen

Fehler beim Ausführen des Befehls "[["/usr/bin/firewall-config"]]"
beseitigt.

Viele Grüße

susejunky

Benutzeravatar
Heinz-Peter
Guru
Guru
Beiträge: 1998
Registriert: 24. Okt 2005, 14:04

Re: Firewall startet nicht

Beitrag von Heinz-Peter » 15. Nov 2018, 19:13

Hallo Linux Freunde,

ich bin ein Leap Nutzer und frage mich: Erstens- wer braucht zwei Firewall? :irre:
Zweitens- warum werden die einfach so, auf ein System installiert?

Grüße Heinz-Peter
Mein Betriebssystem: Suse 13.2/42.2/42.3, Prozessor: Pentium 4 550 (3,40 GHz, FSB800, Hyper-Threading), Grafikkarte: Nvidia Geforce 6610XL (PCIe)/128MByte.
Wir müssen lernen, entweder als Brüder miteinander zu leben oder als Narren unterzugehen.

Benutzeravatar
susejunky
Hacker
Hacker
Beiträge: 428
Registriert: 19. Sep 2014, 18:22

Re: Firewall startet nicht

Beitrag von susejunky » 15. Nov 2018, 20:14

Hallo Heinz-Peter,
Heinz-Peter hat geschrieben:
15. Nov 2018, 19:13
... wer braucht zwei Firewall?
Wenn das von Uwe.Lü gezeigte Ergebnis zu

Code: Alles auswählen

# zypper se -si firewall
valide ist, dann dürfte auf dem System von Uwe.Lü nur eine Firewall installiert sein.
Heinz-Peter hat geschrieben:
15. Nov 2018, 19:13
... warum werden die einfach so, auf ein System installiert?
Bei allen meinen Neu-Installationen von openSUSE Leap 15.0 wurde immer nur "firewalld" installiert.

Möglicherweise wird "firewalld" bei der Aktualisierung von openSUSE Leap 42.3 auf 15.0 installiert, die unter 42.3 verwendete "SuSEfirewall2" jedoch nicht deinstalliert (reine Spekulation meinerseits!).

Viele Grüße

susejunky

Benutzeravatar
Heinz-Peter
Guru
Guru
Beiträge: 1998
Registriert: 24. Okt 2005, 14:04

Re: Firewall startet nicht

Beitrag von Heinz-Peter » 15. Nov 2018, 20:36

Hallo susejunky,

vielen Dank für die Erklärung :thumbs:

Grüße Heinz-Peter
Mein Betriebssystem: Suse 13.2/42.2/42.3, Prozessor: Pentium 4 550 (3,40 GHz, FSB800, Hyper-Threading), Grafikkarte: Nvidia Geforce 6610XL (PCIe)/128MByte.
Wir müssen lernen, entweder als Brüder miteinander zu leben oder als Narren unterzugehen.

Benutzeravatar
Uwe.Lü
Hacker
Hacker
Beiträge: 469
Registriert: 7. Nov 2004, 22:21

Re: Firewall startet nicht

Beitrag von Uwe.Lü » 20. Nov 2018, 12:26

Das Problem ist gelöst. Ich bin wie folgt vorgegangen:
1. Über Yast habe ich die Yast-Firewall und firewall-config gelöscht.
2. danach zypper dup - die Yast-Firewall wurde wieder installiert.
3. Über Yast - Dienste die firewalld aktivieren, fertig.

Jetzt startet Yast Firewall wieder.
Danke an alle, die sich dieses Themas angenommen haben.

LG Uwe
Acer Aspire V17 Nitro - Black Edition, Distribution: openSUSE Leap 15.0 (x86_64), NVIDIA Corporation GM107M (GeForce GTX 860M)
Acer Extensa, Distribution: openSuse Leap 15.0, Kernel-Version: 4.12.14-lp150.11-default

Antworten