Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[erledigt] Firewalld startet nicht automatisch beim Booten

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
Benutzeravatar
f.gruber
Hacker
Hacker
Beiträge: 414
Registriert: 24. Jun 2006, 19:40
Wohnort: Bad Schallerbach

[erledigt] Firewalld startet nicht automatisch beim Booten

Beitrag von f.gruber » 8. Nov 2018, 20:11

Hallo,
ich muss unter openSuse Leap 15 nach jedem Server reboot das Service firewalld manuell starten. Da in letzter Zeit so oft Kernel Updates installiert werden, die einen Neustart erfordern, ist das ziemlich lästig.

Wüsste nicht, dass ich etwas falsch gemacht haben sollte.

Das Kommando

Code: Alles auswählen

systemctl enable firewalld.service
sollte doch dafür sorgen, dass der Dienst automatisch gestartet wird.
Außerdem habe ich auch mit YAST - Diensteverwaltung kontrolliert und sehe in der Spalte Start den Eintrag On Boot beim Dienst firewalld.

Kennt dieses Verhalten noch jemand bzw. kann mir jemand einen Tipp geben?
Zuletzt geändert von f.gruber am 9. Nov 2018, 22:29, insgesamt 1-mal geändert.
Gruß
Ferdinand

Werbung:
spoensche
Moderator
Moderator
Beiträge: 7395
Registriert: 30. Okt 2004, 23:53
Wohnort: Siegen

Re: Firewalld startet nicht automatisch beim Booten

Beitrag von spoensche » 9. Nov 2018, 18:03

Poste mal die Ausgabe von

Code: Alles auswählen

systemctl status firewalld.service

Benutzeravatar
f.gruber
Hacker
Hacker
Beiträge: 414
Registriert: 24. Jun 2006, 19:40
Wohnort: Bad Schallerbach

Re: Firewalld startet nicht automatisch beim Booten

Beitrag von f.gruber » 9. Nov 2018, 21:12

Code: Alles auswählen

systemctl status firewalld.service

Code: Alles auswählen

● firewalld.service - firewalld - dynamic firewall daemon
   Loaded: loaded (/usr/lib/systemd/system/firewalld.service; enabled; vendor preset: disabled)
   Active: active (running) since Thu 2018-11-08 20:02:48 CET; 1 day 1h ago
     Docs: man:firewalld(1)
 Main PID: 1716 (firewalld)
    Tasks: 2 (limit: 4915)
   CGroup: /system.slice/firewalld.service
           └─1716 /usr/bin/python3 -Es /usr/sbin/firewalld --nofork --nopid

Nov 08 20:02:47 t2792 systemd[1]: Starting firewalld - dynamic firewall daemon...
Nov 08 20:02:48 t2792 systemd[1]: Started firewalld - dynamic firewall daemon.
Gruß
Ferdinand

Benutzeravatar
f.gruber
Hacker
Hacker
Beiträge: 414
Registriert: 24. Jun 2006, 19:40
Wohnort: Bad Schallerbach

Re: Firewalld startet nicht automatisch beim Booten

Beitrag von f.gruber » 9. Nov 2018, 21:19

Kann man da vielleicht etwas herauslesen?

Code: Alles auswählen

journalctl -b | grep firewalld

Code: Alles auswählen

Nov 08 20:01:57  systemd[1]: is_symlink_with_known_name(firewalld.service, firewalld.service) → 1
Nov 08 20:02:47 systemd[1]: Starting firewalld - dynamic firewall daemon...
Nov 08 20:02:48 systemd[1]: Started firewalld - dynamic firewall daemon.
Nov 08 20:07:12 systemd[1]: is_symlink_with_known_name(firewalld.service, firewalld.service) → 1
Nov 08 20:07:13 systemd[1]: is_symlink_with_known_name(firewalld.service, firewalld.service) → 1
Nov 08 20:07:16 systemd[1]: is_symlink_with_known_name(firewalld.service, firewalld.service) → 1
Nov 08 20:07:17 systemd[1]: is_symlink_with_known_name(firewalld.service, firewalld.service) → 1
Nov 08 20:07:22 systemd[1]: is_symlink_with_known_name(firewalld.service, firewalld.service) → 1
Nov 08 20:07:23 systemd[1]: is_symlink_with_known_name(firewalld.service, firewalld.service) → 1
Gruß
Ferdinand

Benutzeravatar
susejunky
Hacker
Hacker
Beiträge: 425
Registriert: 19. Sep 2014, 18:22

Re: Firewalld startet nicht automatisch beim Booten

Beitrag von susejunky » 9. Nov 2018, 21:49

Hallo f.gruber,
f.gruber hat geschrieben:
8. Nov 2018, 20:11
... ich muss unter openSuse Leap 15 nach jedem Server reboot das Service firewalld manuell starten.
...
Außerdem habe ich auch mit YAST - Diensteverwaltung kontrolliert und sehe in der Spalte Start den Eintrag On Boot beim Dienst firewalld.
Ist auf diesem System auch noch SuSEfirewall2 installiert? Meines Wissens können firewalld und SuSEfirewall2 nicht parallel genutzt werden.

Auf der SUSE-Mailingliste gab es diesen Beitrag "https://lists.opensuse.org/opensuse/201 ... 00641.html". Ich habe ihn nicht weiter verfolgt, aber vielleicht hilft er Dir weiter (z.B.: "https://lists.opensuse.org/opensuse/201 ... 00678.html").

Viele Grüße

susejunky

Benutzeravatar
f.gruber
Hacker
Hacker
Beiträge: 414
Registriert: 24. Jun 2006, 19:40
Wohnort: Bad Schallerbach

Re: Firewalld startet nicht automatisch beim Booten

Beitrag von f.gruber » 9. Nov 2018, 22:29

Danke für diesen Hinweis.

Ich habe SuSEfirewall2 mit YAST deinstalliert und dann einen reboot gemacht.

Und der firewalld läuft :p
Gruß
Ferdinand

Antworten