Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[gelöst] Leap 15 Bootmenü Einträge zu anderer leap version und win10 verschwunden

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
gorgonz
Member
Member
Beiträge: 168
Registriert: 13. Mai 2006, 19:37
Wohnort: Frankenland

[gelöst] Leap 15 Bootmenü Einträge zu anderer leap version und win10 verschwunden

Beitrag von gorgonz » 26. Okt 2018, 14:40

Hab jetzt auf 2 Systemen das Problem, dass die bisherigen Bootmenüpunkte verschwunden sind und nur noch "leap 15" und "Advanced options" angeboten wird.

Bei einem System (ohne Windows) Partition) hatte ich eine (von 3) Platten geputzt und leap 15 neu installiert. Beim ersten Boot war das komplette Menü noch da, nach dem Update aller Pakete nur die schon erwähnten 2 Menüpunkte. hmm, das könnte auch was anderes sein, weil die Neuinstallation erfolgte, weil der Boot nicht mehr zuverlässig klappte ;-).

Beim anderen System (mit Win10) habe ich nur normal Updates gefahren und Win10 in diesem Zeitraum nicht gebootet.

Wisst ihr, ob da was in Arbeit ist oder muss ich das Bootmenü selbst reparieren? Oder gibt es die Möglichkeit, die Partitionen wieder auf Bootpartitionen scannen zu lassen und daraus ein neues Bootmenü zu erstellen?

Vielen Dank vorab schon für Ideen dazu :-)
Zuletzt geändert von gorgonz am 26. Okt 2018, 16:05, insgesamt 1-mal geändert.
Meine Systeme:
PC (I7-2600K): openSUSE leap 15.0 (64bit), QT 5.9.4, KDE Frameworks 5.45.0, 4.12.14-lp150.12.22-default
Laptop: Samsung RC530 (I7-2670QM), openSUSE tumbleweed, QT 5.11.0, KDE Frameworks 5.47.0, kernel 4.17.5-1-default

Werbung:
Benutzeravatar
Uwe.Lü
Hacker
Hacker
Beiträge: 466
Registriert: 7. Nov 2004, 22:21

Re: Leap 15 Bootmenü Einträge zu anderer leap version und win10 verschwunden

Beitrag von Uwe.Lü » 26. Okt 2018, 15:40

Also, OS Leap 15.0 kann Uefi. Ich hatte mal ein gleich gelagertes Problem und habe die Installation nach einmal angestossen.
Irgend wann meldet sich die Installation, das Uefi ordnungsgemäß installiert ist, dann die Installation abbrechen und neu starten.
Das sollte helfen.
Acer Aspire V17 Nitro - Black Edition, Distribution: openSUSE Leap 15.0 (x86_64), NVIDIA Corporation GM107M (GeForce GTX 860M)
Acer Extensa, Distribution: openSuse Leap 15.0, Kernel-Version: 4.12.14-lp150.11-default

gorgonz
Member
Member
Beiträge: 168
Registriert: 13. Mai 2006, 19:37
Wohnort: Frankenland

[gelöst] Leap 15 Bootmenü Einträge zu anderer leap version und win10 verschwunden

Beitrag von gorgonz » 26. Okt 2018, 16:04

Vielen Dank für Deine schnelle Antwort, Uwe.Lü :-)

Ja, daran dachte ich auch als Erstes. Aber da mein Mainboard schon etwas in die Jahre gekommen ist, hatte ich von Anfang an auf UEFI verzichtet. Daher dürfte das keine Rolle spielen.

Beim Suchen einer Lösung bin ich jetzt auf einen Beitrag im OpenSuse-Forum gestoßen, der meinen Verdacht bestätigt. Es ist tatsächlich über das Update ein fehlerhafter Bootmanager installiert worden und es wird sogar eine Abhilfe vorgeschlagen, die bei mir (vorerst) geholfen hat:

YaST => Bootloader und Tab "Bootloader-Optionen"
Option "Fremdes OS testen" deaktivieren und "OK"

Dann das Gleiche wieder und den Haken wieder setzen.

Bei mir sind jetzt wieder alle Bootoptionen vorhanden, der Beitrag signalisiert jedoch, dass derzeit Vorsicht bei Bootloader Update angesagt ist, bis der Fehler gefixed ist.

Bei Interesse der Link zu diesem Eintrag: https://www.opensuse-forum.de/thread/41 ... /?pageNo=1
Meine Systeme:
PC (I7-2600K): openSUSE leap 15.0 (64bit), QT 5.9.4, KDE Frameworks 5.45.0, 4.12.14-lp150.12.22-default
Laptop: Samsung RC530 (I7-2670QM), openSUSE tumbleweed, QT 5.11.0, KDE Frameworks 5.47.0, kernel 4.17.5-1-default

Antworten