Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[gelöst] Finde keinen Treiber für Broadcom BCM4134

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
gorgonz
Member
Member
Beiträge: 166
Registriert: 13. Mai 2006, 19:37
Wohnort: Frankenland

[gelöst] Finde keinen Treiber für Broadcom BCM4134

Beitrag von gorgonz » 14. Sep 2018, 20:15

Es geht um einen Laptop Dell Inspiron. Laut HW Info sitzt ein WLAN Chip BCM43142A0 drauf

Ich finde viele Infos zu diversen BCM Chips, aber nichts zu diesem.

Anlass ist natürlich, dass WLAN nicht geht ;-)
Zuletzt geändert von gorgonz am 16. Sep 2018, 19:19, insgesamt 1-mal geändert.
Meine Systeme:
PC (I7-2600K): openSUSE leap 15.0 (64bit), QT 5.9.4, KDE Frameworks 5.45.0, 4.12.14-lp150.12.13-default
Laptop: Samsung RC530 (I7-2670QM), openSUSE tumbleweed, QT 5.11.0, KDE Frameworks 5.47.0, kernel 4.17.5-1-default

Werbung:
Benutzeravatar
tomm.fa
Moderator
Moderator
Beiträge: 5161
Registriert: 21. Jan 2006, 17:18
Wohnort: OWL - Kreis Gütersloh
Kontaktdaten:

Re: Finde keinen Treiber für BCM4134

Beitrag von tomm.fa » 14. Sep 2018, 20:33

https://linux-club.de/wiki/opensuse/Broadcom_Wireless

Ansonsten:

Distribution ist?
Ausgabe von:

Code: Alles auswählen

cat /etc/*release
Verwendeter Kernel ist?
Ausgabe von:

Code: Alles auswählen

uname -a
Hartware um welche es genau geht ist welche?
Ausgabe von:

Code: Alles auswählen

/sbin/lspci -nnk | grep -i -A3 net
Linupedia - Wiki des Linux-Club.
Keine Unterstützung/Hilfestellung per PN!

gorgonz
Member
Member
Beiträge: 166
Registriert: 13. Mai 2006, 19:37
Wohnort: Frankenland

Re: Finde keinen Treiber für BCM4134

Beitrag von gorgonz » 15. Sep 2018, 00:02

Mist ... klar ... ich hab die Versionsinfos vergessen. Sorry, ich musste weg und wollte die Anfrage noch einstellen ;-)
Aber jetzt ...

Code: Alles auswählen

cat /etc/*release

Code: Alles auswählen

NAME="openSUSE Leap"
VERSION="15.0"
ID="opensuse-leap"
ID_LIKE="suse opensuse"
VERSION_ID="15.0"
PRETTY_NAME="openSUSE Leap 15.0"
ANSI_COLOR="0;32"
CPE_NAME="cpe:/o:opensuse:leap:15.0"

Code: Alles auswählen

uname -a

Code: Alles auswählen

Linux linux-wsdu 4.12.14-lp150.12.16-default #1 SMP Tue Aug 14 17:51:27 UTC 2018 (28574e6) x86_64 x86_64 x86_64 GNU/Linux

Code: Alles auswählen

/sbin/lspci -nnk | grep -i -A3 net

Code: Alles auswählen

02:00.0 Network controller [0280]: Broadcom Limited BCM43142 802.11b/g/n [14e4:4365] (rev 01)
        Subsystem: Dell Wireless 1704 802.11n + BT 4.0 [1028:0016]
        Kernel driver in use: bcma-pci-bridge
        Kernel modules: bcma
03:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8101/2/6E PCI Express Fast Ethernet controller [10ec:8136] (rev 05)
        Subsystem: Dell Device [1028:0565]
        Kernel driver in use: r8169
        Kernel modules: r8169
Meine Systeme:
PC (I7-2600K): openSUSE leap 15.0 (64bit), QT 5.9.4, KDE Frameworks 5.45.0, 4.12.14-lp150.12.13-default
Laptop: Samsung RC530 (I7-2670QM), openSUSE tumbleweed, QT 5.11.0, KDE Frameworks 5.47.0, kernel 4.17.5-1-default

Sauerland
Guru
Guru
Beiträge: 3191
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: Finde keinen Treiber für BCM4134

Beitrag von Sauerland » 15. Sep 2018, 07:55

Einfachste Möglichkeit:
Und hier mit broadcom-wl aus dem Packman Repo.
https://linux-club.de/wiki/opensuse/Bro ... oadcom-sta
Desktop: OpenSUSE Leap 15.0, Nvidia-Grafik Kernel 4.x
Laptop: OpenSUSE Leap 15.0, Intel-Skylake, Kernel 4.12

Benutzeravatar
tomm.fa
Moderator
Moderator
Beiträge: 5161
Registriert: 21. Jan 2006, 17:18
Wohnort: OWL - Kreis Gütersloh
Kontaktdaten:

Re: Finde keinen Treiber für BCM4134

Beitrag von tomm.fa » 15. Sep 2018, 08:05

Halte dich an:
Um genauer zu sein: https://linux-club.de/wiki/opensuse/Bro ... oadcom-sta

Es scheint so das die passende Firmware für diese Karte in keinem Paket mitgeliefert wird. Diese ist weder im Kernel selbst, in kernel-firmware oder bcm43xx-firmware enthalten. Ob das Paket pullin-bcm43xx-firmware helfen würde, kann ich (noch nicht) nicht beurteilen.

Mich würde noch die Ausgabe von

Code: Alles auswählen

dmesg | grep -Ei "firmware|wlan|bcma|brcm"
interessieren.
Linupedia - Wiki des Linux-Club.
Keine Unterstützung/Hilfestellung per PN!

gorgonz
Member
Member
Beiträge: 166
Registriert: 13. Mai 2006, 19:37
Wohnort: Frankenland

Re: Finde keinen Treiber für BCM4134

Beitrag von gorgonz » 15. Sep 2018, 12:59

Vielen Dank für eure guten Rückmeldungen :-)

Ich habe es so inzwischen hinbekommen, überlege jetzt, wie ich das für andere dokumentieren kann.
Also, es hat alles mit Bordmitteln geklappt, das heißt über normales Installieren von Paketen aus den gängigen Repositories inkl. packman. Allerdings hatte ich den Moment der richtigen Konfigurierung verpasst, weil der Befehl

Code: Alles auswählen

systemctl restart NetworkManager.service
den Treiber doch nicht sofort übernommen hat. Daher habe ich erst nach mehreren Aktivitäten nach einem Boot gemerkt, dass es jetzt doch geklappt hat.

Mensch tomm.fa, Deine Frage habe ich zu spät gelesen, trotzdem noch den dmesg (aus dem jetzt funktionierenden System):

Code: Alles auswählen

dmesg | grep -Ei "firmware|wlan|bcma|brcm"
[    0.017670] Spectre V2 : Enabling Restricted Speculation for firmware calls
[    0.086387] ACPI: [Firmware Bug]: BIOS _OSI(Linux) query ignored
[    3.568879] [Firmware Bug]: ACPI(PEGP) defines _DOD but not _DOS
[    5.054978] wlan0: Broadcom BCM4365 802.11 Hybrid Wireless Controller 6.30.223.271 (r587334)
[    6.574650] bluetooth hci0: Direct firmware load for brcm/BCM.hcd failed with error -2
[    6.574652] Bluetooth: hci0: BCM: Patch brcm/BCM.hcd not found
[ 1474.946138] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
Hier also nur, was ich in Summe geändert habe ;-)

So war die Situation, als es noch nicht geklappt hatte:
https://picload.org/view/dlppdrol/yast- ... e.png.html

Dann habe ich sukzessive Pakete dazu genommen mit diesem Ergebnis:
https://picload.org/view/dlppdril/yast- ... r.png.html

Dabei sind bcm43legacy, broadcom-wl und broadcom-wl-kmp-default von packman geholt. Vielleicht hat es ja auch alle Pakete gebraucht, bevor es funktioniert hat ;-)

Fragen, um besser dokumentieren zu können:
- Wie geht es eigentlich, Bilder hier in den Beitrag zu integrieren? Musste jetzt auf picload.org Link ausweichen
- Am liebsten hätte ich die Repo-Informationen zu installierten broadcom Paketen inkl. Version und Repositoryname als Text geholt, aber ist mir (mit zypper se) nicht gelungen

Achja, der restart des NetworkManagers hat wahrscheinlich deshalb nicht geklappt, weil ich zwischendurch mal auf wicked zurückgestellt habe und da hätte ich einen anderen Befehl für den restart eingeben müssen ;-). Nur bei wicked gibt es (für mich) die Möglichkeit, neue Netzwerkkarten einzutragen. Wäre das auch mit NetworkManager gegangen? Wie?
Meine Systeme:
PC (I7-2600K): openSUSE leap 15.0 (64bit), QT 5.9.4, KDE Frameworks 5.45.0, 4.12.14-lp150.12.13-default
Laptop: Samsung RC530 (I7-2670QM), openSUSE tumbleweed, QT 5.11.0, KDE Frameworks 5.47.0, kernel 4.17.5-1-default

Benutzeravatar
tomm.fa
Moderator
Moderator
Beiträge: 5161
Registriert: 21. Jan 2006, 17:18
Wohnort: OWL - Kreis Gütersloh
Kontaktdaten:

Re: Finde keinen Treiber für BCM4134

Beitrag von tomm.fa » 15. Sep 2018, 13:20

gorgonz hat geschrieben:
15. Sep 2018, 12:59
Allerdings hatte ich den Moment der richtigen Konfigurierung verpasst, weil der Befehl

Code: Alles auswählen

systemctl restart NetworkManager.service
den Treiber doch nicht sofort übernommen hat. Daher habe ich erst nach mehreren Aktivitäten nach einem Boot gemerkt, dass es jetzt doch geklappt hat.
Wenn du Wicked verwendest, dann bringt ein Neustart vom NetworkManager auch nichts, steht aber auch im Artikel der Linupedia was stattdessen verwendet werden soll.

gorgonz hat geschrieben:
15. Sep 2018, 12:59
Dabei sind bcm43legacy, broadcom-wl und broadcom-wl-kmp-default von packman geholt. Vielleicht hat es ja auch alle Pakete gebraucht, bevor es funktioniert hat ;-)
Eigentlich brauchst du nur broadcom-wl und broadcom-wl-kmp-default.

gorgonz hat geschrieben:
15. Sep 2018, 12:59
- Wie geht es eigentlich, Bilder hier in den Beitrag zu integrieren? Musste jetzt auf picload.org Link ausweichen
Andere Möglichkeiten gibt es hier auch nicht.

gorgonz hat geschrieben:
15. Sep 2018, 12:59
- Am liebsten hätte ich die Repo-Informationen zu installierten broadcom Paketen inkl. Version und Repositoryname als Text geholt, aber ist mir (mit zypper se) nicht gelungen
Du hast die anderen Ausgaben doch auch aus der Konsole hierhin bekommen. Oder wusstest du den richtigen Befehl für Zypper nicht?

Code: Alles auswählen

zypper se -si broadcom b43 bcm
wäre eine Möglichkeit gewesen.

gorgonz hat geschrieben:
15. Sep 2018, 12:59
Achja, der restart des NetworkManagers hat wahrscheinlich deshalb nicht geklappt, weil ich zwischendurch mal auf wicked zurückgestellt habe und da hätte ich einen anderen Befehl für den restart eingeben müssen ;-).
Siehe meine erste Antwort hier im Beitrag.
gorgonz hat geschrieben:
15. Sep 2018, 12:59
Nur bei wicked gibt es (für mich) die Möglichkeit, neue Netzwerkkarten einzutragen. Wäre das auch mit NetworkManager gegangen? Wie?
Da ich diesen nicht verwende… keine Ahnung.
Linupedia - Wiki des Linux-Club.
Keine Unterstützung/Hilfestellung per PN!

gorgonz
Member
Member
Beiträge: 166
Registriert: 13. Mai 2006, 19:37
Wohnort: Frankenland

Re: Finde keinen Treiber für BCM4134

Beitrag von gorgonz » 16. Sep 2018, 19:26

tomm.fa hat geschrieben:
15. Sep 2018, 13:20

Code: Alles auswählen

zypper se -si broadcom b43 bcm
wäre eine Möglichkeit gewesen.
Hey tomm,fa, genauso was habe ich gesucht, Danke Dir! :-)

So, fertig!
Meine Systeme:
PC (I7-2600K): openSUSE leap 15.0 (64bit), QT 5.9.4, KDE Frameworks 5.45.0, 4.12.14-lp150.12.13-default
Laptop: Samsung RC530 (I7-2670QM), openSUSE tumbleweed, QT 5.11.0, KDE Frameworks 5.47.0, kernel 4.17.5-1-default

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast