Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

firewalld startet nicht automatisch

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
th.giese
Hacker
Hacker
Beiträge: 305
Registriert: 16. Apr 2006, 13:32

firewalld startet nicht automatisch

Beitrag von th.giese » 7. Aug 2018, 18:13

Hallo zusammen,

ich hab openSUSE Leap 15 installiert mit KDE. Nachdem ich eine Joomla!-Umgebung lokal installiert habe, wollte ich alles im Netzwerk testen. Mit anderen Geräten habe ich keinen Zugriff erhalten. Aus Vorerfahrungen mit anderen Versionen von openSUSE hatte ich sofort einen geschlossenen Port der Firewall in Verdacht. Beim Start des Yast-Moduls Firewall ist mir dann aufgefallen, dass es da einen Firewall-Daemon geben muss. Also flugs die Dienstverwaltung inspiziert und siehe da, firewalld war nicht gestartet. Nachdem Start hats dann auch lokal geklappt mit der lokalen Webseite im lokalen Netz.
Nach dem Neustart ist der firewalld allerdings wieder nicht gestartet. Es scheint so, dass die Veränderung im Dienstemanager von Yast nicht permanent gespeichert wird.
Wo muss ich dran drehen, dass der firewalld bei jedem Neustart gleich mit aktiviert wird?
Zuletzt geändert von gehrke am 10. Aug 2018, 07:39, insgesamt 1-mal geändert.
Grund: Titel korrigiert
Bis dann
Thomas

Werbung:
Sauerland
Guru
Guru
Beiträge: 3159
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: fierwalld startet nicht automatisch

Beitrag von Sauerland » 7. Aug 2018, 18:35

Code: Alles auswählen

systemctl enable firewalld
Das startet den Dienst firewalld bei jedem Systemstart.

Siehe:

Code: Alles auswählen

systemctl status firewalld
Desktop: OpenSUSE Leap 42.3, Nvidia-Grafik Kernel 4.4
Laptop: OpenSUSE Leap 42.3, Intel-Skylake, Kernel 4.x, Windows 10

marce
Advanced Hacker
Advanced Hacker
Beiträge: 1054
Registriert: 19. Jun 2008, 13:16
Wohnort: Dettenhausen
Kontaktdaten:

Re: fierwalld startet nicht automatisch

Beitrag von marce » 7. Aug 2018, 18:40

wobei ich da auf irgendwas anderes tippen würde - eine nicht aktive Firewall war noch nie Ursache für fehlgeschlagene Verbindungen...

uhelp
Member
Member
Beiträge: 100
Registriert: 25. Nov 2012, 19:33

Re: fierwalld startet nicht automatisch

Beitrag von uhelp » 7. Aug 2018, 20:58

Doch, das hat das Problem schon gelöst. Aber sehr, sehr indirekt.

firewalld ist ein Dienst, der als Frontend zu nftables agiert, was wiederum der Nachfolger von iptables ist.
Das Problem wurde indirekt erschlagen, da firewalld sogar ein Dbus Interface mitbringt, womit Apps die Firewall zur Laufzeit steuern können. Außerdem kommt es mit einem riesigen Satz an Netfilterregeln und für so ziemlich alle Serivices daher und arbeitet auch mit den üblichen fail2ban usw. gut zusammen.

Auch ein blinder Schmied trifft mal nen Korn.

Gräfin Klara
Hacker
Hacker
Beiträge: 327
Registriert: 23. Jun 2008, 20:51

Re: fierwalld startet nicht automatisch

Beitrag von Gräfin Klara » 8. Aug 2018, 15:58

uhelp hat geschrieben:
7. Aug 2018, 20:58
Doch, das hat das Problem schon gelöst. Aber sehr, sehr indirekt.

firewalld ist ein Dienst, der als Frontend zu nftables agiert, was wiederum der Nachfolger von iptables ist.
Das Problem wurde indirekt erschlagen, da firewalld sogar ein Dbus Interface mitbringt, womit Apps die Firewall zur Laufzeit steuern können. Außerdem kommt es mit einem riesigen Satz an Netfilterregeln und für so ziemlich alle Serivices daher und arbeitet auch mit den üblichen fail2ban usw. gut zusammen.

Auch ein blinder Schmied trifft mal nen Korn.
Das ist eine albtraumhafte Entwicklung von der privat-statischen zur öffentlich-dynamischen Kernelkonfiguration über Netlink, wobei niemand mehr sicher sein kann, ob die gewünschte Sicherheit überhaupt noch gegeben ist. Wenn Applikationen und sogar daemons über d-bus sich ihre eigenen Policies schaffen können, dann wird sie Angelegenheit bedenklich. Man sollte sich gut überlegen, die Sicherheit in die Hände Dritter zu legen. Wenn irgendwelche Programmierer die gewollte Systemsicherheit durch Bugs oder Absicht verändern können, dann ist das gesamte System obsolet. Der logisch nächste Schritt wäre ein Server-Daemon mit d-bus Funktionalität, damit sich ein "Experte" remote die Firewall nach Wunsch konfigurieren kann. Damit minimiert sich der Aufwand für den Staatstrojaner auf ein paar Zeilen Bash.

Gruß
Gräfin Klara

uhelp
Member
Member
Beiträge: 100
Registriert: 25. Nov 2012, 19:33

Re: fierwalld startet nicht automatisch

Beitrag von uhelp » 8. Aug 2018, 18:31

Du träumst von einem sicheren System?
Träum weiter!

In der hiesigen Realität ist Sicherheit ein Prozess, kein Zustand.
Und dieser Prozess verlangt ständiges Mühen und Lernen.

Seit ca. 1960 gibt es keine sicheren Systeme.
Es hat sich nur graduell etwas geändert:
Wir kriegen mehr und schneller Ärger.
Aber wir haben auch die Tools, um das wieder auf ein normal unsicheres Maß zu schrauben.

th.giese
Hacker
Hacker
Beiträge: 305
Registriert: 16. Apr 2006, 13:32

Re: fierwalld startet nicht automatisch

Beitrag von th.giese » 8. Aug 2018, 19:42

Sauerland hat geschrieben:
7. Aug 2018, 18:35

Code: Alles auswählen

systemctl enable firewalld
Das startet den Dienst firewalld bei jedem Systemstart.

Siehe:

Code: Alles auswählen

systemctl status firewalld
Hallo Sauerland,
vielen Dank für Deine Hilfe. Leider bleibt das Problem, nach Eingabe von

Code: Alles auswählen

systemctl enable firewalld
ändert sich nichts. Der Status ist inaktiv, genauso wie es bei Yast im Dienstemanager angezeigt wird:

Code: Alles auswählen

firewalld.service - firewalld - dynamic firewall daemon
   Loaded: loaded (/usr/lib/systemd/system/firewalld.service; enabled; vendor preset: disabled)
   Active: inactive (dead)
     Docs: man:firewalld(1)
:irre:
Bis dann
Thomas

Sauerland
Guru
Guru
Beiträge: 3159
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: fierwalld startet nicht automatisch

Beitrag von Sauerland » 8. Aug 2018, 19:49

Der Status ist inaktiv, genauso wie es bei Yast im Dienstemanager angezeigt wird:
Auch nach einem Neustart?

Ansonsten als root:

Code: Alles auswählen

systemctl start firewalld
Desktop: OpenSUSE Leap 42.3, Nvidia-Grafik Kernel 4.4
Laptop: OpenSUSE Leap 42.3, Intel-Skylake, Kernel 4.x, Windows 10

th.giese
Hacker
Hacker
Beiträge: 305
Registriert: 16. Apr 2006, 13:32

Re: fierwalld startet nicht automatisch

Beitrag von th.giese » 9. Aug 2018, 18:01

Sauerland hat geschrieben:
8. Aug 2018, 19:49
Der Status ist inaktiv, genauso wie es bei Yast im Dienstemanager angezeigt wird:
Auch nach einem Neustart?

Ansonsten als root:

Code: Alles auswählen

systemctl start firewalld
Ja, beim Neustart ist alles wieder beim Alten. Das ist ja mein Problem. Kann man da vielleicht eine Systemdatei manuell verändern?
Bis dann
Thomas

Sauerland
Guru
Guru
Beiträge: 3159
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: fierwalld startet nicht automatisch

Beitrag von Sauerland » 9. Aug 2018, 18:16

Poste:

Code: Alles auswählen

zypper se -si tables firewall
Sowie als root mit su -:

Code: Alles auswählen

systemctl start firewalld
und

Code: Alles auswählen

systemctl status firewalld
Desktop: OpenSUSE Leap 42.3, Nvidia-Grafik Kernel 4.4
Laptop: OpenSUSE Leap 42.3, Intel-Skylake, Kernel 4.x, Windows 10

th.giese
Hacker
Hacker
Beiträge: 305
Registriert: 16. Apr 2006, 13:32

Re: fierwalld startet nicht automatisch

Beitrag von th.giese » 9. Aug 2018, 18:23

Sauerland hat geschrieben:
9. Aug 2018, 18:16
Poste:

Code: Alles auswählen

zypper se -si tables firewall
Sowie als root mit su -:

Code: Alles auswählen

systemctl start firewalld
und

Code: Alles auswählen

systemctl status firewalld
das wird angezeigt:

Code: Alles auswählen

Installierte Pakete werden gelesen...

S  | Name             | Typ       | Version            | Arch   | Repository                     
---+------------------+-----------+--------------------+--------+--------------------------------
i+ | Firewall         | Anwendung |                    | noarch | Haupt-Repository (OSS)         
i+ | Firewall         | Anwendung |                    | noarch | openSUSE-Leap-15.0-1           
i+ | SuSEfirewall2    | Paket     | 3.6.378-lp150.1.15 | noarch | Haupt-Repository (OSS)         
i+ | SuSEfirewall2    | Paket     | 3.6.378-lp150.1.15 | noarch | openSUSE-Leap-15.0-1           
i+ | ebtables         | Paket     | 2.0.10.4-lp150.3.1 | x86_64 | Haupt-Repository (OSS)         
i+ | ebtables         | Paket     | 2.0.10.4-lp150.3.1 | x86_64 | openSUSE-Leap-15.0-1           
i+ | firewall-config  | Paket     | 0.5.3-lp150.2.3.1  | noarch | Hauptaktualisierungs-Repository
i+ | firewall-config  | Paket     | 0.5.3-lp150.2.3.1  | noarch | openSUSE:Leap:15.0:Update      
i+ | firewall-macros  | Paket     | 0.5.3-lp150.2.3.1  | noarch | Hauptaktualisierungs-Repository
i+ | firewall-macros  | Paket     | 0.5.3-lp150.2.3.1  | noarch | openSUSE:Leap:15.0:Update      
i+ | firewalld        | Paket     | 0.5.3-lp150.2.3.1  | noarch | Hauptaktualisierungs-Repository
i+ | firewalld        | Paket     | 0.5.3-lp150.2.3.1  | noarch | openSUSE:Leap:15.0:Update      
i+ | firewalld-lang   | Paket     | 0.5.3-lp150.2.3.1  | noarch | Hauptaktualisierungs-Repository
i+ | firewalld-lang   | Paket     | 0.5.3-lp150.2.3.1  | noarch | openSUSE:Leap:15.0:Update      
i+ | iptables         | Paket     | 1.6.2-lp150.1.1    | x86_64 | Haupt-Repository (OSS)         
i+ | iptables         | Paket     | 1.6.2-lp150.1.1    | x86_64 | openSUSE-Leap-15.0-1           
i+ | libxtables12     | Paket     | 1.6.2-lp150.1.1    | x86_64 | Haupt-Repository (OSS)         
i+ | libxtables12     | Paket     | 1.6.2-lp150.1.1    | x86_64 | openSUSE-Leap-15.0-1           
i+ | python3-firewall | Paket     | 0.5.3-lp150.2.3.1  | noarch | Hauptaktualisierungs-Repository
i+ | python3-firewall | Paket     | 0.5.3-lp150.2.3.1  | noarch | openSUSE:Leap:15.0:Update      
i+ | xtables-plugins  | Paket     | 1.6.2-lp150.1.1    | x86_64 | Haupt-Repository (OSS)         
i+ | xtables-plugins  | Paket     | 1.6.2-lp150.1.1    | x86_64 | openSUSE-Leap-15.0-1           
i+ | yast2-firewall   | Paket     | 4.0.25-lp150.1.1   | noarch | Haupt-Repository (OSS)         
i+ | yast2-firewall   | Paket     | 4.0.25-lp150.1.1   | noarch | openSUSE-Leap-15.0-1
mit

Code: Alles auswählen

systemctl start firewalld
das "start" hab ich in deinem letzten Post überlesen....
Bis dann
Thomas

Sauerland
Guru
Guru
Beiträge: 3159
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: firewalld startet nicht automatisch

Beitrag von Sauerland » 10. Aug 2018, 12:48

Ich hab die SuSEfirewall2 deinstalliert.......
Desktop: OpenSUSE Leap 42.3, Nvidia-Grafik Kernel 4.4
Laptop: OpenSUSE Leap 42.3, Intel-Skylake, Kernel 4.x, Windows 10

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste