Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[Solved] Scanner Plustek OpticPro 9636T

Alles rund um Hardware, die unter Linux läuft oder zum Laufen gebracht werden soll

Moderator: Moderatoren

Antworten
BastiL
Newbie
Newbie
Beiträge: 25
Registriert: 25. Jul 2004, 17:43

[Solved] Scanner Plustek OpticPro 9636T

Beitrag von BastiL »

Hallo zusammen,

mit Hilfe folgender Posts hier habe ich meinen Scanner unter SuSe 9.0, Kernel 2.6.6 (Vanilla) schon ziemlich ans laufen gebracht:

http://www.linux-club.de/viewtopic.php?t=10279: Scanner Howto
http://www.linux-club.de/viewtopic.php?t=11072 Plustek OpticPro P12
http://www.linux-club.de/viewtopic.php?t=10525 OpticPro 12000T

Jetzt habe ich aber ein Problem, das ich weder mit Hilfe des Forums noch mittels Google lösen konnte.

Code: Alles auswählen

export SANE_DEBUG_PLUSTEK_PP=20 ; scanimage -L
liefert:

[sanei_debug] Setting debug level of plustek_pp to 20.
[plustek_pp] PlustekPP backend V0.01-8, part of sane-backends 1.0.14
[plustek_pp] ># Plustek-PP SANE Backend configuration file<
[plustek_pp] ># For use with Plustek parallel-port scanners<
[plustek_pp] >#<
[plustek_pp] ><
[plustek_pp] >#<
[plustek_pp] ># user either [direct] or [kernel] to access the scanner<
[plustek_pp] ># when using [kernel], device specifies the device-node, which is created<
[plustek_pp] ># by the kernel-module loader (applies only to Linux)<
[plustek_pp] ># when using [direct], device is used to set the parallel-port base address<
[plustek_pp] ># or a device-name suitable for libieee1284, i.e. parport0<
[plustek_pp] >#<
[plustek_pp] >[direct]<
[plustek_pp] >device 0x378<
[plustek_pp] Decoding device name >0x378<
[plustek_pp] ><
[plustek_pp] >#<
[plustek_pp] ># leave the default values as specified in /etc/modules.conf<
[plustek_pp] >#<
[plustek_pp] >#option warmup -1<
[plustek_pp] >#option lOffOnEnd -1<
[plustek_pp] >#option lampOff -1<
[plustek_pp] ><
[plustek_pp] ># model override switch, mostly for cosmetic changes, if the autodetection<
[plustek_pp] ># does not work or could not work correctly<
[plustek_pp] >#option mov 7<
[plustek_pp] ><
[plustek_pp] >#<
[plustek_pp] ># example for accessing the scanner via libieee1284<
[plustek_pp] >#<
[plustek_pp] >#[direct]<
[plustek_pp] >#device parport0<
[plustek_pp] ><
[plustek_pp] >#<
[plustek_pp] ># example for accessing the scanner via the kernel module<
[plustek_pp] >#<
[plustek_pp] >#[kernel]<
[plustek_pp] >#device /dev/pt_drv<
[plustek_pp] >#<
[plustek_pp] >#option warmup -1<
[plustek_pp] >#option lOffOnEnd -1<
[plustek_pp] >#option lampOff -1<
[plustek_pp] attach (0x378, 0xbfffc200, (nil))
[plustek_pp] Device configuration:
[plustek_pp] device name : >0x378<
[plustek_pp] direct I/O : yes
[plustek_pp] warmup : -1s
[plustek_pp] lampOff : -1
[plustek_pp] lampOffOnEnd : yes
[plustek_pp] model override: 0
[plustek_pp] ---------------------
[plustek_pp] drvopen()
[plustek_pp] open: PtDrvInit failed: 4
[plustek_pp] open failed: -1
[plustek_pp] sane_get_devices (0xbfffe2c8, 0)

Im Forum von G.Jäger (http://www.linuxhacker.org/cgi-bin/ezml ... epccckejhi) habe ich gefunden, dass dann entweder libieee1248 support oder direct io support fehlt. Ersteren habe ich einkompiliert, zweiteren finde ich unter Menuconfig nicht.... Außerdem hab eich noch das Probem, dass ich das Modul parport_pc jedes Mal von Hand laden muss, seit ich die modprobe.conf geändert habe. Wer hat weitere Ideen?

Danke, Basti
Benutzeravatar
scanner_freak
Hacker
Hacker
Beiträge: 300
Registriert: 19. Mai 2004, 13:12

Re: Scanner Plustek OpticPro 9636T - open: PtDrvInit failed:

Beitrag von scanner_freak »

Hi,

eigentlich bist Du ja schon ziemlich weit gekommen...
Die plustek_pp.conf ist für Deinen Fall falsch eingestellt, Du
möchtest über /dev/parport0 scannen, und somit sollte in der
plustek_pp.conf eigentlich nur folgendes drin stehen:

Code: Alles auswählen

[direct]
device parport0
Probier das mal aus, stelle aber bitte sicher, dass das Modul
ppdev geladen ist...

So wie die plustek_pp.conf derzeit gesetzt ist, versucht das
Backend direkt auf die Parallelport-Adresse 0x378 zuzugreifen
und das "lehnt" Linux ab - alternativ kannst Du die Konfiguration
mal lassen und als root User:
scanimage -L
ausprobieren...

Grüsse,
Gerhard
BastiL
Newbie
Newbie
Beiträge: 25
Registriert: 25. Jul 2004, 17:43

Danke

Beitrag von BastiL »

Hallo Gerhard,

danke, dass du dich um mein Problem bemühst. Leider haben deine Verbesserungsvorschläge nichs geändert.

Zunächst einmal muss ich ppdev und parport_pc von Hand laden, das ginge auch komfortabler. Anschließend liefert

Code: Alles auswählen

export SANE_DEBUG_PLUSTEK_PP=20 ; scanimage -L
auch nichts neues:
[sanei_debug] Setting debug level of plustek_pp to 20.
[plustek_pp] PlustekPP backend V0.01-8, part of sane-backends 1.0.14
[plustek_pp] ># Plustek-PP SANE Backend configuration file<
[plustek_pp] ># For use with Plustek parallel-port scanners<
[plustek_pp] >#<
[plustek_pp] ><
[plustek_pp] >#<
[plustek_pp] ># user either [direct] or [kernel] to access the scanner<
[plustek_pp] ># when using [kernel], device specifies the device-node, which is created<
[plustek_pp] ># by the kernel-module loader (applies only to Linux)<
[plustek_pp] ># when using [direct], device is used to set the parallel-port base address<
[plustek_pp] ># or a device-name suitable for libieee1284, i.e. parport0<
[plustek_pp] >#<
[plustek_pp] >#[direct]<
[plustek_pp] >#device 0x378<
[plustek_pp] ><
[plustek_pp] >#<
[plustek_pp] ># leave the default values as specified in /etc/modules.conf<
[plustek_pp] >#<
[plustek_pp] >#option warmup -1<
[plustek_pp] >#option lOffOnEnd -1<
[plustek_pp] >#option lampOff -1<
[plustek_pp] ><
[plustek_pp] ># model override switch, mostly for cosmetic changes, if the autodetection<
[plustek_pp] ># does not work or could not work correctly<
[plustek_pp] >#option mov 7<
[plustek_pp] ><
[plustek_pp] >#<
[plustek_pp] ># example for accessing the scanner via libieee1284<
[plustek_pp] >#<
[plustek_pp] >[direct]<
[plustek_pp] >device parport0<
[plustek_pp] Decoding device name >parport0<
[plustek_pp] ><
[plustek_pp] >#<
[plustek_pp] ># example for accessing the scanner via the kernel module<
[plustek_pp] >#<
[plustek_pp] >#[kernel]<
[plustek_pp] >#device /dev/pt_drv<
[plustek_pp] >#<
[plustek_pp] >#option warmup -1<
[plustek_pp] >#option lOffOnEnd -1<
[plustek_pp] >#option lampOff -1<
[plustek_pp] attach (parport0, 0xbfffc1f0, (nil))
[plustek_pp] Device configuration:
[plustek_pp] device name : >parport0<
[plustek_pp] direct I/O : yes
[plustek_pp] warmup : -1s
[plustek_pp] lampOff : -1
[plustek_pp] lampOffOnEnd : yes
[plustek_pp] model override: 0
[plustek_pp] ---------------------
[plustek_pp] drvopen()
[plustek_pp] open: PtDrvInit failed: 4
[plustek_pp] open failed: -1
[plustek_pp] sane_get_devices (0xbfffe2b8, 0)

An der Konfiguration von plustek_pp.conf scheint es also nicht zu liegen. Hast du noch andere Ideen?

Danke und Gruß

Basti[/code]
Benutzeravatar
scanner_freak
Hacker
Hacker
Beiträge: 300
Registriert: 19. Mai 2004, 13:12

Re: Danke

Beitrag von scanner_freak »

BastiL hat geschrieben:...
An der Konfiguration von plustek_pp.conf scheint es also nicht zu liegen. Hast du noch andere Ideen?
Wie sagte einst Günter Netzer zu Gerhard Delling: "So hören Sie doch, was ich
sage!!!" :) :)
Also probiere bitte das Kommando
export SANE_DEBUG_PLUSTEK_PP=20 ; scanimage -L
als root User aus.
Wenn das geht, dann müssen die Rechte des Devices /dev/parport/0
angepasst werden. Das automatische laden der Parallelport Treiber kriegen
wir dann auch noch in Griff...

Grüsse,
Gerhard
BastiL
Newbie
Newbie
Beiträge: 25
Registriert: 25. Jul 2004, 17:43

Das...

Beitrag von BastiL »

habe ich gemacht, Gerhard. Das geht zwar aus meinem obigen Posting nicht hervor, aber ich habe den Befehl aus einer root-Konsole heraus aufgerufen.Sorry, dass ich das nicht explizit hingeschriben habe. Die Ausgabe ist die oben gepostete. :cry: :cry:

Gruß Basti
Benutzeravatar
scanner_freak
Hacker
Hacker
Beiträge: 300
Registriert: 19. Mai 2004, 13:12

Beitrag von scanner_freak »

Hi,

probier mal:

Code: Alles auswählen

export SANE_DEBUG_PLUSTEK_PP=20 ; export SANE_DEBUG_SANEI_PP=20 ; scanimage -L
wieder als root-User, wir wollen mal sehen, warum wir nicht auf den Parallelport
rauskommen...

Grüsse,
Gerhard
BastiL
Newbie
Newbie
Beiträge: 25
Registriert: 25. Jul 2004, 17:43

Beitrag von BastiL »

Code: Alles auswählen

export SANE_DEBUG_PLUSTEK_PP=20 ; export SANE_DEBUG_SANEI_PP=20 ; scanimage -L
wieder als root-User

liefert zusätzlich zur obigen Ausgabe noch:
[sanei_pp] sanei_pp_open: called for device `parport0`
[sanei_pp] sanei_pp_open: support not compiled
[sanei_pp] sanei_pp_open: basically, this backend does only compile
[sanei_pp] sanei_pp_open: on x86 architectures. Furthermore it
[sanei_pp] sanei_pp_open: needs ioperm() and inb()/outb() calls.
[sanei_pp] sanei_pp_open: alternativly it makes use of libieee1284
[sanei_pp] sanei_pp_open: (which isn't present either)

Da läuft wohl was mit libieee1284 falsch. Make menuconfig angeworfen und festgestellt: Unter Device Drivers -> Parallel Port Support ist IEEE 1284 transfer modes aktiviert. Warum klappt das trotzdem nicht? Yast findet das entsprechende Modul in der Version 0.28. Nach rpmseek ist das die aktuelle Version. Der Link im Forum von G. Jäger ging ja in die gleiche Richtung, hat mir aber nicht weiter geholfen. (siehe erstes Posting) Die Module parport, parport_pc und ppdev habe ich geladen. Letztere beide muss ich von Hand laden. Wie trage ich die denn in die modprobe.conf ein?
Übrigens: Wenn die Module geladen sind geht mein Parallelportdrucker.

Dane für weitere Tipps, Basti
BastiL
Newbie
Newbie
Beiträge: 25
Registriert: 25. Jul 2004, 17:43

Beitrag von BastiL »

Die Module parport, parport_pc und ppdev habe ich geladen. Letztere beide muss ich von Hand laden. Wie trage ich die denn in die modprobe.conf ein?

Da bin ich einen Schritt weiter: parport_pc wird jetzt geladen, da
danach diese Zeilen auskommentieren:

alias parport_lowlevel parport_pc
options parport_pc io=0x378 irq=none,none
# If you have multiple parallel ports, specify them this way:
# options parport_pc io=0x378,0x278 irq=none,none
wohl heissen soll, das das so da stehen muss. Bei mir stand das schon so da und ich habs dann auskommentiert..... Allerdings ändert das leider immer noch nichts daran, dass der Scanner nicht tut, Fehlermeldungen beliben gleich.

:? Basti
Benutzeravatar
scanner_freak
Hacker
Hacker
Beiträge: 300
Registriert: 19. Mai 2004, 13:12

Beitrag von scanner_freak »

Hi,
BastiL hat geschrieben:...
Da läuft wohl was mit libieee1284 falsch. Make menuconfig angeworfen und festgestellt: Unter Device Drivers -> Parallel Port Support ist IEEE 1284 transfer modes aktiviert. Warum klappt das trotzdem nicht? Yast findet das entsprechende Modul in der Version 0.28....
Deine Analyse ist vollkommen korrekt ;)
Das Problem liegt nicht an der Kernelkonfiguration, sondern
an der SANE Konfiguration...
Woher nimmst Du SANE? Selber compiliert?
Hohl Dir die aktuellen von packman.links2linux und probier das
nochmal, wenn das nicht geht, muss ich mein HowTo doch noch
um das Kapitel "SANE compilieren" vervollständigen :) :)
Stell aber bitte sicher, dass Du keine SANE Leichen mehr auf Deiner
Büchse liegen hast...

Grüsse,
Gerhard
BastiL
Newbie
Newbie
Beiträge: 25
Registriert: 25. Jul 2004, 17:43

Beitrag von BastiL »

Hi gerhard,

Deine Analyse ist vollkommen korrekt ;)
schön :-)

Das Problem liegt nicht an der Kernelkonfiguration, sondern
an der SANE Konfiguration...
Woher nimmst Du SANE? Selber compiliert?
Sane hab ich in der aktuellen Version selbst kompiliert. Dabei bin ich auch auf das Problem gestossen, das hier im Forum schon einmal beschrieben wurde, nämlich dass Sane dann in einem anderen Verzeichnis liegt als das *.rpm Paket-Sane. Ich habe versucht das durch Angabe anderer Verzeichnisse bei der Installationm zu umgehen, das hat nicht komplett geklappt. Ich weiss jetzt zwar, wo was liegt, aber Linux vielleicht nicht so genau..... Ich werde heute abend dort mal "aufräumen". Das Problem bei *.rpm ist, dass ich dann tausende Pakete aktualisieren müsste, wenn ich das Paket für Suse 9.1 nehme. Das Suse 9.0 Paket ist nicht auf dem aktuellen Stand. Deshalb habe ich selbst kompiliert.

Grüsse Basti
Benutzeravatar
scanner_freak
Hacker
Hacker
Beiträge: 300
Registriert: 19. Mai 2004, 13:12

Beitrag von scanner_freak »

Hallo BastiL,

wenn Du selber compilierst, solltest Du für SuSE folgenden configure Aufruf
verwenden:

Code: Alles auswählen

./configure --prefix=/usr --sysconfdir=/etc --mandir=/usr/share/man --infodir=/usr/share/info
das überdengelt zwar nicht alles komplett (Doku vorallem nicht), tut aber nicht
weh. Evtl. solltest Du /etc/sane.d/ vorher leeren...

Nachdem configure seinen Dienst getan hat, sollte dessen Zusammenfassung
so aussehen:

Code: Alles auswählen

LIBS="-lusb -lnsl -lm -ljpeg -lieee1284 -lgphoto2 -lm -lresmgr"
-> Installation directories:
Configuration: /etc
Libraries:     /usr/lib
Binaries:      /usr/bin and /usr/sbin
Manpages:      /usr/share/man
Documentation:
-> Network parameters:
Build saned:   yes
IPv6 support:  yes
-> The following backends will be built:
abaton agfafocus apple artec as6e avision bh canon canon630u coolscan coolscan2 dc25 dmc epson fujitsu gt68xx hp leo matsushita microtek microtek2 mustek mustek_pp mustek_usb nec pie plustek plustek_pp ricoh s9036 sceptre sharp sp15c st400 tamarack test teco1 teco2 teco3 umax umax_pp umax1220u artec_eplus48u ma1509 ibm hp5400 u12 snapscan dc210 dc240 canon_pp hpsj5s gphoto2 qcam v4l net sm3600
****************************************************************
* Please be sure to read file PROBLEMS in this directory       *
* BEFORE running any of the SANE applications.  Some devices   *
* may be damaged by inproper operation, so please do heed this *
* advice.                                                      *
****************************************************************
Wichtig ist in Deinem Fall, dass -lieee1284 in der LIBS Zeile drin ist.
Ggf, solltest Du Dir die libiee1248 holen:
http://cyberelk.net/tim/data/libieee128 ... .8.tar.bz2

Auspacken, konfigurieren, compilieren und installieren:

Code: Alles auswählen

 ./configure --prefix=/usr --sysconfdir=/etc --mandir=/usr/share/man
Danach nochmals SANE konfigurieren, compilieren und installieren - fertig...

Viel Erfolg,
Gerhard
BastiL
Newbie
Newbie
Beiträge: 25
Registriert: 25. Jul 2004, 17:43

Beitrag von BastiL »

Hallo Gerhard,

danke für deine ausdauernde HIlfeleistung :-). Ohne dich hätte ich vermutlich längst die FInte ins Korn geworfen. Ok, der neue Stand:

Code: Alles auswählen

./configure --prefix=/usr --sysconfdir=/etc --mandir=/usr/share/man --infodir=/usr/share/info
Wichtig ist in Deinem Fall, dass -lieee1284 in der LIBS Zeile drin ist.
War sie nicht!
Ggf, solltest Du Dir die libiee1248 holen:
http://cyberelk.net/tim/data/libieee128 ... .8.tar.bz2
Hab ich gemacht!
Auspacken, konfigurieren, compilieren und installieren:

Code: Alles auswählen

 ./configure --prefix=/usr --sysconfdir=/etc --mandir=/usr/share/man
Hab ich gemacht!
Danach nochmals SANE konfigurieren, compilieren und installieren - fertig...
Hab ich auch gemacht, dann war -lieee1284 in der LIBS Zeile drin.

Jetzt liefert (egal ob root oder nicht)

Code: Alles auswählen

export SANE_DEBUG_PLUSTEK_PP=20 ; export SANE_DEBUG_SANEI_PP=20 ; scanimage -L
nur noch... (wenig gesprächig):

No scanners were identified. If you were expecting something different,
check that the scanner is plugged in, turned on and detected by the
sane-find-scanner tool (if appropriate). Please read the documentation
which came with this software (README, FAQ, manpages).

Die Konfiguration von dll.conf und plustek_pp.conf habe ich nach der Sane-Neuinstallation natürlich neu gemacht. Habe davor Sane-Reste die ich gefunden habe alle gelöscht... :cry: :x Was nun?

Gruß Basti
Benutzeravatar
scanner_freak
Hacker
Hacker
Beiträge: 300
Registriert: 19. Mai 2004, 13:12

Beitrag von scanner_freak »

BastiL hat geschrieben:...
Jetzt liefert (egal ob root oder nicht)

Code: Alles auswählen

export SANE_DEBUG_PLUSTEK_PP=20 ; export SANE_DEBUG_SANEI_PP=20 ; scanimage -L
nur noch... (wenig gesprächig):
.
.
.
Die Konfiguration von dll.conf und plustek_pp.conf habe ich nach der
Sane-Neuinstallation natürlich neu gemacht.
Was heisst das? Wie sehen die aus und wo stehen die?
Ich bin mir ziemlich sicher, dass der Eintrag plustek_pp in der
/etc/sane.d/dll.conf entweder mit nem Kommentar versehen ist
(was default mässig der Fall ist) oder sonst ein Fehler drin steckt.
Schau mal da nach und entferne das Zeichen.

Poste mal folgenden Output, sowie die beiden Dateien
/etc/sane.d/plustek_pp.conf und /etc/sane.d/dll.conf

Code: Alles auswählen

 export SANE_DEBUG_DLL=255; export SANE_DEBUG_PLUSTEK_PP=20 ; export SANE_DEBUG_SANEI_PP=20 ; scanimage -L
Das sollte dann Licht ins Dunkel bringen.
Grüsse,
Gerhard
BastiL
Newbie
Newbie
Beiträge: 25
Registriert: 25. Jul 2004, 17:43

Beitrag von BastiL »

Die Konfiguration von dll.conf und plustek_pp.conf habe ich nach der
Sane-Neuinstallation natürlich neu gemacht.

Was heisst das? Wie sehen die aus und wo stehen die?
...
Schau mal da nach und entferne das Zeichen.
Das war schon richtig. Das ist meine /etc/sane.d/dll.conf:
# enable the next line if you want to allow access through the network:
#net
#abaton
#agfafocus
#apple
#avision
#artec
#artec_eplus48u
#as6e
#bh
#canon
#canon630u
#canon_pp
#coolscan
#coolscan2
#dc25
#dc210
#dc240
#dmc
#epson
#fujitsu
#gphoto2
#gt68xx
#hp
#hpsj5s
#hp5400
#ibm
#leo
#ma1509
#matsushita
#microtek
#microtek2
#mustek
#mustek_pp
#mustek_usb
#nec
#pie
#pint
#plustek
plustek_pp
#pnm
#qcam
#ricoh
#s9036
#sceptre
#sharp
#sm3600
#snapscan
#sp15c
#st400
#tamarack
#teco1
#teco2
#teco3
#test
#u12
#umax
#umax_pp
#umax1220u
#v4l
#
# The following backends are not included in the sane-backends distribution
# If you want to use them, download them from their webpages and read their
# documentation
#
# HP OfficeJet backend homepage: http://hpoj.sf.net/
# Uncomment the following line if hpoj is installed:
#hpoj

Und die /etc/sane.d/plustek_pp.conf sieht so aus:
# Plustek-PP SANE Backend configuration file
# For use with Plustek parallel-port scanners
#

#
# user either [direct] or [kernel] to access the scanner
# when using [kernel], device specifies the device-node, which is created
# by the kernel-module loader (applies only to Linux)
# when using [direct], device is used to set the parallel-port base address
# or a device-name suitable for libieee1284, i.e. parport0
#
#[direct]
#device 0x378

#
# leave the default values as specified in /etc/modules.conf
#
#option warmup -1
#option lOffOnEnd -1
#option lampOff -1

# model override switch, mostly for cosmetic changes, if the autodetection
# does not work or could not work correctly
#option mov 7

#
# example for accessing the scanner via libieee1284
#
[direct]
device parport0

#
# example for accessing the scanner via the kernel module
#
#[kernel]
#device /dev/pt_drv
#
#option warmup -1
#option lOffOnEnd -1
#option lampOff -1

Die Vorgabe der Verzeichnisse bei der Konfiguration von Sane scheint funktioniert zu haben. Zumindest sind die Default-Verzeichnisse /usr/local/etc/ und /usr/local/lib leer, nachdem ich die ja vor der Neukompilation gelöscht habe. Die Suche nach dll.conf liefert neben /etc/sane.d noch eine weitere Datei; nämlich die im Sourceverzeichnis.

Code: Alles auswählen

 export SANE_DEBUG_DLL=255; export SANE_DEBUG_PLUSTEK_PP=20 ; export SANE_DEBUG_SANEI_PP=20 ; scanimage -L
Das liefert als Root:
su
Password:
Basti:/etc/sane.d # export SANE_DEBUG_DLL=255; export SANE_DEBUG_PLUSTEK_PP=20 ; export SANE_DEBUG_SANEI_PP=20 ; scanimage -L
[sanei_debug] Setting debug level of dll to 255.
[dll] sane_init: SANE dll backend version 1.0.10 from sane-backends 1.0.14
[dll] sane_init: reading dll.conf
[dll] add_backend: adding backend `plustek_pp'
[dll] sane_get_devices
[dll] load: searching backend `plustek_pp' in `/usr/local/lib/sane'
[dll] load: trying to load `/usr/local/lib/sane/libsane-plustek_pp.so.1'
[dll] load: couldn't open `/usr/local/lib/sane/libsane-plustek_pp.so.1' (No such file or directory)
[dll] load: couldn't find backend `plustek_pp' (No such file or directory)
[dll] sane_get_devices: found 0 devices

No scanners were identified. If you were expecting something different,
check that the scanner is plugged in, turned on and detected by the
sane-find-scanner tool (if appropriate). Please read the documentation
which came with this software (README, FAQ, manpages).
[dll] sane_exit: exiting
[dll] sane_exit: finished

Aha... Irgendwo war das mit den Pfaden nicht vollständig richtig, zumindest werden werden die libs woanders erwartet. Wenn ich die nötigen Libs von /usr/lib/sane nach /usr/local/lib/sane kopiere, dann findet der plötzlich die dll.conf nicht mehr:
Basti:/usr/local/lib/sane # export SANE_DEBUG_DLL=255; export SANE_DEBUG_PLUSTEK_PP=20 ; export SANE_DEBUG_SANEI_PP=20 ; scanimage -L
[sanei_debug] Setting debug level of dll to 255.
[dll] sane_init: SANE dll backend version 1.0.10 from sane-backends 1.0.14
[dll] sane_init: Couldn't open config file (dll.conf): No such file or directory
[dll] sane_get_devices
[dll] sane_get_devices: found 0 devices

No scanners were identified. If you were expecting something different,
check that the scanner is plugged in, turned on and detected by the
sane-find-scanner tool (if appropriate). Please read the documentation
which came with this software (README, FAQ, manpages).
[dll] sane_exit: exiting
[dll] sane_exit: finished

Da müsste ich jetzt das womöglich auch kopieren. Das habe ich schon letztes Mal so gemacht. Dann entsteht ein Durcheinander und zum Schluss läuft nix... Irgendwie muss ich Sane mit anderen Prameter komplieren, oder Gerhard?

Gruß Basti
Benutzeravatar
scanner_freak
Hacker
Hacker
Beiträge: 300
Registriert: 19. Mai 2004, 13:12

Beitrag von scanner_freak »

Hi,
BastiL hat geschrieben:...
Da müsste ich jetzt das womöglich auch kopieren. Das habe ich schon letztes Mal so gemacht. Dann entsteht ein Durcheinander und zum Schluss läuft nix... Irgendwie muss ich Sane mit anderen Prameter komplieren, oder Gerhard?
nix, da! Die Parameter stimmen und kopieren darfst Du um
Himmels Willen auch nix mehr. Wenn Du nach wie vor Probleme
hast, so liegt das einfach noch daran, dass Du nicht alle "Leichen"
beseitigt hast. Also das ganze nochmal. Jetzt lass uns erstmal
aufräumen:

rm -rf /usr/local/lib/sane
rm -rf /usr/lib/sane
rm -rf /usr/local/etc/sane.d
rm /usr/local/bin/scanimage
rm /usr/bin/scanimage
rm /usr/local/bin/sane*
rm /usr/bin/sane*

Dann gehst Du bitte nochmals in das SANE-Quellverzeichnis und
räumst zuerst auf:

make distclean

dann nochmals den oben beschriebenen configure Schritt, make all
und make install...

Jetzt sollte alles richtig und vorallem nur einmal da sein, vorallem
scanimage sollte sich nur in /usr/bin befinden und die libsane
Libraries in /usr/lib/sane und sonst nirgends - bitte überrprüfen.
Nicht vergessen:
dll.conf und plustek_pp.conf in /etc/sane.d auch wieder anpassen

So das sollte es gewesen sein.
Grüsse,
Gerhard
BastiL
Newbie
Newbie
Beiträge: 25
Registriert: 25. Jul 2004, 17:43

:-):-)

Beitrag von BastiL »

rm -rf /usr/local/lib/sane
rm -rf /usr/lib/sane
rm -rf /usr/local/etc/sane.d
rm /usr/local/bin/scanimage
rm /usr/bin/scanimage
rm /usr/local/bin/sane*
rm /usr/bin/sane*

Dann gehst Du bitte nochmals in das SANE-Quellverzeichnis und
räumst zuerst auf:

make distclean

dann nochmals den oben beschriebenen configure Schritt, make all
und make install...

Jetzt sollte alles richtig und vorallem nur einmal da sein, vorallem
scanimage sollte sich nur in /usr/bin befinden und die libsane
Libraries in /usr/lib/sane und sonst nirgends - bitte überrprüfen.
Nicht vergessen:
dll.conf und plustek_pp.conf in /etc/sane.d auch wieder anpassen

So das sollte es gewesen sein.

Das war es vorläufig. Geht im Moment nur als root, aber das werde ich noch ändern. Danke dir vielmals für deine Hilfe.

Grüsse,
Gerhard[/quote]
Antworten