Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Wechsel von IDE zu SATA LW unzureichend, doch nicht gelöst!

Alles rund um Hardware, die unter Linux läuft oder zum Laufen gebracht werden soll

Moderator: Moderatoren

Antworten
Benutzeravatar
willithepimp
Member
Member
Beiträge: 168
Registriert: 10. Jan 2009, 12:59

Wechsel von IDE zu SATA LW unzureichend, doch nicht gelöst!

Beitrag von willithepimp »

Hallo,

nach dem Wechsel meines IDE-Brenners zu einem SATA DVD-ROM Laufwerk und einem SATA DVD Brenner ist die volle Funktion nicht gewährleistet. Einige ähnliche Lösungen hier im Board führten nicht zum Ziel, wahrscheinlich auch, weil die Sachlage da etwas anders war.

Zum Problem. Ich habe einen neuen Rechner aufgebaut aber mangels LW noch mal den alten IDE-Brenner als Installationslaufwerk benutzt. Die Installation verlief erfolgreich. Alle Codecs eingespielt und so klappte auch alles. Daten lesen, schreiben, Musik-CD's hören, DVD's abspielen. Auch Filme.
Inzwischen sind meine neuen SATA-LW's da und eingebaut. Nun stellt sich die Situation folgendermaßen dar:
Daten-CD's können gelesen werden. Daten können auf Festplatte gespeichert werden. Mit K3b wurde eine 1 zu 1 Kopie einer Musik-CD simuliert. Problemlos. Aber!
Es lassen sich keine Musik-CD's mit z.B. KsCD oder XMMS wiedergeben. Die CD wird einfach nicht erkannt. Mounte ich sie als Root, werden die Inhalte dargestellt, aber auch hier ist kein hören möglich. Grip erkennt die Stücke, listet die Titel richtig auf, kann aber weder abspielen, noch rippen und kodieren. Ähnlich stellt sich die Situation von Film-DVD's dar. Mit Kaffeine läuft gar nichts. Den VCL-Player konnte ich zur Mitarbeit bewegen. Inzwischen jedoch macht auch er wieder nicht mit.
Das Verhalten ist bei beiden Laufwerken gleich. Da zumindest Daten richtig erkannt werden und damit auch alles getan werden kann, scheint es so zu sein, dass die Datenträger auch richtig gemountet werden. Aber irgendwas verhindert, dass Multimediainhalte richtig weitergegeben werden. Hat jemand ne Idee, die mich weiterbringt?

Vielen Dank
Zuletzt geändert von willithepimp am 12. Feb 2010, 11:45, insgesamt 2-mal geändert.
altashveede
Member
Member
Beiträge: 130
Registriert: 9. Jun 2007, 20:13

Re: Wechsel von IDE zu SATA LW unzureichend

Beitrag von altashveede »

Mal ins Blaue geschossen:

Ich würde die in Betracht kommenden Pakete noch einmal neu einspielen. Dann werden sie mit der jetzt vorhandenen Hardware noch einmal neu konfiguriert. Manchmal hilft so etwas.
Benutzeravatar
willithepimp
Member
Member
Beiträge: 168
Registriert: 10. Jan 2009, 12:59

Re: Wechsel von IDE zu SATA LW unzureichend

Beitrag von willithepimp »

Ja, hab ich schon getan. Brachte aber nichts. Außerdem vermeldet Xine bei fehlerhaften Codecs, dass es mit den Daten nichts anfangen kann, weil keine Codecs vorhanden seien. Das ist aber hier nicht der Fall. Es wird nicht mal ein Medium wie CD oder DVD erkannt.
spoensche
Moderator
Moderator
Beiträge: 7539
Registriert: 30. Okt 2004, 23:53
Wohnort: Siegen

Re: Wechsel von IDE zu SATA LW unzureichend

Beitrag von spoensche »

Was sagen die Logfiles, wenn du eine CD/DVD ein legst?
Benutzeravatar
willithepimp
Member
Member
Beiträge: 168
Registriert: 10. Jan 2009, 12:59

Re: Wechsel von IDE zu SATA LW unzureichend

Beitrag von willithepimp »

spoensche hat geschrieben:Was sagen die Logfiles, wenn du eine CD/DVD ein legst?
Inhalt der /var/log/message bei Einlegen einer Audio-CD:
Feb 9 12:16:33 linux-2fpt kernel: [ 1807.242805] sr 1:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
Feb 9 12:16:33 linux-2fpt kernel: [ 1807.242834] sr 1:0:0:0: [sr0] Sense Key : Illegal Request [current]
Feb 9 12:16:33 linux-2fpt kernel: [ 1807.242853] sr 1:0:0:0: [sr0] Add. Sense: Illegal mode for this track
Feb 9 12:16:33 linux-2fpt kernel: [ 1807.242874] end_request: I/O error, dev sr0, sector 0
Feb 9 12:16:33 linux-2fpt kernel: [ 1807.242889] __ratelimit: 68 callbacks suppressed
Feb 9 12:16:33 linux-2fpt kernel: [ 1807.242902] Buffer I/O error on device sr0, logical block 0
Feb 9 12:16:33 linux-2fpt kernel: [ 1807.242922] Buffer I/O error on device sr0, logical block 1
Feb 9 12:16:33 linux-2fpt kernel: [ 1807.242937] Buffer I/O error on device sr0, logical block 2
Feb 9 12:16:33 linux-2fpt kernel: [ 1807.242950] Buffer I/O error on device sr0, logical block 3
Feb 9 12:16:33 linux-2fpt kernel: [ 1807.242964] Buffer I/O error on device sr0, logical block 4
Feb 9 12:16:33 linux-2fpt kernel: [ 1807.242977] Buffer I/O error on device sr0, logical block 5
Feb 9 12:16:33 linux-2fpt kernel: [ 1807.242991] Buffer I/O error on device sr0, logical block 6
Feb 9 12:16:33 linux-2fpt kernel: [ 1807.243004] Buffer I/O error on device sr0, logical block 7
Feb 9 12:16:33 linux-2fpt kernel: [ 1807.243018] Buffer I/O error on device sr0, logical block 8
Feb 9 12:16:33 linux-2fpt kernel: [ 1807.243031] Buffer I/O error on device sr0, logical block 9
Feb 9 12:16:33 linux-2fpt kernel: [ 1807.272171] sr 1:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
Feb 9 12:16:33 linux-2fpt kernel: [ 1807.272199] sr 1:0:0:0: [sr0] Sense Key : Illegal Request [current]
Feb 9 12:16:33 linux-2fpt kernel: [ 1807.272217] sr 1:0:0:0: [sr0] Add. Sense: Illegal mode for this track
Ab hier werden die letzten drei Zeilen mehrfach wiederholt.

Dennoch kann ich eine teilweise Lösung vermelden. Da brat mir einer nen Storch! ;-)
Mit dem VLC-Player kann ich über das Menü "Media - Medium öffnen" Film-DVD's und Audio-CD's normal abspielen. Alles funzt, obwohl KsCD nach wie vor vermeldet, es sei keine (Audio) CD vorhanden.
spoensche
Moderator
Moderator
Beiträge: 7539
Registriert: 30. Okt 2004, 23:53
Wohnort: Siegen

Re: Wechsel von IDE zu SATA LW unzureichend

Beitrag von spoensche »

Wenn die CD's Kratzer haben, können die IO Fehler auftreten, weil der Laser die Daten nicht richtig und erst nach wiederholtem Male lesen kann.
Benutzeravatar
willithepimp
Member
Member
Beiträge: 168
Registriert: 10. Jan 2009, 12:59

Re: Wechsel von IDE zu SATA LW unzureichend

Beitrag von willithepimp »

Nee, keine Kratzer. Da bin ich noch viel zu sehr dem alten Vinyl verbunden. :-)
Nachdem ich vermeldet hatte, dass alles gelöst sei, muss ich nun wieder sagen, es ist wie am Anfang. Heute funktionierts wieder nicht mehr.
Folgende Fakten sind zu vermelden: hwinfo --cd erfasst DVD-ROM wie auch den DVD-Brenner richtig als /dev/sr0 bzw. sr1
Ausgabe für den Brenner:
[Created at block.247]
UDI: /org/freedesktop/Hal/devices/storage_model_CDDVDW_SH_S223C
Unique ID: nOPI.4hfYXh4pul1
Parent ID: 7EWs.WPBK7Mqox0D
SysFS ID: /class/block/sr1
SysFS BusID: 3:0:0:0
SysFS Device Link: /devices/pci0000:00/0000:00:11.0/host3/target3:0:0/3:0:0:0
Hardware Class: cdrom
Model: "TSSTcorp CDDVDW SH-S223C"
Vendor: "TSSTcorp"
Device: "CDDVDW SH-S223C"
Revision: "SB01"
Driver: "ahci", "sr"
Driver Modules: "ahci"
Device File: /dev/sr1 (/dev/sg3)
Device Files: /dev/sr1, /dev/block/11:1, /dev/scd1, /dev/disk/by-path/pci-0000:00:11.0-scsi-3:0:0:0, /dev/cdrom, /dev/cdrw, /dev/dvd, /dev/dvdrw
Device Number: block 11:1 (char 21:3)
Features: CD-R, CD-RW, DVD, DVD-R, DVD-RW, DVD+R, DVD+RW, DVD+DL, DVDRAM
Drive status: no medium
Config Status: cfg=no, avail=yes, need=no, active=unknown
Attached to: #4 (SATA controller)
Drive Speed: 52
Aber! Z.B. Grip zeigt unter Konfiguration - CD-ROM Laufwerk standardmäßig /dev/cdrom an. Unter dieser Einstellung erkennt Grip keine CD. Trage ich jedoch /dev/sr0 für das DVD-ROM LW ein, wird alles erkannt. Es scheint nur eine Frage der Verlinkung zu sein, die ich allerdings nicht nachvollziehen kann.
Antworten