Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Gelöst: Anmeldeproblem KDE4

Alles rund um die möglichen Desktopumgebungen wie KDE, Gnome, XFCE usw. die es unter Linux gibt

Moderator: Moderatoren

Antworten
chefe
Newbie
Newbie
Beiträge: 39
Registriert: 24. Mai 2006, 19:06

Gelöst: Anmeldeproblem KDE4

Beitrag von chefe »

Hallo,

ich arbeite mit Opensuse 11.2 x86_64, Linux 2.6.31.8-0.1-desktop x86_64, KDE 4.3.4 (KDE 4.3.4) "release 2".
Bei der Anmeldung gebe ich meinen Nutzernamen und dass Passwort ein, es geht dann weiter und nach kurzer Zeit zum Anmeldebildschirm zurück. Anmeldung mit root geht, Anmeldung mit Nutzernamen und root bei einem Failsafe-Start geht auch. Beim Booten mit init 3 und anschließendem Login als Nutzer und startx friert alles ein. Was geht da nicht mehr? Vielen Dank im Voraus für Hilfe.

Jürgen
Zuletzt geändert von chefe am 5. Feb 2010, 17:49, insgesamt 1-mal geändert.
Benutzeravatar
revealed
Guru
Guru
Beiträge: 3016
Registriert: 15. Sep 2006, 12:50

Re: Anmeldeproblem KDE4

Beitrag von revealed »

Hallo.

Vielleicht hilft ja die /home/DEINUSER/.xsession-errors weiter und gibt aufschluss, wo es eventuell abstürzt?

Gruß,

R
|Nb: T60 2008 43G @oS Leap 42.1 | Pc: @oS TW Core i5 4670k; 8 GB RAM; MSI Z87 G43 Gaming | MSI TF 770 GTX | 840 EVO; SX900 |The reason computer chips are so small is computers don't eat much. | systemd | Mini Tuning guide für openSUSE 13.2 |
Tooltime
Advanced Hacker
Advanced Hacker
Beiträge: 1202
Registriert: 28. Mai 2008, 17:49

Re: Anmeldeproblem KDE4

Beitrag von Tooltime »

Das klingt nach Festplatte ist voll. Mal als root einloggen und mit df -h nach schauen.
chefe
Newbie
Newbie
Beiträge: 39
Registriert: 24. Mai 2006, 19:06

Re: Anmeldeproblem KDE4

Beitrag von chefe »

revealed hat geschrieben:Hallo.

Vielleicht hilft ja die /home/DEINUSER/.xsession-errors weiter und gibt aufschluss, wo es eventuell abstürzt?

Gruß,

R
Diese Datei zeigt:

Code: Alles auswählen

/etc/X11/xim: Checking whether an input method should be started.
sourcing /etc/sysconfig/language to get the value of INPUT_METHOD
INPUT_METHOD is not set or empty (no user selected input method).
Trying to start a default input method for the locale de_DE.UTF-8 ...
There is no default input method for the current locale.
Dummy input method "none" (do not use any fancy input method by default)
startkde: Starting up...
kdeinit4: preparing to launch /usr/lib64/libkdeinit4_klauncher.so
kdeinit4: preparing to launch /usr/lib64/libkdeinit4_kded4.so
kdeinit4: preparing to launch /usr/lib64/libkdeinit4_kbuildsycoca4.so
kbuildsycoca4 running...
kdeinit4: preparing to launch /usr/lib64/libkdeinit4_kconf_update.so
Invalid D-BUS member name 'idle-hint' found in interface 'org.freedesktop.ConsoleKit.Session' while parsing introspection
Invalid D-BUS member name 'is-local' found in interface 'org.freedesktop.ConsoleKit.Session' while parsing introspection
Invalid D-BUS member name 'x11-display-device' found in interface 'org.freedesktop.ConsoleKit.Session' while parsing introspection
Invalid D-BUS member name 'x11-display' found in interface 'org.freedesktop.ConsoleKit.Session' while parsing introspection
Invalid D-BUS member name 'display-device' found in interface 'org.freedesktop.ConsoleKit.Session' while parsing introspection
Invalid D-BUS member name 'remote-host-name' found in interface 'org.freedesktop.ConsoleKit.Session' while parsing introspection
Invalid D-BUS member name 'session-type' found in interface 'org.freedesktop.ConsoleKit.Session' while parsing introspection
Invalid D-BUS member name 'unix-user' found in interface 'org.freedesktop.ConsoleKit.Session' while parsing introspection
X Error: XSyncBadAlarm 154
  Extension:    144 (Uknown extension)
  Minor opcode: 11 (Unknown request)
  Resource id:  0x0
X Error: XSyncBadAlarm 154
  Extension:    144 (Uknown extension)
  Minor opcode: 11 (Unknown request)
  Resource id:  0x0
kdeinit4: preparing to launch /usr/lib64/libkdeinit4_kcminit_startup.so
kdeinit4: preparing to launch /usr/lib64/libkdeinit4_ksmserver.so
<unknown program name>(3262)/ KStartupInfo::createNewStartupId: creating:  "linux-zpgc;1265220315;781262;3262_TIME0" : "unnamed app"
kephald starting up 
XRANDR error base:  164 
RRInput mask is set!! 
RandRScreen::loadSettings - adding mode:  64 1680 x 1050 
RandRScreen::loadSettings - adding mode:  65 1680 x 1050 
RandRScreen::loadSettings - adding mode:  66 1280 x 1024 
RandRScreen::loadSettings - adding mode:  67 1280 x 1024 
RandRScreen::loadSettings - adding mode:  68 1440 x 900 
RandRScreen::loadSettings - adding mode:  69 1280 x 960 
RandRScreen::loadSettings - adding mode:  70 1152 x 864 
RandRScreen::loadSettings - adding mode:  71 1152 x 864 
RandRScreen::loadSettings - adding mode:  72 1024 x 768 
RandRScreen::loadSettings - adding mode:  73 1024 x 768 
RandRScreen::loadSettings - adding mode:  74 832 x 624 
RandRScreen::loadSettings - adding mode:  75 800 x 600 
RandRScreen::loadSettings - adding mode:  76 800 x 600 
RandRScreen::loadSettings - adding mode:  77 800 x 600 
RandRScreen::loadSettings - adding mode:  78 640 x 480 
RandRScreen::loadSettings - adding mode:  79 640 x 480 
RandRScreen::loadSettings - adding mode:  80 720 x 400 
RandRScreen::loadSettings - adding crtc:  57 
RandRScreen::loadSettings - adding crtc:  58 
RandRScreen::loadSettings - adding output:  59 
Setting CRTC 57 on output "DVI-I_1/digital" (previous 0 ) 
CRTC outputs: (59) 
Output name: "DVI-I_1/digital" 
Output refresh rate: 59.8833 
Output rect: QRect(0,0 1680x1050) 
Output rotation: 1 
RandRScreen::loadSettings - adding output:  60 
Setting CRTC 0 on output "DVI-I_1/analog" (previous 0 ) 
RandRScreen::loadSettings - adding output:  61 
Setting CRTC 0 on output "TV_7PIN_DIN" (previous 0 ) 
RandRScreen::loadSettings - adding output:  62 
Setting CRTC 0 on output "DVI-I_2/digital" (previous 0 ) 
RandRScreen::loadSettings - adding output:  63 
Setting CRTC 0 on output "DVI-I_2/analog" (previous 0 ) 
XRandROutputs::init 
got a valid edid block... 
vendor code: "GSM" 
product id: 22123 
serial number: 43738 
  added output  59 
  added output  60 
  added output  61 
  added output  62 
  added output  63 
output: "DVI-I_1/analog" QRect(0,0 0x0) 0 false false 
output: "DVI-I_1/digital" QRect(0,0 1680x1050) 0 false false 
output: "DVI-I_2/analog" QRect(0,0 0x0) 0 false false 
output: "DVI-I_2/digital" QRect(0,0 0x0) 0 false false 
output: "TV_7PIN_DIN" QRect(0,0 0x0) 0 false false 
load xml 
connected: 1 
looking for current "DVI-I_1/digital" 
known "*" has score: 0.125 
screen: 0 QRect(0,0 1680x1050) 
looking for a matching configuration... 
connected: 1 
looking for current "DVI-I_1/digital" 
known "*" has score: 0.125 
found outputs, known: false 
connected: 1 
looking for current "DVI-I_1/digital" 
known "*" has score: 0.125 
activate external configuration!! 
registered the service: true 
screens registered on the bus: true 
outputs registered on the bus: true 
configurations registered on the bus: true 
kdeinit4: preparing to launch /usr/lib64/libkdeinit4_kglobalaccel.so
WARNING: Application calling GLX 1.3 function "glXCreatePixmap" when GLX 1.3 is not supported!  This is an application bug!
WARNING: Application calling GLX 1.3 function "glXQueryDrawable" when GLX 1.3 is not supported!  This is an application bug!
sh: /opt/kde3/bin/kreadconfig: Datei oder Verzeichnis nicht gefunden
kdeinit4: preparing to launch /usr/lib64/libkdeinit4_plasma-desktop.so
plasma-desktop: cannot connect to X server :0
kdeinit4: Fatal IO error: client killed
kdeinit4: sending SIGHUP to children.
kglobalaccel: Fatal IO error: client killed
kwin: Fatal IO error: client killed
kded4: Fatal IO error: client killed
KCrash: Application 'ksmserver' crashing...
kdeinit4: sending SIGTERM to children.
kdeinit4: Exit.
Warning: connect() failed: : Datei oder Verzeichnis nicht gefunden
KCrash cannot reach kdeinit, launching directly.
klauncher: Exiting on signal 15
klauncher: Exiting on signal 1
kdeinit4: Fatal IO error: client killed
kdeinit4: sending SIGHUP to children.
drkonqi: cannot connect to X server :0.0
kdeinit4: sending SIGTERM to children.
kdeinit4: Exit.
Ohne alle Einzelheiten zu verstehen, fällt mir auf, dass die Datei kreadconfig im falschen Verzeichnis gesucht wird., müsste /usr/bin sein. Ist mir ein Rätsel. Ich kann mir nur vorstellen, dass ich am Wochenende ein fehlerhaftes Update auf KDE geladen habe...
Jürgen
Benutzeravatar
Jägerschlürfer
Moderator
Moderator
Beiträge: 4506
Registriert: 1. Jul 2005, 12:22
Wohnort: nahe Würzburg

Re: Anmeldeproblem KDE4

Beitrag von Jägerschlürfer »

chefe hat geschrieben:Ich kann mir nur vorstellen, dass ich am Wochenende ein fehlerhaftes Update auf KDE geladen habe...
Jürgen
was für ein Update war denn das und welche Repos hast du denn eingebunden bzw. wie hast du denn das Update installiert?
Was liefert denn die Ausgabe von

Code: Alles auswählen

zypper lr -p
>Linux-Club Foren FAQ< >LC-Wiki<

Know your enemy and know yourself Sun Tzu
chefe
Newbie
Newbie
Beiträge: 39
Registriert: 24. Mai 2006, 19:06

Re: Anmeldeproblem KDE4

Beitrag von chefe »

Vielen Dank für die Unterstützung. Es gibt viele Anwendungen, die kread.config benutzen. Deshalb habe ich die Suche eingestellt und /.kde4 gesichert und anschließend gelöscht. Nun geht's wieder.
Antworten