Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

ide support für Brenner abgestellt?

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
EagleFox
Member
Member
Beiträge: 115
Registriert: 12. Mai 2005, 18:43

ide support für Brenner abgestellt?

Beitrag von EagleFox »

Hallo zusammen,

ich weiß nicht, ob es hier hin gehört, aber ich versuche es mal in dieser Rubrik.
Meine beiden DVD-Brenner werden mir als /dev/sr0 und /dev/sr1 angezeigt und werden durch den Treiber pata bedient. Seit dem das so ist (ich habe von SuSE 10.2 auf SuSE 11.2 umgestellt) kann ich keine DVD mehr brennen. Es wurde in einem anderen Thread
http://www.linux-club.de/viewtopic.php?f=18&t=107491
festgestellt, dass durch das Hinzufügen des ide-gd_mod in der /etc/sysconfig/kernel mit anschließendem mkinitrd und reboot, die Laufwerke wieder als /dev/hd* angezeigt werden und das Brennen wieder funktioniert. Das klappt bei mir nicht. Wie ich ergoogelt habe, scheint sich was seit dem 2.6.28er Kernel etwas in den ide-Subroutinen getan zu haben.

Meine mkinitrd Ausgabe sieht so aus:

Code: Alles auswählen

Kernel image: /boot/vmlinuz-2.6.31.8-0.1-default
Initrd image: /boot/initrd-2.6.31.8-0.1-default
Root device: /dev/disk/by-id/ata-SAMSUNG_HD401LJ_S0HVJ1CLB06116-part2 (/dev/sdd2) (mounted on / as ext4)
Resume device: /dev/disk/by-id/ata-WDC_WD1600BB-00GUA0_WD-WCAL91713648-part1 (/dev/sdb1)
Kernel Modules: thermal_sys thermal pata_sis sata_sis ata_generic ide-core sis5513 ide-pci-generic ide-gd_mod processor fan crc16 jbd2 ext4
Das ide-gd_mod wird geladen, aber meine ide-Laufwerke werden weiterhin als sr* behandelt und als Treiber wird weiterhin pata angezeigt.
Kann mir jemand helfen, wie ich dem Kernel beibringen kann, dass er wieder das ide-gd_mod nimmt und damit mit meinen Brennern kommuniziert?

Ich hoffe Ihr habt da noch ne Idee!

Beste Grüße
EagleFox
jengelh
Guru
Guru
Beiträge: 4039
Registriert: 20. Nov 2004, 17:42
Kontaktdaten:

Re: ide support für Brenner abgestellt?

Beitrag von jengelh »

EagleFox hat geschrieben:Hallo zusammen,
Meine beiden DVD-Brenner werden mir als /dev/sr0 und /dev/sr1 angezeigt und werden durch den Treiber pata bedient. Seit dem das so ist (ich habe von SuSE 10.2 auf SuSE 11.2 umgestellt) kann ich keine DVD mehr brennen.
Wie kommst du darauf, dass man keine DVD mehr schreiben könnte?
Nur DVD oder auch CD?
Und wie sieht's mit einem aktuellen cdrecord aus? (Nicht wodim das... nichtmal DVD+ kann als ich das letzte Mal nachsah)
EagleFox
Member
Member
Beiträge: 115
Registriert: 12. Mai 2005, 18:43

Re: ide support für Brenner abgestellt?

Beitrag von EagleFox »

Wie kommst du darauf, dass man keine DVD mehr schreiben könnte?
Na wie wohl, bei mir geht es halt nicht! Bricht immer wieder ab, ohne auch nur einen Kratzer auf die Scheibe zu bringen! Ja auch cdrecord habe ich mir von schily kompiliert und ja ich habe auch smake genutzt und ja wodim habe ich auch verbannt und ja ...

Habe ich alles ausprobiert, nichts führt zum Ergebnis, dass ich DVD +/- brennen kann. Seit geraumer Zeit versuche ich das Problem zu lösen und habe mich durch mehrere Foren geschlagen.

Aber darum geht es in diesem Thread ja nicht, sonst hätte ich nicht unter dieser Rubrik gepostet. Der Ansatz von fluxbox (siehe link oben) ist quasi meine letzte Hoffnung.
fluxbox
Newbie
Newbie
Beiträge: 9
Registriert: 18. Jan 2010, 08:57

Re: ide support für Brenner abgestellt?

Beitrag von fluxbox »

Ich habe momentan keinen Zugriff auf meinen Suse-Rechner, kann also nicht vergleichen, aber mir fällt grad auf, dass bei dir ide-cd_mod nicht bei den "Kernel Modules:" steht. Das Modul ide-gd_mod wird ja, wenn ich nicht irre, nur für ATA-Festplatten und Disketten-Laufwerke benötigt. Vielleicht spielt es eine Rolle, dass ich neben dem Brenner auch eine Festplatte am IDE-Controller habe...
Benutzeravatar
lOtz1009
Moderator
Moderator
Beiträge: 7177
Registriert: 23. Jan 2008, 09:51
Wohnort: Sulzbach/Ts.
Kontaktdaten:

Re: ide support für Brenner abgestellt?

Beitrag von lOtz1009 »

Also der Support für IDE-Brenner wurde sicherlich nicht eingestellt.
Ich habe selbst einen (LG) und der brennt bisher auch jede Scheibe die er verfüttert bekommt. Egal ob CD oder DVD (-R,+R,-RW).
vi is an editor with two modes: one which destroys your input and the other which beeps at you.
Für meine Beiträge gilt:
Bild
fluxbox
Newbie
Newbie
Beiträge: 9
Registriert: 18. Jan 2010, 08:57

Re: ide support für Brenner abgestellt?

Beitrag von fluxbox »

@lOtz1009 Natürlich nicht, es geht nur darum die alten IDE-Treiber anstelle der PATA-Treiber zu verwenden. Ab Kernel 2.6.33 gelten erstere übrigens als "deprecated" (und letztere nicht mehr als experimentell).
Zuletzt geändert von fluxbox am 27. Jan 2010, 09:28, insgesamt 1-mal geändert.
EagleFox
Member
Member
Beiträge: 115
Registriert: 12. Mai 2005, 18:43

Re: ide support für Brenner abgestellt?

Beitrag von EagleFox »

@fluxbox Hmm, seltsam, ist mir gar nicht aufgefallen. In der /etc/sysconfig/kernel steht sie aber drin.

nach nochmaliger mkinitrd:

Code: Alles auswählen

Kernel image:   /boot/vmlinuz-2.6.31.8-0.1-default
Initrd image:   /boot/initrd-2.6.31.8-0.1-default
Root device:    /dev/disk/by-id/ata-SAMSUNG_HD401LJ_S0HVJ1CLB06116-part2 (/dev/sdc2) (mounted on / as ext4)
Resume device:  /dev/disk/by-id/ata-WDC_WD1600BB-00GUA0_WD-WCAL91713648-part1 (/dev/sdb1)
Kernel Modules: thermal_sys thermal pata_sis sata_sis ata_generic ide-core sis5513 ide-pci-generic ide-gd_mod cdrom ide-cd_mod processor fan crc16 jbd2 ext4
Features:       block usb resume.userspace resume.kernel
Bootsplash:     openSUSE (1280x1024)
Ich hatte nur die Ausgabe aus meinem ersten Post bei Dir kopiert. Da hatte ich sie noch nicht drin. :roll:

P.S. Ich habe auch zwei ide Festplatten im Rechner, die werden auch mit pata bedient.

P.S.S In der boot.msg ist mir aufgefallen, dass der pata Treiber vor der Erkennung der Laufwerke geladen wird, die ide Treiber jedoch erst viel später. Kann man die Reihenfolge durch irgendwelche Optionen in der 00-system.conf oder 99-local.conf irgendwie ändern?
fluxbox
Newbie
Newbie
Beiträge: 9
Registriert: 18. Jan 2010, 08:57

Re: ide support für Brenner abgestellt?

Beitrag von fluxbox »

EagleFox hat geschrieben:In der boot.msg ist mir aufgefallen, dass der pata Treiber vor der Erkennung der Laufwerke geladen wird, die ide Treiber jedoch erst viel später. Kann man die Reihenfolge durch irgendwelche Optionen in der 00-system.conf oder 99-local.conf irgendwie ändern?
Darüber habe ich auch nachgedacht... Ich weiß nicht, ob die Reihenfolge der Module, die in /etc/sysconfig/kernel explizit angegeben sind, eine Rolle spielt, du könntest ja mal sis5513, ide-cd_mod und ide-gd_mod ganz an den Anfang stellen, die pata- und sata-Module vielleicht auch ganz herausnehmen (damit sie erst nach Erkennung der Laufwerke nachgeladen werden).
Wenn das nicht klappt, gibt es für die modprobe.d/*.conf Dateien ja anderererseits auch solche Konstrukte wie

Code: Alles auswählen

install sata_sis { /sbin/modprobe sis5513; } ; /sbin/modprobe --ignore-install sata_sis
um z.B. sis5513 vor sata_sis zu laden - da kann ich dir jetzt aber nicht im Detail helfen...
Vielleicht ist beim 64bit-Kernel alles auch etwas problematisch, weil libata kein Modul, sondern fest im Kernel ist (deshalb hat options libata atapi_enabled=0 auch nichts bewirkt).
EagleFox
Member
Member
Beiträge: 115
Registriert: 12. Mai 2005, 18:43

Re: ide support für Brenner abgestellt?

Beitrag von EagleFox »

Die einfache Umstellung in der /etc/sysconfig/kernel hat zum Erfolg geführt! Danke fluxbox.
Nun sind meine Brenner wieder /dev/hd*. Brennen klappt aber immernoch nicht, Fehler sind die gleichen wie mit dem pata Treiber. Ich gebs auf.
jengelh
Guru
Guru
Beiträge: 4039
Registriert: 20. Nov 2004, 17:42
Kontaktdaten:

Re: ide support für Brenner abgestellt?

Beitrag von jengelh »

Ich hab die Erfahrung gemacht, dass die Brenner den Schreibgeist aufgeben, sobald die 2 Jahre seit Kauf rum sind. :zensur:
Benutzeravatar
revealed
Guru
Guru
Beiträge: 3016
Registriert: 15. Sep 2006, 12:50

Re: ide support für Brenner abgestellt?

Beitrag von revealed »

Ich hab die Erfahrung gemacht, dass die Brenner den Schreibgeist aufgeben, sobald die 2 Jahre seit Kauf rum sind.
Da hab ich schonmal gute Erfahrungen mit Linsenreinigen gemacht. Mit zusatzfreiem Öl und parfümfreien Alkohol und Wattestäbchen. Besonders wenn beim Computer geraucht wurde, beispielsweise. Da war tatsächlich so nen gelber Film auf der Linse, dass dieser nimmer wollte.

Fraglich, ob der Brenner beispielsweise mit einem anderen Betriebssystem funktioniert, bzw. ob Möglichkeit besteht zu testen? Und sowas aufschrauben und reinigen ist nicht jedermanns Sache. Allein die Aufkleber auf dem Gehäuse sind Grund genug.

Gruß,

R
|Nb: T60 2008 43G @oS Leap 42.1 | Pc: @oS TW Core i5 4670k; 8 GB RAM; MSI Z87 G43 Gaming | MSI TF 770 GTX | 840 EVO; SX900 |The reason computer chips are so small is computers don't eat much. | systemd | Mini Tuning guide für openSUSE 13.2 |
EagleFox
Member
Member
Beiträge: 115
Registriert: 12. Mai 2005, 18:43

Re: ide support für Brenner abgestellt?

Beitrag von EagleFox »

Also Linse reinigen habe ich schon gemacht. CDs brennt er ja auch brav. Nur DVDs will er nicht mehr. Weder + noch -, obwohl er beides mal gebrannt hatte. Ich versuche den mal in meinem Windows Rechner einzubauen und zu sehen, ob er da funzt. Würde mich eigentlich wundern wenn nicht, denn vor dem Update auf 11.2 ging er ja noch.
Antworten