Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[geloest] Suse 11 Partition automatisch einhaengen fstab

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
Fennec
Newbie
Newbie
Beiträge: 23
Registriert: 4. Aug 2008, 02:38

[geloest] Suse 11 Partition automatisch einhaengen fstab

Beitrag von Fennec »

Hi

Ich komme mal wieder nicht mit dieser fstab zurecht. Um die Virtualbox zu nutzen, habe ich "umpartitioniert", um meine Daten auf eine extra Partition auszulagern. Und diese Partition bekomme ich nicht automatisch gemountet. Ueber Yast geht es EIN Mal und nur wenn ich nicht reboote. Reboote ich aber, ist die Partition wieder weg und muss sie manuell mounten. Schreiben geht dann aber auch nicht mehr.
Ich finde die Fehler nicht und brauche Hilfe.

Es geht also um die /dev/sda4

Meine fstab

Code: Alles auswählen

/dev/sda1                                                           /boot                ext3        acl,user_xattr                                        1 2
/dev/sda4                                                           /home/tux/Daten      ext3        acl,user_xattr                                        0 0
/dev/sdc1                                                           /Fat32               vfat        user,noauto,users,gid=users,umask=0002,utf8=true      0 0
/dev/sdc2                                                           /home/tux/backup     ext3        user,noauto,acl,user_xattr                            0 0
/dev/disk/by-id/scsi-SATA_WDC_WD1500ADFD-_WD-WMAP41429713-part2     swap                 swap        defaults                                              0 0
/dev/disk/by-id/scsi-SATA_WDC_WD1500ADFD-_WD-WMAP41429713-part3     /                    ext3        acl,user_xattr                                        1 1
/dev/disk/by-id/scsi-SATA_WDC_WD1500ADFD-_WD-WMAP41418587-part1     /home                ext3        acl,user_xattr                                        1 2
proc                                                                /proc                proc        defaults                                              0 0
sysfs                                                               /sys                 sysfs       noauto                                                0 0
debugfs                                                             /sys/kernel/debug    debugfs     noauto                                                0 0
usbfs                                                               /proc/bus/usb        usbfs       noauto                                                0 0
devpts                                                              /dev/pts             devpts      mode=0620,gid=5                                       0 0
mtab

Code: Alles auswählen

/dev/sda3 / ext3 rw,acl,user_xattr 0 0
proc /proc proc rw 0 0
sysfs /sys sysfs rw 0 0
debugfs /sys/kernel/debug debugfs rw 0 0
udev /dev tmpfs rw 0 0
devpts /dev/pts devpts rw,mode=0620,gid=5 0 0
/dev/sda1 /boot ext3 rw,acl,user_xattr 0 0
/dev/sdb1 /home ext3 rw,acl,user_xattr 0 0
fusectl /sys/fs/fuse/connections fusectl rw 0 0
securityfs /sys/kernel/security securityfs rw 0 0
none /proc/sys/fs/binfmt_misc binfmt_misc rw 0 0

Zusatzlich habe ich beim Booten folgenden Fehler

/dev/sdb1 on /home type ext3 (rw,acl,user_xattr) failed

Funktioniert aber komischerweise alles.
Zuletzt geändert von Fennec am 21. Jan 2010, 12:17, insgesamt 1-mal geändert.
Tooltime
Advanced Hacker
Advanced Hacker
Beiträge: 1202
Registriert: 28. Mai 2008, 17:49

Re: Suse 11 Partition automatisch einhaengen fstab mal wieder

Beitrag von Tooltime »

Beim Starten wird die fstab Zeilenweise abgearbeitet, daher läuft das Mounten von /home/tux/Daten u. /home/tux/backup ins Leere, da /home noch nicht gemountet ist.

Und die Moral von der Geschicht, wenn man die fstab erweitert, dann hängt man die neuen Einträge unten an und quetscht sie nicht einfach davor.
Fennec
Newbie
Newbie
Beiträge: 23
Registriert: 4. Aug 2008, 02:38

Re: Suse 11 Partition automatisch einhaengen fstab mal wieder

Beitrag von Fennec »

Hi,

auweia, da soll doch mal jemand drauf kommen. Dafuer schlage ich mir die halbe Nacht um die Ohren ;(
Fehlermeldung ist weg, die Partition wird gemountet aber schreiben kann ich darauf noch nicht.

tux@home:~/Desktop> cp Dual_1.png /home/tux/Daten
cp: reguläre Datei „/home/tux/Daten/Dual_1.png“ kann nicht angelegt werden: Keine Berechtigung

Wo habe ich da noch den Fehler ?

Code: Alles auswählen

/dev/sda1                                                               /boot                ext3        acl,user_xattr                                        1 2
/dev/disk/by-id/scsi-SATA_WDC_WD1500ADFD-_WD-WMAP41429713-part3         /                    ext3        acl,user_xattr                                        1 1
/dev/disk/by-id/scsi-SATA_WDC_WD1500ADFD-_WD-WMAP41429713-part2         swap                 swap        defaults                                              0 0
/dev/disk/by-id/scsi-SATA_WDC_WD1500ADFD-_WD-WMAP41418587-part1         /home                ext3        acl,user_xattr                                        1 2
proc                                                                    /proc                proc        defaults                                              0 0
sysfs                                                                   /sys                 sysfs       noauto                                                0 0
debugfs                                                                 /sys/kernel/debug    debugfs     noauto                                                0 0
usbfs                                                                   /proc/bus/usb        usbfs       noauto                                                0 0
devpts                                                                  /dev/pts             devpts      mode=0620,gid=5                                       0 0
/dev/sda4                                                               /home/tux/Daten      ext3        user,auto,acl,user_xattr                              0 0
/dev/sdc2                                                               /home/tux/backup     ext3        user,noauto,acl,user_xattr                            0 0
/dev/sdc1                                                               /Fat32               vfat        user,noauto,users,gid=users,umask=0002,utf8=true      0 0
admine
Administrator
Administrator
Beiträge: 8865
Registriert: 15. Feb 2004, 21:13
Kontaktdaten:

Re: Suse 11 Partition automatisch einhaengen fstab mal wieder

Beitrag von admine »

Schau dir die Rechte auf dem Mount-Punkt an bei gemounteter Partition.
Auch ein "rw" als Option in der /etc/fstab könnte hilfreich sein. ;)
..:: unser Linux-Club-Wiki ::..
-------------------------
..:: Deutsche Mugge ::..
-------------------------
Fennec
Newbie
Newbie
Beiträge: 23
Registriert: 4. Aug 2008, 02:38

Re: Suse 11 Partition automatisch einhaengen fstab mal wieder

Beitrag von Fennec »

Das war es. Ich habe noch die Rechte vergeben und alles laeuft wie es soll.
Was mich jetzt noch irritiert ist, warum funktionierte das bei den beiden anderen Partitionen Fat32 / backup von allein ?

Jedenfalls Danke an alle fuer die Hilfe. Problem geloest und auch verstanden.
admine
Administrator
Administrator
Beiträge: 8865
Registriert: 15. Feb 2004, 21:13
Kontaktdaten:

Re: Suse 11 Partition automatisch einhaengen fstab mal wieder

Beitrag von admine »

Fennec hat geschrieben:warum funktionierte das bei den beiden anderen Partitionen Fat32 / backup von allein ?
Für eine vfat-Partition werden die Rechte ausschließlich über die Optionen der fstab gesetzt.
Für deine backup-Partition hast du dann vermutlich schon mal entsprechende Rechte vergeben.
..:: unser Linux-Club-Wiki ::..
-------------------------
..:: Deutsche Mugge ::..
-------------------------
Fennec
Newbie
Newbie
Beiträge: 23
Registriert: 4. Aug 2008, 02:38

Re: [geloest] Suse 11 Partition automatisch einhaengen fstab

Beitrag von Fennec »

Das kann sein, die backup Partition habe ich schon lange.
Vielleicht sollte ich dieses YAST mal loeschen und wieder mehr ueber die shell machen. Man verlernt duch dieses KlickiBunti alles so schnell und vor allem verlaesst man sich viel zu sehr auf dieses Yast. "Yast wird es schon richten" Nur leider ist das Gegenteil der Fall.
Antworten