Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Problem(e) mit postgresql

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
Benutzeravatar
KKN
Newbie
Newbie
Beiträge: 45
Registriert: 29. Sep 2004, 20:29
Wohnort: Nettersheim in der Eifel

Problem(e) mit postgresql

Beitrag von KKN »

[gelöst]Hallo!
Ich hatte Lx-Office-erp installiert und gut zum Laufen gebracht, vieles rumprobiert und gespielt.
Wollte dann das ganze sauber haben und habe fatalerweise alle Datenbanken gelöscht. Und seitdem geht nichts mehr.
Danach ließen sich keine DB mehr einrichten und der Zugang zu Lx funktionierte auch nicht mehr. Nach vielem erfolglosen Rumprobieren hab ich mit Yast alles deinstalliert und wieder neu installiert, ohne Erfolg. Das Problem liegt bei postgres. Ich glaube durch das viele Hin und Her ist das ganze total durcheinander.
Zustand jetzt:

Wenn ich in Yast mit dem Runleveleditor postgesql auf "ein" setzen will, schreibt er Yes* (mit "*").

Code: Alles auswählen

linux-v4ld:/home/Klaus # rcpostgresql status
Checking for PostgreSQL:                                             unused
In

Code: Alles auswählen

/var/lib/pgsql/initlog/
steht:

Code: Alles auswählen

Die Dateien, die zu diesem Datenbanksystem gehören, werden dem Benutzer
»postgres« gehören. Diesem Benutzer muss auch der Serverprozess gehören.

Der Datenbankcluster wird mit der Locale de_DE.UTF-8 initialisiert werden.
Die Standarddatenbankkodierung wurde entsprechend auf UTF8 gesetzt.
Die Standardtextsuchekonfiguration wird auf »german« gesetzt.

erzeuge Verzeichnis var/lib/pgsql/data ... ok
erzeuge Unterverzeichnisse ... ok
wähle Vorgabewert für max_connections ... 100
wähle Vorgabewert für shared_buffers/max_fsm_pages ... 32MB/204800
erzeuge Konfigurationsdateien ... ok
erzeuge Datenbank template1 in var/lib/pgsql/data/base/1 ... ok
initialisiere pg_authid ... ok
initialisiere Abhängigkeiten ... ok
erzeuge Systemsichten ... ok
lade Systemobjektbeschreibungen ... ok
erzeuge Konversionen ... ok
erzeuge Wörterbücher ... ok
setze Privilegien der eingebauten Objekte ... ok
erzeuge Informationsschema ... ok
führe Vacuum in Datenbank template1 durch ...ok
kopiere template1 nach template0 ... ok
kopiere template1 nach postgres ... ok

Erfolg. Sie können den Datenbankserver jetzt mit

    /usr/bin/postgres -D var/lib/pgsql/data
oder
    /usr/bin/pg_ctl -D var/lib/pgsql/data -l logdatei start

starten.
Merkwürdig ist, dass /var/lib/pgsql/data mittlerweile zu /var/lib/pgsql/var/lib/data/var/lib/data...........???? geworden ist.
Alls user postgres :

Code: Alles auswählen

/usr/bin/postgres -D var/lib/pgsql/data 
ergibt

Code: Alles auswählen

postgres@linux-v4ld:/home/Klaus> /usr/bin/postgres -D Var/lib/pgsql/data
postgres kann nicht auf die Serverkonfigurationsdatei »/home/Klaus/Var/lib/pgsql/data/postgresql.conf« zugreifen: Datei oder Verzeichnis nicht gefunde
In meiner Verzweiflung hab ich einen alten Rechner mit Suse 10.0 rausgekramt, installiert und postgres lief.
Ich hoffe jemand hat eine Idee und kann helfen, sonst befürchte ich, dass ich Suse 11.1. neu installieren muss.

Postgres 8.3, Suse 11.1.
Zuletzt geändert von KKN am 19. Jan 2010, 00:00, insgesamt 1-mal geändert.
Benutzeravatar
KKN
Newbie
Newbie
Beiträge: 45
Registriert: 29. Sep 2004, 20:29
Wohnort: Nettersheim in der Eifel

Re: Problem(e) mit postgresql

Beitrag von KKN »

[gelöst] Ich hab mit Yast nochmal wieder deinstalliert und alles nochmal durchgesucht und Dateien von Hand gelöscht. Dann wieder installiert. Jetzt läuft postgreSQL.
Linux-Frischling
Antworten