Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Skuriles Mausproblem

Alles rund um Hardware, die unter Linux läuft oder zum Laufen gebracht werden soll

Moderator: Moderatoren

Antworten
la muerte
Newbie
Newbie
Beiträge: 17
Registriert: 25. Nov 2009, 09:52

Skuriles Mausproblem

Beitrag von la muerte »

Hallo Linux-Club!

Ich benutze Linux Open Suse 11.2 auf einem Rechner und habe Probleme mit der Logitech Cordless Desktop Comfort (PS2)

Also, das Problem ist plötzlich aufgetaucht, ohne irgendwelche Änderungen der Einstellungen oder Austauschen der Maus. Wenn ich die Maus und die Tastatur angeschlossen habe während ich boote, bzw wenn ich nichts angeschlossen habe geht nach dem boot die Maus nicht, die Tastatur geht nur so lange bis ich etwas mit der Maus mache. Wenn ich Tastatur und Maus über ein PS2 zu USB Adapter anschließe, reagiert die Maus, jedoch schreibe ich dann durch das Bewegen bzw. Klicken und die Tastatur schreibt auch. Das Adapter funktioniert aber normalerweise einwandfrei!
Wenn ich nun aber mit einer anderen Maus boote und anschließend die Mäuse tausche funktioniert die Logitech! Deshalb denke ich kann es nicht am PS2 liegen. Sieht für mich so aus als ob er keine Maus erkennt wenn ich mit der Logitech boote. An Treibern sollte es auch nicht liegen, da ich keine gelöscht oder installiert habe und die Tatsache dass das Problem plötzlich kam ohne an der Software etwas zu verändern weist auf einen Hardwaredefekt hin.. also im Großen und Ganzen bin ich verwirrt :)

Freue mich über alle Tipps!

mfg
Benutzeravatar
whois
Administrator
Administrator
Beiträge: 16611
Registriert: 11. Okt 2004, 08:50
Wohnort: Aachen
Kontaktdaten:

Re: Skuriles Mausproblem

Beitrag von whois »

Kommt hier irgendeine spezifische Ausgabe?
Mit gestarteter nicht funktionierender Mouse.

Code: Alles auswählen

hwinfo --mouse
Benutzeravatar
lOtz1009
Moderator
Moderator
Beiträge: 7177
Registriert: 23. Jan 2008, 09:51
Wohnort: Sulzbach/Ts.
Kontaktdaten:

Re: Skuriles Mausproblem

Beitrag von lOtz1009 »

Ich würde da mal in die /var/log/Xorg.0.log und /var/log/messages schauen, ob es entsprechende Meldungen zu dem Problem gibt.
Existiert bei dir eine /etc/X11/xorg.conf ?
vi is an editor with two modes: one which destroys your input and the other which beeps at you.
Für meine Beiträge gilt:
Bild
la muerte
Newbie
Newbie
Beiträge: 17
Registriert: 25. Nov 2009, 09:52

Re: Skuriles Mausproblem

Beitrag von la muerte »

Hallo,

leider sitze ich momentan nicht an dem betroffenen Rechner.
@ whois: Ich habe vorhin in die Hardwareinformationen auf Softwareebene geschaut und es wurde keine Maus angezeigt, lediglich die Tastatur.
@ lOtz1009: Kann ich dir nicht sagen ob /etc/X11/xorg.conf exisitert, ich werde es bei Gelegenheit nachschauen und spätestens morgen bescheid geben.
la muerte
Newbie
Newbie
Beiträge: 17
Registriert: 25. Nov 2009, 09:52

Re: Skuriles Mausproblem

Beitrag von la muerte »

So.. erstmal guten morgen :)

also mit gestarteter nicht funktionierender Maus kommt keine Ausgabe bei hwinfo --mouse.

Die Datei /etc/X11/xorg.conf existiert und enthält folgendes:

Code: Alles auswählen

Section "Files"
  FontPath     "/usr/share/fonts/misc:unscaled"
  FontPath     "/usr/share/fonts/local"
  FontPath     "/usr/share/fonts/75dpi:unscaled"
  FontPath     "/usr/share/fonts/100dpi:unscaled"
  FontPath     "/usr/share/fonts/Type1"
  FontPath     "/usr/share/fonts/URW"
  FontPath     "/usr/share/fonts/Speedo"
  FontPath     "/usr/share/fonts/PEX"
  FontPath     "/usr/share/fonts/cyrillic"
  FontPath     "/usr/share/fonts/latin2/misc:unscaled"
  FontPath     "/usr/share/fonts/latin2/75dpi:unscaled"
  FontPath     "/usr/share/fonts/latin2/100dpi:unscaled"
  FontPath     "/usr/share/fonts/latin2/Type1"
  FontPath     "/usr/share/fonts/latin7/75dpi:unscaled"
  FontPath     "/usr/share/fonts/baekmuk:unscaled"
  FontPath     "/usr/share/fonts/japanese:unscaled"
  FontPath     "/usr/share/fonts/kwintv"
  FontPath     "/usr/share/fonts/truetype"
  FontPath     "/usr/share/fonts/uni:unscaled"
  FontPath     "/usr/share/fonts/CID"
  FontPath     "/usr/share/fonts/ucs/misc:unscaled"
  FontPath     "/usr/share/fonts/ucs/75dpi:unscaled"
  FontPath     "/usr/share/fonts/ucs/100dpi:unscaled"
  FontPath     "/usr/share/fonts/hellas/misc:unscaled"
  FontPath     "/usr/share/fonts/hellas/75dpi:unscaled"
  FontPath     "/usr/share/fonts/hellas/100dpi:unscaled"
  FontPath     "/usr/share/fonts/hellas/Type1"
  FontPath     "/usr/share/fonts/misc/sgi:unscaled"
  FontPath     "/usr/share/fonts/xtest"
  FontPath     "/opt/kde3/share/fonts"
  InputDevices "/dev/gpmdata"
  InputDevices "/dev/input/mice"
EndSection

Section "ServerFlags"
  Option       "AllowMouseOpenFail" "on"
  Option       "ZapWarning" "on"
EndSection

Section "Module"
  Load         "freetype"
  Load         "dbe"
  Load         "dri"
  Load         "glx"
  Load         "extmod"
EndSection

Section "InputDevice"
  Driver       "kbd"
  Identifier   "Keyboard[0]"
  Option       "Protocol" "Standard"
  Option       "XkbLayout" "de"
  Option       "XkbModel" "microsoftpro"
  Option       "XkbRules" "xfree86"
  Option       "XkbVariant" "nodeadkeys"
EndSection


Section "InputDevice"
  Driver       "mouse"
  Identifier   "Mouse[1]"
  Option       "Buttons" "9"
  Option       "Device" "/dev/input/mice"
  Option       "Name" "ImExPS/2 Generic Explorer Mouse"
  Option       "Protocol" "explorerps/2"
  Option       "Vendor" "Sysp"
  Option       "ZAxisMapping" "4 5"
EndSection


Section "Monitor"
  Option       "CalcAlgorithm" "XServerPool"
  DisplaySize  305 230
  HorizSync    31-38
  Identifier   "Monitor[0]"
  ModelName    "800X600@60HZ"
  Option       "DPMS"
  Option       "PreferredMode" "800x600"
  VendorName   "--> VESA"
  VertRefresh  50-60
  UseModes     "Modes[0]"
EndSection


Section "Modes"
  Identifier   "Modes[0]"
EndSection


Section "Screen"
  SubSection "Display"
    Depth      15
    Modes      "default" 
  EndSubSection
  SubSection "Display"
    Depth      16
    Modes      "default" 
  EndSubSection
  SubSection "Display"
    Depth      24
    Modes      "default" 
  EndSubSection
  SubSection "Display"
    Depth      8
    Modes      "default" 
  EndSubSection
  Device       "Device[0]"
  Identifier   "Screen[0]"
  Monitor      "Monitor[0]"
EndSection


Section "Device"
  BoardName    "Framebuffer Graphics"
  Driver       "fbdev"
  Identifier   "Device[0]"
  Screen       0
  VendorName   "VESA"
EndSection



Section "ServerLayout"
  Identifier   "Layout[all]"
  InputDevice  "Keyboard[0]" "CoreKeyboard"
  InputDevice  "Mouse[1]" "CorePointer"
  Option       "Clone" "off"
  Option       "Xinerama" "off"
  Screen       "Screen[0]"
EndSection


Section "DRI"
    Group      "video"
    Mode       0660
EndSection

Section "Extensions"
EndSection
In /var/log/Xorg.0.log steht über die Maus:

Code: Alles auswählen

(**) Mouse[1]: Device: "/dev/input/mice"
(**) Mouse[1]: Protocol: "explorerps/2"
(**) Option "CorePointer"
(**) Mouse[1]: always reports core events
(**) Option "Device" "/dev/input/mice"
(**) Option "Buttons" "9"
(==) Mouse[1]: Emulate3Buttons, Emulate3Timeout: 50
(**) Option "ZAxisMapping" "4 5"
(**) Mouse[1]: ZAxisMapping: buttons 4 and 5
(**) Mouse[1]: Buttons: 13
(**) Mouse[1]: Sensitivity: 1
(II) evaluating device (Keyboard[0])
(II) XINPUT: Adding extended input device "Keyboard[0]" (type: KEYBOARD)
(II) evaluating device (Mouse[1])
(II) XINPUT: Adding extended input device "Mouse[1]" (type: MOUSE)
(II) Mouse[1]: ps2EnableDataReporting: succeeded
Could not init font path element /usr/share/fonts/TTF/, removing from list!
Could not init font path element /usr/share/fonts/OTF, removing from list!
(II) FBDEV(0): FBIOBLANK: Invalid argument (Screen blanking not supported by vesafb of Linux Kernel)
in /var/log/messages konnte ich wegen Administrationsproblemen und fehlender Maus nicht einsehen. Folgt aber in Kürze!

mfg
la muerte
Newbie
Newbie
Beiträge: 17
Registriert: 25. Nov 2009, 09:52

Re: Skuriles Mausproblem

Beitrag von la muerte »

So zu /var/log/messages :

Code: Alles auswählen

Jan 12 08:34:45 linux-fv2p kernel: psmouse.c: Wheel Mouse at isa0060/serio1/input0 lost synchronization, throwing 1 bytes away.
Jan 12 08:34:47 linux-fv2p kernel: psmouse.c: failed to re-enable mouse on isa0060/serio1
Jan 12 08:34:47 linux-fv2p kernel: psmouse.c: resync failed, issuing reconnect request
Jan 12 08:34:47 linux-fv2p kernel: psmouse.c: Failed to reset mouse on isa0060/serio1
Jan 12 08:34:55 linux-fv2p kernel: psmouse.c: Failed to reset mouse on isa0060/serio1
Jan 12 08:35:05 linux-fv2p kernel: input: PS/2 Generic Mouse as /devices/platform/i8042/serio1/input/input5
Jan 12 08:35:05 linux-fv2p kernel: psmouse.c: Failed to enable mouse on isa0060/serio1
Das ist so ziemlich das einzige was über die Maus da steht, denke aber eher dass dies von dem Vorgang ist, wenn ich mit der funktionierenden Maus boote und dannach wechsle.

Und was ich vergessen hatte, das ganze geht über ein KVM-Switch von TRENDnet, TK-401R heißt das. Vielleicht hats auch damit was zutun, aber das ganze läuft auch schon immer über das Switch und vorher hats ja auch funktioniert :)
Antworten