Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

11.2 - Brennen klappt nicht

Alles rund um das Thema Multimedia unter Linux

Moderator: Moderatoren

Susefreund
Newbie
Newbie
Beiträge: 9
Registriert: 9. Mär 2007, 18:18

11.2 - Brennen klappt nicht

Beitrag von Susefreund »

Hallo Leute,
unter 11.1 klappt das Brennen, unter 11.2 (kde 4.3.4 release 2) nicht. Hardwareprob also ausgeschlossen.
Habe auf meiner Kiste 11.1 und 11.2 mit der jeweiligen kde Version ohne Experimente quasi „out of the box“ laufen.
Zusätzliche Quellen sind identisch. Packman ist dabei.

Rechtevergabe sieht auf beiden root-Partitionen unter /usr/bin/ bzw. /X11 identisch aus.
Habe auch kb3-codecs versuchsweise weggelassen. Alles de- und dann neu installiert usw.
Brasero gibt ähnliche Fehlermeldungen...

wodim --devices
0 dev='/dev/scd0' rwrw-- : 'HL-DT-ST' 'DVDRAM GH22LS50'

Dmesg unter 11.2
583.916202] sr 1:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
[ 583.916224] sr 1:0:0:0: [sr0] Sense Key : Illegal Request [current]
[ 583.916241] Info fld=0x0
[ 583.916249] sr 1:0:0:0: [sr0] Add. Sense: Logical block address out of range
[ 583.916266] end_request: I/O error, dev sr0, sector 0
[ 583.916279] __ratelimit: 3 callbacks suppressed
[ 583.916289] Buffer I/O error on device sr0, logical block 0
[ 583.918997] sr 1:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
[ 583.919017] sr 1:0:0:0: [sr0] Sense Key : Illegal Request [current]
[ 583.919034] Info fld=0x0
[ 583.919040] sr 1:0:0:0: [sr0] Add. Sense: Logical block address out of range
[ 583.919058] end_request: I/O error, dev sr0, sector 0
[ 583.919071] Buffer I/O error on device sr0, logical block 0
[ 584.517231] cdrom: This disc doesn't have any tracks I recognize!
**********
wodim beim Brennen als root unter 11.2:
...
tarting new track at sector: 0
Track 01: 1 of 644 MB written (fifo 100%) [buf 96%] 3.6x.Errno: 5 (Input/output error), write_g1 scsi sendcmd: no error
CDB: 2A 00 00 00 02 0F 00 00 1F 00
status: 0x2 (CHECK CONDITION)
Sense Bytes: 70 00 05 00 00 00 00 0A 2A 30 02 80 21 02 00 00
Sense Key: 0x5 Illegal Request, Segment 0
Sense Code: 0x21 Qual 0x02 (invalid address for write) Fru 0x0
Sense flags: Blk 0 (not valid)
cmd finished after 0.002s timeout 40s

write track data: error after 1079296 bytes
wodim: The current problem looks like a buffer underrun.
wodim: It looks like 'driveropts=burnfree' does not work for this drive.
wodim: Please report.
wodim: Make sure that you are root, enable DMA and check your HW/OS set up.

Wäre über Ideen sehr dankbar!
HG
Thomas
Benutzeravatar
longman
Advanced Hacker
Advanced Hacker
Beiträge: 866
Registriert: 22. Apr 2004, 19:01
Wohnort: zuhause

Re: 11.2 - Brennen klappt nicht

Beitrag von longman »

Läuft das CD/RW im DMA Modus ?

Ansonsten schau mal hier:
http://www.linupedia.org/opensuse/Linux ... chleunigen
Tschüss bis neulich,
Gruss Burkhard aka longman
- This System is MS free and works fine -


Linupedia - Wiki des Linux Club | NICHT LESEN! AUF GAR KEINEN FALL! NIEMALS NICHT!
Freddie62
Guru
Guru
Beiträge: 1581
Registriert: 24. Jan 2006, 14:21

Re: 11.2 - Brennen klappt nicht

Beitrag von Freddie62 »

Welche k3b-Version werkelt denn da?

Code: Alles auswählen

rpm -qa|grep k3b
CU Freddie
4 X Tumbleweed, Kernel: 5.4.10-1-default, LXDE. Schleppi: Dell Latitude 5520 mit Win7 Prof./Tumbleweed-X64, Kernel: 5.4.10-1-default, LXDE
Susefreund
Newbie
Newbie
Beiträge: 9
Registriert: 9. Mär 2007, 18:18

Re: 11.2 - Brennen klappt nicht

Beitrag von Susefreund »

Moin Burkhard,
moin Freddy;

Dank für eure Unterstützung!!

Hilft euch das weiter:

/dev/scd0:
multcount = 0 (off)
IO_support = 1 (32-bit)
readonly = 0 (off)
readahead = 256 (on)
HDIO_GETGEO failed: Inappropriate ioctl for device
(sieht unter 11.1 genauso aus)

hdparm -i /dev/scd0

/dev/scd0:

Model=HL-DT-ST DVDRAM GH22LS50, FwRev=TL01, SerialNo=K0099P85337
Config={ Fixed Removeable DTR<=5Mbs DTR>10Mbs nonMagnetic }
RawCHS=0/0/0, TrkSize=0, SectSize=0, ECCbytes=0
BuffType=unknown, BuffSize=unknown, MaxMultSect=0
(maybe): CurCHS=0/0/0, CurSects=0, LBA=yes, LBAsects=0
IORDY=on/off, tPIO={min:120,w/IORDY:120}, tDMA={min:120,rec:120}
PIO modes: pio0 pio3 pio4
DMA modes: mdma0 mdma1 mdma2
UDMA modes: udma0 udma1 udma2 udma3 udma4 *udma5
AdvancedPM=no
Drive conforms to: unknown: ATA/ATAPI-3,4,5,6,7

* signifies the current active mode


k3b-lang-1.69.0-40.pm.44.3.noarch
k3b-1.69.0-40.pm.44.4.x86_64

Dank und Gruß
Thomas
Benutzeravatar
whois
Administrator
Administrator
Beiträge: 16612
Registriert: 11. Okt 2004, 08:50
Wohnort: Aachen
Kontaktdaten:

Re: 11.2 - Brennen klappt nicht

Beitrag von whois »

Hi Thomas

Läuft folgendes Modul?

Code: Alles auswählen

rpm -qa|grep ahci
cu
Susefreund
Newbie
Newbie
Beiträge: 9
Registriert: 9. Mär 2007, 18:18

Re: 11.2 - Brennen klappt nicht

Beitrag von Susefreund »

Hallo Leute,
der letzte Tipp bringt uns auf die Spur, nur ich bin noch zu blöd...
rpm -qa|grep ahci
Fehlanzeige.

lsmod | grep ahci
Fehlanzeige
(unter der anderen root-Partition mit 11.1 finde ich mit lsmod ahci und libata, diese fehlen hier mit 11.2. - ist vll. ein Kernelupdate kurz nach der Installation von 11.2 an allem Schuld - ?)

nun frech probiert:
modprobe -v ahci
builtin ahci

aber danach
lsmod | grep ahci
erneut Fehlanzeige

Wieso kann modprobe ahci einbauen, denn es kommt ja keine Fehlermeldung wie diese von mir provoziert mit dem Modul "test"
FATAL: Module test not found.
aber dann andererseit lsmod ahci nicht auflisten?

Wie heißt das rpm.Paket, indem ahci enthalten ist?
Was macht libata (s.o), das hier unter 11.2 auch nicht autom. geladen wird?
Für modprobe libata gilt das gleiche: builtin libata - keine Listung bei lsmod!
Was mache ich falsch???

Dank und Gruß
Thomas
Susefreund
Newbie
Newbie
Beiträge: 9
Registriert: 9. Mär 2007, 18:18

Re: 11.2 - Brennen klappt nicht

Beitrag von Susefreund »

Nachtrag:
dmesg | grep -i ahci
[ 0.487675] ahci 0000:00:09.0: version 3.0
[ 0.488103] ahci 0000:00:09.0: PCI INT A -> Link[LSA0] -> GSI 23 (level, low) -> IRQ 23
[ 0.488159] ahci 0000:00:09.0: irq 28 for MSI/MSI-X
[ 0.488208] ahci 0000:00:09.0: AHCI 0001.0200 32 slots 6 ports 3 Gbps 0x3f impl IDE mode
[ 0.488211] ahci 0000:00:09.0: flags: 64bit ncq sntf led clo pmp pio
[ 0.488213] ahci 0000:00:09.0: setting latency timer to 64
[ 0.488524] scsi0 : ahci
[ 0.488618] scsi1 : ahci
[ 0.488656] scsi2 : ahci
[ 0.488699] scsi3 : ahci
[ 0.488737] scsi4 : ahci
[ 0.488774] scsi5 : ahci
Hilft das noch weiter? (Meldung übrigens unter 11.1 und 11.2 identisch)
Gruß
Thomas
mkossmann
Member
Member
Beiträge: 181
Registriert: 3. Aug 2009, 19:07

Re: 11.2 - Brennen klappt nicht

Beitrag von mkossmann »

Susefreund hat geschrieben:Hallo Leute,
der letzte Tipp bringt uns auf die Spur, nur ich bin noch zu blöd...
rpm -qa|grep ahci
Fehlanzeige.

lsmod | grep ahci
Fehlanzeige
(unter der anderen root-Partition mit 11.1 finde ich mit lsmod ahci und libata, diese fehlen hier mit 11.2. - ist vll. ein Kernelupdate kurz nach der Installation von 11.2 an allem Schuld - ?)

nun frech probiert:
modprobe -v ahci
builtin ahci

aber danach
lsmod | grep ahci
erneut Fehlanzeige
Das sagt doch alles ;) In 11.2 hat SUSE die Kernelkonfiguration dahingehend geändert, das AHCI nicht mehr als Module gebaut wird, sondern fest in den Kernel eingebaut wird ( Ein Blick in /proc/config.gz zeigt dir: CONFIG_SATA_AHCI = y)
Benutzeravatar
whois
Administrator
Administrator
Beiträge: 16612
Registriert: 11. Okt 2004, 08:50
Wohnort: Aachen
Kontaktdaten:

Re: 11.2 - Brennen klappt nicht

Beitrag von whois »

mkossmann hat geschrieben:Das sagt doch alles ;) In 11.2 hat SUSE die Kernelkonfiguration dahingehend geändert, das AHCI nicht mehr als Module gebaut wird, sondern fest in den Kernel eingebaut wird ( Ein Blick in /proc/config.gz zeigt dir: CONFIG_SATA_AHCI = y)
Das war mir ehrlich gesagt bis dato auch unbekannt.
fluxbox
Newbie
Newbie
Beiträge: 9
Registriert: 18. Jan 2010, 08:57

Re: 11.2 - Brennen klappt nicht

Beitrag von fluxbox »

Ist das ein IDE-Brenner? Mit einem solchen hatte ich dasselbe Problem

Code: Alles auswählen

[  143.106357] cdrom: This disc doesn't have any tracks I recognize!
[  143.133215] sr 1:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
[  143.133224] sr 1:0:0:0: [sr0] Sense Key : Illegal Request [current] 
[  143.133232] Info fld=0x0
[  143.133234] sr 1:0:0:0: [sr0] Add. Sense: Logical block address out of range
[  143.133242] sr 1:0:0:0: [sr0] CDB: Read(10): 28 00 00 00 00 00 00 00 01 00
[  143.133251] end_request: I/O error, dev sr0, sector 0
[  143.133261] Buffer I/O error on device sr0, logical block 0
Meine Lösung war den PATA IDE Treiber zu deaktivieren, so dass der alte IDE Treiber genutzt wird, indem ich in /etc/sysconfig/kernel das Modul pata_amd (habe hier ein AMD-Board) herausgenommen und danach mit mkinitrd die initial ramdisk neu erzeugt habe. Danach war der Brenner wieder wie früher unter /dev/hdc statt /dev/sr0 (Link nach /dev/dvd geht per udev).

Code: Alles auswählen

#INITRD_MODULES="thermal pata_amd sata_nv ata_generic amd74xx ide_pci_generic processor fan"
INITRD_MODULES="thermal sata_nv ata_generic amd74xx ide_pci_generic ide_gd_mod processor fan"
Musst mal sehen welches Modul bei dir zuständig ist, aber Achtung: Wenn in der initrd ein für das Erkennen der root-Partition benötigtes Modul fehlt, bootet der Rechner nicht mehr, also z.B. vorher ein Backup der alten initrd machen.
Zuletzt geändert von fluxbox am 19. Jan 2010, 00:40, insgesamt 1-mal geändert.
Susefreund
Newbie
Newbie
Beiträge: 9
Registriert: 9. Mär 2007, 18:18

Re: 11.2 - Brennen klappt nicht

Beitrag von Susefreund »

Toller Hinweis: Treiber schon im Kernel! Sorry. Danke.
Der LG gh22ls50 ist ein SATA Gerät. Dank auch für diese Idee!
...?
Gruß
Thomas
Susefreund
Newbie
Newbie
Beiträge: 9
Registriert: 9. Mär 2007, 18:18

Re: 11.2 - Brennen klappt nicht

Beitrag von Susefreund »

Liebe Listige,
beginne jetzt parallel dort zu posten:
[url]http://www.opensuse-forum.de/showthread ... #post12273[/url]
Vielen Dank für Eure bisherige Hilfe. Vll. kommt jetzt neuer Schwung in mein Problem...
Gruß
Thomas
EagleFox
Member
Member
Beiträge: 115
Registriert: 12. Mai 2005, 18:43

Re: 11.2 - Brennen klappt nicht

Beitrag von EagleFox »

Hallo zusammen,

ich wollte den Tip von fluxbox mal ausprobieren. Wenn ich aber in der /etc/sysconfig/kernel das pata modul entferne und mkinitrd ausführe, kommt immernoch folgende Meldung:
Kernel image: /boot/vmlinuz-2.6.31.8-0.1-default
Initrd image: /boot/initrd-2.6.31.8-0.1-default
Root device: /dev/disk/by-id/ata-SAMSUNG_HD401LJ_S0HVJ1CLB06116-part2 (/dev/sdd2) (mounted on / as ext4)
Resume device: /dev/disk/by-id/ata-WDC_WD1600BB-00GUA0_WD-WCAL91713648-part1 (/dev/sdb1)
Kernel Modules: thermal_sys thermal pata_sis sata_sis ata_generic ide-core sis5513 ide-pci-generic ide-gd_mod processor fan crc16 jbd2 ext4
in der /etc/sysconfig/kernel steht:
INITRD_MODULES="thermal sata_sis ata_generic sis5513 ide_pci_generic ide_gd_mod processor fan"
wieso bringt der dann immernoch das pata_sis Modul mit rein?
Gibt es noch irgendwo ne Datei, in der Module festgelegt werden?
fluxbox
Newbie
Newbie
Beiträge: 9
Registriert: 18. Jan 2010, 08:57

Re: 11.2 - Brennen klappt nicht

Beitrag von fluxbox »

Oh, stimmt, darüber hatte ich mich auch zunächst gewundert. Nachdem aber mit der neuen initrd das Device sich geändert hat und das Brennen wieder funktionierte (DVD-RW ließen sich nur im Modus "restricted overwrite" bei durchschnittlich 0.6x brennen, im "incremental sequential" Modus gar nicht, jetzt geht es wieder mit maximaler Geschwindigkeit), habe ich mich nicht weiter darum gekümmert. Entscheidend war, dass ich das Modul ide_gd_mod zusätzlich in die initrd aufgenommen habe. Das übernimmt nun die Kontrolle über den DVD-Brenner, pata_amd wird danach gar nicht mehr geladen, wie lsmod zeigt. In der Voreinstellung ist ide_gd_mod in der initrd nicht drin - den Inhalt kann man sich übrigens so anzeigen lassen:

Code: Alles auswählen

gunzip -c /boot/initrd-2.6.31.8-0.1-default| cpio -t
Wie man nun partout verhindern kann, dass ein bestimmtes Modul in die initrd aufgenommen wird, weiß ich nicht.
Susefreund
Newbie
Newbie
Beiträge: 9
Registriert: 9. Mär 2007, 18:18

Re: 11.2 - Brennen klappt nicht

Beitrag von Susefreund »

Hallo Männer,
ihr habt's drauf und ich verstehe mehr oder weniger Bahnhof. ... War das noch mein Problem?
Also:
Der Brenner LG gh22ls50 ist ein SATA Gerät (?)
Wozu brauchte ich dann den ide-Treiber?

lsmod | grep ide
ide_gd_mod 36592 0
ide_cd_mod 36080 0
cdrom 48232 2 ide_cd_mod,sr_mod
ide_pci_generic 5484 0
ide_core 148128 4 ide_gd_mod,ide_cd_mod,ide_pci_generic,amd74xx

Sorry. Bitte noch mal langsam zum Mitdenken für mich DAU... ;-(
Gruß Th
EagleFox
Member
Member
Beiträge: 115
Registriert: 12. Mai 2005, 18:43

Re: 11.2 - Brennen klappt nicht

Beitrag von EagleFox »

Also bei mir will das nicht klappen.

Code: Alles auswählen

lsmod | grep ide
ide_cd_mod             35856  0
cdrom                  47688  2 ide_cd_mod,sr_mod
ide_gd_mod             36368  0
ide_pci_generic         5484  0
ide_core              148480  4 ide_cd_mod,ide_gd_mod,ide_pci_generic,sis5513

Code: Alles auswählen

lsmod | grep ata
ata_generic             6508  0
sata_sis                7276  6
pata_sis               15628  5 sata_sis
pata_sis wird also geladen und meine Brenner sind immernoch /dev/sr0 und /dev/sr1
Yast zeigt mir auch, dass der genutzte Treiber für die beiden Laufwerke pata_sis ist.
Wie bekomme ich es nun hin, dass der ide treiber genutzt wird?

@Susefreund das ganze ist für Dich nicht relevant, weil Dein Brenner SATA ist.
fluxbox
Newbie
Newbie
Beiträge: 9
Registriert: 18. Jan 2010, 08:57

Re: 11.2 - Brennen klappt nicht

Beitrag von fluxbox »

Susefreund hat geschrieben: ... War das noch mein Problem?
Nein, Ich bin nur auf EagleFoxs Beitrag eingegangen, und vielleicht helfen diese Informationen jemand anderem, der per Google oder sonstwie auf diesen Thread trifft.
Susefreund hat geschrieben: Der Brenner LG gh22ls50 ist ein SATA Gerät (?)
Das ist mir nicht entgangen, deshalb habe ich dir auch nicht weiter zu helfen versucht, da ich keine Erfahrung mit SATA-Brennern habe.
Susefreund hat geschrieben: Wozu brauchte ich dann den ide-Treiber?
Wenn an der IDE-Schnittstelle nichts angeschlossen ist, gar nicht. Die Module werden vermutlich trotzdem geladen, einfach weil das Mainboard eine IDE-Schnittstelle hat.
Susefreund hat geschrieben: Bitte noch mal langsam zum Mitdenken für mich DAU... ;-(
Für IDE-Geräte enthält der Linux-Kernel momentan eine ältere und eine neuere Generation von Treibern, wobei die neuere auch SATA-Geräte unterstützt. Mein IDE-Brenner kommt offenbar besser mit den älteren Treibern zurecht. Mein Vorgehen, Suse zur Verwendung derselben zu bugsieren, habe ich oben beschrieben. Für SATA-Geräte gibt es vermutlich keinen ähnlichen Lösungsansatz bzw. Notbehelf.
fluxbox
Newbie
Newbie
Beiträge: 9
Registriert: 18. Jan 2010, 08:57

Re: 11.2 - Brennen klappt nicht

Beitrag von fluxbox »

EagleFox hat geschrieben: pata_sis wird also geladen und meine Brenner sind immernoch /dev/sr0 und /dev/sr1
Ich habe grad den Kernel mit der alten initrd (also ohne ide_gd_mod) laufen - wollte sehen, ob das Laden des ahci-Moduls (ja, beim i686er-Kernel ist es ein Modul) hilft (tut es nicht) - und hier sieht es so aus:

Code: Alles auswählen

lsmod|grep ata
ata_generic             2707  0 
sata_nv                20684  4 
pata_amd                9146  2 
libata                177357  4 ahci,ata_generic,sata_nv,pata_amd
Das heisst pata_amd wird nicht von sata_nv (da hängt eine SATA-Festplatte dran) benötigt, aber bei dir wird pata_sis von sata_sis benötigt...
EagleFox
Member
Member
Beiträge: 115
Registriert: 12. Mai 2005, 18:43

Re: 11.2 - Brennen klappt nicht

Beitrag von EagleFox »

Dass pata_sis von sata_sis benötigt wird, habe ich gesehen. Ich habe SATA-Festplatten, kann das also nicht weglassen.

Ich bin auf diesen Artikel gestoßen:

http://www.easylinux.de/Artikel/ausgabe ... index.html

Das scheint mir nahe an mein Problem heran zu kommen. Nur klappt die Lösung, dass ich in der menu.lst sr0=ide-cd hineinschreibe nicht.
fluxbox
Newbie
Newbie
Beiträge: 9
Registriert: 18. Jan 2010, 08:57

Re: 11.2 - Brennen klappt nicht

Beitrag von fluxbox »

Bei einem 7 Jahre alten Artikel habe ich Zweifel, ob das heute so noch gültig ist, aber Kernel- oder Modulparameter sind natürlich ein guter Ansatzpunkt. modinfo libata offenbart u.a. den Parameter atapi_enabled, also habe ich mal in /etc/modprobe.d/99-local.conf folgendes eingetragen

Code: Alles auswählen

options libata atapi_enabled=0
dann ide_gd_mod wieder aus /etc/sysconfig/kernel herausgenommen und die initrd neu erstellt. Ergebnis: Der Brenner wird gar nicht mehr initialisiert, denn libata ignoriert ihn und ide_gd_mod ist nicht in der initrd. Also würde ich vermuten, dass bei dir obige Option UND ide_gd_mod in der initrd zum gewünschten Ergebnis führt (bei mir reicht ja letzteres allein).

P.S. Auch wenn du nur /etc/modprobe.d/99-local.conf änderst, musst du trotzdem erneut mkinitrd aufrufen, denn auch diese Datei ist Bestandteil der initrd.

P.P.S. Du kannst alternativ auch libata.atapi_enabled=0 als kernel-Parameter in menu.lst eintragen.
Antworten