Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[Gelöst] Grafikprobleme Intel Tigerlake

Alles rund um Hardware, die unter Linux läuft oder zum Laufen gebracht werden soll

Moderator: Moderatoren

Antworten
Freddie62
Guru
Guru
Beiträge: 1609
Registriert: 24. Jan 2006, 14:21

[Gelöst] Grafikprobleme Intel Tigerlake

Beitrag von Freddie62 »

Hallo Zusammen
Seit kurzer Zeit habe ich ein neues Notebook mit einer Intel Tigerlake-GraKa. Leider wird beim Öffnen von Fenstern, etc. die Grafik in diesen Fenstern kurzzeitig stark schwarz verpixelt, bis sich das Ganze beruhigt. Leider habe ich für diese GraKa nichts Großartiges gefunden: "Für Linux gibt es bei Intel keine GraKa-Treiber, diese sind Bestandteil Ihrer Distribution."
Bis auf diese Seltsamkeit, die inzwischen echt nervt, läuft das Notebook (Dell Latitude 5521) echt gut.
Ich verwende Tumbleweed mit Kernel 5.14.6-1-default. Der sollte eigentlich aktuell genug sein.
Die GraKa ist:

Code: Alles auswählen

 hwinfo --gfxcard
29: PCI 02.0: 0300 VGA compatible controller (VGA)              
  [Created at pci.386]
  Unique ID: _Znp.PxgAdNHCrxD
  SysFS ID: /devices/pci0000:00/0000:00:02.0
  SysFS BusID: 0000:00:02.0
  Hardware Class: graphics card
  Model: "Intel TigerLake-H GT1 [UHD Graphics]"
  Vendor: pci 0x8086 "Intel Corporation"
  Device: pci 0x9a68 "TigerLake-H GT1 [UHD Graphics]"
  SubVendor: pci 0x1028 "Dell"
  SubDevice: pci 0x0a67 
  Revision: 0x01
  Driver: "i915"
  Driver Modules: "i915"
  Memory Range: 0x6054000000-0x6054ffffff (rw,non-prefetchable)
  Memory Range: 0x4000000000-0x400fffffff (ro,non-prefetchable)
  I/O Ports: 0x3000-0x303f (rw)
  Memory Range: 0x000c0000-0x000dffff (rw,non-prefetchable,disabled)
  IRQ: 152 (1632309 events)
  Module Alias: "pci:v00008086d00009A68sv00001028sd00000A67bc03sc00i00"
  Driver Info #0:
    Driver Status: i915 is active
    Driver Activation Cmd: "modprobe i915"
  Config Status: cfg=new, avail=yes, need=no, active=unknown

Primary display adapter: #29
Jemand eine Idee, wo ich ansetzen könnte?

CU Freddie
Zuletzt geändert von Freddie62 am 17. Dez 2021, 13:25, insgesamt 1-mal geändert.
5 X Tumbleweed, mit LXDE (3 x AMD, 2 x Intel). Schleppi (Firma): Dell Latitude 5520 mit Win10 Prof., priv. Medion mit Tumbleweed, LXDE
Sauerland
Guru
Guru
Beiträge: 4297
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: Grafikprobleme Intel Tigerlake

Beitrag von Sauerland »

Poste:

Code: Alles auswählen

zypper se -si xf86 intel
Grafikkarte ist ab kernel 5.4 vorhanden, sollte also auch schon mit Leap 15.2 laufen.
Desktop: OpenSUSE Leap 15.3, Nvidia-Grafik Kernel 5.x
Laptop: OpenSUSE Leap 15.3, Intel-Skylake, Kernel 5.3
josef-wien
Ultimate Guru
Ultimate Guru
Beiträge: 5683
Registriert: 23. Sep 2008, 17:09

Re: Grafikprobleme Intel Tigerlake

Beitrag von josef-wien »

Code: Alles auswählen

inxi -Gxxx
Freddie62
Guru
Guru
Beiträge: 1609
Registriert: 24. Jan 2006, 14:21

Re: Grafikprobleme Intel Tigerlake

Beitrag von Freddie62 »

Code: Alles auswählen

zypper se -si xf86 intel
Repository-Daten werden geladen...
Installierte Pakete werden gelesen...

S | Name                  | Type  | Version      | Arch   | Repository
--+-----------------------+-------+--------------+--------+------------------------
i | intel-media-driver    | Paket | 21.3.3-2.1   | x86_64 | (Systempakete)
i | intel-vaapi-driver    | Paket | 2.4.1-4.1    | x86_64 | (Systempakete)
i | kernel-firmware-intel | Paket | 20210901-1.2 | noarch | (Systempakete)
i | libXxf86vm1           | Paket | 1.1.4-1.21   | x86_64 | openSUSE-Tumbleweed-Oss
i | libdrm_intel1         | Paket | 2.4.107-2.1  | x86_64 | (Systempakete)
i | ucode-intel           | Paket | 20210608-1.2 | x86_64 | openSUSE-Tumbleweed-Oss
i | xf86-input-evdev      | Paket | 2.10.6-3.3   | x86_64 | (Systempakete)
i | xf86-input-joystick   | Paket | 1.6.3-2.3    | x86_64 | (Systempakete)
i | xf86-input-keyboard   | Paket | 1.9.0-2.3    | x86_64 | (Systempakete)
i | xf86-input-libinput   | Paket | 1.2.0-1.1    | x86_64 | (Systempakete)
i | xf86-input-vmmouse    | Paket | 13.1.0-8.3   | x86_64 | (Systempakete)
i | xf86-input-wacom      | Paket | 0.40.0-1.3   | x86_64 | (Systempakete)
i | xf86-video-fbdev      | Paket | 0.5.0-2.3    | x86_64 | (Systempakete)
i | xf86-video-vesa       | Paket | 2.5.0-2.3    | x86_64 | (Systempakete)
und

Code: Alles auswählen

inxi -Gxxx
Graphics:  Device-1: Intel TigerLake-H GT1 [UHD Graphics] vendor: Dell driver: i915 v: kernel bus-ID: 0000:00:02.0 
           chip-ID: 8086:9a68 class-ID: 0300 
           Device-2: Sunplus Innovation Integrated_Webcam_FHD type: USB driver: uvcvideo bus-ID: 3-3:2 chip-ID: 1bcf:2ba9 
           class-ID: 0e02 serial: 01.00.00 
           Display: x11 server: X.org 1.20.13 driver: loaded: modesetting unloaded: fbdev,vesa alternate: intel 
           resolution: <missing: xdpyinfo> 
           OpenGL: renderer: Mesa Intel UHD Graphics (TGL GT1) v: 4.6 Mesa 21.2.2 direct render: Yes
CU Freddie
5 X Tumbleweed, mit LXDE (3 x AMD, 2 x Intel). Schleppi (Firma): Dell Latitude 5520 mit Win10 Prof., priv. Medion mit Tumbleweed, LXDE
josef-wien
Ultimate Guru
Ultimate Guru
Beiträge: 5683
Registriert: 23. Sep 2008, 17:09

Re: Grafikprobleme Intel Tigerlake

Beitrag von josef-wien »

Als erstes würde ich das Paket xf86-video-intel installieren und das grafische System neu starten. Wenn dann immer noch
Freddie62 hat geschrieben:driver: loaded: modesetting
zu lesen ist, müssen wir Xorg überreden, intel zu verwenden.

P. S. "Systempakete" bedeutet, daß im Tumbleweed-Repo neuere Versionen zur Verfügung stehen.
Freddie62
Guru
Guru
Beiträge: 1609
Registriert: 24. Jan 2006, 14:21

Re: Grafikprobleme Intel Tigerlake

Beitrag von Freddie62 »

Hallo Josef-Wien

Leider "durfte" ich kurzfristig für fast zwei Wochen auf Dienstreise und hatte keine Zeit mich um diese Sache zu kümmern. Inzwischen bin ich zurück und habe gerade mal xf86-video-intel (plus Abhängigkeiten) installiert. Jetzt scheint das Ganze problemlos zu funktionieren:

Code: Alles auswählen

inxi -Gxxx
Graphics:  Device-1: Intel TigerLake-H GT1 [UHD Graphics] vendor: Dell driver: i915 v: kernel bus-ID: 0000:00:02.0 
           chip-ID: 8086:9a68 class-ID: 0300 
           Device-2: Sunplus Innovation Integrated_Webcam_FHD type: USB driver: uvcvideo bus-ID: 3-3:2 chip-ID: 1bcf:2ba9 
           class-ID: 0e02 serial: 01.00.00 
           Display: x11 server: X.org 1.21.1.1 driver: loaded: intel unloaded: fbdev,modesetting,vesa 
           resolution: <missing: xdpyinfo> 
           OpenGL: renderer: Mesa Intel UHD Graphics (TGL GT1) v: 4.6 Mesa 21.2.2 direct render: Yes 

Darauf wäre ich jetzt definitiv nicht gekommen. Hatte aber auch nichts diesbezügliches gefunden.
Vielen Dank daher nochmal an Josef-Wien.

CU Freddie
5 X Tumbleweed, mit LXDE (3 x AMD, 2 x Intel). Schleppi (Firma): Dell Latitude 5520 mit Win10 Prof., priv. Medion mit Tumbleweed, LXDE
Antworten