Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

PING im gemischten Netzwerk

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
Jörg Hofmann
Newbie
Newbie
Beiträge: 3
Registriert: 29. Nov 2021, 23:52

PING im gemischten Netzwerk

Beitrag von Jörg Hofmann »

Guten Abend,

an besten stelle ich mich erstmal vor: Mein Name ist Jörg, Baujahr 1964 und ich arbeite seit fast 10 Jahren mit verschiedenen Linux-Versionen, Debian auf dem Server und Mint auf dem Desktop. Technisch bin ich immer noch Rookie, weil ich vor allem Anwender bin. Texte in markdown verfassen und über Pandoc als HTML- oder TeX-Datei ausgeben lassen, kalkulieren mit Libreoffice, sowie ein wenig Inkscape oder Gimp.

Aber sicher sage ich Euch nichts neues, wenn es immer noch Programme gibt, die nach WINDOWS verlangen. Bei mir sind es im wesentlichen die Steuerprogramme, Lexware und DATEV. Ist ja kein Problem, dachte ich, während des Lockdowns habe ich mich oft per Remmina auf WINDOWS-Rechnern angemeldet und dort Unterricht gemacht. Das klappte (bisher) im eigenen und im Internet.

Womit ich endlich beim Thema bin: Der "Hauptrechner" ist meine Linux-Maschine, Linux Mint 20.1 Cinnamon, und gelegentlich brauche ich die Windows-Programme. Bisher hat es immer so funktioniert, das ich bei Remmina ein Skript hinterlegt habe, das den Rechner über QOL startet. Hier ist es:

Code: Alles auswählen

#!/bin/sh
wakeonlan 74:46:A0:90:03:A6 
Aber nun passiert folgendes, starte ich wol.sh in einem Terminal, wird der WINDOWS-PC gestartet und ich kann mich kurz darauf mit Remmina verbinden. Aber aus Remmina heraus läßt sich wol.sh nicht starten und der Verbindungsaufbau scheitert. Und der Clou, der WINDOWS-PC läßt sich von Linux aus nicht anpingen, obwohl eingeschaltet ist. Es heißt immer, 100% Paketverlust.

So, jetzt bin ich gespannt, ob Ihr sowas auch schon erlebt habt und freue mich auf Eure Tipps. Aber, auf VirtualBox bin ich auch schon gekommen, aber DATEV und Lexware spielen da nicht mit.

Danke, das Ihr bis hierher gelesen habt und
Gute N8
Jörg
marce
Advanced Hacker
Advanced Hacker
Beiträge: 1403
Registriert: 19. Jun 2008, 13:16
Wohnort: Dettenhausen
Kontaktdaten:

Re: PING im gemischten Netzwerk

Beitrag von marce »

Dann poste doch bitte mal den konkreten Ping-Befehl, die Netzwerkkonfig von Linux und Windows und prüfe mal die Firewall aller beteiligten Systeme.

Ein- und Ausgaben bitte in [ code]-Tags.
Benutzeravatar
Geier0815
Guru
Guru
Beiträge: 4473
Registriert: 14. Jun 2004, 09:12

Re: PING im gemischten Netzwerk

Beitrag von Geier0815 »

Also von Windows-Servern kann ich dir mit ziemlicher Sicherheit sagen dass diese per firewall ein ankommendes Ping per default blockieren. Da mußt Du bei den Einstellungen bei. Ob das bei den Desktop-Varianten auch so ist, weiß ich nicht, würde ich aber von aus gehen.
Wenn Windows die Lösung ist...
kann ich dann bitte das Problem zurück haben?
Benutzeravatar
/dev/null
Moderator
Moderator
Beiträge: 1393
Registriert: 4. Sep 2005, 20:02
Wohnort: in Hengasch

Re: PING im gemischten Netzwerk

Beitrag von /dev/null »

Ich habe mich auch mal gewundert, warum ich einen "außerhäusigen" WIN 10 (pro) Rechner, welcher sehr stabil über mein WireGuard-VPN erreichbar ist, nicht per ping erreichen konnte. Letztendlich musste ich mir von Dr. Gockel sagen lassen, dass das eine "Sicherheitseinstellung" dieses OS ist, welche natürlich dann auch leicht zu korrigieren war.
Ob das auch bei der Home-Version so ist, weiß ich nicht.

Ansonsten kann ich sagen, dass ich alle hosts in meinem großen VPN-Netz (*) alle sauber "pingen" kann. Und ich freue mich darüber, dass die meisten Anfragen und Antworten per IPv6 aufgelöst und beantwortet werden. Heutzutage muss ich IPv4 schon mit "-4" erzwingen.
(*) Bewusst 2x "Netz" geschrieben. Mein VPN besteht mittlerweile aus insgesamt 8 in Deutschland und 2 Nachbarländern verteilten VPN-Servern. Und an jedem Server "hängen" die außerhäusig betriebenen Geräte der jeweiligen Nutzer. Und ja, so mancher trägt eine WinDOSe spazieren ... . Und schon sind wir wieder beim Thema.

vy 73 de Peter
openSuSE Tumbleweed, Kernel 5.16.x.-desktop x86_64, KDE, MUA: Betterbird, FairEmail
PC: Intel ® Core ™ i5- 2500, NB: TUXEDO Intel ® Core ™ i5- 4340M
S/MIME, denn ich will bestimmen, wer meine Mails lesen kann.
Schau hier: http://www.thunderbird-mail.de
Jörg Hofmann
Newbie
Newbie
Beiträge: 3
Registriert: 29. Nov 2021, 23:52

Re: PING im gemischten Netzwerk

Beitrag von Jörg Hofmann »

Erstmal ganz herzlichen Dank für die schnelle Hilfe. PING funktioniert jetzt, es war die Firewall.

Leider wurde das eigentliche Problem dadurch nicht gelöst. Remmina soll vor der RDP-Verbindung den Zielcomputer wecken, falls erforderlich. Dazu habe ich ein kleines Skript erstellt, das ich hier gefunden habe.
https://www.andysblog.de/remmina-wake-o ... inzufuegen

Hier meine Fassung:

Code: Alles auswählen

#!/bin/sh
while ! ping -c3 192.168.1.59
 do
  wakeonlan 74:46:A0:90:03:A6
  sleep 5s 
done
Im Terminal funktioniert es einwandfrei, starte ich es aber als Precommand in Remmina, wird zwar angezeigt, dass ein externes Kommando ausgeführt wird, passiert nichts. Besser gesagt, das Skript hängt in der while-Schleife, weil das wakeonlan nicht funktioniert. Und weil das Skript auch hängt, wenn ich den PC vorher manuell starte, heißt das wohl auch, dass die Pings nicht zurück kommen. Remmina wurde über die "Anwendungsverwaltung" als Flatpack installiert.

Ich habe mir schon einen Wolf gegooglet, vor allem, weil es vor einem Vierteljahr noch funktionierte, wenn auch nicht mit diesen Rechnern.

Und jetzt hoffe ich, dass Ihr wieder so schnell helfen könnt. ;-)
marce
Advanced Hacker
Advanced Hacker
Beiträge: 1403
Registriert: 19. Jun 2008, 13:16
Wohnort: Dettenhausen
Kontaktdaten:

Re: PING im gemischten Netzwerk

Beitrag von marce »

"es funktioniert nicht" ist keine sonderlich aussagekräftige Fehlermeldung.

Tut das Script denn, wenn Du es manuell aufrufst?

Wenn ja - als erstes würde ich mal allen Aufrufen den kompletten Pfad verpassen.
Jörg Hofmann
Newbie
Newbie
Beiträge: 3
Registriert: 29. Nov 2021, 23:52

Re: PING im gemischten Netzwerk

Beitrag von Jörg Hofmann »

marce hat geschrieben: 2. Dez 2021, 14:41 "es funktioniert nicht" ist keine sonderlich aussagekräftige Fehlermeldung.

Tut das Script denn, wenn Du es manuell aufrufst?
Es tut genau was es soll, der Rechner wird angepingt, erfolgt keine Antwort gibt es ein wakeonlan, sobald eine Antwort kommt, beendet sich das Skript.
Wenn ja - als erstes würde ich mal allen Aufrufen den kompletten Pfad verpassen.
Das war nie anders. Remmina findet das Skript auch, denn es meldet, dass ein externer Befehl ausgeführt wird. Aber dann passiert nichts mehr, der Rechner startet nicht und wenn ich ihn vorher gestartet habe, beendet sich das Skript trotzdem nicht.
marce
Advanced Hacker
Advanced Hacker
Beiträge: 1403
Registriert: 19. Jun 2008, 13:16
Wohnort: Dettenhausen
Kontaktdaten:

Re: PING im gemischten Netzwerk

Beitrag von marce »

deswegen würde ich ja auch erst mal alle Aufrufe mit kompletten Pfad in das Script setzen. Also ping, wakeonlan, ...

Dann gerne auch noch mal sowas wie Debug-Ausgaben in ein Logfile, ...
Antworten