Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Umstieg auf pipewire!

Alles rund um das Thema Multimedia unter Linux

Moderator: Moderatoren

Antworten
HarryMalaria
Member
Member
Beiträge: 241
Registriert: 17. Nov 2005, 18:24

Umstieg auf pipewire!

Beitrag von HarryMalaria »

Ich hab vor einiger zeit zufällig von pipewire erfahren. nun hab ich gesehen, das in leap 15.3 einige pipewire packekte schon installiert waren, da wurde ich neugierig. ich mußte nur noch das packet pipewire-pulseaudio und pipewire-alsa installiern, dann wird angezeigt, das einige pulseaudio packete gelöscht werden. nach der bestätigung wirde die installation durchgeführt. nach einem neustart, lief alles prima, auch mein bluetooth headset läuft auf anhieb, der einzige unterschied ist, das die cpu auslastung, etwas geringer ist, was ich gelesen habe, ein vorteil von pipewire sein soll. die einstellungen kann ich weiterhin mit pavucotrol druchführen. das einzig komische ist, in kde ist das lautsprecherapplet zur lautstärkenreglung verschwunden. als anwender, merkt man keinen unterschied, außer der cpu auslastung, wenn man darauf wert legt.
whois
Ultimate Guru
Ultimate Guru
Beiträge: 16667
Registriert: 11. Okt 2004, 08:50
Wohnort: Aachen
Kontaktdaten:

Re: Umstieg auf pipewire!

Beitrag von whois »

Hi

Interessant da habe ich mir ehrlich gesagt noch nie Gedanken drüber gemacht.
Sobald ich mal etwas Zeit habe werde ich mir das auch mal ansehen.
thx

Das mit dem Lautsprecher Icon scheint ein Bug zu sein.

https://github.com/NixOS/nixpkgs/issues/117966

cu
Benutzeravatar
gehrke
Moderator
Moderator
Beiträge: 2320
Registriert: 10. Nov 2012, 11:00

Re: Umstieg auf pipewire!

Beitrag von gehrke »

In Fedora 34 schon Default.
Keinen Bock mehr auf zentralisierte soziale Netzwerke von US-Konzernen?
Join the fediverse: https://fediverse.party/en/fediverse/ (Friendica, Mastodon, Diaspora und vieles mehr)
HarryMalaria
Member
Member
Beiträge: 241
Registriert: 17. Nov 2005, 18:24

Re: Umstieg auf pipewire!

Beitrag von HarryMalaria »

Ich hatte mir auch noch nie Gedanken gemacht, ich war nur neugierig. Ich bin eh überrascht, dass es so problemlos funktioniert, aber wie gesagt ich nutze nur einen Kopfhörer mit klinkenstecker und ein bluetooth headset, beides lief auf anhieb. die cpu auslastung ist auch etwas geringer, aber das war nur ein kurzer test.
HarryMalaria
Member
Member
Beiträge: 241
Registriert: 17. Nov 2005, 18:24

Re: Umstieg auf pipewire!

Beitrag von HarryMalaria »

Das mit dem Lautsprecher Icon scheint ein Bug zu sein.

https://github.com/NixOS/nixpkgs/issues/117966

cu
Für dieses kleine Problem hab ich eine Lösung gefunden: Man muß nur Kmix installieren, das integriert sich dann automatisch in die Miniprogramme. Ich hab auch plasma5-pa probiert, da gibt es aber Abhängigkeitsprobleme. Aber wie gesagt, das ist nur ein Problem, wenn man das Applet will, die Einstellungen über pavucontrol funktionnieren sowieso, mam nuß es halt über das Menü aufrufen. In Gnome tritt das Problem gar viell, gar nicht auf. Bisher läuft das auch ohne Probleme sowohl mit einem Klinkensteckerheadset und einen Bluetoothheadset.
whois
Ultimate Guru
Ultimate Guru
Beiträge: 16667
Registriert: 11. Okt 2004, 08:50
Wohnort: Aachen
Kontaktdaten:

Re: Umstieg auf pipewire!

Beitrag von whois »

gehrke hat geschrieben: 4. Jun 2021, 18:06 In Fedora 34 schon Default.
Fedora hat imho einige gute Sachen drauf die mir Gefallen.
Mit Red Hat hatte ich damals wenig am Hut.
Bisher fehlte mir die Zeit mich da etwas mehr einzuarbeiten.
Ich glaube ich werde mir diese sobald ich etwas mehr Freiraum habe mehr zu Gemüte führen. ;)

cu
HarryMalaria
Member
Member
Beiträge: 241
Registriert: 17. Nov 2005, 18:24

Re: Umstieg auf pipewire!

Beitrag von HarryMalaria »

Erste Erfahrungen mit pipewire. Soweit funktioniert es sehr gut. Ich hab zwei Ausgabegeräte: Ein Headset mit Klinkenstecker und ein USB Bluetoothheadset.
Meine bisherigen Feststellungen: ursprünglich hatte ich die version pipewire 0.3.24 drauf, ich hab dann in den repos gesucht, dort gibt es welche, die die version 0.30.30 anbieten, soll eine bessere bluetoothunterstützung haben.
Meine Feststellungen: Nach einem Boot, zeigt mir pavucontrol als ausgabegeräte . signalklänge und zweimal spell-checker an, wenn ich eine virtuelle maschine starte, zeigt er mir auch den virt-manager an und dort läuft der sound auch, sowohl mit klinke und bluetooth. wenn ich das bluetooth headset verbinde und es sit aktiv und z.b ein youtube video starte, kommt der sound teilweise erst nach ein ca. 8 bis 15 sekunden.
peobleme treten nach einem aufwachen aus dem standby auf: klinke und bluetooth funktionieren weiterhin, aber der sound in der virtuel machine ist weg (ist kein problem für mich, nutze es nicht für sound, fälle nur auf) und in pavucontrol sind die beiden einträge spell-checker weg.
auch der befehl:
systemctl --user restart pipewire pipewire-pulse
behebt das problem mit der virtuel box nicht. erst ein reboot löst das problem.
was mir noch auffiel, in der konfiguration unter internes audio ist ein weiterer punkt mit "pro audio" hinzugekommen. und einen mixer für pipewire scheint es auch nicht zu geben, da wird auf pavcontrol verwiesen, was auch gut klappt. also wer nur ein klinkenheadset nutzt, dürfte kein problem haben, auch mit bluetooth dürfte man mit kleinen einschränkungen gut hinkommen. mal sehen, wie sich das weiter entwickelt.
Antworten