Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[Gelöst] Handbrake stürzt ab

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Benutzeravatar
Opensource Anhänger
Member
Member
Beiträge: 163
Registriert: 14. Nov 2007, 23:03
Wohnort: SHG

[Gelöst] Handbrake stürzt ab

Beitrag von Opensource Anhänger »

Hallo,

habe auf meinem Rechner Handbrake von packman installiert. Leider stürzt Handbrake ab, sobald ich einen Film als Quelle auswähle.
Wenn ich Handbrake von der Konsole starte, kommt nur folgender Fehler.

Code: Alles auswählen

user@linux-3ihj:~> ghb
Speicherzugriffsfehler (Speicherabzug geschrieben)
Wenn ich als root starte:

Code: Alles auswählen

ghb

(ghb:17652): GLib-GIO-CRITICAL **: g_dbus_proxy_new_sync: assertion 'G_IS_DBUS_CONNECTION (connection)' failed
Error creating proxy: Verbindung ist geschlossen (g-io-error-quark, 18)
Error creating proxy: Verbindung ist geschlossen (g-io-error-quark, 18)
Error creating proxy: Verbindung ist geschlossen (g-io-error-quark, 18)
Error creating proxy: Verbindung ist geschlossen (g-io-error-quark, 18)
Error creating proxy: Verbindung ist geschlossen (g-io-error-quark, 18)
Speicherzugriffsfehler (Speicherabzug geschrieben)
Diese Repos laufen zurzeit bei mir.

Code: Alles auswählen

zypper lr -uEP
#  | Alias                               | Name                                                                 | Aktiviert | GPG-Überprüfung | Aktualisierung | Priorität | URI                                                                                 
---+-------------------------------------+----------------------------------------------------------------------+-----------+-----------------+----------------+-----------+-------------------------------------------------------------------------------------
14 | packman                             | packman                                                              | Ja        | (r ) Ja         | Ja             |   70      | http://packman.inode.at/suse/openSUSE_Leap_15.1/                                    
 1 | Epson                               | Drucker Epson                                                        | Ja        | ( p) Ja         | Nein           |   75      | dir:/home/user/Downloads/Linux/Epson                                            
 2 | LibreOffice_Factory                 | The development branch for LibreOffice packages (openSUSE_Leap_15.1) | Ja        | (r ) Ja         | Nein           |   83      | http://download.opensuse.org/repositories/LibreOffice:/Factory/openSUSE_Leap_15.1/  
13 | openSUSE_Leap_15.1                  | Mozilla                                                              | Ja        | (r ) Ja         | Ja             |   85      | http://download.opensuse.org/repositories/mozilla/openSUSE_Leap_15.1/               
20 | repo-oss                            | Haupt-Repository                                                     | Ja        | (r ) Ja         | Ja             |   87      | http://download.opensuse.org/distribution/leap/15.1/repo/oss/                       
23 | repo-update                         | Hauptaktualisierungs-Repository                                      | Ja        | (r ) Ja         | Ja             |   87      | http://download.opensuse.org/update/leap/15.1/oss                                   
 7 | http-download.opensuse.org-47f526e3 | home:Lazy_Kent:devel                                                 | Ja        | (r ) Ja         | Ja             |   97      | http://download.opensuse.org/repositories/home:/Lazy_Kent:/devel/openSUSE_Leap_15.1/
 9 | http-download.opensuse.org-b9942b04 | home:Herbster0815                                                    | Ja        | (r ) Ja         | Nein           |   97      | http://download.opensuse.org/repositories/home:/Herbster0815/openSUSE_Leap_15.1/    
 3 | dvd                                 | dvd                                                                  | Ja        | (r ) Ja         | Ja             |   99      | http://opensuse-guide.org/repo/openSUSE_Leap_15.1/                                  
 6 | http-download.opensuse.org-18bd5f43 | openSUSE:Factory                                                     | Ja        | (r ) Ja         | Ja             |   99      | http://download.opensuse.org/tumbleweed/repo/oss/                                   
19 | repo-non-oss                        | Non-OSS Repository                                                   | Ja        | (r ) Ja         | Ja             |   99      | http://download.opensuse.org/distribution/leap/15.1/repo/non-oss/                   
24 | repo-update-non-oss                 | Aktualisierungs-Repository (Nicht-Open-Source-Software)              | Ja        | (r ) Ja         | Ja             |   99      | http://download.opensuse.org/
Kann mir jemand weiterhelfen, woran es liegt?
Zuletzt geändert von Opensource Anhänger am 22. Mai 2020, 22:03, insgesamt 1-mal geändert.
Gräfin Klara
Hacker
Hacker
Beiträge: 572
Registriert: 23. Jun 2008, 20:51

Re: Handbrake stürzt ab

Beitrag von Gräfin Klara »

... g-io-error-quark

Partition voll?
Benutzeravatar
Opensource Anhänger
Member
Member
Beiträge: 163
Registriert: 14. Nov 2007, 23:03
Wohnort: SHG

Re: Handbrake stürzt ab

Beitrag von Opensource Anhänger »

Habe eben nachgeschaut. 5 GB sind frei. Normalerweise um die 10 GB. Das sollte eigentlich reichen.

Das g-io-error-quark kommt nur beim Start.

Beim Auswählen der Quelle kommt dann Speicherzugriffsfehler (Speicherabzug geschrieben)
Benutzeravatar
tomm.fa
Moderator
Moderator
Beiträge: 5415
Registriert: 21. Jan 2006, 17:18
Wohnort: OWL - Kreis Gütersloh
Kontaktdaten:

Re: Handbrake stürzt ab

Beitrag von tomm.fa »

Opensource Anhänger hat geschrieben: 21. Mai 2020, 20:45 Diese Repos laufen zurzeit bei mir.

Code: Alles auswählen

zypper lr -uEP
#  | Alias                               | Name                                                                 | Aktiviert | GPG-Überprüfung | Aktualisierung | Priorität | URI                                                                                 
---+-------------------------------------+----------------------------------------------------------------------+-----------+-----------------+----------------+-----------+-------------------------------------------------------------------------------------
…
 6 | http-download.opensuse.org-18bd5f43 | openSUSE:Factory                                                     | Ja        | (r ) Ja         | Ja             |   99      | http://download.opensuse.org/tumbleweed/repo/oss/                                   
…
24 | repo-update-non-oss                 | Aktualisierungs-Repository (Nicht-Open-Source-Software)              | Ja        | (r ) Ja         | Ja             |   99      | http://download.opensuse.org/
Ein openSUSE Tumbleweed Repositorium bei openSUSE 15.1? Das Non-OSS-Update-Repo hat eine URL ohne Funktion, richtig wäre

Code: Alles auswählen

http://download.opensuse.org/update/leap/15.1/non-oss/
statt

Code: Alles auswählen

http://download.opensuse.org/
Bringe die beiden Sachen erstmal in Ordnung, alles was aus dem Repositorium openSUSE:Factory installiert ist umstellen auf ein entsprechendes openSUSE Leap 15.1 Repo und dann das Repositorium entfernen.
Beim Repositorium „Aktualisierungs-Repository (Nicht-Open-Source-Software)“ die URL anpassen und dann ein Update durchführen; aber dort sind eh nicht viele Pakete enthalten.
Linupedia - Wiki des Linux-Club.
Keine Unterstützung/Hilfestellung per PN!
Sauerland
Guru
Guru
Beiträge: 3821
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: Handbrake stürzt ab

Beitrag von Sauerland »

Code: Alles auswählen

 6 | http-download.opensuse.org-18bd5f43 | openSUSE:Factory                                                     | Ja        | (r ) Ja         | Ja             |   99      | http://download.opensuse.org/tumbleweed/repo/oss/    
Irgendwelche Fragen bei Leap 15.1?

Edit:
zu spät.......
Desktop: OpenSUSE Leap 15.2, Nvidia-Grafik Kernel 5.x
Laptop: OpenSUSE Leap 15.2, Intel-Skylake, Kernel 5.3
Benutzeravatar
Opensource Anhänger
Member
Member
Beiträge: 163
Registriert: 14. Nov 2007, 23:03
Wohnort: SHG

Re: Handbrake stürzt ab

Beitrag von Opensource Anhänger »

OK, das mit Tumbleweed habe ich übersehen. :???:

Das Non_OS-Update hatte unter Yast die richtige URL eingetragen. Ich habe sie aber noch einmal neu eingetragen und jetzt ist es auch richtig bei Zypper zu finden.

Code: Alles auswählen

zypper lr -uEP
#  | Alias                               | Name                                                                 | Enabled | GPG Check | Refresh | Priority | URI                                                                                 
---+-------------------------------------+----------------------------------------------------------------------+---------+-----------+---------+----------+-------------------------------------------------------------------------------------
13 | packman                             | packman                                                              | Yes     | (r ) Yes  | Yes     |   70     | http://packman.inode.at/suse/openSUSE_Leap_15.1/                                    
 1 | Epson                               | Drucker Epson                                                        | Yes     | ( p) Yes  | No      |   75     | dir:/home/user/Downloads/Linux/Epson                                            
 2 | LibreOffice_Factory                 | The development branch for LibreOffice packages (openSUSE_Leap_15.1) | Yes     | (r ) Yes  | No      |   83     | http://download.opensuse.org/repositories/LibreOffice:/Factory/openSUSE_Leap_15.1/  
12 | openSUSE_Leap_15.1                  | Mozilla                                                              | Yes     | (r ) Yes  | Yes     |   85     | http://download.opensuse.org/repositories/mozilla/openSUSE_Leap_15.1/               
19 | repo-oss                            | Haupt-Repository                                                     | Yes     | (r ) Yes  | Yes     |   87     | http://download.opensuse.org/distribution/leap/15.1/repo/oss/                       
22 | repo-update                         | Hauptaktualisierungs-Repository                                      | Yes     | (r ) Yes  | Yes     |   87     | http://download.opensuse.org/update/leap/15.1/oss                                   
 6 | http-download.opensuse.org-47f526e3 | home:Lazy_Kent:devel                                                 | Yes     | (r ) Yes  | Yes     |   97     | http://download.opensuse.org/repositories/home:/Lazy_Kent:/devel/openSUSE_Leap_15.1/
 3 | dvd                                 | dvd                                                                  | Yes     | (r ) Yes  | Yes     |   99     | http://opensuse-guide.org/repo/openSUSE_Leap_15.1/                                  
18 | repo-non-oss                        | Non-OSS Repository                                                   | Yes     | (r ) Yes  | Yes     |   99     | http://download.opensuse.org/distribution/leap/15.1/repo/non-oss/                   
23 | repo-update-non-oss                 | Aktualisierungs-Repository (Nicht-Open-Source-Software)              | Yes     | (r ) Yes  | Yes     |   99     | http://download.opensuse.org/update/leap/15.1/non-oss/                              
Bei Handbrake hat sich noch nichts dadurch geändert.
Benutzeravatar
tomm.fa
Moderator
Moderator
Beiträge: 5415
Registriert: 21. Jan 2006, 17:18
Wohnort: OWL - Kreis Gütersloh
Kontaktdaten:

Re: Handbrake stürzt ab

Beitrag von tomm.fa »

Opensource Anhänger hat geschrieben: 21. Mai 2020, 23:27Bei Handbrake hat sich noch nichts dadurch geändert.
Wenn du nur an den Repositorien was geändert hast, dann bringt das auch nicht viel, fehlt noch der Rest:
tomm.fa hat geschrieben: 21. Mai 2020, 22:37Bringe die beiden Sachen erstmal in Ordnung, alles was aus dem Repositorium openSUSE:Factory installiert ist umstellen auf ein entsprechendes openSUSE Leap 15.1 Repo und dann das Repositorium entfernen.
Beim Repositorium „Aktualisierungs-Repository (Nicht-Open-Source-Software)“ die URL anpassen und dann ein Update durchführen; aber dort sind eh nicht viele Pakete enthalten.
Auch mal, so zum Spaß, die Ausgaben von

Code: Alles auswählen

zypper se -s handbrake

Code: Alles auswählen

zypper se -si | grep -Ei "systemp|System P"
hier vorführen.
Linupedia - Wiki des Linux-Club.
Keine Unterstützung/Hilfestellung per PN!
Benutzeravatar
Opensource Anhänger
Member
Member
Beiträge: 163
Registriert: 14. Nov 2007, 23:03
Wohnort: SHG

Re: Handbrake stürzt ab

Beitrag von Opensource Anhänger »

Umstellen musste ich nichts, da vom falschen Repo nichts installiert war. Hatte aber nach dem Löschen noch mal zur Sicherheit ein Zypper Up durchgeführt.

Gerne gebe ich die Meldungen für dein Befehle hier raus.

Weitere Antworten kann ich erst morgen Abend geben, da ich morgen Arbeite.

Code: Alles auswählen

zypper se -s handbrake
Loading repository data...
Reading installed packages...

S  | Name                    | Type       | Version         | Arch   | Repository
---+-------------------------+------------+-----------------+--------+-----------
   | handbrake               | srcpackage | 1.3.2-pm151.1.1 | noarch | packman   
   | handbrake-cli           | package    | 1.3.2-pm151.1.1 | x86_64 | packman   
   | handbrake-cli-debuginfo | package    | 1.3.2-pm151.1.1 | x86_64 | packman   
   | handbrake-debuginfo     | package    | 1.3.2-pm151.1.1 | x86_64 | packman   
   | handbrake-debugsource   | package    | 1.3.2-pm151.1.1 | x86_64 | packman   
i+ | handbrake-gtk           | package    | 1.3.2-pm151.1.1 | x86_64 | packman   
   | handbrake-gtk-debuginfo | package    | 1.3.2-pm151.1.1 | x86_64 | packman   
i+ | handbrake-gtk-lang      | package    | 1.3.2-pm151.1.1 | noarch | packman   

Code: Alles auswählen

zypper se -si | grep -Ei "systemp|System P"
i+ | MediathekView                          | package | 13.5.1.1581431954.34b50420-lp151.5.1       | noarch | (System Packages)                                                   
i+ | MozillaFirefox-branding-openSUSE       | package | 68-2.1                                     | x86_64 | (System Packages)                                                   
i+ | breeze4-style                          | package | 5.17.4-lp151.271.1                         | x86_64 | (System Packages)                                                   
i+ | ca-certificates-mozilla                | package | 2.40-2.1                                   | noarch | (System Packages)                                                   
i+ | distribution-logos-openSUSE-Kubic      | package | 20190414-2.3                               | noarch | (System Packages)                                                   
i+ | ffmpeg-3                               | package | 3.4.5-4.pm151.1                            | x86_64 | (System Packages)                                                   
i+ | flvstreamer                            | package | 2.1c1-lp151.5.2                            | x86_64 | (System Packages)                                                   
i+ | gimp-help                              | package | 2.8.2-4.1                                  | noarch | (System Packages)                                                   
i+ | gimp-help-de                           | package | 2.8.2-4.1                                  | noarch | (System Packages)                                                   
i+ | gstreamer-plugins-bad-lang             | package | 1.12.5-4.3                                 | noarch | (System Packages)                                                   
i+ | gstreamer-plugins-ugly-lang            | package | 1.12.5-3.2                                 | noarch | (System Packages)                                                   
i+ | josm                                   | package | 1.5.16239-lp151.2.1                        | noarch | (System Packages)                                                   
i+ | josm-fonts                             | package | 1.5.16239-lp151.2.1                        | noarch | (System Packages)                                                   
i+ | kernel-default                         | package | 5.6.12-1.3                                 | x86_64 | (System Packages)                                                   
i+ | kernel-default                         | package | 5.6.8-1.2                                  | x86_64 | (System Packages)                                                   
i+ | libavcodec57                           | package | 3.4.5-4.pm151.1                            | x86_64 | (System Packages)                                                   
i+ | libavdevice57                          | package | 3.4.5-4.pm151.1                            | x86_64 | (System Packages)                                                   
i+ | libavfilter6                           | package | 3.4.5-4.pm151.1                            | x86_64 | (System Packages)                                                   
i+ | libavformat57                          | package | 3.4.5-4.pm151.1                            | x86_64 | (System Packages)                                                   
i+ | libavresample3                         | package | 3.4.5-4.pm151.1                            | x86_64 | (System Packages)                                                   
i+ | libavutil55                            | package | 3.4.5-4.pm151.1                            | x86_64 | (System Packages)                                                   
i+ | libbreezecommon4-5                     | package | 5.17.4-lp151.271.1                         | x86_64 | (System Packages)                                                   
i+ | libdvdcss2                             | package | 1.4.2-1.3                                  | x86_64 | (System Packages)                                                   
i+ | libdvdnav4                             | package | 6.1.0-1.1                                  | x86_64 | (System Packages)                                                   
i  | libdvdread8                            | package | 6.1.1-1.1                                  | x86_64 | (System Packages)                                                   
i+ | libffi8                                | package | 3.3.git30-1.2                              | x86_64 | (System Packages)                                                   
i+ | libopenssl1_1                          | package | 1.1.1g-2.1                                 | x86_64 | (System Packages)                                                   
i+ | libp11-kit0                            | package | 0.23.20-1.1                                | x86_64 | (System Packages)                                                   
i+ | libpoppler-cpp0                        | package | 0.88.0-1.1                                 | x86_64 | (System Packages)                                                   
i+ | libpoppler-glib8                       | package | 0.88.0-1.1                                 | x86_64 | (System Packages)                                                   
i+ | libpoppler91                           | package | 0.81.0-lp151.8.1                           | x86_64 | (System Packages)                                                   
i  | libpoppler99                           | package | 0.88.0-lp151.1.1                           | x86_64 | (System Packages)                                                   
i+ | libpostproc54                          | package | 3.4.5-4.pm151.1                            | x86_64 | (System Packages)                                                   
i+ | libswresample2                         | package | 3.4.5-4.pm151.1                            | x86_64 | (System Packages)                                                   
i+ | libswscale4                            | package | 3.4.5-4.pm151.1                            | x86_64 | (System Packages)                                                   
i+ | libtizonia0                            | package | 0.19.0-lp151.2.1                           | x86_64 | (System Packages)                                                   
i+ | libx265-179                            | package | 3.2.1-pm151.3.3                            | x86_64 | (System Packages)                                                   
i  | libxine2-pulse                         | package | 1.2.10-1.1                                 | x86_64 | (System Packages)                                                   
i+ | master-pdf-editor                      | package | 5.4.38-lp151.1.1                           | x86_64 | (System Packages)                                                   
i+ | openSUSE-release-dvd                   | package | 15.1-lp151.298.1                           | x86_64 | (System Packages)                                                   
i+ | p11-kit                                | package | 0.23.20-1.1                                | x86_64 | (System Packages)                                                   
i+ | p11-kit-32bit                          | package | 0.23.20-1.1                                | x86_64 | (System Packages)                                                   
i+ | p11-kit-tools                          | package | 0.23.20-1.1                                | x86_64 | (System Packages)                                                   
i+ | poppler-data                           | package | 0.4.9-1.4                                  | noarch | (System Packages)                                                   
i+ | python2-fuzzywuzzy                     | package | 0.17.0-lp151.1.1                           | noarch | (System Packages)                                                   
i+ | python2-pafy                           | package | 0.5.4-lp151.2.1                            | noarch | (System Packages)                                                   
i+ | python3-fuzzywuzzy                     | package | 0.17.0-lp151.2.1                           | noarch | (System Packages)                                                   
i+ | python3-pafy                           | package | 0.5.5-lp151.2.1                            | noarch | (System Packages)                                                   
i+ | shared-python-startup                  | package | 0.1-3.1                                    | noarch | (System Packages)                                                   
i+ | snapd                                  | package | 2.43.3-lp150.1.1                           | x86_64 | (System Packages)                                                   
i+ | systemd-icon-branding-openSUSE         | package | 84.87.20191004-3.9                         | noarch | (System Packages)                                                   
i+ | teamviewer-suse                        | package | 15.1.3937-0                                | x86_64 | (System Packages)                                                   
i+ | tizonia                                | package | 0.19.0-lp151.2.1                           | x86_64 | (System Packages)                                                   
i+ | tizonia-bash-completion                | package | 0.19.0-lp151.2.1                           | noarch | (System Packages) 
Benutzeravatar
tomm.fa
Moderator
Moderator
Beiträge: 5415
Registriert: 21. Jan 2006, 17:18
Wohnort: OWL - Kreis Gütersloh
Kontaktdaten:

Re: Handbrake stürzt ab

Beitrag von tomm.fa »

Opensource Anhänger hat geschrieben: 21. Mai 2020, 23:45 Umstellen musste ich nichts, da vom falschen Repo nichts installiert war.
Nö, überhaupt nichts. Der installierte kernel-deault, als Beispiel, kommt dann woher?

Opensource Anhänger hat geschrieben: 21. Mai 2020, 23:45Hatte aber nach dem Löschen noch mal zur Sicherheit ein Zypper Up durchgeführt.
Ein einfaches „zypper up“ hilft in diesem Fall aber nicht viel.


Ein

Code: Alles auswählen

zypper -vv dup --allow-vendor-change --from packman
könnte auch mal wieder ausgeführt werden.
Linupedia - Wiki des Linux-Club.
Keine Unterstützung/Hilfestellung per PN!
Benutzeravatar
Opensource Anhänger
Member
Member
Beiträge: 163
Registriert: 14. Nov 2007, 23:03
Wohnort: SHG

Re: Handbrake stürzt ab

Beitrag von Opensource Anhänger »

Code: Alles auswählen

 ffmpeg-3                     3.4.5-4.pm151.1 -> 3.4.5-pm151.4.5  x86_64  packman  http://packman.links2linux.de            
  gstreamer-plugins-bad-lang   1.12.5-4.3 -> 1.12.5-pm151.4.13     noarch  packman  http://packman.links2linux.de            
  gstreamer-plugins-ugly-lang  1.12.5-3.2 -> 1.12.5-pm151.3.8      noarch  packman  http://packman.links2linux.de            
  libavcodec57                 3.4.5-4.pm151.1 -> 3.4.5-pm151.4.5  x86_64  packman  http://packman.links2linux.de            
  libavdevice57                3.4.5-4.pm151.1 -> 3.4.5-pm151.4.5  x86_64  packman  http://packman.links2linux.de            
  libavfilter6                 3.4.5-4.pm151.1 -> 3.4.5-pm151.4.5  x86_64  packman  http://packman.links2linux.de            
  libavformat57                3.4.5-4.pm151.1 -> 3.4.5-pm151.4.5  x86_64  packman  http://packman.links2linux.de            
  libavresample3               3.4.5-4.pm151.1 -> 3.4.5-pm151.4.5  x86_64  packman  http://packman.links2linux.de            
  libavutil55                  3.4.5-4.pm151.1 -> 3.4.5-pm151.4.5  x86_64  packman  http://packman.links2linux.de            
  libpostproc54                3.4.5-4.pm151.1 -> 3.4.5-pm151.4.5  x86_64  packman  http://packman.links2linux.de            
  libswresample2               3.4.5-4.pm151.1 -> 3.4.5-pm151.4.5  x86_64  packman  http://packman.links2linux.de            
  libswscale4                  3.4.5-4.pm151.1 -> 3.4.5-pm151.4.5  x86_64  packman  http://packman.links2linux.de            
  libxine2-pulse               1.2.10-1.1 -> 1.2.10-pm151.155.3    x86_64  packman  openSUSE -> http://packman.links2linux.de

The following package is going to change vendor:
  libxine2-pulse  1.2.10-1.1 -> 1.2.10-pm151.155.3  x86_64  packman  openSUSE -> http://packman.links2linux.de
es hat kleine Änderungen gegeben.
Als Root kommen nicht mehr die Anfangsfehler beim Starten. Wenn ich Film von Festplatte auswähle,kommt kein Absturz. Beim Start ab dann doch. Wenn ich eine DVD auswähle weiterhin sofort ein Absturz.

Code: Alles auswählen

Attempting to use device /dev/sr0 mounted on /run/media/user/<WUNDER> for CSS authentication
Speicherzugriffsfehler (Speicherabzug geschrieben)
Aus diesen Repos nicht. Krieg es aber gerade nicht zusammen von welchem Repo es kommt.

Code: Alles auswählen

zypper info kernel-default
Loading repository data...
Reading installed packages...


Information for package kernel-default:
---------------------------------------
Repository     : @System                        
Name           : kernel-default                 
Version        : 5.6.12-1.3                     
Arch           : x86_64                         
Vendor         : openSUSE                       
Installed Size : 164.5 MiB                      
Installed      : Yes                            
Status         : up-to-date                     
Source package : kernel-default-5.6.12-1.3.nosrc
Summary        : The Standard Kernel            
Description    :                                
    The standard kernel for both uniprocessor and multiprocessor systems.


    Source Timestamp: 2020-05-12 17:44:12 +0000
    GIT Revision: 9bff61bd292aa608110286ee434d5ca043d5a248
    GIT Branch: stable
Zuletzt geändert von Opensource Anhänger am 22. Mai 2020, 22:04, insgesamt 1-mal geändert.
Sauerland
Guru
Guru
Beiträge: 3821
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: Handbrake stürzt ab

Beitrag von Sauerland »

Zuerst als root:

Code: Alles auswählen

zypper dup --allow-vendor-change --from http://download.opensuse.org/distribution/leap/15.1/repo/oss/ 

Code: Alles auswählen

zypper -vv dup --allow-vendor-change --from packman

Code: Alles auswählen

zypper up
Desktop: OpenSUSE Leap 15.2, Nvidia-Grafik Kernel 5.x
Laptop: OpenSUSE Leap 15.2, Intel-Skylake, Kernel 5.3
Benutzeravatar
Opensource Anhänger
Member
Member
Beiträge: 163
Registriert: 14. Nov 2007, 23:03
Wohnort: SHG

Re: Handbrake stürzt ab

Beitrag von Opensource Anhänger »

Die Befehle von Sauerland haben funktioniert. Handbrake läuft jetzt ohne Absturz.

Ein paar aber muss ich schreiben. Der Downgrade auf Opensuse funktioniert erst nach 2 Anläufen, dazwischen durch der Prozess festhing. Ich musste dafür den PC Neustarten. Das gleiche auch wieder beim Upgrade auf Packmann.

Der Downgrade vom Kernel lief nicht. Obwohl der neue Kernel installiert wurde, blieb der alte erhalten.

Zypper meldet Konflikte bei Python die ich aber ignoriert habe.

Es ist recht zeitaufwändig. Eine Neuinstallation von DVD aus dürfte schneller sein. Allerdings lernt man hier etwas mehr dazu.

Ich möchte mich bei allen für Ihre Hinweise bedanken.
Gräfin Klara
Hacker
Hacker
Beiträge: 572
Registriert: 23. Jun 2008, 20:51

Re: Handbrake stürzt ab - Gelöst

Beitrag von Gräfin Klara »

Super!
Ja, @Sauerland kennt sich mit Distributionsangelegenheiten bestens aus.
Mir ist das ein Rätsel.
Wie kann es sein, dass Distributionen die Installation von Binaries zulassen, obwohl kompatible Libraries nicht zur Verfügung stehen
oder Updates von Libraries durchführen, obwohl Abhängigkeiten existieren.
So oder ähnlich sieht das für mich aus. Wie kann das sein?
Sauerland
Guru
Guru
Beiträge: 3821
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: Handbrake stürzt ab - Gelöst

Beitrag von Sauerland »

Wie kann es sein, dass Distributionen die Installation von Binaries zulassen, obwohl kompatible Libraries nicht zur Verfügung stehen
oder Updates von Libraries durchführen, obwohl Abhängigkeiten existieren.
So oder ähnlich sieht das für mich aus. Wie kann das sein?
Das sind meist neuere libs, die ohne Probleme bauen, aber mit Paketen nicht funktionieren, die gegen alte libs gebaut sind.

Es wird beim Paketbau nicht abgefragt:

Code: Alles auswählen

Requires = lib Version 1.4.1
sondern meist

Code: Alles auswählen

Requires >= lib Version 1.4.1
Und wenn dann in Version 1.5.1 nur etwas an einer Funktion geändert wird, haben dann Pakete Schluckauf.

Ist mir mit einer lib aus meinem Repo auch schon passiert, das dann ein Paket aus dem OSS Schluckauf bekommen hat......
Muss man erst mal drauf kommen.
Desktop: OpenSUSE Leap 15.2, Nvidia-Grafik Kernel 5.x
Laptop: OpenSUSE Leap 15.2, Intel-Skylake, Kernel 5.3
Sauerland
Guru
Guru
Beiträge: 3821
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: Handbrake stürzt ab - Gelöst

Beitrag von Sauerland »

Zypper meldet Konflikte bei Python die ich aber ignoriert habe.
So etwas sollte man tunlichst vermeiden, sondern auflösen.
Meist gibt zypper da auch schon Lösungsvorschläge an.
Desktop: OpenSUSE Leap 15.2, Nvidia-Grafik Kernel 5.x
Laptop: OpenSUSE Leap 15.2, Intel-Skylake, Kernel 5.3
Benutzeravatar
Opensource Anhänger
Member
Member
Beiträge: 163
Registriert: 14. Nov 2007, 23:03
Wohnort: SHG

Re: Handbrake stürzt ab - Gelöst

Beitrag von Opensource Anhänger »

Ging leider nicht zu vermeiden, da er beim Downgrade meldete, dass er das Gegenstück für den Downgrade nicht fand und es nur ignorieren oder Abbruch gab. Bis jetzt läuft der PC stabil und ohne Probleme.

VLC machte ja auch Probleme, aber hier konnte ich Pakete löschen, was ich auch gemacht habe.
Sauerland
Guru
Guru
Beiträge: 3821
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: [Gelöst] Handbrake stürzt ab

Beitrag von Sauerland »

Poste einfach einmal als root:

Code: Alles auswählen

zypper up
Kannst du abbrechen, aber zumindest sieht man mal die Konflikte.
Desktop: OpenSUSE Leap 15.2, Nvidia-Grafik Kernel 5.x
Laptop: OpenSUSE Leap 15.2, Intel-Skylake, Kernel 5.3
Benutzeravatar
Opensource Anhänger
Member
Member
Beiträge: 163
Registriert: 14. Nov 2007, 23:03
Wohnort: SHG

Re: [Gelöst] Handbrake stürzt ab

Beitrag von Opensource Anhänger »

Gerne

Code: Alles auswählen

zypper up
Loading repository data...
Reading installed packages...

The following 74 package updates will NOT be installed:
  MozillaThunderbird MozillaThunderbird-translations-common boomaga boomaga-lang epson-inkjet-printer-escpr flute icoutils libabw-0_1-1 libbase libcdr-0_1-1 libcmis-0_5-5 libe-book-0_1-1 libeot0
  libepubgen-0_1-1 libetonyek-0_1-1 libexttextcat libexttextcat-2_0-0 libfonts libformula libfreehand-0_1-1 libgraphite2-3 libhyphen0 liblangtag1 liblayout libloader liblpsolve55-0 libmspub-0_1-1
  libmwaw-0_3-3 libmythes-1_2-0 libnumbertext-1_0-0 libnumbertext-data libodfgen-0_1-1 libpagemaker-0_0-0 libqxp-0_0-0 libreoffice libreoffice-base libreoffice-base-drivers-firebird libreoffice-calc
  libreoffice-draw libreoffice-filters-optional libreoffice-gnome libreoffice-gtk3 libreoffice-icon-themes libreoffice-impress libreoffice-l10n-de libreoffice-l10n-en libreoffice-mailmerge
  libreoffice-math libreoffice-pyuno libreoffice-qt5 libreoffice-share-linker libreoffice-writer librepository librevenge-0_0-0 librevenge-stream-0_0-0 libserializer libstaroffice-0_0-0 libvisio-0_1-1
  libwpd-0_10-10 libwpg-0_3-3 libwps-0_4-4 libxmlsec1-1 libxmlsec1-nss1 libzmf-0_0-0 myspell-de myspell-de_DE myspell-dictionaries myspell-en myspell-en_US myspell-lightproof-en patterns-office-office
  pentaho-libxml pentaho-reporting-flow-engine sac

Nothing to do.
Ich habe auch das Mozilla Repo wieder in Betrieb genommen. Firefox 60 lts ist für mich keine Alternative
Sauerland
Guru
Guru
Beiträge: 3821
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: [Gelöst] Handbrake stürzt ab

Beitrag von Sauerland »

Poste auch noch einmal:

Code: Alles auswählen

zypper ve
Desktop: OpenSUSE Leap 15.2, Nvidia-Grafik Kernel 5.x
Laptop: OpenSUSE Leap 15.2, Intel-Skylake, Kernel 5.3
Benutzeravatar
Opensource Anhänger
Member
Member
Beiträge: 163
Registriert: 14. Nov 2007, 23:03
Wohnort: SHG

Re: [Gelöst] Handbrake stürzt ab

Beitrag von Opensource Anhänger »

Code: Alles auswählen

zypper ve
Retrieving repository 'Hauptaktualisierungs-Repository' metadata ...................................................................................................................................[done]
Building repository 'Hauptaktualisierungs-Repository' cache ........................................................................................................................................[done]
Loading repository data...
Reading installed packages...

Problem: nothing provides libsane1 needed by master-pdf-editor-5.4.38-lp151.1.1.x86_64
 Solution 1: deinstallation of master-pdf-editor-5.4.38-lp151.1.1.x86_64
 Solution 2: break master-pdf-editor-5.4.38-lp151.1.1.x86_64 by ignoring some of its dependencies

Choose from above solutions by number or cancel [1/2/c/d/?] (c): 2
Resolving dependencies...

Dependencies of all installed packages are satisfied.
Master-pdf-editor werde ich eventuell auch wieder deinstallieren. Hatte nur jemand beim Corona Antrag für Selbstständige geholfen wo Okular leider nicht genutzt werden konnte.

Aber den Befehl kannte ich auch noch nicht. Den werde ich mir auch notieren.

Vielen Dank Sauerland
Antworten