Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[gelöst] Kernel-Update 4.12.14-lp150.12.10.1 - danach keine Grafik

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Gesperrt
admine
Administrator
Administrator
Beiträge: 8781
Registriert: 15. Feb 2004, 21:13
Kontaktdaten:

[gelöst] Kernel-Update 4.12.14-lp150.12.10.1 - danach keine Grafik

Beitrag von admine » 8. Aug 2018, 10:07

Hallo Leute,

bei mir kam heute das Kernel-Update auf die Version 4.12.14-lp150.12.10.1 rein.
Danach bootete mein Laptop nicht mehr.

Der Boot-Prozess blieb stehen bei

Code: Alles auswählen

.
.
.
Starting X Display Manager...
Started Defragment file data and/or directory metadata.
Started Daily rotation of log files.
Started Timeline of Snapper Snapshots.
Started Backup of /etc/sysconfig.
Started Check if mainboard battery is Ok.
Starting Postfix Mail Transport Agent...
Started Scrub btrfs filesystem, verify block checksums.
Reached target Timers.
Stopped Defragment file data and/or directory metadata.
Started Write information about system start to sysstat log.
Starting Locale Service...
und das war's :???:

Reboot mit altem Kernel => alles wieder gut.
Noch hab ich keinen Plan, woran es liegt.
Dies aber zur Info für euch.
..:: unser Linux-Club-Wiki ::..
-------------------------
..:: Deutsche Mugge ::..
-------------------------

Werbung:
marce
Advanced Hacker
Advanced Hacker
Beiträge: 1071
Registriert: 19. Jun 2008, 13:16
Wohnort: Dettenhausen
Kontaktdaten:

Re: [Info] Kernel-Update 4.12.14-lp150.12.10.1

Beitrag von marce » 8. Aug 2018, 11:09

Das System scheint aber doch sauber zu booten und "oben" zu sein?

... "bootet nicht" meint also vermutlich eher sowas wie "grafische Oberfläche startet nicht"? - das wäre nach einem neuen Kernel an sich ja nichts ungewöhnliches...

admine
Administrator
Administrator
Beiträge: 8781
Registriert: 15. Feb 2004, 21:13
Kontaktdaten:

Re: [Info] Kernel-Update 4.12.14-lp150.12.10.1

Beitrag von admine » 8. Aug 2018, 11:15

Ja genau, das hab ich inzwischen auch "erforscht" ;)
Also in r3 bootet er sauber.
Nach Eingabe "init 5" wechselt er auf Display7 und nichts :(
Da sind sind dann auch seltsamerweise die anderen Displays nicht verfügbar und ich sehe keine Meldungen. Das ist grad seltsam :???:

EDIT: bei Eingabe von "startx" sieht es zunächst so aus, als ob die Grafik startet, dann wird der Bildschirm schwarz und bleibt so.
Ein Wechsel auf Display1, an dem root angemeldet war, ist nicht mehr möglich.
Jetzt muss ich gestehen, hab ich grad keinen Plan mehr :???:
..:: unser Linux-Club-Wiki ::..
-------------------------
..:: Deutsche Mugge ::..
-------------------------

admine
Administrator
Administrator
Beiträge: 8781
Registriert: 15. Feb 2004, 21:13
Kontaktdaten:

Re: Kernel-Update 4.12.14-lp150.12.10.1 - danach keine Grafik

Beitrag von admine » 8. Aug 2018, 11:35

Hier noch Infos zu meiner Karte:

Code: Alles auswählen

hwinfo --gfxcard
34: PCI 100.0: 0300 VGA compatible controller (VGA)             
  [Created at pci.378]
  Unique ID: VCu0.xVMssAe1k49
  Parent ID: vSkL.HBIEsup+SaA
  SysFS ID: /devices/pci0000:00/0000:00:01.0/0000:01:00.0
  SysFS BusID: 0000:01:00.0
  Hardware Class: graphics card
  Model: "nVidia GT218M [NVS 3100M]"
  Vendor: pci 0x10de "nVidia Corporation"
  Device: pci 0x0a6c "GT218M [NVS 3100M]"
  SubVendor: pci 0x17aa "Lenovo"
  SubDevice: pci 0x215c 
  Revision: 0xa2
  Driver: "nouveau"
  Driver Modules: "nouveau"
  Memory Range: 0xcc000000-0xccffffff (rw,non-prefetchable)
  Memory Range: 0xd0000000-0xdfffffff (ro,non-prefetchable)
  Memory Range: 0xce000000-0xcfffffff (ro,non-prefetchable)
  I/O Ports: 0x2000-0x2fff (rw)
  Memory Range: 0x000c0000-0x000dffff (rw,non-prefetchable,disabled)
  IRQ: 26 (70693 events)
  I/O Ports: 0x3c0-0x3df (rw)
  Module Alias: "pci:v000010DEd00000A6Csv000017AAsd0000215Cbc03sc00i00"
  Driver Info #0:
    Driver Status: nouveau is active
    Driver Activation Cmd: "modprobe nouveau"
  Config Status: cfg=no, avail=yes, need=no, active=unknown
  Attached to: #31 (PCI bridge)

Primary display adapter: #34
Ich wäre über Hilfe sehr erfreut :ops:

Edit:
Oben gepostete Ausgabe ist der Stand mit dem alten Kernel. Aber die Ausgabe mit dem neuen Kernel sieht völlig identisch aus.
..:: unser Linux-Club-Wiki ::..
-------------------------
..:: Deutsche Mugge ::..
-------------------------

josef-wien
Ultimate Guru
Ultimate Guru
Beiträge: 5099
Registriert: 23. Sep 2008, 17:09

Re: Kernel-Update 4.12.14-lp150.12.10.1 - danach keine Grafik

Beitrag von josef-wien » 8. Aug 2018, 12:18

admine hat geschrieben:
8. Aug 2018, 11:15
hab ich grad keinen Plan mehr
Bleibe vorläufig beim bisherigen Kernel.

openSUSE verwendet keinen Langzeit-Kernel, sondern hatte die aberwitzige Idee, den schon lange toten Kernel 4.12 künstlich am Leben zu erhalten. Das bedeutet, daß Änderungen aktueller Kernel in den 4.12 rückportiert werden, und dabei entstehen zwangsläufig Fehler.

admine
Administrator
Administrator
Beiträge: 8781
Registriert: 15. Feb 2004, 21:13
Kontaktdaten:

Re: Kernel-Update 4.12.14-lp150.12.10.1 - danach keine Grafik

Beitrag von admine » 8. Aug 2018, 12:23

josef-wien hat geschrieben:
8. Aug 2018, 12:18
admine hat geschrieben:
8. Aug 2018, 11:15
hab ich grad keinen Plan mehr
Bleibe vorläufig beim bisherigen Kernel.
Das hab ich auch vor und Danke für die Bestätigung.
So bisschen hab ich ja den Verdacht, dass es mit den "nouveau"-Treibern zu tun hat.
Aber auf Nvidia zu switchen hab ich auch keinen Bock, um dann festzustellen, dass es nicht geholfen hat.
..:: unser Linux-Club-Wiki ::..
-------------------------
..:: Deutsche Mugge ::..
-------------------------

josef-wien
Ultimate Guru
Ultimate Guru
Beiträge: 5099
Registriert: 23. Sep 2008, 17:09

Re: Kernel-Update 4.12.14-lp150.12.10.1 - danach keine Grafik

Beitrag von josef-wien » 8. Aug 2018, 12:27

admine hat geschrieben:
8. Aug 2018, 12:23
dass es mit den "nouveau"-Treibern zu tun hat
Auch, aber nicht nur: https://lists.opensuse.org/opensuse-bug ... 00882.html

Benutzeravatar
Feuervogel
Hacker
Hacker
Beiträge: 727
Registriert: 4. Feb 2009, 16:28
Wohnort: Heusenstamm

Re: Kernel-Update 4.12.14-lp150.12.10.1 - danach keine Grafik

Beitrag von Feuervogel » 8. Aug 2018, 13:32

Hallo josef-wien,
josef-wien hat geschrieben:
8. Aug 2018, 12:18
openSUSE verwendet keinen Langzeit-Kernel, sondern hatte die aberwitzige Idee, den schon lange toten Kernel 4.12 künstlich am Leben zu erhalten. Das bedeutet, daß Änderungen aktueller Kernel in den 4.12 rückportiert werden, und dabei entstehen zwangsläufig Fehler.
openSUSE Leap baut aber doch auf SUSE Linux Enterprise auf.
Warum war/ist SUSE Linux Enterprise selbst nicht in der Lage auf einen "echten" und möglichst aktuellen Langzeit-Kernel aufzusetzen? Oder bei einem Sprung auf eine nächste Kernelversion den dann aktuellen jüngeren LTS-Kernel zu nehmen?

Logisch wäre doch gewesen, beim Wechsel von SLE 12.n (Leap 42.n) nach SLE 15.n (Leap 15.n) auf den 4.14er-Kernel zu setzen.

Hier verstehe ich die "Philosophie" von SUSE Linux Enterprise (openSUSE Leap) nicht. :/

Gruß
Feuervogel
Zuletzt geändert von Feuervogel am 9. Aug 2018, 09:00, insgesamt 1-mal geändert.
Innerhalb der Computergemeinschaft lebt man nach der Grundregel, die Gegenwart sei ein Programmfehler, der in der nächsten Ausgabe behoben sein wird.
Clifford Stoll

Benutzeravatar
f.gruber
Hacker
Hacker
Beiträge: 410
Registriert: 24. Jun 2006, 19:40
Wohnort: Bad Schallerbach

Re: Kernel-Update 4.12.14-lp150.12.10.1 - danach keine Grafik

Beitrag von f.gruber » 8. Aug 2018, 15:19

Habe auch seit heute, seit dem Kernel Update auf 4.12.14-lp150.12.10-default, das gleiche Problem:
Totalcrash beim Booten.
Letzte Meldung am Bildschirm:

Code: Alles auswählen

Started Locale Service
Habe als Workaround im Bootmanager den Kernel 4.12.14-lp150.12.7 zum Booten eingestellt.
Also abwarten und wieder einmal tief seufzen :roll:
Gruß
Ferdinand

admine
Administrator
Administrator
Beiträge: 8781
Registriert: 15. Feb 2004, 21:13
Kontaktdaten:

Re: Kernel-Update 4.12.14-lp150.12.10.1 - danach keine Grafik

Beitrag von admine » 8. Aug 2018, 15:26

f.gruber hat geschrieben:
8. Aug 2018, 15:19
Habe auch seit heute, seit dem Kernel Update auf 4.12.14-lp150.12.10-default, das gleiche Problem:
Totalcrash beim Booten.
Totalcrash ist jetzt vermutlich etwas übertrieben ;) denn wer nur auf Zeile arbeitet, hat vermutlich keine Probleme.
Aber dein Workaround wurde ja auch hier schon genannt und empfohlen :thumbs:
..:: unser Linux-Club-Wiki ::..
-------------------------
..:: Deutsche Mugge ::..
-------------------------

Sauerland
Guru
Guru
Beiträge: 3208
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: Kernel-Update 4.12.14-lp150.12.10.1 - danach keine Grafik

Beitrag von Sauerland » 8. Aug 2018, 18:27

Desktop: OpenSUSE Leap 15.0, Nvidia-Grafik Kernel 4.x
Laptop: OpenSUSE Leap 15.0, Intel-Skylake, Kernel 4.12

dzug
Guru
Guru
Beiträge: 2106
Registriert: 5. Nov 2004, 15:49
Wohnort: Siegen

Re: Kernel-Update 4.12.14-lp150.12.10.1 - danach keine Grafik

Beitrag von dzug » 8. Aug 2018, 20:05

Hei.
Ich verwende Kernel aus Repo Kernel Stable.
Zur Zeit 4-17.13-2.1
Bei 43.2/ 15.0/ Tumbleweed.
Läuft hervorragend.
Gruss dzug.
Mein System:15.0+15.1+Tumbleweed
sda1= / + sda2=/home
sdb1=/heim 450 Gb
sdb2=swap 15 Gb
sdc1 /daten 1Tb
sdd1/daten1/1Tb
sde=Leer=Backup?
Laptop Toshiba Satellite/C660 15.0 und 15.1

Benutzeravatar
f.gruber
Hacker
Hacker
Beiträge: 410
Registriert: 24. Jun 2006, 19:40
Wohnort: Bad Schallerbach

Re: Kernel-Update 4.12.14-lp150.12.10.1 - danach keine Grafik

Beitrag von f.gruber » 8. Aug 2018, 20:43

admine hat geschrieben:
8. Aug 2018, 15:26
Totalcrash ist jetzt vermutlich etwas übertrieben ;) denn wer nur auf Zeile arbeitet, hat vermutlich keine Probleme.
Aber dein Workaround wurde ja auch hier schon genannt und empfohlen :thumbs:
Übertrieben?
Ich kann keine einzige virtuelle Konsole aktivieren (Strg + Alt + 1 - 10). Das System reagiert auf gar nichts - nicht einmal auf 10 mal Strg + Alt + Entf.
Das Einzige, was ich tun kann ist: 10 Sekunden den Ausschaltknopf drücken.
Gruß
Ferdinand

Sauerland
Guru
Guru
Beiträge: 3208
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: Kernel-Update 4.12.14-lp150.12.10.1 - danach keine Grafik

Beitrag von Sauerland » 8. Aug 2018, 20:48

Übertrieben?
Ich kann keine einzige virtuelle Konsole aktivieren (Strg + Alt + 1 - 10). Das System reagiert auf gar nichts - nicht einmal auf 10 mal Strg + Alt + Entf.
Das Einzige, was ich tun kann ist: 10 Sekunden den Ausschaltknopf drücken.
Und starten im Runlevel 3?
Desktop: OpenSUSE Leap 15.0, Nvidia-Grafik Kernel 4.x
Laptop: OpenSUSE Leap 15.0, Intel-Skylake, Kernel 4.12

Benutzeravatar
f.gruber
Hacker
Hacker
Beiträge: 410
Registriert: 24. Jun 2006, 19:40
Wohnort: Bad Schallerbach

Re: Kernel-Update 4.12.14-lp150.12.10.1 - danach keine Grafik

Beitrag von f.gruber » 8. Aug 2018, 21:13

Sauerland hat geschrieben:
8. Aug 2018, 20:48
Und starten im Runlevel 3?
In den Runlevel 3 kann ich starten - das geht.
Gebe ich dann aber init 5 ein, friert das System ein.
Letzte Meldung:

Code: Alles auswählen

Starting Terminate Plymouth Boot Screen
Sonst sehe ich keine hilfreichen Meldungen.

Ich hatte auch beim vorigen Kernel schon Probleme mit dem Boten. Damals bekam ich dezidiert die Meldung

Code: Alles auswählen

Could not start X Server
oder so ähnlich ...

Der Zufall brachte mich auf folgende Idee:
Ich entfernte die Bootoptionen

Code: Alles auswählen

splash=silent quiet showopts
Daraufhin startete das System wieder durch in den grafischen Modus und ich war zufrieden - was trügerisch war :D .
Gruß
Ferdinand

Benutzeravatar
f.gruber
Hacker
Hacker
Beiträge: 410
Registriert: 24. Jun 2006, 19:40
Wohnort: Bad Schallerbach

Re: Kernel-Update 4.12.14-lp150.12.10.1 - danach keine Grafik

Beitrag von f.gruber » 10. Aug 2018, 15:52

Das heute über die Aktualisierungsverwaltung installierte Kernel Update 4.12.14-lp150.12.13 scheint das Problem gelöst zu haben.
Der Rechner bootet jedenfalls wieder normal in die grafische Oberfläche Plasma 5.

War also ein Bug :nosmile:
Gruß
Ferdinand

Benutzeravatar
Jägerschlürfer
Moderator
Moderator
Beiträge: 4474
Registriert: 1. Jul 2005, 12:22
Wohnort: nahe Würzburg

Re: Kernel-Update 4.12.14-lp150.12.10.1 - danach keine Grafik

Beitrag von Jägerschlürfer » 12. Aug 2018, 12:22

Feuervogel hat geschrieben:
8. Aug 2018, 13:32
openSUSE Leap baut aber doch auf SUSE Linux Enterprise auf.
Warum war/ist SUSE Linux Enterprise selbst nicht in der Lage auf einen "echten" und möglichst aktuellen Langzeit-Kernel aufzusetzen? Oder bei einem Sprung auf eine nächste Kernelversion den dann aktuellen jüngeren LTS-Kernel zu nehmen?

Logisch wäre doch gewesen, beim Wechsel von SLE 12.n (Leap 42.n) nach SLE 15.n (Leap 15.n) auf den 4.14er-Kernel zu setzen.

Hier verstehe ich die "Philosophie" von SUSE Linux Enterprise (openSUSE Leap) nicht. :/
Das verstehe ich auch nicht so wirklich. Eignetlich sollte die Enterprise Version ja stabil laufen und nicht durch solche Fehler beeinflusst werden,...
>Linux-Club Foren FAQ< >LC-Wiki< >Paketsuche<

Meine Systeme:
Desktop1: Debian 8
Desktop2: Windows 7, Debian, Aptosid, Opensuse
Notebook: Manjaro
Netbook: Windows 10

admine
Administrator
Administrator
Beiträge: 8781
Registriert: 15. Feb 2004, 21:13
Kontaktdaten:

Re: Kernel-Update 4.12.14-lp150.12.10.1 - danach keine Grafik

Beitrag von admine » 13. Aug 2018, 07:41

f.gruber hat geschrieben:
10. Aug 2018, 15:52
Das heute über die Aktualisierungsverwaltung installierte Kernel Update 4.12.14-lp150.12.13 scheint das Problem gelöst zu haben.
Der Rechner bootet jedenfalls wieder normal in die grafische Oberfläche Plasma 5.
Dass kann ich so bestätigen und schließe hiermit den Thread. :)
..:: unser Linux-Club-Wiki ::..
-------------------------
..:: Deutsche Mugge ::..
-------------------------

Gesperrt