Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[gelöst] eSATA Festplatte wird nicht erkannt

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
KingBecks
Member
Member
Beiträge: 80
Registriert: 28. Jan 2007, 18:25
Wohnort: Villingen-Schwenningen

[gelöst] eSATA Festplatte wird nicht erkannt

Beitrag von KingBecks » 24. Sep 2009, 19:54

Hi
Ich hab mir gestern eine neue eSATA Festplatte gekauft und in diese eine Seagate Barracude ST3500320AS mit 500GB eingebaut.
Leider kann ich nicht auf die Festplatte zugreifen. /var/log/messages meint folgendes:

Code: Alles auswählen

Sep 24 19:48:53 1337computor kernel: ata6: softreset failed (device not ready)
Sep 24 19:48:53 1337computor kernel: ata6: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
Sep 24 19:48:53 1337computor kernel: ata6: link online but device misclassified, retrying
Sep 24 19:48:53 1337computor kernel: ata6: hard resetting link
AHCI ist im BIOS aktiviert.
Kann ich die Platte dennoch irgendwie zum laufen bekommen?
Zuletzt geändert von KingBecks am 3. Okt 2009, 12:35, insgesamt 1-mal geändert.
Gruß

KingBecks

Werbung:
Benutzeravatar
robi
Moderator
Moderator
Beiträge: 3160
Registriert: 25. Aug 2004, 02:13

Re: eSATA Festplatte wird nicht erkannt

Beitrag von robi » 24. Sep 2009, 20:42

Ein großer Teil solcher Probleme sind irgendwelche Verkabelungsprobleme. Siehe zB http://debianforum.de/forum/viewtopic.php?f=13&t=111381
Zuerstmal dort alles richtig überprüfen und austesten.

Wenn das alles nichts hilft, kann es auch alles mögliche sein, es gab wenn man bei Google sucht in der Vergangenheit in diesem Umfeld jedenfalls schon jede Menge Probleme. Größeren Probleme auf Linuxseite sollten heute in aktuellen Kernelversionen behoben sein. Allerdings bleibt auch ein gewisses Restrisiko, das dort beim Kombinieren der Hardware irgendwas in irgend einem Protokoll überhaupt nicht 100% kombatibel mit Linux zusammen arbeiten will.

robi

Tooltime
Advanced Hacker
Advanced Hacker
Beiträge: 1202
Registriert: 28. Mai 2008, 17:49

Re: eSATA Festplatte wird nicht erkannt

Beitrag von Tooltime » 24. Sep 2009, 21:32

Ich würde die Platte am ausgeschalteten Rechner anstöpseln, die Platte hochlaufen lassen, den Rechner starten und sofort ins BIOS gehen. Dort müsste die Platte sichtbar sein, wenn nicht stimmt irgend etwas an der Hardware nicht. Erst dann würde ich schauen ob Linux diese findet und ob hotpluging funktioniert.

KingBecks
Member
Member
Beiträge: 80
Registriert: 28. Jan 2007, 18:25
Wohnort: Villingen-Schwenningen

Re: eSATA Festplatte wird nicht erkannt

Beitrag von KingBecks » 25. Sep 2009, 19:03

Also die Platte wird vom BIOS erkannt und wie ich feststellen musste, auch vom Linux allerdings nur wenn sie beim booten eingestöpselt ist.
Und darauf zugreifen kann ihc wenn sie per eSATA dran hängt nur als root.
Dann sollte aber zumindest bedeuten, dass es prinzipiell möglich sein sollte oder?
Gruß

KingBecks

spoensche
Moderator
Moderator
Beiträge: 7396
Registriert: 30. Okt 2004, 23:53
Wohnort: Siegen

Re: eSATA Festplatte wird nicht erkannt

Beitrag von spoensche » 25. Sep 2009, 22:47

Ist die Platte Partitioniert und hast du dem System auch mitgeteilt, in welchem Mountpoint die Partitionen eingehängt werden sollen und wer welche Rechte auf den Partitionen hat?

Ein paar Informationen von deiner Seite wären hilfreich.

KingBecks
Member
Member
Beiträge: 80
Registriert: 28. Jan 2007, 18:25
Wohnort: Villingen-Schwenningen

Re: eSATA Festplatte wird nicht erkannt

Beitrag von KingBecks » 26. Sep 2009, 01:41

Das Grundproblem denke ich ist, dass wenn ich die Platte am laufenden System anhänge, kein device erstellt wird und die Fehlermeldung in den messages kommen. Ich denke jetzt dass es klar ist dass ich die Platte nur als root verwenden, weil sie ja nicht in der fstab steht. Brauch ich ja eigentlich auch nicht, weil sie ja später per automount eingebunden werden soll (wenn ich sie am laufenden System anhäng). Ich habe auch schon etwas über Probleme mit dem ahci-Modul, das ja für den SATA-Controller verwendet wird, und IRQ's gelesen, aber in /proc/interrupts tauchen keine doppelten auf. Vielleicht hat das was mit dem BIOS zu tun, dass das beim bootvorgang irgendetwas für die Platte oder den SATA-Controller einrichtet, was Linux (eben vielleicht das ahci-Modul) sonst selber machen müsste.

Hoffe hier kann man was hilfreiches rauslesen.
Gruß

KingBecks

KingBecks
Member
Member
Beiträge: 80
Registriert: 28. Jan 2007, 18:25
Wohnort: Villingen-Schwenningen

Re: eSATA Festplatte wird nicht erkannt

Beitrag von KingBecks » 3. Okt 2009, 12:34

Also ich hab das Problem gelöst!
Es lag ganz einfach nur daran, dass ich die Platte erst anschalten und erst später das eSATA Kabel anschliessen musste.
Dann noch ein chmod auf das Device und das wars - jetzt funktioniert alles!
Danke an alle die versucht haben zu helfen ;)

Antworten