Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[gelöst] Xserver andert Display-Helligkeit beim Start

Alles rund um Hardware, die unter Linux läuft oder zum Laufen gebracht werden soll

Moderator: Moderatoren

Gesperrt
grf
Newbie
Newbie
Beiträge: 44
Registriert: 14. Nov 2005, 12:23

[gelöst] Xserver andert Display-Helligkeit beim Start

Beitrag von grf » 9. Nov 2007, 18:15

Hallo,

ich habe mein neues Notebook HP 6510b mit integrierter Intel-Grafik (965 GM) unter openSUSE 10.3 weitestgehend problemlos zum Laufen bekommen.
Eine sehr nervige Sache habe ich aber bis jetzt noch nicht in den Griff bekommen: Beim Start von kdm bzw. dem Start und dem Beenden des Xservers (und auch beim Start von MPlayer) setzt dieser die Helligkeit des Display-Backlights auf Maximum. Allerdings selbst das irgendwie fehlerhaft, denn wenn ich mit den Tasten nachreguliere, springt die Helligkeit wieder auf den vorher eingestellten Wert +/-1.

Ich vermute, dass der Treiber "intel", der in xorg.conf eingestellt ist, noch irgendeinen hässlichen Bug hat.
Bei einem anderen HP-Laptop hatte ich diesen Fehler interessanterweise mit dem Treiber "i810" und nicht mit dem Treiber "intel"...

Kennt jemand einen Workaround oder gar eine Lösung für dieses Problem?

Gruß
Michael
Sowas kommt von sowas.

Werbung:
grf
Newbie
Newbie
Beiträge: 44
Registriert: 14. Nov 2005, 12:23

Beitrag von grf » 12. Nov 2007, 22:00

Hab nun auch mal glxgears ausprobiert und bekomme nach ca. 30 Sekunden einen reproduzierbaren Absturz des Xservers (3D ist abgeschaltet). Der "intel"-Treiber scheint also sehr schrottig zu sein, denn mit "vesa" gibt es weder Absturz noch die nervige Verstellung der Bildschirmhelligkeit.
Leider kann vesa nicht 1280x800. :(
Gibt es eine andere Alternative zu dem "intel"-Treiber für 965GM? Der "i810" funktioniert leider nicht...

Michael
Sowas kommt von sowas.

grf
Newbie
Newbie
Beiträge: 44
Registriert: 14. Nov 2005, 12:23

Re: Xserver andert Display-Helligkeit beim Start

Beitrag von grf » 24. Jun 2008, 23:00

Der Thread ist schon etwas älter, aber hier nochmal ein Update für die, die vielleicht das gleiche Problem haben. Es war ein Bug am Treiber für den intel 965GM. Wurde mir nach Schreiben des Bugreports bestätigt. Der Bug ist erst mit der openSuse11 aus dem Treiber raus...

Michael.
Sowas kommt von sowas.

grf
Newbie
Newbie
Beiträge: 44
Registriert: 14. Nov 2005, 12:23

Re: Xserver andert Display-Helligkeit beim Start

Beitrag von grf » 25. Jun 2008, 20:08

Nachtrag zum Nachtrag: Der Treiber scheint nun unter openSuse11 wirklich ok zu sein. Allerdings scheint der kpowersave einen hässlichen Bug zu haben: Jedesmal bei dem Versuch, über Fn-Tasten die DIsplay-Helligkeit zu verstellen, endet in völlig chaotischem Hin- und Hergestelle der Helligkeit. Wenn kpowersave beendet wird, lässt sich die Helligkeit wieder normal per Fn-Tasten verändern.
Einzige Lösung bleibt nur die Einstellung der Helligkeit per "xbacklight -set xx", solange der knetworkmanager läuft. Es sei denn, irgend jemand hat noch eine andere Lösung (alle Eingriffe zur Helligkeit in der kpowersave-Konfiguration sind übrigens deaktiviert).

Michael.
Sowas kommt von sowas.

admine
Administrator
Administrator
Beiträge: 8801
Registriert: 15. Feb 2004, 21:13
Kontaktdaten:

Re: Xserver andert Display-Helligkeit beim Start

Beitrag von admine » 25. Jun 2008, 22:19

Ich glaub, du bist nicht ganz allein mit deinem Problem. :(
Mich nervt so etwas dieser Art auch gerade:
http://lists.opensuse.org/opensuse-de/2 ... 00991.html
..:: unser Linux-Club-Wiki ::..
-------------------------
..:: Deutsche Mugge ::..
-------------------------

grf
Newbie
Newbie
Beiträge: 44
Registriert: 14. Nov 2005, 12:23

Re: Xserver andert Display-Helligkeit beim Start

Beitrag von grf » 25. Jun 2008, 23:44

Die einzige Lösung ist zur Zeit, den kpowersave zu beenden und nicht beim Anmelden starten zu lassen. Das hilft zwar nicht gegen das Verstellen der Helligkeit beim Kernel-Start (irgendeine ACPI-Geschichte), aber gegen die Probleme mit der Display-Helligkeit unter KDE.

MIchael.
Sowas kommt von sowas.

admine
Administrator
Administrator
Beiträge: 8801
Registriert: 15. Feb 2004, 21:13
Kontaktdaten:

Re: Xserver andert Display-Helligkeit beim Start

Beitrag von admine » 26. Jun 2008, 07:44

Wenn ich KPowersave nicht mit starten lasse beim Booten, dann ist der Schirm auch in der richtigen Helligkeit.
Nur beim Umschalten auf Konsole wird er dann doch dunkel.

Na ja und auf BIOS-Update, wie mir geraten wurde, hab ich *ich gestehe* nicht wirklich Lust.
Aber eh es nur noch nervt, werde ich auch diesen Weg testen.
..:: unser Linux-Club-Wiki ::..
-------------------------
..:: Deutsche Mugge ::..
-------------------------

grf
Newbie
Newbie
Beiträge: 44
Registriert: 14. Nov 2005, 12:23

Re: Xserver andert Display-Helligkeit beim Start

Beitrag von grf » 26. Jun 2008, 22:35

Was hast Du für einen Laptop? Mein HP 6510b mit Intel 965GM-Grafik hat das aktuelle BIOS drauf (von Januar 2008).

Michael.
Sowas kommt von sowas.

admine
Administrator
Administrator
Beiträge: 8801
Registriert: 15. Feb 2004, 21:13
Kontaktdaten:

Re: Xserver andert Display-Helligkeit beim Start

Beitrag von admine » 26. Jun 2008, 22:48

grf hat geschrieben:Was hast Du für einen Laptop?
Steht im ersten Posting des Maillinglisten-Link ;)
ASUS F3F
..:: unser Linux-Club-Wiki ::..
-------------------------
..:: Deutsche Mugge ::..
-------------------------

grf
Newbie
Newbie
Beiträge: 44
Registriert: 14. Nov 2005, 12:23

Re: Xserver andert Display-Helligkeit beim Start

Beitrag von grf » 26. Jun 2008, 23:12

admine hat geschrieben:
grf hat geschrieben:Was hast Du für einen Laptop?
Steht im ersten Posting des Maillinglisten-Link ;)
ASUS F3F
Ups, stimmt. :)
Da bleibt uns wahrscheinlich nur das Warten auf Patches.

Michael.
Sowas kommt von sowas.

grf
Newbie
Newbie
Beiträge: 44
Registriert: 14. Nov 2005, 12:23

Re: Xserver andert Display-Helligkeit beim Start

Beitrag von grf » 7. Jul 2008, 19:55

So, mein Problem scheint gelöst, dank eines Bugreports. :D

Der Lösungsweg, der auch einem anderen Kollegen mit Dell-Notebook half, ist folgender:

Das Modul "video" muss in die Blacklist, darf also beim Start nicht geladen werden. Man erreicht das, indem man in der Datei "blacklist" im Verzeichnis "/etc/modprobe.d/" folgenden Eintrag vornimmt:

Code: Alles auswählen

blacklist video
Danach den Rechner neu starten (Einfach das Modul per "rmmod video" nur zu entladen, reicht nicht aus!).
Beim Dell-Notebook scheint dann das Modul "dcdbas" notwendig zu sein, bei meinem HP läuft nun alles auch ohne dieses perfekt.

Michael.
Sowas kommt von sowas.

Benutzeravatar
onkelchentobi
Guru
Guru
Beiträge: 1899
Registriert: 11. Feb 2005, 15:54
Wohnort: BW - Stuttgart
Kontaktdaten:

Re: Xserver andert Display-Helligkeit beim Start

Beitrag von onkelchentobi » 7. Jul 2008, 21:07

Wenn es geloest ist mach ich hier mal zu und kenzeichne es entsprechend.
GNU/Debian Linux - Testing 32 Bit / Kernel 2.6.30.2 Vanilla / Ion3 - 20090110 / i2p

*** NO E-PATENTS ***

admine
Administrator
Administrator
Beiträge: 8801
Registriert: 15. Feb 2004, 21:13
Kontaktdaten:

Re: [gelöst] Xserver andert Display-Helligkeit beim Start

Beitrag von admine » 15. Jul 2008, 18:46

Noch zur Vollständigkeit - bei mir hat sich das Problem mit dem letzten Kernel-Update (2.6.25.9-0.2-default) erledigt :)
..:: unser Linux-Club-Wiki ::..
-------------------------
..:: Deutsche Mugge ::..
-------------------------

Gesperrt