Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

vServer einrichten

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
BiZNiZ
Member
Member
Beiträge: 106
Registriert: 24. Aug 2004, 12:30
Wohnort: Munster, Lüneburger Heide

vServer einrichten

Beitrag von BiZNiZ »

Moin ...
... wir haben seit heute Zugriff auf unseren vServer ...

Laut Anbieter ist dort SuSE installiert ...
Wie finde ich raus, welche Version ??? Bislang weiß ich nur, dass ein 2.4'er Kernel verwendet wird ... demnach tippe ich auf 9.0 oder 9.1

Ich würde gerne diverse rpms nachinstallieren, bekomme aber bei der Eingabe von

Code: Alles auswählen

rpm -i --test paketname.rpm
immer die Anzeige, dass diverse Abhängigkeiten erst aufgelöst werden müssen ...

Dachte somit schon einmal an apt ...
Aber auch da stehe ich schon vor dem Rätsel, welche Version ich brauche ...

Habe zwar den Anbieter diesbezüglich schon angefragt, aber noch keine Antwort erhalten ...

Weiß rgendjemand welche Version ich für einen vServer bei Evanzo brauche???
Ein Freund ist jemand, der Dich kennt ( ... und trotzdem mag ) !!!
BiZNiZ
Member
Member
Beiträge: 106
Registriert: 24. Aug 2004, 12:30
Wohnort: Munster, Lüneburger Heide

ein wenig schlauer ...

Beitrag von BiZNiZ »

... bin ich schon ...

eVanzo verwendet SuSE 8.2 ...

habe auch die entsprechenden apt-Pakete mittlerweile installieren können (dank --nodeps ), bekomme aber noch imemr die meldung:

Code: Alles auswählen

apt-get: error while loading sharde libraries: librpm.so.0: cannot open shared object file: no such file or directory
Folglich fehlt doch diese wohl ...

Wo kriege ich die passende nun her und wo muss sie hinkopiert werden ???
Ein Freund ist jemand, der Dich kennt ( ... und trotzdem mag ) !!!
BiZNiZ
Member
Member
Beiträge: 106
Registriert: 24. Aug 2004, 12:30
Wohnort: Munster, Lüneburger Heide

mir feht der Durchblick ...

Beitrag von BiZNiZ »

habe jetzt mittels

Code: Alles auswählen

find / -name librpm*
die Datei gefunden und entsprechend mal die PATH-Variable mittels

Code: Alles auswählen

export PATH= /usr/i486-linux-libc5/lib:$PATH 
erweitert ...
"export" zeigt mir nun auch diesen Pfad mit an ...

Trotzdem findet apt-get noch immer die librpm.so.0 nicht ...

APT-GET scheint nur in /usr/lib nach libraries zu suchen ...

Hat irgendjemand 'ne Idee ???
Ein Freund ist jemand, der Dich kennt ( ... und trotzdem mag ) !!!
BiZNiZ
Member
Member
Beiträge: 106
Registriert: 24. Aug 2004, 12:30
Wohnort: Munster, Lüneburger Heide

und wieder ein Stück weiter ...

Beitrag von BiZNiZ »

nachdem ich aus dem Ordner /usr/i486-linux-libc5/lib diverse files nach /usr/lib kopiert hatte, lief endlich das erwartete apt-get update ...

Es lief komplett durch und meldete danach zum Abschluss:

Code: Alles auswählen

apt-get: relocation error: /usr/lib/librpm.so.0: undefined symbol: _fxstat
Hört sich für mich danach an, dass die librpm.so.0 nicht die ist, die von APT-GET erwartet wird ... evtl. falsche Version ???

Brauche dringend 'ne Idee ...
Ein Freund ist jemand, der Dich kennt ( ... und trotzdem mag ) !!!
Antworten