Datumsproblem beim Kopieren

Alles rund um die möglichen Desktopumgebungen wie KDE, Gnome, XFCE usw. die es unter Linux gibt

Moderator: Moderatoren

Antworten
Benutzeravatar
rbest
Hacker
Hacker
Beiträge: 560
Registriert: 10. Nov 2004, 14:28
Kontaktdaten:

Datumsproblem beim Kopieren

Beitrag von rbest » 20. Apr 2006, 14:04

Hi Leute,
wusste mal wieder nicht, wo ich dieses Thema unterbringen soll. Bin gerade am Schreiben ein paar kleiner scripts. Und zwar möchte ich nichts anderes, als Dateien neueren Datums von einem Samba-LW auf eine USB-Platte zu befördern. Sind also beides FAT-Partitionen. Das wollte ich so bewerkstelligen:

Code: Alles auswählen

cp /r1/windows/D/Daten /windows/D/Daten -r -u -p
-p hatte ich irgendwo in einem Beitrag gelesen. Aber das Datum im Ziel hat danach immer das aktuelle Kopierdatum.
Wie krieg ich das gebacken, dass ich dieselben Attribute wie in der Quelle krieg?
Wenn doch alle so wären wie ich --- sein sollte.
Acer Aspire X3990 - (SuSE 13.2, kubuntu 14 und Linux Mint 16)
Roland Best

Werbung:
Benutzeravatar
rbest
Hacker
Hacker
Beiträge: 560
Registriert: 10. Nov 2004, 14:28
Kontaktdaten:

Beitrag von rbest » 20. Apr 2006, 17:48

hi Leute,
seid ihr alle im Urlaub oder gips keine Lösung für mein Problem?
Wenn doch alle so wären wie ich --- sein sollte.
Acer Aspire X3990 - (SuSE 13.2, kubuntu 14 und Linux Mint 16)
Roland Best

sc_m
Member
Member
Beiträge: 205
Registriert: 31. Okt 2005, 21:59
Wohnort: Frankfurt

Beitrag von sc_m » 20. Apr 2006, 18:03

Verwende rsync statt cp, das bietet diese Optionen und noch viel mehr.

Edit: Wobei ich aber nicht so recht weiß, wie sich rsync bei FAT-Partitionen verhält.

Benutzeravatar
rbest
Hacker
Hacker
Beiträge: 560
Registriert: 10. Nov 2004, 14:28
Kontaktdaten:

Beitrag von rbest » 20. Apr 2006, 19:14

danke, die kopiererei klappt, aber ich finde nach wie vor keinen Parameter für Nicht-Verändern von Datum und Zeit.
Wenn doch alle so wären wie ich --- sein sollte.
Acer Aspire X3990 - (SuSE 13.2, kubuntu 14 und Linux Mint 16)
Roland Best

sc_m
Member
Member
Beiträge: 205
Registriert: 31. Okt 2005, 21:59
Wohnort: Frankfurt

Beitrag von sc_m » 21. Apr 2006, 00:12

Dann zitiere ich hier einmal "man rsync":
-t, --times
This tells rsync to transfer modification times along with the
files and update them on the remote system.

Benutzeravatar
rbest
Hacker
Hacker
Beiträge: 560
Registriert: 10. Nov 2004, 14:28
Kontaktdaten:

Beitrag von rbest » 21. Apr 2006, 11:46

danke dir. -t hatte ich schon ausprobiert, aber kamen haufen Fehlermeldungen (soweit ich weiss hiess das "could not permit time" oder so ähnlich.
Vielleicht geht das nur bei lokalen Laufwerken, zumindest wird das bei krusader so beschrieben. Aber ich probier rsync einfach mal in der console.
Wenn doch alle so wären wie ich --- sein sollte.
Acer Aspire X3990 - (SuSE 13.2, kubuntu 14 und Linux Mint 16)
Roland Best

sc_m
Member
Member
Beiträge: 205
Registriert: 31. Okt 2005, 21:59
Wohnort: Frankfurt

Beitrag von sc_m » 21. Apr 2006, 11:55

Zumindest am FAT-Dateisystem liegt's nicht, das habe ich gerade ausprobiert.

Benutzeravatar
rbest
Hacker
Hacker
Beiträge: 560
Registriert: 10. Nov 2004, 14:28
Kontaktdaten:

Beitrag von rbest » 22. Apr 2006, 14:24

danke, jetzt hab ich's. Irgendwo war ich blind.
Wenn doch alle so wären wie ich --- sein sollte.
Acer Aspire X3990 - (SuSE 13.2, kubuntu 14 und Linux Mint 16)
Roland Best

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast