VNC-Performance-Problem bei Anbindung an Screen 0

Alles rund um die möglichen Desktopumgebungen wie KDE, Gnome, XFCE usw. die es unter Linux gibt

Moderator: Moderatoren

Antworten
Benutzeravatar
Kochbeutelreis
Newbie
Newbie
Beiträge: 5
Registriert: 15. Apr 2006, 12:27
Wohnort: Burghausen
Kontaktdaten:

VNC-Performance-Problem bei Anbindung an Screen 0

Beitrag von Kochbeutelreis » 15. Apr 2006, 12:51

Hallo zusammen,

ich hab SuSE Linux 9.3 und ich hab ein Performance-Problem, wenn ich vom Windows aus per VNC auf die Arbeitsfläche der direkt auf dem Linux-Rechner laufenden Sitzung (Screen 0) zugreife. Wenn ich dagegen mit :1 per VNC eine neue Sitzung erstell, dann ist die Performance optimal. Ich brauch aber Zugriff auf die vorhandene Sitzung.

Auf einem älteren Rechner hab ich ebenfalls SuSE Linux 9.3 laufen und da ist die Performance auch dann optimal, wenn ich per VNC auf Screen 0 zugreife. Ich hab damals recht viel rumgebastelt, weiss aber nicht mehr, was ich gemacht hab :-)

Kann mir jemand sagen, was ich gegen das Performance-Problem auf meinem neuen Linux-Rechner tun kann?

Vielen Dank im Voraus und viele Grüße,
Kochbeutelreis

Werbung:
rolle
Guru
Guru
Beiträge: 3721
Registriert: 4. Mai 2004, 21:50
Kontaktdaten:

Beitrag von rolle » 15. Apr 2006, 13:49

Welche Performance geht denn in den Keller? Falls es die Übertragungsgeschwindigkeit sein sollte, dann experimentiere mal mit der Farbtiefe, der übertragenen Desktopgröße und mit der Komprimierung der Daten. Auch die Nichtübertragung eines Hintergrundbildes kann helfen. Das alles müßte im Viewer einstellbar sein.
Horrido, Roland

Für meine Postings gilt außer bei Zitaten hier im Linux-Club die Creative Commons.

Benutzeravatar
Kochbeutelreis
Newbie
Newbie
Beiträge: 5
Registriert: 15. Apr 2006, 12:27
Wohnort: Burghausen
Kontaktdaten:

Beitrag von Kochbeutelreis » 15. Apr 2006, 14:18

rolle hat geschrieben:Welche Performance geht denn in den Keller? Falls es die Übertragungsgeschwindigkeit sein sollte, dann experimentiere mal mit der Farbtiefe, der übertragenen Desktopgröße und mit der Komprimierung der Daten.
Hallo rolle,

darum gehts leider nicht. Es ist so, dass er auf meinem neuen Linux-Rechner speziell nur bei Anbindung an die bestehende Session (:0) das irgendwie in einem anderen Modus macht und das bremst die Sitzung ungemein. Dabei fällt auf, dass auch das Mauszeigersymbol nur ein ganz karger weisser Pfeil ist. Auf meinem alten Rechner dagegen werden auch mit :0 sämtliche Mauszeigersymbole übertragen, wenn auch monochrom, und das sehr schnell, obwohls nur ein 1000er ist, der neue ist ein 2400er. Ansonsten fällt noch auf, dass bei einer :0-Anbindung an den neuen Linux-Rechner das VNC-Viewer-Fenster im Stil von "andy@tux (freigegebene Arbeitsfläche)" betitelt wird, während es beim alten Rechner im Stil von "root's x11 desktop (linux:0)" betitelt wird, AUCH bei einer :0-Anbindung.

Ich hab mal gelesen, dass es für die :0-VNC-Anbindung drei verschiedene Einrichtungsmöglichkeiten gibt. Leider hab ich keinen Peil mehr, was ich bei meinem alten Rechner damals gemacht hab. Es hat wohl damit zu tun, dass bei der ineffizienten Art und Weise ein performancebremsendes Softwarepolling aktiv wird. Gerade deshalb gibt es noch 2 andere, sehr viel performantere Möglichkeiten. Wäre dankbar, wenn ich wüsste, welche :-)

Viele Grüße,
Kochbeutelreis

rolle
Guru
Guru
Beiträge: 3721
Registriert: 4. Mai 2004, 21:50
Kontaktdaten:

Beitrag von rolle » 15. Apr 2006, 14:57

Dann fangen wir mal vorne an. :wink: Wie startest Du den VNC-Server jeweils für Screen :0 und :1?
Horrido, Roland

Für meine Postings gilt außer bei Zitaten hier im Linux-Club die Creative Commons.

Benutzeravatar
Kochbeutelreis
Newbie
Newbie
Beiträge: 5
Registriert: 15. Apr 2006, 12:27
Wohnort: Burghausen
Kontaktdaten:

Beitrag von Kochbeutelreis » 15. Apr 2006, 15:12

rolle hat geschrieben:Dann fangen wir mal vorne an. :wink: Wie startest Du den VNC-Server jeweils für Screen :0 und :1?
Der Xvnc läuft über den xinetd-Daemon.

Wo kann ich :0 und :1 getrennt konfigurieren? Gerade darum gehts mir. Vielleicht bin ich dann schon einen großen Schritt weiter.

Hier ist die /etc/xinetd.d/vnc meines neuen Rechners. Die vom alten sieht genauso aus.

# default: off
# description: This serves out a VNC connection which starts at a KDM login \
# prompt. This VNC connection has a resolution of 1024x768, 16bit depth.
service vnc1
{
socket_type = stream
protocol = tcp
wait = no
user = nobody
server = /usr/X11R6/bin/Xvnc
server_args = :42 -inetd -once -query localhost -geometry 1024x768 -depth 16
type = UNLISTED
port = 5901
}
# default: off
# description: This serves out a VNC connection which starts at a KDM login \
# prompt. This VNC connection has a resolution of 1280x1024, 16bit depth.
service vnc2
{
type = UNLISTED
port = 5902
socket_type = stream
protocol = tcp
wait = no
user = nobody
server = /usr/X11R6/bin/Xvnc
server_args = :42 -inetd -once -query localhost -geometry 1280x1024 -depth 16
disable = yes
}
# default: off
# description: This serves out a VNC connection which starts at a KDM login \
# prompt. This VNC connection has a resolution of 1600x1200, 16bit depth.
service vnc3
{
type = UNLISTED
port = 5903
socket_type = stream
protocol = tcp
wait = no
user = nobody
server = /usr/X11R6/bin/Xvnc
server_args = :42 -inetd -once -query localhost -geometry 1600x1200 -depth 16
disable = yes
}
# default: off
# description: This serves out the vncviewer Java applet for the VNC \
# server running on port 5901, (vnc port 1).
service vnchttpd1
{
socket_type = stream
protocol = tcp
wait = no
user = nobody
server = /usr/X11R6/bin/vnc_inetd_httpd
server_args = 1024 768 5901
type = UNLISTED
port = 5801
}
# default: off
# description: This serves out the vncviewer Java applet for the VNC \
# server running on port 5902, (vnc port 2).
service vnchttpd2
{
type = UNLISTED
port = 5802
socket_type = stream
protocol = tcp
wait = no
user = nobody
server = /usr/X11R6/bin/vnc_inetd_httpd
server_args = 1280 1024 5902
disable = yes
}
# default: off
# description: This serves out the vncviewer Java applet for the VNC \
# server running on port 5902, (vnc port 3).
service vnchttpd3
{
type = UNLISTED
port = 5803
socket_type = stream
protocol = tcp
wait = no
user = nobody
server = /usr/X11R6/bin/vnc_inetd_httpd
server_args = 1600 1200 5903
disable = yes
}
Zuletzt geändert von Kochbeutelreis am 15. Apr 2006, 15:18, insgesamt 1-mal geändert.

rolle
Guru
Guru
Beiträge: 3721
Registriert: 4. Mai 2004, 21:50
Kontaktdaten:

Beitrag von rolle » 15. Apr 2006, 15:17

Aber per xinetd kommst Du nicht auf Screen :0 (Das ist der Screen des lokalen X-Servers auf dem VNC-Server.). Mmh, vielleicht hilft Dir ein Blick in die Howtosammlung am oberen Forenende des LTSP, VNC und NX-Forums. Da findest Du viele Möglichkeiten, wie Du einen VNC-Server starten kannst, eventuell ist da eine Variante dabei, die schneller läuft.
Horrido, Roland

Für meine Postings gilt außer bei Zitaten hier im Linux-Club die Creative Commons.

Benutzeravatar
Kochbeutelreis
Newbie
Newbie
Beiträge: 5
Registriert: 15. Apr 2006, 12:27
Wohnort: Burghausen
Kontaktdaten:

Beitrag von Kochbeutelreis » 15. Apr 2006, 15:24

rolle hat geschrieben:Aber per xinetd kommst Du nicht auf Screen :0 (Das ist der Screen des lokalen X-Servers auf dem VNC-Server.).
Das ist schon mal ein guter Hinweis, danke. Das heisst, dass die xinetd-Einträge für die :0-Anbindung keine Rolle spielen. Wie kann ich nachvollziehen, von welchem VNC-Server ich über welchen Port bedient werde, wenn ich mich per :0 draufhäng?
rolle hat geschrieben:Mmh, vielleicht hilft Dir ein Blick in die Howtosammlung am oberen Forenende des LTSP, VNC und NX-Forums. Da findest Du viele Möglichkeiten, wie Du einen VNC-Server starten kannst, eventuell ist da eine Variante dabei, die schneller läuft.
Hab schon gegruhscht :-) Leider steh ich momentan ein bisschen daneben, weil ich eben nicht weiss, über welchen VNC-Server die Verbindung hergestellt wird, wenn ich mich per :0 draufhäng. Wenn ich das wüsste und die dazugehörigen Konfigurationsdateien wüsste, hätte ich einen Anhaltspunkt.

Viele Grüße,
Andy

rolle
Guru
Guru
Beiträge: 3721
Registriert: 4. Mai 2004, 21:50
Kontaktdaten:

Beitrag von rolle » 15. Apr 2006, 15:28

Um auf Screen :0 (Port 5900/5800) zu kommen, gibt es mehrere Möglichkeiten: VNC per SAX2, per vino bei laufendem Gnome, per Desktopfreigabe bei laufendem KDE oder per x11vnc.
Horrido, Roland

Für meine Postings gilt außer bei Zitaten hier im Linux-Club die Creative Commons.

Benutzeravatar
Kochbeutelreis
Newbie
Newbie
Beiträge: 5
Registriert: 15. Apr 2006, 12:27
Wohnort: Burghausen
Kontaktdaten:

Beitrag von Kochbeutelreis » 15. Apr 2006, 17:11

rolle hat geschrieben:Mmh, vielleicht hilft Dir ein Blick in die Howtosammlung am oberen Forenende des LTSP, VNC und NX-Forums. Da findest Du viele Möglichkeiten, wie Du einen VNC-Server starten kannst, eventuell ist da eine Variante dabei, die schneller läuft.

Ich hab grad dein VNC How To http://www.linux-club.de/viewtopic.php?t=37440 gelesen. Methode 7 hat mein Problem gelöst. Ist ein Performanceunterschied wie Tag und Nacht.

Ich danke dir vielmals!

Viele Grüße,
Andy

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste