[gelöst] Xorg.0.log.old permission denied (auch für root!!!)

Alles rund um die möglichen Desktopumgebungen wie KDE, Gnome, XFCE usw. die es unter Linux gibt

Moderator: Moderatoren

Antworten
Scuppa
Member
Member
Beiträge: 78
Registriert: 24. Feb 2004, 16:42
Wohnort: Mainz-Kastel

[gelöst] Xorg.0.log.old permission denied (auch für root!!!)

Beitrag von Scuppa » 4. Apr 2006, 22:33

Hallo,

ich habe seit kurzem ein sehr merkwürdiges Problem ohne die leiseste Ahnung zu haben, wodurch dieses ausgelöst sein könnte: Wenn ich SuSE 10.0 boote startet nicht der Anmeldungsmanager sondern nur die Konsole. Wenn ich dort startx eingebe, EGAL ob als User oder Root erhalte ich die Fehlermeldungen:

Code: Alles auswählen

Fatal server error: Cannot move old log file ("/var/log/org.0.log" to "/var/log/Xorg.0.log.old"
und

Code: Alles auswählen

xinit: Connection refused (errno 111): unable to connect to X server
xinit: No such process (errno 3): Server error
Eine Datei "Xorg.0.log.old" ist aber im Verzeichnis /var/log anscheinend nicht vorhanden. Wenn ich die Datei "/var/log/Xorg.0.log" lösche klappt startx für Root und User, aber eben nur einmal, danach muss die Datei erneut gelöscht werden.

Ich habe als Root ansonsten Lese- und Schreibzugriff auf /var/log, nur wenn ich z.B. eine "Dummy-Datei" namens Xorg.0.log.old erstellen will oder auch deren Berechtigungen (obwohl sie ja gar nicht da ist) ändern will oder sie löschen bekomme ich die Meldung "permission denied"! Es ist, als wäre eine Phantomdatei "Xorg.0.log.old" in dem Verzeichnis vorhanden, auf die jeder Zugriff verweigert wird...

Kann sich jemand darauf einen Reim machen?!

Danke und Gruß,

Scuppa
Zuletzt geändert von Scuppa am 7. Apr 2006, 21:29, insgesamt 1-mal geändert.

Werbung:
Scuppa
Member
Member
Beiträge: 78
Registriert: 24. Feb 2004, 16:42
Wohnort: Mainz-Kastel

Beitrag von Scuppa » 7. Apr 2006, 19:25

Hat wirklich keiner eine Idee?!

Kann ich vielleicht irgendwie die Zugriffsrechte für xorg zurücksetzen oder so?
Hilft vielleicht eine Neuinstallation des grafischen Systems, wenn ja wie mach' ich das richtig? Habe APT installiert.

Die grafische Oberfläche läuft wie gesagt ansonsten problemlos. Sie startet aber eben nur, wenn ich die Xorg.0.log vorher lösche...

Scuppa
Member
Member
Beiträge: 78
Registriert: 24. Feb 2004, 16:42
Wohnort: Mainz-Kastel

Beitrag von Scuppa » 7. Apr 2006, 21:38

Okay, ich hab's geschafft :P!

Lösung:

Mit der Installations-CD/DVD im Rescue-Modus gestartet und als root angemeldet.

Code: Alles auswählen

fsck /dev/'bootpartition' --rebuild-tree
ausgeführt.

Damit hat er dann alles repariert. Anscheinend endeten die Bezüge, unter anderem für die /var/log/Xorg.0.log.old und die /var/log/boot.msg im Nichts, wodurch auch keinerlei Zugriff mehr auf diese Dateien möglich war.

Was auch immer das Ganze ausgelöst hat...

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast