Probleme mit Schriftgrößen

Alles rund um die möglichen Desktopumgebungen wie KDE, Gnome, XFCE usw. die es unter Linux gibt

Moderator: Moderatoren

Antworten
Benutzeravatar
thw
Newbie
Newbie
Beiträge: 24
Registriert: 26. Sep 2004, 20:57
Wohnort: Elbflorenz
Kontaktdaten:

Probleme mit Schriftgrößen

Beitrag von thw » 23. Mär 2006, 15:03

Hallo,

nachdem ich SuSE 10 auf einen Rechner installiert hatte, waren die Schriftarten bei GTK-Programmen (z.B. Firefox) extrem klein und kaum lesbar. Habe hier im Forum gesucht und diese gtk-qt-engine installiert. Der Menüpunkt "GTK-Programme" erscheint jedoch nicht im Kontrollzentrum. Habe daher einen anderen Tipp verfolgt und das gnome-Controlcenter installiert und dort die Schriftgrößen für GTK-Programme angepasst. Diesen gnome-settings-daemon hab' ich in KDE-Autostart gemacht. Leider habe ich jetzt folgendes Problem:
Die Schriftgrößen von GTK-Programmen werden jetzt schön angezeigt. Die KDE-Schriftarten auf dem Desktop und im K-Menü usw. sind auch in Ordnung. Bei einigen KDE-Programmen (z.B. Konqueror, aber auch YAST2) sind die Schriften jetzt allerdings riesig. Viele Konfigurationsdialoge passen deshalb gar nicht richtig auf den Bildschirm.

Wenn ich im KDE-Kontrollzentrum die Schriftgröße verringere, verringern sich aber auch die Schriftgrößen z.B. im K-Menü (die ja richtig sind). Außerdem werden dann auch die Änderungen im gnome-control-center kaputt gemacht. Wenn ich dann die GTK-Einstellung in gnome wieder repariere, habe ich wieder das Problem mit den KDE-Schriftgrößen...

Wie komme ich denn aus diesem Kreis heraus? Und warum funktioniert das GTK-Panel im Kontrollzentrum nicht? Mein Ubuntu kann's doch auch :cry:

Danke,
thw
"Mein Computer ist so schnell, der schafft eine Endlosschleife in 3 Sekunden."
[Christian Guhl in ger.ct]

Against TCPA! TCPA bedeutet, Freiheit verlieren! http://www.againsttcpa.com

Werbung:
Benutzeravatar
gm2601
Hacker
Hacker
Beiträge: 775
Registriert: 4. Dez 2005, 11:53

Beitrag von gm2601 » 23. Mär 2006, 19:03

THW hat geschrieben:.....Habe daher einen anderen Tipp verfolgt und das gnome-Controlcenter installiert und dort die Schriftgrößen für GTK-Programme angepasst. Diesen gnome-settings-daemon hab' ich in KDE-Autostart gemacht......
:wink: Hmmm, kommt mir irgendwie bekannt vor und ich dachte man müsse sich daran nur gewöhnen, wenn man eine 10.1Alpha...jetzt Beta drauf hat. Sorry, war nicht das was Du erwartet hast...


Gruß nach Dräähsdn :wink:
gm2601

alley_cat
Newbie
Newbie
Beiträge: 16
Registriert: 1. Jun 2005, 15:20

Beitrag von alley_cat » 24. Mär 2006, 08:31

Also ich habe mal dasselbe Problem gehabt und folgendes festgestellt:

Die gtk-qt-Engine, die auf der Suse-DVD dabei ist läßt leider keinen Menüpunkt im Kontrollzentrum erscheinen. Keine Ahnung warum. Ich hoffe die kriegen das jetzt mal zur 10.1 hin.

Die Lösung ist einfach:
Ich habe einfach die gtk-qt-Engine von Guru direkt runtergeladen und installiert. Danach war der Menüpunkt auch da.

Übrigens hatte ich das schon einmal gepostet:
http://www.linux-club.de/viewtopic.php? ... highlight=

Benutzeravatar
Sven Bauduin
Hacker
Hacker
Beiträge: 503
Registriert: 9. Okt 2005, 13:10

Beitrag von Sven Bauduin » 24. Mär 2006, 08:57

Ich kann das genau so bestätigen. Habe die andere Fariante zwar nicht getestet,
aber mit der GTK-GT-Engine von Guru klappt's auf jeden fall und du kannst die
Schriftarten und die Schriftgrößes problemlos anpassen.

Gruß Sven

kettwiesel
Newbie
Newbie
Beiträge: 6
Registriert: 15. Mär 2006, 14:32

kaum weiss man wie es geht - ist alles so einfach !

Beitrag von kettwiesel » 28. Mär 2006, 18:28

kaum zu glauben aber wahr. das problem mit krakeligen
unleserlichen und zu kleinen schriften (fonts) begleitet mich
auf meiner linux reise seit suse 8.1. damals habe ich
nach langem suchen eine teilllösung für den browser mozilla
gefunden. (kann mich nur noch wage daran erinnern : eine
konfigurationsdatei userchrome.css musste im heimatverzeichniss
des users angelegt und editiert werden - argh)
seit einigen monaten benutze ich die suse 10.0 (super - slick - version ) und hatte nun gleich mehrere programme auf meinem
kde-desktop mit denen das arbeiten aufgrund schwer lesbarer
menu - schriften keinen spass machte (kynaptic, firefox, audacity,
streamtuner).
möglicherweise kann man die schriftarten und schriftgrössen dieser programme über ihre konfigurations-dateien einstellen,
aber z.B konnte ich nichts dergleichen in der .audacity config
datei finden. durch zufall bin ich eben auf diesen beitrag gestossen
und habe die anleitungen befolgt :
nach dem anlegen der "suser-guru" installationsquelle über yast
und dem installieren der gtk-qt-engine erschien im kde-kontrollzenter - erscheinungsbild -der gtk-button.
nach dem neustart des x-servers wurden die einstellungen
wirksam. alle oben erwähnten programme haben jetzt endlich
ein gut lesbares schriftbild.
VIELEN DANK !

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste