[gelöst] Aktualisierung „Liquid Weather

Alles rund um die möglichen Desktopumgebungen wie KDE, Gnome, XFCE usw. die es unter Linux gibt

Moderator: Moderatoren

Gesperrt
herbali
Hacker
Hacker
Beiträge: 260
Registriert: 2. Dez 2004, 17:09
Kontaktdaten:

[gelöst] Aktualisierung „Liquid Weather

Beitrag von herbali » 11. Mär 2006, 19:31

Beim Versuch Liquid Weather online zu aktualisieren, erhalte ich folgende Fehlermeldung.

> /temp/kde-herbali/ < kann nicht umbenannt werden. Bitte überprüfen sie die Berechtigung.

Wo und wie, muss ich was unternehmen, um diesen Anforderungen gerecht zu werden?

Danke für jeden Rat.
Zuletzt geändert von herbali am 16. Mär 2006, 23:17, insgesamt 2-mal geändert.
Linux 2.6.22.17-0.1-default i686, openSUSE 10.3, KDE:3.5.10, KDE 4.2 Devel, E17
"Die Lösung ist immer einfach, man muss sie nur finden."
Alexander Solschenizyn

Werbung:
tuxxland
Member
Member
Beiträge: 121
Registriert: 9. Sep 2005, 19:21
Wohnort: Krefeld

Beitrag von tuxxland » 11. Mär 2006, 20:19

...einfach auf die HP von LW gehen und dir die das neue LW runterladen...

Griffin
Guru
Guru
Beiträge: 3235
Registriert: 10. Mai 2005, 14:11
Kontaktdaten:

Beitrag von Griffin » 11. Mär 2006, 20:28

"Komm zur dunklen Seite, Luke. Hier gibt es Milch und Kekse!" - Darth Vader

Yoda: "Dunkel die andere Seite ist, Obi Wan"-"Sei still und iss endlich deinen Toast"

herbali
Hacker
Hacker
Beiträge: 260
Registriert: 2. Dez 2004, 17:09
Kontaktdaten:

Beitrag von herbali » 12. Mär 2006, 01:35

Griffin hat geschrieben:Sehe ich auch so:
http://www.linux-club.de/viewtopic.php?p=314655#314655
@tuxxland
@Griffin

Zitat tuxxland
...einfach auf die HP von LW gehen und dir die das neue LW runterladen...
______________________________________________________________________
Zitat Griffin
und dann starte es über Superkaramba => "Open Local Theme"
Das sollte dann gehen (ging zumindest bei mir).
________________________________________________________

Danke für die Tipps.

Leider geht das bei mir nicht so einfach. Liquid Weather 10.2.skz wird gestarte, lässt sich aber nicht konfigurieren.
Rätselhaft bei der Geschichte ist für mich, dass die Version lwp-9.3.2.skz voll konfigurierbar war,
wenn ich sie jetzt starte, können auch keine Einstellungen mehr vorgenommen werden.

M.f.G.
herbali

tuxxland
Member
Member
Beiträge: 121
Registriert: 9. Sep 2005, 19:21
Wohnort: Krefeld

Beitrag von tuxxland » 12. Mär 2006, 10:14

...denk daran: LWP braucht image magick (richtig geschrieben? müsste unter yast oder apt zu finden sein)...

viel Erfolg

Griffin
Guru
Guru
Beiträge: 3235
Registriert: 10. Mai 2005, 14:11
Kontaktdaten:

Beitrag von Griffin » 12. Mär 2006, 10:25

Bei mir geht es. Habe ich gerade getestet.

Prüf doch mal die Berechtigungen von diesem Ordner:
/home/DU/.superkaramba
Hier lagern afaik die Konfigurationen von Superkaramba und seinen Themes.
Hast du dort evtl. keine Schreibrechte?

Superkaramba 0.37 hast du, oder?
"Komm zur dunklen Seite, Luke. Hier gibt es Milch und Kekse!" - Darth Vader

Yoda: "Dunkel die andere Seite ist, Obi Wan"-"Sei still und iss endlich deinen Toast"

herbali
Hacker
Hacker
Beiträge: 260
Registriert: 2. Dez 2004, 17:09
Kontaktdaten:

Beitrag von herbali » 12. Mär 2006, 13:32

@tuxxland
@Griffin

Zitat tuxxland

..denk daran: LWP braucht image magick (richtig geschrieben? müsste unter yast oder apt zu finden sein)...

viel Erfolg
_________________
Antwort:
ImageMagick-6.2.3.-4.1 ist mit Yast installiert.
_________________________________________________________________________
Zitat Griffin

Bei mir geht es. Habe ich gerade getestet.

Prüf doch mal die Berechtigungen von diesem Ordner:
/home/DU/.superkaramba
Hier lagern afaik die Konfigurationen von Superkaramba und seinen Themes.
Hast du dort evtl. keine Schreibrechte?

Superkaramba 0.37 hast du, oder?
_______________________________________________________________________
Antwort:
Sperkaramba 0.37_1.0-2.guru suse 100.i686 ist installiert
Ordner: /homeDU/.superkaramba

Zugangsberchtigungen

Eigentümer Anzeige und Änderung des Inhalts möglich
Gruppe Anzeige und Änderung des Inhalts möglich
Sonstige Anzeige und Änderung des Inhalts möglich

Habe soweit alles überprüft, geht aber immer noch nicht.
LiquidWeather wird gestartet kann aber nicht kofiguriert werden.
Wer kennt das Problem und kann helfen?
danke

M.f.G.
herbali

tuxxland
Member
Member
Beiträge: 121
Registriert: 9. Sep 2005, 19:21
Wohnort: Krefeld

Beitrag von tuxxland » 12. Mär 2006, 20:11

da du doch kde 3.5. hast deinstalliere doch mal dein superkaramba von guru ,denn das ist doch sowieso bei kde dabei. vielleicht hilft das?

herbali
Hacker
Hacker
Beiträge: 260
Registriert: 2. Dez 2004, 17:09
Kontaktdaten:

Beitrag von herbali » 12. Mär 2006, 23:16

tuxxland hat geschrieben:da du doch kde 3.5. hast deinstalliere doch mal dein superkaramba von guru ,denn das ist doch sowieso bei kde dabei. vielleicht hilft das?
Zitat aus Yast
Geschützt:
Dieses Paket ist installiert und sollte nicht verändert werden, da unaufgelöste Abhängigkeiten zu anderen Paketen bestehen oder auftreten könnten. Verwenden Sie diesen Status für Pakete von Drittanbietern, die nicht von neueren, auf der Distribution vorhandenen Versionen überschrieben werden sollen.
Nach diesem Hinweis bin ich mir nicht sicher, ob Dein bestimmt gut gemeinter Rat die Lösung ist.
Vielleicht gibt es einen nicht ganz so radikalen Vorschlag, die Sache wieder zum laufen zu bringen.

M.f.G.
herbali

herbali
Hacker
Hacker
Beiträge: 260
Registriert: 2. Dez 2004, 17:09
Kontaktdaten:

Beitrag von herbali » 15. Mär 2006, 11:43

Habe das Paket Superperkaramba 0.37_1.0-2.guru suse 100.i686 nun doch deinstalliert.
Wenn ich Superkaramba 0.37 neu installieren will, erhalte ich diese Fehlermeldung.

linux:/home/herbali/Superkara/superkaramba-0.37/superkaramba # ./configure
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking target system type... i686-pc-linux-gnu
checking for a BSD-compatible install... /usr/bin/install -c
checking for -p flag to install... yes
checking whether build environment is sane... yes
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking for kde-config... /opt/kde3/bin/kde-config
checking where to install... /opt/kde3 (as returned by kde-config)
checking for style of include used by make... GNU
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
checking dependency style of gcc... gcc3
checking how to run the C preprocessor... gcc -E
checking for g++... no
checking for c++... no
checking for gpp... no
checking for aCC... no
checking for CC... no
checking for cxx... no
checking for cc++... no
checking for cl... no
checking for FCC... no
checking for KCC... no
checking for RCC... no
checking for xlC_r... no
checking for xlC... no
checking whether we are using the GNU C++ compiler... no
checking whether g++ accepts -g... no
checking dependency style of g++... none
checking whether gcc is blacklisted... no
checking whether g++ supports -Wmissing-format-attribute... no
checking whether gcc supports -Wmissing-format-attribute... yes
checking whether g++ supports -Wundef... no
checking whether g++ supports -Wno-long-long... no
checking whether g++ supports -Wno-non-virtual-dtor... no
checking how to run the C++ preprocessor... /lib/cpp
checking whether g++ supports -O0... no
checking whether g++ supports -Wl,--no-undefined... no
not using lib directory suffix
checking for a sed that does not truncate output... /usr/bin/sed
checking for egrep... grep -E
checking for ld used by gcc... /usr/i586-suse-linux/bin/ld
checking if the linker (/usr/i586-suse-linux/bin/ld) is GNU ld... yes
checking for /usr/i586-suse-linux/bin/ld option to reload object files... -r
checking for BSD-compatible nm... /usr/bin/nm -B
checking whether ln -s works... yes
checking how to recognise dependent libraries... pass_all
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking dlfcn.h usability... yes
checking dlfcn.h presence... yes
checking for dlfcn.h... yes
checking for g77... no
checking for f77... no
checking for xlf... no
checking for frt... no
checking for pgf77... no
checking for fort77... no
checking for fl32... no
checking for af77... no
checking for f90... no
checking for xlf90... no
checking for pgf90... no
checking for epcf90... no
checking for f95... no
checking for fort... no
checking for xlf95... no
checking for ifc... no
checking for efc... no
checking for pgf95... no
checking for lf95... no
checking for gfortran... no
checking whether we are using the GNU Fortran 77 compiler... no
checking whether accepts -g... no
checking the maximum length of command line arguments... 32768
checking command to parse /usr/bin/nm -B output from gcc object... ok
checking for objdir... .libs
checking for ar... ar
checking for ranlib... ranlib
checking for strip... strip
checking if gcc static flag works... yes
checking if gcc supports -fno-rtti -fno-exceptions... no
checking for gcc option to produce PIC... -fPIC
checking if gcc PIC flag -fPIC works... yes
checking if gcc supports -c -o file.o... yes
checking whether the gcc linker (/usr/i586-suse-linux/bin/ld) supports shared libraries... yes
checking whether -lc should be explicitly linked in... no
checking dynamic linker characteristics... GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking for shl_load... no
checking for shl_load in -ldld... no
checking for dlopen... no
checking for dlopen in -ldl... yes
checking whether a program can dlopen itself... yes
checking whether a statically linked program can dlopen itself... yes
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... no
configure: creating libtool
appending configuration tag "CXX" to libtool
checking whether the g++ linker (/usr/i586-suse-linux/bin/ld) supports shared libraries... yes
libtool.m4: error: problem compiling CXX test program
checking for g++ option to produce PIC...
checking if g++ supports -c -o file.o... no
checking whether the g++ linker (/usr/i586-suse-linux/bin/ld) supports shared libraries... yes
checking dynamic linker characteristics... GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking for shl_load... (cached) no
checking for shl_load in -ldld... (cached) no
checking for dlopen... (cached) no
checking for dlopen in -ldl... (cached) yes
checking whether a program can dlopen itself... (cached) yes
checking whether a statically linked program can dlopen itself... (cached) yes
appending configuration tag "F77" to libtool
checking for msgfmt... /usr/bin/msgfmt
checking for gmsgfmt... /usr/bin/msgfmt
checking for xgettext... :
checking if C++ programs can be compiled... no
configure: error: Your Installation isn't able to compile simple C++ programs.
Check config.log for details - if you're using a Linux distribution you might miss
a package named similar to libstdc++-dev.
linux:/home/herbali/Superkara/superkaramba-0.37/superkaramba # make
make: *** Keine Targets angegeben und keine »make«-Steuerdatei gefunden. Schluss.
linux:/home/herbali/Superkara/superkaramba-0.37/superkaramba #

Als Anfänger und des Englischen unkundiger, ersehe ich hier leider nicht, wo der Fehler liegt.
Was mache ich falsch?
Wer kann helfen?
danke
M.f.G.
herbali
Zuletzt geändert von herbali am 15. Mär 2006, 16:27, insgesamt 1-mal geändert.

Jelmo
Newbie
Newbie
Beiträge: 18
Registriert: 17. Apr 2005, 13:50

Beitrag von Jelmo » 15. Mär 2006, 13:46

hecking if C++ programs can be compiled... no

^^sieht irgendwie ganz danach aus als wenn der C++ Compiler nicht richtig funktioniert.

Nach dem neusten KDE Update ist Superkaramba nicht mehr mit dabei. Besorg dir das RPM von Guru. Dann via Yast installieren, wenns dann nicht klappt bekommst du wenigstens gesagt was ihm fehlt.

herbali
Hacker
Hacker
Beiträge: 260
Registriert: 2. Dez 2004, 17:09
Kontaktdaten:

Beitrag von herbali » 15. Mär 2006, 16:46

Jelmo hat geschrieben:hecking if C++ programs can be compiled... no

^^sieht irgendwie ganz danach aus als wenn der C++ Compiler nicht richtig funktioniert.

Nach dem neusten KDE Update ist Superkaramba nicht mehr mit dabei. Besorg dir das RPM von Guru. Dann via Yast installieren, wenns dann nicht klappt bekommst du wenigstens gesagt was ihm fehlt.
Der Tipp bringt mich leider nicht weiter, Superkaramba 0.37_1.0-2.guru suse 100.i686 habe
ich gerade deinstalliert, weil es damit Probleme gab.
(siehe die vorhergehenden Schreiben)
Das kde Update habe ich bereits gemacht, daher ist mir auch bekannt, dass Superkaramba nicht mehr dabei ist.
Ich frage:
Welches Paket (Version) von Superkaramba muss installiert sein, damit LiquidWeather mit allen Funktionen anwendbar ist?
Welche Pakete werden für Superkaramba zusätzlich benötigt?


M.f.G.
herbali

Jelmo
Newbie
Newbie
Beiträge: 18
Registriert: 17. Apr 2005, 13:50

Beitrag von Jelmo » 16. Mär 2006, 07:34

0.37 solltest du schon nehmen. Steht aber auch auf der LW Homepage.

ImageMagik brauchste --- stand hier aber auch schonmal

zusätzliche Pakete sind mir soweit nicht bekannt.

-wie oben aber schon erwähnt. Sieht nach dem Compiler aus. Installiere mal gcc und g++. Dann probier es mal aus.

tuxxland
Member
Member
Beiträge: 121
Registriert: 9. Sep 2005, 19:21
Wohnort: Krefeld

Beitrag von tuxxland » 16. Mär 2006, 08:09


Benutzeravatar
spezi
Hacker
Hacker
Beiträge: 756
Registriert: 19. Mai 2004, 12:24
Wohnort: die Stadt im Wald

Beitrag von spezi » 16. Mär 2006, 08:33

Guten Morgen,
superkaramba ist bei den kdeutils3-extra dabei.
Bei mir läuft allerdings die guru-Version, weil das kde-Sk Teile meiner Systemauskünfte nicht richtig anzeigt.

Code: Alles auswählen

 	
Habe das Paket Superperkaramba 0.37_1.0-2.guru suse 100.i686 nun doch deinstalliert.
Wenn ich Superkaramba 0.37 neu installieren will, erhalte ich diese Fehlermeldung.

linux:/home/herbali/Superkara/superkaramba-0.37/superkaramba # ./configure 
Warum ./configure, ein rpm Paket ?

mfg
spezi
Intel Pentium G2020 - MSI H61I-E35 B3, Samsung RV720, BR MFC-J4420CW, FRITZ!Box 7490, Syynology DS215j, oS 13.2/ 42.3, Raucher

herbali
Hacker
Hacker
Beiträge: 260
Registriert: 2. Dez 2004, 17:09
Kontaktdaten:

Beitrag von herbali » 16. Mär 2006, 15:46

@spezi,
zu Deiner Frage,
warum configure in einem rpm Paket?
Das Paket welches ich installieren wollte und von dem die Fehleranzeige beim Versuch der
Installation stammt, ist superkaramba-0.37.tar.gz
Habe dann kdeutilitis3-extra nochmal mit Synaptic installiert.
SuperKaramba gestartet.
LiquidWeather als neues Design heruntergeladen.
LW in SuperKaramba mit lokales Design öffnen, gestartet.
Ergebnis:
LiquidWeather läuft, lässt sich aber nicht konfigurieren.
Das bedeutet ich bin genau wieder da, wo ich begonnen habe.
Die guru Version hatte ich auch schon mit dem gleichen Ergebnis installiert.
Da muss bei mir der Wurm drin seien, ich komme einfach nicht weiter. Das eigenartige
ist, dass alles schon einwandfrei lief.
Mach einer Aktualisierung von LW startete es in englischer Sprache und die Kofiguration
war nicht mehr möglich. Glaube aber nicht, dass das der Ausschlaggebende Punkt war.
Denke eher dass es an irgendeinem Update liegt, leider kann ich nicht mehr nachvollziehen,
was da in letzter Zeit alles so ablief.
Schön, dass Du einen Rat gegeben hast.

@tuxxland, Jelmo, danke auch für Eure Beiträge,

M.f.G.
herbali
Linux 2.6.22.17-0.1-default i686, openSUSE 10.3, KDE:3.5.10, KDE 4.2 Devel, E17
"Die Lösung ist immer einfach, man muss sie nur finden."
Alexander Solschenizyn

Hollaender
Member
Member
Beiträge: 117
Registriert: 25. Feb 2006, 21:14

Beitrag von Hollaender » 16. Mär 2006, 19:27

Ok, ich hatte dieselbe Fehlermeldung: "Could not rename partial file /tmp/kde-derk/.
Please check permissions".

Jetzt klappt es aber! Du musst 2mal klicken im "SuperKaramba Theme" liquidweather++
Fenster. Dann wird's aktualisiert ohne Fehlermeldung.

Gr, Derk

herbali
Hacker
Hacker
Beiträge: 260
Registriert: 2. Dez 2004, 17:09
Kontaktdaten:

Beitrag von herbali » 16. Mär 2006, 20:29

Alles geklärt.
Superkaramba 0.37_1.0-2.guru suse 100.i686 neu installiert
Alles was bisher vorgeschlagen wurde, noch ein mal gemacht.
Beim durchsehen des Verzeichnis /home/user/.superkaramba/lwp/fade in der lwp_gui_config
den Fehler gesehen.
Die Ursache war, dass ich im Home -Verzeichnis den Ordner Icons, wie auch immer,
gelöscht hatte.
Den Ordner habe ich erstellt und die Themen neu geladen.
LiquidWeather lässt sich nun wieder konfigurieren.
Danke für die Beiträge
M.f.G.
herbali
Linux 2.6.22.17-0.1-default i686, openSUSE 10.3, KDE:3.5.10, KDE 4.2 Devel, E17
"Die Lösung ist immer einfach, man muss sie nur finden."
Alexander Solschenizyn

Gesperrt

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast