Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

beagle und mono

Alles rund um die möglichen Desktopumgebungen wie KDE, Gnome, XFCE usw. die es unter Linux gibt

Moderator: Moderatoren

Antworten
Benutzeravatar
lariamat
Member
Member
Beiträge: 65
Registriert: 20. Dez 2004, 11:59
Wohnort: Berlin

beagle und mono

Beitrag von lariamat » 31. Dez 2005, 14:50

Hallo
Ich stelle die beagle-Frage mal in diesem Forum, weil beagle ja zu gnome gehört und es sonst kein passenderes Forum gibt.

Also:
Hab dummerweise ein update für mono aus dem apt-repository gnome gezogen. Danach war beagle im eimer. Hab wieder zur vorherigen mono-version downgegradet
Der Beagle Deamon läuft, aber best (GUI für beagle) startet nicht.
Hab in der Konsole best eingegeben. Dann kommt:

Code: Alles auswählen

** (/usr/lib/beagle/Best.exe:6834): WARNING **: The following assembly referenced from /usr/lib/mono/gac/gecko-sharp/2.0.0.0__ccf7d78a55e9f021 /gecko-sharp.dll could not be loaded:
     Assembly:   gtk-sharp    (assemblyref_index=2)
     Version:    2.8.0.0
     Public Key: 35e10195dab3c99f
The assembly was not found in the Global Assembly Cache, a path listed in the MONO_PATH environment variable, or in the location of the execut ing assembly (/usr/lib/mono/gac/gecko-sharp/2.0.0.0__ccf7d78a55e9f021).


** (/usr/lib/beagle/Best.exe:6834): WARNING **: The class Gtk.Bin could not be loaded, used in /usr/lib/mono/gac/gecko-sharp/2.0.0.0__ccf7d78a 55e9f021/gecko-sharp.dll (token 0x0100000e)

** ERROR **: file class.c: line 2119 (mono_class_setup_parent): should not be reached
aborting...
Abgebrochen

In dem Verzeichnis /usr/lib/mono/gac/gecko-sharp/2.0.0.0__ccf7d78a55e9f021 liegt die fragliche dll und dazu eine gleichnamige dll.config. Sie enthält den folgenden Text:

Code: Alles auswählen

<configuration>
  <dllmap dll="libglib-2.0-0.dll" target="libglib-2.0.so.0"/>
  <dllmap dll="libgobject-2.0-0.dll" target="libgobject-2.0.so.0"/>
  <dllmap dll="libatk-1.0-0.dll" target="libatk-1.0.so.0"/>
  <dllmap dll="libgtk-win32-2.0-0.dll" target="libgtk-x11-2.0.so.0"/>
  <dllmap dll="gtkembedmoz.dll" target="libgtkembedmoz.so"/>
</configuration>

Ich hab leider keinen Plan was ich mit der MONO_PATH Umgebungsvariable anstellen soll oder was es mit dem assembly auf sich hat.

Kann mir jemand weiterhelfen?
Wär super!
Danke


uname -a: Linux linux 2.6.13-15.7-default #1 Tue Nov 29 14:32:29 UTC 2005 i686 i686 i386 GNU/Linux

suse 10.0, gnome, glib2-2.8.1-3, mono-1.1.8.3-6, monodoc

Werbung:
Benutzeravatar
lariamat
Member
Member
Beiträge: 65
Registriert: 20. Dez 2004, 11:59
Wohnort: Berlin

Beitrag von lariamat » 31. Dez 2005, 15:19

Ok, Sorry. Hab die Antwort selber gefunden.
Aber vielleicht hat jemand anderes ja auch mal das Problem. Dann kann er hier die Lösung finden.

Es funktioniert wieder mit der Version 0.10-7 von gecko-sharp2.
smart hat bei meinem mono-Ausflug gecko-sharp2 auf eine neuere Version upgedated. Die funzte nicht

Grüße

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste