[gelöst] ~/.Xmodmap wird beim X-Serverstart nicht geladen

Alles rund um die möglichen Desktopumgebungen wie KDE, Gnome, XFCE usw. die es unter Linux gibt

Moderator: Moderatoren

Antworten
Falkenstein
Hacker
Hacker
Beiträge: 510
Registriert: 14. Mai 2005, 18:35
Kontaktdaten:

[gelöst] ~/.Xmodmap wird beim X-Serverstart nicht geladen

Beitrag von Falkenstein » 30. Dez 2005, 20:22

Hi!
Ich hab unter Opensuse 10.0 die .Xmodmap im User-Home angepasst, wie unter SuSE 9.3 auch schon.
Nur wird die Datei nicht automatisch beim X-Serverstart geladen, man muss sie zu Fuss laden.
xmodmap .Xmodmap
KDE ist 3.5.0a.
KHotkeys hab ich bereits probehalber deaktiviert - ohne Erfolg.
Die Änderungen habe ich ebenfalls in der /etc/X11/Xmodmap vorgenommen.
Was mach ich falsch?


!!
!! Xmodmap: Some Settings for a Intel based PC and keyboard
!!
!! Note: the scan codes of the keys (keycode) used here
!! are specific for PC and compatible keyboards.
!!
!! by werner 1993, 1997-99

!!
!! Backarrow key is symbol BackSpace
!! Modifiers for backarrow key
!! Shift-BS is Symbol BackSpace
!! Alt-BS is Symbol DeleteWord
!! Remove key is Symbol Delete
!!
keycode 22 = BackSpace Terminate_Server
keycode 107 = Delete

!!
!! Right control key is Control or, if shifted, Compose
!!
remove control = Control_R
keycode 109 = Control_R Multi_key
add control = Control_R

!!
!! WIN95 keys: WIN left and WIN right
!! we overwrite Meta_L and Meta_R or Multi_key
!! to avoid confusion with older keyboards.
!!
clear mod4
keycode 115 = Super_L
keycode 116 = Super_R Multi_key
add mod4 = Super_L Super_R

!!
!! and WIN menu
!!
keycode 117 = Menu

!! keycode 91 = KP_Delete comma
!! keycode 227 = F13
!! keycode 223 = F14
!! keycode 222 = F15


keycode 162 = F13
keycode 164 = F14
keycode 237 = F15
keycode 236 = F16
keycode 235 = F17
keycode 174 = F18
keycode 176 = F19
Aus /etc/X11/xorg.conf
Section "InputDevice"
Driver "kbd"
Identifier "Keyboard[0]"
Option "Protocol" "Standard"
Option "XkbLayout" "de,de,gb,us"
Option "XkbModel" "pc105"
Option "XkbOptions" "grp:alt_shift_toggle"
Option "XkbRules" "xfree86"
Option "XkbVariant" "xfree86"
EndSection
Zuletzt geändert von Falkenstein am 2. Jan 2006, 22:47, insgesamt 1-mal geändert.

Werbung:
xapient
Member
Member
Beiträge: 140
Registriert: 25. Mai 2004, 13:35

Beitrag von xapient » 2. Jan 2006, 15:48

beim xserver start sollte diese doch auch noch nicht geladen sein .. erst wenn du dich als user eingeloggt hast.. oder nicht?

wenn du eine dauerhafte systemweite änderung durchführen willst empfehl ich dir von der modmap abzusehen und es SO zu machen.. (viele wege führen nach rom - auch das ist nur einer davon...)

http://www.pc-portal.at/useraction.php? ... ostid=6423

mfg
xape
..die ursache für die meisten computerprobleme ist ca. 60 cm vor dem bildschirm zu finden...
__________
http://xapient.net
http://proxy.xapient.net

Benutzeravatar
mada
Hacker
Hacker
Beiträge: 570
Registriert: 22. Sep 2004, 20:38
Wohnort: Freiburg i.Brsg.
Kontaktdaten:

Beitrag von mada » 2. Jan 2006, 19:50

die Xmodmap wird PER DEFAULT nirgends nicht geladen bei SuSE. Am einfachsten schreibst Du ein Skript nach ~/bin/loadXmodmap mit dem Du manuell die Xmodmap lädst und verlinkst dieses Skript in den Autostartordner von KDE (ich gehe mal davon aus, dass Du KDE verwendest, wenn nicht dann den entsprechenden Automatismus Deiner DE/WM verwenden):
ln -s ~/bin/loadXmodmap ~/.kde/Autostart/
*Evidently, one is not going to be able to build a castle of blocks unless the blocks are a good deal smaller than the castle - E. Hecht

Falkenstein
Hacker
Hacker
Beiträge: 510
Registriert: 14. Mai 2005, 18:35
Kontaktdaten:

Beitrag von Falkenstein » 2. Jan 2006, 20:38

Danke für die Antwort.
Seit SuSE 10.0 hab ich mal das Automatische Login aktiviert.
Daher.
Bei 9.3 musste ich mich von Hand einloggen, da wurde die Xmodmap dann auch geladen.
Ich habs jetzt im Autostart.
madas Lösung klappt bestens.

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast