Suse 10.0 mit KDE 3.5 will nicht (CXXABI_1.3.1 not found)

Alles rund um die möglichen Desktopumgebungen wie KDE, Gnome, XFCE usw. die es unter Linux gibt

Moderator: Moderatoren

Antworten
chaos2000
Newbie
Newbie
Beiträge: 4
Registriert: 19. Dez 2005, 09:16

Suse 10.0 mit KDE 3.5 will nicht (CXXABI_1.3.1 not found)

Beitrag von chaos2000 » 19. Dez 2005, 09:21

Hallo,

ich habe gestern von Suse 9.2 auf die 10.0 upgedatet und auch gleich die aktulle KDE 3.5 aufgespielt.
Leider bekomme ich eine problem beim öffenen von programmen (z.b. kmail, Konqueror, ...):
Es ist ein Fehler beim Laden von Modul Über Konqueror aufgetreten.
Die vermutliche Ursache ist:
/usr/local/lib/libstdc++.so.6: version `CXXABI_1.3.1' not found (required by /opt/kde3/lib/libkhtml.so.4)
Hat jemand eine Idee was ich falsch gemacht habe? Mit Suse 9.2 funktionierte KDE 3.5 noch super.

THX

Werbung:
Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 19. Dez 2005, 11:47

apt search CXXABI_1.3.1
libstdc++ - The standard C++ shared library
pm -q libstdc++
libstdc++-4.0.2_20050901-3
rpm -ql libstdc++
/usr/lib/libstdc++.so.6
/usr/lib/libstdc++.so.6.0.6
/usr/share/locale/de/LC_MESSAGES/libstdc++.mo
/usr/share/locale/fr/LC_MESSAGES/libstdc++.mo
dann solltest du mal die libstdc++ installieren
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

chaos2000
Newbie
Newbie
Beiträge: 4
Registriert: 19. Dez 2005, 09:16

Beitrag von chaos2000 » 19. Dez 2005, 11:56

danke oc2pus,

... aber die libstdc++ ist installiert:
rpm -ql libstdc++

/usr/lib/libstdc++.so.6
/usr/lib/libstdc++.so.6.0.6
/usr/share/locale/de/LC_MESSAGES/libstdc++.mo
/usr/share/locale/fr/LC_MESSAGES/libstdc++.mo

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 19. Dez 2005, 12:01

hm, strange ;)

prüfe mal:

Code: Alles auswählen

rpm -q --provides libstdc++
libstdc++.so.6
libstdc++.so.6(CXXABI_1.3)
libstdc++.so.6(CXXABI_1.3.1)
libstdc++.so.6(GLIBCXX_3.4)
libstdc++.so.6(GLIBCXX_3.4.1)
libstdc++.so.6(GLIBCXX_3.4.2)
libstdc++.so.6(GLIBCXX_3.4.3)
libstdc++.so.6(GLIBCXX_3.4.4)
libstdc++.so.6(GLIBCXX_3.4.5)
libstdc++.so.6(GLIBCXX_3.4.6)
libstdc++.so.6(libstdc++.so.6)
libstdc++ = 4.0.2_20050901-3
wenn deine libstdc++ das gleiche auswirft, dann hilft ein Aufruf von /sbin/ldconfig als root in einer Konsole vielleicht weiter...
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 19. Dez 2005, 12:06

/usr/local/lib/libstdc++.so.6: version `CXXABI_1.3.1' not found (required by /opt/kde3/lib/libkhtml.so.4)
Kommando zurück ;)
du hast ein selbstcompiliertes Programm am Start ? oder warum sucht dieses in /usr/local/lib ? die gibt es in der Tat nicht :)
evtl steht in /usr/local/lib noch eine alte Version von libstdc++ rum ?

eine schnelle Lösung wäre ein symbolischer link von libstdc++.so.6 nach /usr/local/lib
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

chaos2000
Newbie
Newbie
Beiträge: 4
Registriert: 19. Dez 2005, 09:16

Beitrag von chaos2000 » 19. Dez 2005, 12:35

danke für den tipp;

ldconfig habe ich auch schon probiert - hat nichts gebracht;
selbstcompiliertes Programm sind nicht am start
die libstdc++.so.6 ist sowohl in /usr/lib als auch /usr/local/lib *gr*
ls /usr/lib |grep libstdc++
libstdc++-3-libc6.1-2-2.10.0.so
libstdc++-3-libc6.2-2-2.10.0.so
libstdc++.a
libstdc++.la
libstdc++-libc6.1-1.so.2
libstdc++-libc6.1-2.so.3
libstdc++-libc6.2-2.so.3
libstdc++.so
libstdc++.so.2.7.2
libstdc++.so.2.7.2.8
libstdc++.so.2.8
libstdc++.so.2.8.0
libstdc++.so.2.9
libstdc++.so.2.9.0
libstdc++.so.5
libstdc++.so.5.0.7
libstdc++.so.6
libstdc++.so.6.0.6
ls /usr/local/lib |grep libstdc++
libstdc++.a
libstdc++.la
libstdc++.so
libstdc++.so.6
libstdc++.so.6.0.1
Zuletzt geändert von chaos2000 am 19. Dez 2005, 12:37, insgesamt 1-mal geändert.

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 19. Dez 2005, 12:36

chaos2000 hat geschrieben:danke für den tipp;

ldconfig habe ich auch schon probiert - hat nichts gebracht;
selbstcompiliertes Programm sind nicht am start
die libstdc++.so.6 ist sowohl in /usr/lib als auch /usr/local/lib *gr*
dann lösche die in /usr/local/lib mal. Diese wird zuerst gefunden und passt nicht zum Rest ...
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

chaos2000
Newbie
Newbie
Beiträge: 4
Registriert: 19. Dez 2005, 09:16

Beitrag von chaos2000 » 19. Dez 2005, 12:43

DANKE oc2pus,

das löschen hats gebracht; KDE neu gestartet und schon geht alles.

Danke noch mal.
Problem solved

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast