[gelöst] Unerwünschter xscreensaver: Wie deaktivieren?

Alles rund um die möglichen Desktopumgebungen wie KDE, Gnome, XFCE usw. die es unter Linux gibt

Moderator: Moderatoren

Antworten
gameboy
Hacker
Hacker
Beiträge: 794
Registriert: 5. Aug 2005, 10:27
Wohnort: Hessen / MKK

[gelöst] Unerwünschter xscreensaver: Wie deaktivieren?

Beitrag von gameboy » 14. Dez 2005, 23:37

Hallo zusammen,

obwohl ich den KDE-Bildschirmschoner abgeschaltet habe, wird auf meinem System (Suse 9.3/KDE 3.4.1) regelmäßig ein Screensaver gestartet, der eine Art Slideshow anzeigt. Dies würde ich gern unterbinden. Nach einiger Suche hier im Forum bin ich darauf gekommen, daß der von mir unerwünschter Prozeß namens 'xscreensaver' dafür verantwortlich ist:

Code: Alles auswählen

~> ps -ef | grep xscreen | grep -v grep
td        6766     1  0 Dec03 ?        00:00:29 xscreensaver -nosplash
Ich suche jetzt schon fast seit einer Stunde nach der Stelle (Config-Datei), wo dieser Prozeß gestartet wird. Mit Google findet man allerhand Tips, die Config-Dateien benennen, in denen sich der Aufruf befinden könnte - alles Fehlanzeige, da diese Dateien auf meinem System leider nicht existieren. Genausowenig gibt es bei mir die Datei $HOME/GNUstep/Defaults/WindowMaker (siehe Tip in Beitrag http://www.linux-club.de/viewtopic.php?t=30746#162846).

Was ich ansonsten bereits erfolglos probiert habe:

Code: Alles auswählen

grep -r xscreensaver /etc/*
grep -r xscreensaver $HOME/.[a-zA-Z]*
grep xscreensaver /var/log/boot.msg
Natürlich könnte ich xscreensaver einfach deinstallieren, aber ich möchte mir eigentlich nicht die Möglichkeit nehmen, ihn später einmal zu verwenden. Nur im Moment wäre es mir halt lieber, das Teil wäre deaktiviert.

Gibt es irgendjemanden, der dieses Problem schon gelöst hat?
Zuletzt geändert von gameboy am 29. Dez 2005, 19:03, insgesamt 1-mal geändert.

Werbung:
Benutzeravatar
Pilz
Member
Member
Beiträge: 199
Registriert: 12. Mai 2005, 17:46
Wohnort: Heinsberg

Beitrag von Pilz » 15. Dez 2005, 00:04

Den xscreensaver kannst du über die Konsole mit dem Befehl

Code: Alles auswählen

xscreensaver-demo
konfigurieren. Meintest du das?

Grüße
Stefan
Jeder Tag ist 24 Stunden lang, aber unterschiedlich breit!

gameboy
Hacker
Hacker
Beiträge: 794
Registriert: 5. Aug 2005, 10:27
Wohnort: Hessen / MKK

Beitrag von gameboy » 15. Dez 2005, 00:18

Hallo Pilz,

danke für die schnelle Antwort.

Hm, es gibt in dem Fenster, welches 'xscreensaver-demo' aufruft, im File-Menü einen Punkte 'Kill Daemon'. Leider bin ich mir nicht ganz sicher, was da passiert... - Wird der Prozeß einfach nur abgeschossen, so als wenn ich auf der Konsole 'kill <pid>' eingeben würde? Oder wird dafür gesorgt, daß der Prozeß auch bei zukünftigen Systemstarts (d.h. nach einem Reboot) nicht mehr aktiviert wird?

Bei einem Klick auf 'Help' --> 'Documentation' kommt übrigens die Fehlermeldung: 'sh: kelcenter: command not found', so daß ich das leider nicht nachlesen kann...

gameboy
Hacker
Hacker
Beiträge: 794
Registriert: 5. Aug 2005, 10:27
Wohnort: Hessen / MKK

Beitrag von gameboy » 29. Dez 2005, 14:07

gameboy hat geschrieben:Hm, es gibt in dem Fenster, welches 'xscreensaver-demo' aufruft, im File-Menü einen Punkte 'Kill Daemon'. Leider bin ich mir nicht ganz sicher, was da passiert... - Wird der Prozeß einfach nur abgeschossen, so als wenn ich auf der Konsole 'kill <pid>' eingeben würde? Oder wird dafür gesorgt, daß der Prozeß auch bei zukünftigen Systemstarts (d.h. nach einem Reboot) nicht mehr aktiviert wird?
Nach längerer Zeit habe ich meinen Rechner jetzt doch mal wieder neu gestartet. - Ergebnis: Der automatische Start von xscreensaver ist immer noch vorhanden, das Problem ist also nach wie vor ungelöst.

Über meine diversen Versuche, die Ursache für die automatische Aktivierung des Screensavers zu finden, habe ich ja oben bereits berichtet. Leider gibt es bisher keine Fortschritte zu vermelden... :(

Benutzeravatar
Pilz
Member
Member
Beiträge: 199
Registriert: 12. Mai 2005, 17:46
Wohnort: Heinsberg

Beitrag von Pilz » 29. Dez 2005, 14:40

Hej gameboy

Jetzt weiß ich auch woher du die Option "kill daemon" hast. Man sollte das File nicht überlesen. :oops:
Hast du denn auch in der Karteikarte Display Modes bei der Option Mode "Disable Screen Saver" ausgewählt. Wenn ich bei mir diese Option nicht gewählt habe, dann läuft der Daemon bzw. der Screensaver bei mir auch nach jedem Neustart wieder.

Grüße
Stefan
Jeder Tag ist 24 Stunden lang, aber unterschiedlich breit!

xsession-errors

Beitrag von xsession-errors » 29. Dez 2005, 15:15

Ja, mich ärgert das auch voll das wenn man einen SuSE-Linux Computer benutzt aber nicht KDE als WM das nach einer Viertelstunde der Monitor schwarz wird man aber nichts dagegen machen kann. Ich hatte sogar mir deswegen den Kofler geholt, aber da stand keine Lösung drin. SuSE Linux bevormundet User das Monitore ausgehen müssen und bietet keine Optionen das abzustellen. :(

Traurige Welt! :cry:
Zuletzt geändert von xsession-errors am 29. Dez 2005, 15:21, insgesamt 1-mal geändert.

Benutzeravatar
Pilz
Member
Member
Beiträge: 199
Registriert: 12. Mai 2005, 17:46
Wohnort: Heinsberg

Beitrag von Pilz » 29. Dez 2005, 15:19

Hej xsession-errors
SuSE Linux bevormundet User das Monitore ausgehen müssen und bietet keine Optionen das abzustellen.
Dem kann ich dir nur wiedersprechen. Gerade unter Linux kann man alle Einstellungen vornehmen, die man nur möchte. Vielleicht solltest du dich mal etwas mehr mit der Konsole beschäftigen und nicht nur auf die grafische Oberfläche vertrauen.

Grüße
Stefan
Jeder Tag ist 24 Stunden lang, aber unterschiedlich breit!

xsession-errors

Beitrag von xsession-errors » 29. Dez 2005, 15:26

Pilz hat geschrieben:Dem kann ich dir nur wiedersprechen. Gerade unter Linux kann man alle Einstellungen vornehmen, die man nur möchte. Vielleicht solltest du dich mal etwas mehr mit der Konsole beschäftigen und nicht nur auf die grafische Oberfläche vertrauen.
Prinzipiel gebe ich dir ja recht, aber was ist wenn man den Wald vor lauter Bäumen nicht sieht? Wenn man schon lange nicht mehr die Millionen optionen im Überblick hat und man sich schon Tagelang mit dem Problem beschäftigt hat, das der Monitor ausgeht, man sich teure Fach-Bücher gekauft hat, gegooglet, manpages gelesen... aber trotzdem wird der Monitor schwarz obwohl man dies nicht wünscht. Es ist ja toll alle Möglichkeiten zu haben, aber welche bringt einen zum Ziel...? :roll:

Benutzeravatar
Pilz
Member
Member
Beiträge: 199
Registriert: 12. Mai 2005, 17:46
Wohnort: Heinsberg

Beitrag von Pilz » 29. Dez 2005, 15:29

aber welche bringt einen zum Ziel...?
Prog schreiben, welches den screensaver-daemon killt, ins autostartverzeichniss.. fertig.

edit-----------
Du kannst das screensaver-prog aber auch einfach deinstallieren.
/edit----------
Jeder Tag ist 24 Stunden lang, aber unterschiedlich breit!

xsession-errors

Beitrag von xsession-errors » 29. Dez 2005, 15:58

Pilz hat geschrieben:Prog schreiben, welches den screensaver-daemon killt, ins autostartverzeichniss.. fertig.
Ja, ich habe zwar 5 Anwenderbücher über Linux, aber ein C++ Buch war da nicht bei. Gute Idee, Programm schreiben. Dann werde ich allein mit den Grundlagen des Programmierens jetzt 3 Jahre beschäftigt sein und in 5 Jahren vielleicht fähig sein, zu verhindern das der Bildschirm schwarz wird.

Echt voll die nette Hilfe, ein grosses DANKE.

Benutzeravatar
Pilz
Member
Member
Beiträge: 199
Registriert: 12. Mai 2005, 17:46
Wohnort: Heinsberg

Beitrag von Pilz » 29. Dez 2005, 16:12

Echt voll die nette Hilfe, ein grosses DANKE.
Sorry xsession-errors,
aber deine Postings sahen bisher nicht danach aus, als ob du Hilfe haben möchtest, sondern eher, als daß du einfach nur mal deinem Frust Luft machen wolltest. Wenn du Hilfe haben möchtest, dann solltest du mal dein Problem genau beschreiben, was du zu deinem Prob schon herausgefunden hast und welche Distri du hast. Sonst kann dir schlecht jemand helfen. Also, du bist an der Reihe.... mach was draus.

Grüße
Stefan
Jeder Tag ist 24 Stunden lang, aber unterschiedlich breit!

xsession-errors

Beitrag von xsession-errors » 29. Dez 2005, 16:18

Pilz hat geschrieben:
Echt voll die nette Hilfe, ein grosses DANKE.
Sorry xsession-errors,
aber deine Postings sahen bisher nicht danach aus, als ob du Hilfe haben möchtest, sondern eher, als daß du einfach nur mal deinem Frust Luft machen wolltest. Wenn du Hilfe haben möchtest, dann solltest du mal dein Problem genau beschreiben, was du zu deinem Prob schon herausgefunden hast und welche Distri du hast. Sonst kann dir schlecht jemand helfen. Also, du bist an der Reihe.... mach was draus.

Grüße
Stefan
Also ich benutze opensuse Linux 10.0 mit Fenstermanager enlightenment 16.999, aber das der Bildschirm schwarz wird passiert auch mit Windowmaker. Da kann man gar nichts tun ausser programmieren lernen?
Ich weiss dann aber nicht ob Linux da richtige ist - warum kann man das nicht einfach abschalten in dem man in irgendeiner conf datei das auskommentiert? Ist diese conf Datei geheim?

gameboy
Hacker
Hacker
Beiträge: 794
Registriert: 5. Aug 2005, 10:27
Wohnort: Hessen / MKK

Beitrag von gameboy » 29. Dez 2005, 19:02

Hallo Pilz,
Pilz hat geschrieben:Hast du denn auch in der Karteikarte Display Modes bei der Option Mode "Disable Screen Saver" ausgewählt. Wenn ich bei mir diese Option nicht gewählt habe, dann läuft der Daemon bzw. der Screensaver bei mir auch nach jedem Neustart wieder.
nein, bisher nicht - diese Option hatte ich wohl vollständig übersehen!

VIELEN DANK! Das ist die Lösung.

Benutzeravatar
Pilz
Member
Member
Beiträge: 199
Registriert: 12. Mai 2005, 17:46
Wohnort: Heinsberg

Beitrag von Pilz » 29. Dez 2005, 19:22

@ gameboy
Na also, geht doch.... :D

@xsession-errors

Mal sehen ob ich dir helfen kann. Ich hab zwar keine Erfahrung mit enlightenment und dem windowmanager, aber schaun ma mal. Erstmal wollen wir sehen, ob bei dir auch der xscreensaver läuft.
Dazu gibst du mal bitte

Code: Alles auswählen

ps ax
in der Konsole ein und postes mal die Ausgabe.

edit--------------
Im übrigen ist es nicht schwer ein kleines Shellscript zu schreiben. Als Beispiel um den xscreensaver-daemon zu killen sieht das folgendermaßen aus:

Code: Alles auswählen

#! /bin/sh
xscreensaver-command -exit
/edit-------------
Jeder Tag ist 24 Stunden lang, aber unterschiedlich breit!

xsession-errors

Beitrag von xsession-errors » 29. Dez 2005, 22:32

Pilz hat geschrieben:@ gameboy
Na also, geht doch.... :D

@xsession-errors

Mal sehen ob ich dir helfen kann. Ich hab zwar keine Erfahrung mit enlightenment und dem windowmanager, aber schaun ma mal. Erstmal wollen wir sehen, ob bei dir auch der xscreensaver läuft.
Dazu gibst du mal bitte

Code: Alles auswählen

ps ax
in der Konsole ein und postes mal die Ausgabe.

edit--------------
Im übrigen ist es nicht schwer ein kleines Shellscript zu schreiben. Als Beispiel um den xscreensaver-daemon zu killen sieht das folgendermaßen aus:

Code: Alles auswählen

#! /bin/sh
xscreensaver-command -exit
/edit-------------
Diesen String hab ich dann auch gefunden, weil dieser Thread mich erst daraufgebracht wo man eigentlich suchen muss und nu hab ich das prob (feature) in Griff.

Danke für die Hilfe 8)

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste