[gelöst] · configure meckert: KDE-libs not installed

Alles rund um die möglichen Desktopumgebungen wie KDE, Gnome, XFCE usw. die es unter Linux gibt

Moderator: Moderatoren

Antworten
Falkenstein
Hacker
Hacker
Beiträge: 510
Registriert: 14. Mai 2005, 18:35
Kontaktdaten:

[gelöst] · configure meckert: KDE-libs not installed

Beitrag von Falkenstein » 22. Sep 2005, 09:54

linux:/usr/local/src/kpopup-0.9.8.2 # ./configure --prefix=/opt/kde3
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking target system type... i686-pc-linux-gnu
...
...
...
checking for uic... /usr/lib/qt3/bin/uic
checking whether uic supports -L ... yes
checking whether uic supports -nounload ... yes
yes
checking for rpath... yes
checking for KDE... configure: error:
in the prefix, you've chosen, are no KDE libraries installed. This will fail.
So, check this please and use another prefix!
System ist SuSE-9.3 mit KDE 3.4.2 per Smart(apt) upgedatet.
linux:/ # smart install kdelibs3-3.4.2-25@i586
Loading cache...
Updating cache... ################################################################################# [100%]

warning: kdelibs3-3.4.2-25@i586 is already installed
Computing transaction...
linux:/# smart install kdelibs3-devel-3.4.2-25@i586
Loading cache...
Updating cache... ################################################################################# [100%]

Computing transaction... error: Can't install kdelibs3-devel-3.4.2-25@i586: no package provides kdelibs3-arts
Was soll mir das sagen?
Laut YaST sind kdelibs und kdelibs-devel installiert.
Zuletzt geändert von Falkenstein am 24. Sep 2005, 08:43, insgesamt 2-mal geändert.

Werbung:
Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 22. Sep 2005, 10:07

tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

Falkenstein
Hacker
Hacker
Beiträge: 510
Registriert: 14. Mai 2005, 18:35
Kontaktdaten:

Beitrag von Falkenstein » 22. Sep 2005, 11:03

Ja, das hab ich gelesen.
brauch ich denn arts dafür?
Der compiler meckert ja, das die libs fehlen.
Wie erstell ich denn ein virtuelles rpm?
So von kdelibs-arts nach kdelibs-artsd?

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 22. Sep 2005, 11:05

tuxx hat geschrieben:Wie erstell ich denn ein virtuelles rpm?
steht ganz gross und fett in der HowTo Übersicht:
[HOWTO] Wie erstelle ich ein virtuelles RPM Paket ?
http://www.linux-club.de/viewtopic.php?t=13336

Manchmal frage ich mich wirklich warum ich solche Übersichten erstelle ;(
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

Falkenstein
Hacker
Hacker
Beiträge: 510
Registriert: 14. Mai 2005, 18:35
Kontaktdaten:

Beitrag von Falkenstein » 22. Sep 2005, 11:26

Sorry. Da hab ich nun grad mal nicht geschaut.
Wurstel mich grad durch die kdelibs-3.4.91
Auch nicht besser.
linux:/usr/local/src/kdelibs-3.4.91 # ./configure --prefix=/opt/kde3
...
...
...
You're missing Apple mDNSResponder 85 or later, therefore
dnssd will be compiled as stub, without any real functionality.
If you want zeroconf support (www.zeroconf.org), you should install mDNSResponder first.
See dnssd/INSTALL for details.

You're missing GSSAPI/Kerberos.
KDE can use GSSAPI/Kerberos to authenticate on certain secure websites.
GSSAPI/Kerberos authentication is typically used on intranets.

Your libaspell is too old or not installed, I couldn't find aspell.h.
You must download aspell >= 0.50.2, see http://aspell.net
Spell-checking with libaspell will not be available, only with ispell dicts.

The development package of Hspell is not installed, I couldn't find hspell.h.
Spell-checking Hebrew with libhspell will not be available.
If you need it, install hspell >= 0.9 from sources
see http://www.ivrix.org.il/projects/spell-checker/
or from packages your distribution provides.

You're missing openSSL, or your version is too old (before 0.9.5a).
KDE won't be able to access secure websites without it, so you should
consider installing or upgrading it.
Have a look at http://www.openssl.org, or find a binary package for
your platform.

You're missing libjpeg 6 or later.
KDE won't be able to display JPEG and many web pages won't
work because of this.
You may need to either provide correct --with-extra-... options,
or the development package of libjpeg6b. You can get a source
package of libjpeg from http://www.ijg.org/

You're missing CUPS (Common UNIX Printing System) support.
If you want CUPS support, please install CUPS from http://www.cups.org
or the development packages of your distribution.

No OpenEXR Libraries were found
Install the OpenEXR package (from http://www.openexr.org)
if you want EXR image format support

libacl was not found. Without that library, you will not be able
to manage access control lists on file systems that support them,
such as ext3 or reiserfs.
linux:~ # smart install aspell openSSL libjpeg6 libacl
Loading cache...
Updating cache... ################################################################################# [100%]

warning: aspell-0.60.2-3@i586 is already installed
warning: openssl-0.9.7e-3@i586 is already installed
warning: libjpeg-6.2.0-738@i586 is already installed
warning: libacl-2.2.30-3@i586 is already installed
Computing transaction...
Ist doch zum Verzweifeln.
Spinnt KDE jetzt völlig?

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 22. Sep 2005, 11:45

und auch das zum 1000mal: wenn du Programme selber compilieren willst, brauchst du die korrespondierenden devel-pakete :)

also cups-devel, openssh-devel, .... und diese brauchen dann wiederum andere Pakete. Böse Gesellen aber auch 8)
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

Falkenstein
Hacker
Hacker
Beiträge: 510
Registriert: 14. Mai 2005, 18:35
Kontaktdaten:

Beitrag von Falkenstein » 23. Sep 2005, 05:15

*freu*
linux:/# smart install cups-devel openssl-devel aspell-devel libacl-devel
Loading cache...
Updating cache... ################################################################################# [100%]

Computing transaction...

Installed packages (4):
aspell-devel-0.60.2-3@i586 cups-devel-1.1.23-7@i586 libacl-devel-2.2.30-3@i586 openssl-devel-0.9.7e-3@i586

1.4MB of package files are needed. 5.7MB will be used.

Confirm changes? (Y/n):

Fetching packages...
-> http://ftp4.gwdg.de/pub/linux/suse/apt/ ... 3.i586.rpm
-> http://ftp4.gwdg.de/pub/linux/suse/apt/ ... 7.i586.rpm
-> http://ftp4.gwdg.de/pub/linux/suse/apt/ ... 3.i586.rpm
libacl-devel-2.2.30-3.i586.rpm ################################################################################# [ 25%]
cups-devel-1.1.23-7.i586.rpm ################################################################################# [ 50%]
-> http://ftp4.gwdg.de/pub/linux/suse/apt/ ... 3.i586.rpm
aspell-devel-0.60.2-3.i586.rpm ################################################################################# [ 75%]
openssl-devel-0.9.7e-3.i586.rpm ################################################################################# [100%]


Committing transaction...
Preparing... ################################################################################# [ 0%]
1:Installing libacl-devel ################################################################################# [ 25%]
2:Installing aspell-devel ################################################################################# [ 50%]
3:Installing cups-devel ################################################################################# [ 75%]
4:Installing openssl-devel ################################################################################# [100%]


Falkenstein
Hacker
Hacker
Beiträge: 510
Registriert: 14. Mai 2005, 18:35
Kontaktdaten:

Beitrag von Falkenstein » 24. Sep 2005, 08:43

Hab mir jetzt den Kanzler installiert.
Faxen dicke. :)

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste