UTF8 und kein Ende, es kotzt mich an

Alles rund um die möglichen Desktopumgebungen wie KDE, Gnome, XFCE usw. die es unter Linux gibt

Moderator: Moderatoren

Antworten
Benutzeravatar
StevieD
Member
Member
Beiträge: 128
Registriert: 12. Jun 2005, 18:49
Wohnort: Schmelz, Saarland
Kontaktdaten:

UTF8 und kein Ende, es kotzt mich an

Beitrag von StevieD » 13. Sep 2005, 20:08

Hi,
seit der Installation des eher dürftigen SUSE 9.3 finden sich laufend Programme, welche den Zeichensatz falsch darstellen.
Wenn ich schon Geld für ein OS bezahle, um CD/DVD und ein Handbuch zu haben, hätte ich auch gerne Umlaute und Sonderzeichen lesbar auf dem Bildschirm.
Gibt es eine Universelle Lösung für diese gequierlte Kacke, oder muß ich Programm für Programm von Hand konvertieren?

mfg

St
Kernel 4.4xx leap 42.3, 2x1000GB + 8GB Ram, AMD 6100 Six-Core, nVidia GT250

Werbung:
traffic
Guru
Guru
Beiträge: 2750
Registriert: 13. Feb 2005, 05:50

Beitrag von traffic » 13. Sep 2005, 20:12

Zuallererst lernst Du Dich mal zu benehmen. So wie es jetzt läuft, hab ich nämlich nicht mal Lust, nach der Ursache dieses eher seltenen Problems zu suchen.
openSUSE Factory - GNOME 2.32.1

Griffin
Guru
Guru
Beiträge: 3235
Registriert: 10. Mai 2005, 14:11
Kontaktdaten:

Beitrag von Griffin » 13. Sep 2005, 20:17

Harte Worte mein junger Padawan. :lol:
Dich zu zügeln du lernen musst! Der Weg zur dunklen Seite es ist! :lol:

UTF-8 ist nicht das Problem, es ist die Lösung.
Lies das:
http://www.easylinux.de/Artikel/ausgabe ... 46-basics/
"Komm zur dunklen Seite, Luke. Hier gibt es Milch und Kekse!" - Darth Vader

Yoda: "Dunkel die andere Seite ist, Obi Wan"-"Sei still und iss endlich deinen Toast"

warpi
Hacker
Hacker
Beiträge: 431
Registriert: 17. Mär 2005, 12:04
Wohnort: augsburg

Re: UTF8 und kein Ende, es kotzt mich an

Beitrag von warpi » 14. Sep 2005, 08:03

StevieD hat geschrieben:Gibt es eine Universelle Lösung für diese gequierlte Kacke, oder muß ich Programm für Programm von Hand konvertieren?
Griffin hat geschrieben:Harte Worte mein junger Padawan. :lol:
Dich zu zügeln du lernen musst! Der Weg zur dunklen Seite es ist! :lol:

UTF-8 ist nicht das Problem, es ist die Lösung.
Weise Worte du sprichst Meister Griffin. :D
Geduld man haben muß.

UTF-8 ist noch nicht so lange in den verschiedenen Systemen, dass schon alle Programme auch UTF-8 beherrschen.
Z.B. ist bei einigen Webseiten immer noch das alte ISO-Format im Einsatz.
Deswegen kannste ja auch im FF unter Ansicht --> Zeichenkodierung den Zeichensatz schnell umstellen.

UTF-8 wird aber immer häufiger eingesetzt und in Zukunft das alte ISO-Format gänzlich ersetzen.
Zufriedener 64bit Intel-Quad-Core Benutzer, der darauf nur Linux & sonst nix ran läßt.

Snubnose
Hacker
Hacker
Beiträge: 410
Registriert: 18. Feb 2004, 19:19
Wohnort: Schwabenland

Beitrag von Snubnose » 14. Sep 2005, 08:13

Griffin hat geschrieben:UTF-8 ist nicht das Problem, es ist die Lösung.
Lies das:
http://www.easylinux.de/Artikel/ausgabe ... 46-basics/
^^^ was zum Artikel:
die schreiben dass UTF-8 16 Bit seien ? Ist das deren ernst ? Ich hätte gedacht dass UTF-16 16 Bit hätte...

traffic
Guru
Guru
Beiträge: 2750
Registriert: 13. Feb 2005, 05:50

Re: UTF8 und kein Ende, es kotzt mich an

Beitrag von traffic » 14. Sep 2005, 08:33

warpi hat geschrieben:Z.B. ist bei einigen Webseiten immer noch das alte ISO-Format im Einsatz.
Deswegen kannste ja auch im FF unter Ansicht --> Zeichenkodierung den Zeichensatz schnell umstellen.
Gerade bei Webseiten ist UTF-8 überhaupt kein Thema, weil korrekte Webseiten ihren Zeichensatz entweder im HTTP-Header oder im HTML-Header mitschicken müssen. Das war übrigens schon immer so und nicht erst, seit auch Linux-Distributoren mitbekommen haben, dass es Unicode gibt.
warpi hat geschrieben:UTF-8 wird aber immer häufiger eingesetzt und in Zukunft das alte ISO-Format gänzlich ersetzen.
Das bezweifle ich.

Ich habe auch ehrlich gesagt nicht mal den Hauch einer Ahnung, was der Threadersteller meinen könnte. Das möglichst detailliert zu beschreiben, hat er nämlich vor lauter Fäkalausdrücken leider vergessen.

Webseiten sind wie gesagt kein Thema, Textdateien braucht man nicht zu konvertieren, weil man den Zeichensatz beim Öffnen angeben kann und die Oberfläche der Programme ist weder bei KDE- noch bei GNOME-Anwendungen ein Problem.

Bliebe eventuell noch das Dateisystem, dieses kann man aber mit "convmv" ganz schnell in Ordnung bringen. Aber wo das Problem wirklich liegt, wissen wir ja gar nicht und Details über die Anliegen anderer Leute zu erraten, ist nicht unsere Aufgabe. Ich vermute ein sehr einfach zu lösendes Konfigurationsproblem, aber erstmal beschenkt uns der Threadersteller hoffentlich mit einer ausreichenden Problembeschreibung.
openSUSE Factory - GNOME 2.32.1

ojkastl
Hacker
Hacker
Beiträge: 547
Registriert: 15. Dez 2004, 04:51
Wohnort: Erlangen
Kontaktdaten:

Re: UTF8 und kein Ende, es kotzt mich an

Beitrag von ojkastl » 14. Sep 2005, 11:41

traffic hat geschrieben:
Ich habe auch ehrlich gesagt nicht mal den Hauch einer Ahnung, was der Threadersteller meinen könnte. Das möglichst detailliert zu beschreiben, hat er nämlich vor lauter Fäkalausdrücken leider vergessen.
Wahrscheinlich falsche Locales, falsche Mount-Optionen etc.

Benutzeravatar
Gimpel
Guru
Guru
Beiträge: 1983
Registriert: 11. Feb 2004, 13:58
Wohnort: Mjunik .... "no a hoibe, resi!"
Kontaktdaten:

Beitrag von Gimpel » 14. Sep 2005, 12:56

programm mit

Code: Alles auswählen

LC_ALL=de_DE@euro <exec>
starten, passt.

betroffen sind eh meist nur gtk1/tk/ffw programme, also wo is das prob?
Bild on AMD Athlon64 X2 5600+|64bit|6GB DDR2 800MHz|nVidia GF 8500GT|2.6.29-rc1-moo1|BTRFS|KDE-4.2 SVN trunk + Compiz++|M-Audio Audiophile 2496
----
Bild

ojkastl
Hacker
Hacker
Beiträge: 547
Registriert: 15. Dez 2004, 04:51
Wohnort: Erlangen
Kontaktdaten:

Beitrag von ojkastl » 14. Sep 2005, 16:03

Gimpel hat geschrieben:also wo is das prob?
Das kann nur der OP beantworten.

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast