Geringe Performance unter Linux

Alles rund um die möglichen Desktopumgebungen wie KDE, Gnome, XFCE usw. die es unter Linux gibt

Moderator: Moderatoren

Antworten
Marc_42
Newbie
Newbie
Beiträge: 3
Registriert: 2. Sep 2005, 14:22

Geringe Performance unter Linux

Beitrag von Marc_42 » 4. Sep 2005, 11:37

Ich habe Linux 10.0 beta 4 (64bit) auf meinem Rechner installiert.
Obwohl mein System über einen Athlon 64 3400+ und 2 GB RAM
verfügt, geschieht das Öffnen von Programmen deutlich langsamer
als beispielsweise unter Windows XP X64 Pro.
Auch das Moving von Programmfenstern ist ruckelig, obwohl ich
eine GeForce 6800 Ultra habe. Das ist vielleicht ein Treiberproblem.
Alles in allem reagiert Linux wesentlich behäbiger als Windows.
Kann irgendeiner was dazu sagen? Ich bin ein Linux-Noob! :roll:

Werbung:
Benutzeravatar
spunti
Hacker
Hacker
Beiträge: 598
Registriert: 6. Mai 2004, 10:49

Beitrag von spunti » 4. Sep 2005, 12:05

Das Nachschlieren des Fensters, wenn du es schnell ziehst ist normal, kriegst du nicht weg. Dazu hatte ich was gelesen, kann mich aber schwer dran erinnern, wo das "Problem" lag.
Jedenfalls nicht am Treiber und auch nicht an KDE, sondern tiefer.

Programme könnten wirklich schneller Starten, vielleicht weiß da jemand, woran das liegt. Vielleicht, weil keine Registry da ist, die das System allgemein langsamer macht oder was anderes technisches?
MS-Programme selbst sind bei Win im Hintergrund nat. alle schon halb geladen. Also auch wenn du Word-Schnellstarter nicht aktiviert hast, hast du Teile von Word trotzdem immer geladen, oder?

spunti

Keepers
Advanced Hacker
Advanced Hacker
Beiträge: 1061
Registriert: 25. Jun 2004, 17:58
Wohnort: Hessen

Beitrag von Keepers » 4. Sep 2005, 13:16

Im Allgemeinen startet bei mir unter Linux die Programme wesentlich schneller.
Ob Windows Programme im Hintergrund mitlaedt weiß ich nicht, moechte ich bezweifeln. Ne genaue richtige Aussage ist das aber sicherlich nicht - nur wie ich spontan dazu denke.

Das Nachschlieren des Fensters kenne ich auch noch von alten Windows Zeiten - habe es daher nie als Problem angesehen.
Gruß Keepers
Only time will tell - but who does listen?

Benutzeravatar
onkelchentobi
Guru
Guru
Beiträge: 1899
Registriert: 11. Feb 2005, 15:54
Wohnort: BW - Stuttgart
Kontaktdaten:

Beitrag von onkelchentobi » 4. Sep 2005, 13:41

Linux reagiert wesentlich behäbiger als Windows

Ein weiterer Grund ist...

Der Windows Kern ist eine Art kleiner Server der grob in drei Schichten aufgeteilt ist. Die oberste Schicht, die exikutive für die System Dienste.
Die mittlere Schicht ist der Kern, und die unterste für Hardware.
Der Kern ist hauptsächlich für die Ereignißverteilung optimiert, das sich das System möglichst schnell verhält.
Und gerade hier ist sehr viel optimiert.
Für die geschwindigkeit's Optimierung bietet Windows ein prioritäten Modell. D.h. kommt ein Interrupt, dann werden alle niedrigeren interrupt's unterbrochen. Und der kommende kann behandelt werden.
Es gibt glaube ich ca. 32 prioritäten Level's.
Und dadurch das es hier prioritäten hat, kann man schon ( fast ) sagen das Windows realtime Prioritäten hat, zumindest Soft realtime.
Bei Windows sind die ganzen Serverdienste im Kern bzw. Kernel mit drin, damit's einfach schneller ist.
Und genau an dieser Stelle ist auch die GDI ( Graphics Device Interface ) mit drinnen. Welches ein weiterer Grund ist wieso sich die Windows Oberfläche so schnell anfühlt.
GNU/Debian Linux - Testing 32 Bit / Kernel 2.6.30.2 Vanilla / Ion3 - 20090110 / i2p

*** NO E-PATENTS ***

Marc_42
Newbie
Newbie
Beiträge: 3
Registriert: 2. Sep 2005, 14:22

Beitrag von Marc_42 » 4. Sep 2005, 13:57

In der Tat läd Windows Programmdateien beim Booten in den RAM.
Office Dateien gehören beisp. dazu. Trotzdem ist mein Linux grundsätzlich behäbiger. Auch das Aufrufen des "Start Menüs" (weiß nicht, wie das bei Linux heißt) ist enorm zögerlich.
Vielleicht liegt das an der Beta-Version. Hat jemand Erfahrung mit
10.0 64bit? Ansonsten bin ich sehr zufrieden. Ich betreibe jetzt
3 verschiedene OS`s auf meinem Rechner. Die Installation war nicht
leicht, da ich eine IDE-Platte habe und zusätlich einen Sata-Raid 1 Verbund. Die beiden Windows Versionen sind auf dem Raid Verbund.
Ich mußte den Boot-Sector neu erstellen und zwar auf der IDE-Platte.
Der Bootmanager Grup funktioniert einwandfrei, obwohl dies ein Bug
unter 10.0 sein soll. :wink:
Ich fange jetzt an, Linux kennezulernen und werde zunächst meinen
DSL-Zugang unter Linux klarmachen. Dann geht es weiter mit mp3´s
usw. Ich werde bestimmt noch viele Fragen hier stellen!
:)

Marc_42
Newbie
Newbie
Beiträge: 3
Registriert: 2. Sep 2005, 14:22

Beitrag von Marc_42 » 4. Sep 2005, 14:17

Und dadurch das es hier prioritäten hat, kann man schon ( fast ) sagen das Windows realtime Prioritäten hat, zumindest Soft realtime...


Meinst Du damit, daß jeder aktuelle Interrupt, den ich/User auslöse (nicht das System), Priorität hat?

Benutzeravatar
000Hunter000
Newbie
Newbie
Beiträge: 21
Registriert: 22. Mär 2005, 10:39

Beitrag von 000Hunter000 » 4. Sep 2005, 16:52

Wegen der langsamen Oberfläche probier mal folgendes:

In der Datei /etc/X11/xorg.conf sollte es, falls du den NVIDIA treiber installiert hast so einen Abschnitt geben (zumindest sollte der so ähnlich ausschauen):

Code: Alles auswählen

Section "Device"
  BoardName    "GeForce FX 5900"
  BusID        "2:0:0"
  Driver       "nvidia"
  Identifier   "Device[0]"
  VendorName   "NVidia"
  Option       "RenderAccel" "True"
#  Option       "NvAGP" "1"
#  Option "AllowGLXWithComposite" "1"
#  Option       "HWCursor" "Off"
EndSection
Du solltest hier die Zeile

Code: Alles auswählen

Option       "RenderAccel" "True"
übernehmen. Nach einem neustart von X (einmal aus und wider einloggen genügt oder einfach strg+alt+backspace) solltest du eine spürbare Verbesserung erfahren :)

Benutzeravatar
panamajo
Guru
Guru
Beiträge: 2582
Registriert: 12. Feb 2005, 22:45

Beitrag von panamajo » 4. Sep 2005, 21:08

Anders als viele hier kann ich auf ähnlicher HW wie beschrieben (z.B. AMD64 3000+, 1GB RAM, nVIDIA GeForce 6200) keinen Unterschied feststellen.

Von älteren Rechnern (PIII 600 o.ä.) kenne ich das Problem der langsamen Reaktionszeit (mehrere Sekunden vergehen zwischen Aktion und der Reaktion des Systems), was auf gleicher HW unter Window$ idR. nicht so ausgeprägt auftritt.
OnkelchenTobi hat geschrieben:Der Windows Kern ist eine Art kleiner Server der grob in drei Schichten aufgeteilt ist. Die oberste Schicht, die exikutive für die System Dienste.
Die mittlere Schicht ist der Kern, und die unterste für Hardware.
Der Kern ist hauptsächlich für die Ereignißverteilung optimiert, das sich das System möglichst schnell verhält.
Und gerade hier ist sehr viel optimiert.
Für die geschwindigkeit's Optimierung bietet Windows ein prioritäten Modell. D.h. kommt ein Interrupt, dann werden alle niedrigeren interrupt's unterbrochen. Und der kommende kann behandelt werden.
Es gibt glaube ich ca. 32 prioritäten Level's.
Und dadurch das es hier prioritäten hat, kann man schon ( fast ) sagen das Windows realtime Prioritäten hat, zumindest Soft realtime.
Bei Windows sind die ganzen Serverdienste im Kern bzw. Kernel mit drin, damit's einfach schneller ist.
Und genau an dieser Stelle ist auch die GDI ( Graphics Device Interface ) mit drinnen. Welches ein weiterer Grund ist wieso sich die Windows Oberfläche so schnell anfühlt.
Gibts dazu bitte eine Quellenangabe?

Keepers
Advanced Hacker
Advanced Hacker
Beiträge: 1061
Registriert: 25. Jun 2004, 17:58
Wohnort: Hessen

Beitrag von Keepers » 4. Sep 2005, 22:25

000Hunter000 hat geschrieben:Wegen der langsamen Oberfläche probier mal folgendes:

In der Datei /etc/X11/xorg.conf sollte es, falls du den NVIDIA treiber installiert hast so einen Abschnitt geben (zumindest sollte der so ähnlich ausschauen):

Code: Alles auswählen

Section "Device"
  BoardName    "GeForce FX 5900"
  BusID        "2:0:0"
  Driver       "nvidia"
  Identifier   "Device[0]"
  VendorName   "NVidia"
  Option       "RenderAccel" "True"
#  Option       "NvAGP" "1"
#  Option "AllowGLXWithComposite" "1"
#  Option       "HWCursor" "Off"
EndSection
Du solltest hier die Zeile

Code: Alles auswählen

Option       "RenderAccel" "True"
übernehmen. Nach einem neustart von X (einmal aus und wider einloggen genügt oder einfach strg+alt+backspace) solltest du eine spürbare Verbesserung erfahren :)
Bei mir hat dies nichts gebracht... Ich hatte letztlich meine Grafikkarte gewechselt - nun steht immernoch der alte Name drin. Weiterhin war die

Option "Rotate" "off"

eingestellt. Die habe ich in "RenderAccel" "True" geaendert... Leider keine Veraenderung. Weder in der Performance noch anderes
Gruß Keepers
Only time will tell - but who does listen?

Benutzeravatar
onkelchentobi
Guru
Guru
Beiträge: 1899
Registriert: 11. Feb 2005, 15:54
Wohnort: BW - Stuttgart
Kontaktdaten:

Beitrag von onkelchentobi » 4. Sep 2005, 23:04

panamajo hat geschrieben:Gibts dazu bitte eine Quellenangabe?
Wurde mal vom CCC irgend wo gebracht, frag mich aber bitte nicht wo genau. Das ist schon ein bischen länger her und ich kann mir leider nicht alles oder jede quelle von seiten merken auf denen ich gelesen habe.
GNU/Debian Linux - Testing 32 Bit / Kernel 2.6.30.2 Vanilla / Ion3 - 20090110 / i2p

*** NO E-PATENTS ***

Benutzeravatar
spunti
Hacker
Hacker
Beiträge: 598
Registriert: 6. Mai 2004, 10:49

Beitrag von spunti » 4. Sep 2005, 23:25

In der Chaosradiosenung zu Benutzerfaces könnte das gesagt worden sein. Da gings daraum, daß sich die Maus unter Mac und Linux anders anfühlt.
Ob's genau so gesagt wurde, hab ich mir nicht gemerkt.

noctua
Member
Member
Beiträge: 148
Registriert: 18. Aug 2005, 09:43
Kontaktdaten:

Re: Geringe Performance unter Linux

Beitrag von noctua » 5. Sep 2005, 16:09

Marc Fangmeyer hat geschrieben:Ich habe Linux 10.0 beta 4 (64bit) auf meinem Rechner installiert.
:roll:
Hallo!
Nur mal zur Info: Linux ist eigentlich nur der Kern des Systems. Was du meinst, ist die Distribution. Ich nehme an du hast SuSE, das könnte mit 10.0 hinkommen.
Unter http://www.linux.org findest du allgemeines zu Linux.
In Distributionen werden ein Linux-Kern und Softwarepakete zusammengepackt, das gibt dann dein komplettes System.
Übrigens: Ich hab' auch SuSE bei mir laufen (P3, 500 Mhz, 256 MB) und bei mir versteh ich ja, dass es langsam ist, aber komisch ist das bei dir schon ;)
Du könntest es ja mal mit einer anderen Distribution versuchen (Mandriva ist zum Beispiel auch für Anfänger ganz gut oder Ubuntu), die laufen im allgemeinen ein bisschen flotter.
Viel Spaß noch mit Linux!

Benutzeravatar
panamajo
Guru
Guru
Beiträge: 2582
Registriert: 12. Feb 2005, 22:45

Re: Geringe Performance unter Linux

Beitrag von panamajo » 5. Sep 2005, 16:18

noctua hat geschrieben:Du könntest es ja mal mit einer anderen Distribution versuchen (Mandriva ist zum Beispiel auch für Anfänger ganz gut oder Ubuntu), die laufen im allgemeinen ein bisschen flotter.
Je öfter man das behauptet desto eher glaubt man daran desto wahrer wird es ... dasselbe Prinzip wie bei "Windows ist schneller als Linux".:mrgreen:

Benutzeravatar
000Hunter000
Newbie
Newbie
Beiträge: 21
Registriert: 22. Mär 2005, 10:39

Beitrag von 000Hunter000 » 5. Sep 2005, 16:19

Keepers hat geschrieben:
Bei mir hat dies nichts gebracht... Ich hatte letztlich meine Grafikkarte gewechselt - nun steht immernoch der alte Name drin. Weiterhin war die

Option "Rotate" "off"

eingestellt. Die habe ich in "RenderAccel" "True" geaendert... Leider keine Veraenderung. Weder in der Performance noch anderes
komisch ich hab es grad nochmal ausprobiert. Ich merke einen deutlichen Unterschied. Sicher das der NVIDIA treiber richtig installiert ist?

noctua
Member
Member
Beiträge: 148
Registriert: 18. Aug 2005, 09:43
Kontaktdaten:

Re: Geringe Performance unter Linux

Beitrag von noctua » 5. Sep 2005, 16:40

panamajo hat geschrieben:
noctua hat geschrieben:Du könntest es ja mal mit einer anderen Distribution versuchen (Mandriva ist zum Beispiel auch für Anfänger ganz gut oder Ubuntu), die laufen im allgemeinen ein bisschen flotter.
Je öfter man das behauptet desto eher glaubt man daran desto wahrer wird es ... dasselbe Prinzip wie bei "Windows ist schneller als Linux".:mrgreen:
Hi!
Ich sag ja nicht, dass SuSE schelchter ist. Meiner Meinung nach ist es aber ein bisschen langsamer (Bin übrigens nicht allein mit der Meinung:
whois hat geschrieben:Klar Suse ist etwas langsamer dafür hast du aber auch ein stabiles Bluecreen freies System.
).
Wobei das nicht an SuSE direkt liegen muss, KDE liefert da auch einen großen Beitrag dazu :lol:.
Bei "Windows ist schneller als Linux" vergleicht man ja außerdem zwei grundlegend verschiedene Systeme, deshalb ist der Vergleich hier schlicht falsch.
Aber jetzt wird's ein bisschen offtopic... :oops:

Das ist glaub ich wieder ein Glaubenskrieg :D

Keepers
Advanced Hacker
Advanced Hacker
Beiträge: 1061
Registriert: 25. Jun 2004, 17:58
Wohnort: Hessen

Beitrag von Keepers » 5. Sep 2005, 19:37

000Hunter000 hat geschrieben:
Keepers hat geschrieben:
Bei mir hat dies nichts gebracht... Ich hatte letztlich meine Grafikkarte gewechselt - nun steht immernoch der alte Name drin. Weiterhin war die

Option "Rotate" "off"

eingestellt. Die habe ich in "RenderAccel" "True" geaendert... Leider keine Veraenderung. Weder in der Performance noch anderes
komisch ich hab es grad nochmal ausprobiert. Ich merke einen deutlichen Unterschied. Sicher das der NVIDIA treiber richtig installiert ist?
ich werd das ganze noch einmal ueberpruefen - gegebenenfalls werd ich nvidia nochmal rausschmeißen und neu installieren.
Eigentlich sollte es aber korrekt im Kernel eingebunden sein...
Gruß Keepers
Only time will tell - but who does listen?

Keepers
Advanced Hacker
Advanced Hacker
Beiträge: 1061
Registriert: 25. Jun 2004, 17:58
Wohnort: Hessen

Beitrag von Keepers » 6. Sep 2005, 13:57

Nun tatsaechlich war Nvidia nicht mehr als Modul vorhanden - habe daher alles erneut eingerichtet - jetzt ist eine kleine Verbesserung spuerbar. Doch viel hat sie nicht ausgemacht, schade eigentlich ;-)
Gruß Keepers
Only time will tell - but who does listen?

Antworten

Wer ist online?

Mitglieder in diesem Forum: Google [Bot] und 1 Gast