Enlightenment und andere miniWM

Alles rund um die möglichen Desktopumgebungen wie KDE, Gnome, XFCE usw. die es unter Linux gibt

Moderator: Moderatoren

Antworten
Audio Pro Linux

Enlightenment und andere miniWM

Beitrag von Audio Pro Linux » 6. Jun 2005, 10:44

Hab heute die neuste Version aus dem APT von }-Tux-{ installiert.
Also ich kenn Enlightenment schon aus der Zeit wo Gnome noch jung war und bedauerte immer das Enlightenment zwar hübsch anzusehen, aber nicht Alltagstauglich ist oder weiterentwickelt wird. Paar Jahre hat sich nichts getan und gestern sah ich in der LinuxUser einen beeindruckenden Screenshot.

Naja, gleich mal installiert - und schwer beeindruckt das anscheinend meine Installation schwere Fehler aufweist:
  • -Enlightenment sieht gut aus 8) (Na gut das scheint ein Feature zu sein)
  • -keine einzige externe Anwendung (wie Gimp oder etwa eine Konsole) läuft an wenn ich ein Icon klicke.
  • -wenn ich mich ausloggen will bleibt mein Rechner stehen
  • -Wenn ich mittels strg-alt-F1 mich auf eine Konsole logge, kann ich zwar runterfahren, aber das dauert richtig lange (2min?)
Liegt das an meinem System? Ist Enlightenment mal wieder so buggig?
Das wäre so schade denn er sieht so gut aus.:(

Naja, aussehen ist nicht alles und wmaker make it.

Gruss
APL
Zuletzt geändert von Audio Pro Linux am 7. Jun 2005, 13:53, insgesamt 2-mal geändert.

Werbung:
Benutzeravatar
Gimpel
Guru
Guru
Beiträge: 1983
Registriert: 11. Feb 2004, 13:58
Wohnort: Mjunik .... "no a hoibe, resi!"
Kontaktdaten:

Beitrag von Gimpel » 7. Jun 2005, 12:25

Also ich hab vor einiger zeit, 3-4 wochen oder so, mal aus }-Tux-{' repo Enlightenment 0.17 installiert, der lief astrein.

die icons musste vermutlich anpassen, da die pfade nicht stimmen.
hilfe gibts auf http://get-e.org

Und aufm gentoo benutz ich den ja schon, seit er in CVS is, hatte 3 mal probs damit, zwei tage warten, und alles war gut.

Aber gut, zieh dir die aktuelle stable 0.16.7.2 is bei suse dabei, offiziell isses 0.16.8, die läuft hier auch wie geschmiert, quasi _null_ ram verbrauch, und e16 is eh der mit abstand schnellste WM was verarbeitung von fenstern/s und response time angeht ;)

btw wurde an e16 immer weiter entwickelt, nur der erste anlauf für e17 wurde auf eis gelegt, und liess über 2 jahre auf sich warten.
e16 hat den mit abstand besten composite manager drin, is schnell wie sau. die bedienung is "typisch enlightenment" halt


gruß
tom
Bild on AMD Athlon64 X2 5600+|64bit|6GB DDR2 800MHz|nVidia GF 8500GT|2.6.29-rc1-moo1|BTRFS|KDE-4.2 SVN trunk + Compiz++|M-Audio Audiophile 2496
----
Bild

Audio Pro Linux

Beitrag von Audio Pro Linux » 7. Jun 2005, 12:50

Gimpel hat geschrieben: Enlightenment
Hab ich verbessert ;)

Na, mal sehen, vielleicht war mein SuSE mal wieder "korrupt" - gab gestern noch mehr schwierigkeiten (schon mal ne .xsession-errors mit 600MB gesehen?) und ich nutzte die Gelegenheit dazu, meine installation zu killen, meine Systempartition grösser anzulegen und somit endlich das grosse JAD Tutorial zu realisieren - was ja eine Aufzählung der einzelnen Schritte ist SuSE zu installieren, kernel zu ersetzen und APT zu installieren. das kann man am besten wenn man es macht - und dabei gleich die güte eurer (deiner und oc2pus) Tuts zu überprüfen.

Mal sehen ob Enlightenment auf dieser Installation besser läuft...
Und mal sehen ob ich dann irgendeine möglichkeit finde irgendwas zu ändern: meine Suche gestern, die Icons-verknüpfungen zu ändern, ging nur soweit, das ich im Ordner .e zwar etwas fand, aber das war ein seltsames Format von Dateien, denen mit einem textEditor nicht beizukommen war.

Aber ist vom ausehen her genau das was ich mag, auch wenn das default Thema sehr penetrant daherkommt - aber ist ja auch als Demo gedacht.- Und wenn ein grafisch spektakulärer Desktop auch noch mit geringen Ressourcenverbrauch einhergeht dann will ich mal hoffen das das Designen des nächsten Icons nicht wieder 2 jahre dauert ;)

Gruss
Michael


Nachtrag Stunde später:

Kurze Erklärung für Themenfremde: meine Suche nach dem perfekten minimalistischen Windowmanager hat damit zu tun, das die Standardumgebungen KDE und Gnome Ressourcen schlucken, die ich lieber zum Echtzeitberechnen von Audio brauche (Dh Synthesizer und Sampler zum Musikmachen)

Hab Enlightenment mal wieder aus dem APT von }-Tux-{ für SuSE 9.2 installliert: Das gleiche Bild::shock: beim Ausloggen freezed der Rechner/Xserver (Num-Taste blockiert, kein login über Konsole möglich). Die einzige Besonderheit die meine Grafik aufweist ist der Xinerama-modus über zwei Monitore)

Diesmal ist es eine frische Installation 9.2, hab aber gleich nach Wechsel des Kernels auf einer Minimalinstallation apt-get dist-upgrade durchgeführt.

KDE 3.4.1 ist ja richtig schnell gegen 3.3 ! XFCE4 lässt sich gar nicht mehr aufrufen - ich finde auch das die XFCE APT Pakete inkonsistent sind und seltsame unlösbare Abhängigkeiten haben -XFCE4-desktop lässt sich deshalb nicht installieren. Recht traurig, aber ich hab ja wmaker. Naja, werde wohl mich für KDE für den Alltag (vorher XFCE4) und Windowmaker zum Mucke machen entscheiden...

Obwohl Enlightenment sieht gut aus, das ich es echt bedauere... Tux, prüf doch nochmal das RPM oder sagt mir einer was das Problem sein könnte... Vielleicht könnte man auch noch was an der zZ unglücklichen Prekonfiguration ändern, indem man die Icon-Verküpfungen anpasst. So kann man ja nichtmal ne Konsole aufrufen...

Benutzeravatar
Gimpel
Guru
Guru
Beiträge: 1983
Registriert: 11. Feb 2004, 13:58
Wohnort: Mjunik .... "no a hoibe, resi!"
Kontaktdaten:

Beitrag von Gimpel » 7. Jun 2005, 14:44

oha! xinerama! AFAIK funktioniert der support dafür... aber mangels 2. monitor nie getestet

um die icons bearbeiten zu können, installier dir am besten mal die e_utils.
alle "icons" werden in ~/.e/e/applications/all abgelegt

Code: Alles auswählen

e_util_eapp_edit ~/.e/e/applications/all/moo.eapp
dann noch das menü anpassen (Ibar) ---> .e/e./applications/bar/.order

http://get-e.org/User_Guide/English_pages/3.3.html
;)
Bild on AMD Athlon64 X2 5600+|64bit|6GB DDR2 800MHz|nVidia GF 8500GT|2.6.29-rc1-moo1|BTRFS|KDE-4.2 SVN trunk + Compiz++|M-Audio Audiophile 2496
----
Bild

Audio Pro Linux

Beitrag von Audio Pro Linux » 7. Jun 2005, 15:12

Gimpel hat geschrieben:oha! xinerama! AFAIK funktioniert der support dafür... aber mangels 2. monitor nie getestet

um die icons bearbeiten zu können, installier dir am besten mal die e_utils.
alle "icons" werden in ~/.e/e/applications/all abgelegt

Code: Alles auswählen

e_util_eapp_edit ~/.e/e/applications/all/moo.eapp
dann noch das menü anpassen (Ibar) ---> .e/e./applications/bar/.order

http://get-e.org/User_Guide/English_pages/3.3.html
;)
Ich weiss aber nicht ob ich unter den umständen momentan Enlightenment starte: meine (dokumentierte) Systemneuinstallation hatte ich ja gemacht, nach dem nach freeze des Xservers beim ausloggen auch die X Config umgeschrieben war und kdm nicht mehr funktionierte :shock:

Ich hätte das reparieren können, weil ich mittlerweile auch mit Linux im Textmodus ganz gut klarkomme, aber die Gelegenheit war günstig - und so hab ich mir auch selbst in den A++++ getreten endlich das Tut zu schreiben (bzw anzufangen, ist sehr gross): http://www.jacklab.net/index.php?option ... lang=de_DE

Und mit Präkonfiguration meine ich auch, das das RPM gleich "vernünftig" vorbereitet ist, was ja afaik gehen muss - ich meine auf die Zielplattform SuSE Linux und für den Anwender. Ich finde ja zurechtfrickeln ist eine schöne Freizeitbeschäftigung, aber ich frickel ehrlich lieber an Sounds rum als an biestigen Windowmangern :wink:

bzw ich muss relativ schnell zu Ergebnissen kommen: Wenn ich nach einer halbe Stunde suchen keinen Anhaltspunkt gefunden habe um einen WM nach meinen Vorstellungen anzupassen, dann wandert er nach /dev/null...

Für Enlightenment würde ich sogar 2 Stunden in Kauf nehmen!

Aber wenn es am Xinerama liegt (wird ausdrücklich unterstützt lt. Enlightenment homepage) muss ich wohl Enlightenment noch 2 Jahre zurückstellen bis e19... :x

taki
Advanced Hacker
Advanced Hacker
Beiträge: 974
Registriert: 30. Apr 2004, 17:40
Wohnort: Berlin
Kontaktdaten:

Beitrag von taki » 7. Jun 2005, 17:31

Audio Pro Linux hat geschrieben: schon mal ne .xsession-errors mit 600MB gesehen?
Schon mal eine mehrere GB große .xsession-errors gesehen? Hatte mal am Anfang der Rumquälerei mit ATI-Treibern (3.4.irgendwas oder war es noch früher?) das Problem, dass mein Benutzerkonto scheinbar zerschossen war. Habe ewig rumgesucht, ehe ich merkte, dass mein Homelaufwerk zu 100% zu war - wegen der .xsession-errors...
Audio Pro Linux hat geschrieben: :shock: beim Ausloggen freezed der Rechner/Xserver (Num-Taste blockiert, kein login über Konsole möglich). Die einzige Besonderheit die meine Grafik aufweist ist der Xinerama-modus über zwei Monitore)
Gimpel hat geschrieben: e16 hat den mit abstand besten composite manager drin
Das wird es sein. Bei KDE ist der zum Glück optional. Ich habe mit composite arg üble Erfahrungen gemacht. Ich denke mal, dass auch Du eine Grafikkarte hast, deren Treiber nicht so gut damit klarkommen.

@gimpel
Hat Enlightenment evtl. Schalter, mit denen man ihn ohne composite verwenden kann? Ob Enlightenment dann aber immer noch mit Lichtgeschwindigkeit rast ist die Frage.
SuSE 12.3 kernel 3.7.10-1.16-desktop, K Desktop Environment Version 4.10.5 r1 - Medion Titanium Aldi v. 03/2009

Benutzeravatar
Gimpel
Guru
Guru
Beiträge: 1983
Registriert: 11. Feb 2004, 13:58
Wohnort: Mjunik .... "no a hoibe, resi!"
Kontaktdaten:

Beitrag von Gimpel » 7. Jun 2005, 18:57

bringt mal nicht e16 mit e17 durcheinander. die sind _völlig_ verschieden.

e16.8 startet per default _ohne_ composite, und e16.7.2 hat keinen composite manager. und ohnehin muss man die extension explizit in der xorg.conf aktivieren

und composite is der gschwindigkeit eher schädlich, also langsamer wird er ohne ganz bestimmt nicht.
aber wie gesagt: composite nur bei e16.8, kA was SuSE ausliefert, }-Tux-{ baut e17.... alles was anderes

AudioProLinux: wenn e17 von }-Tux-{ nicht rennt, dann teste doch mal e16, auch eyecandy ohne ende.

e17 ist pre-alpha CVS only code. es gibt noch keinen release und nix...
Bild on AMD Athlon64 X2 5600+|64bit|6GB DDR2 800MHz|nVidia GF 8500GT|2.6.29-rc1-moo1|BTRFS|KDE-4.2 SVN trunk + Compiz++|M-Audio Audiophile 2496
----
Bild

}-Tux-{
Moderator
Moderator
Beiträge: 696
Registriert: 12. Dez 2004, 19:54
Kontaktdaten:

Beitrag von }-Tux-{ » 7. Jun 2005, 20:14

Ich habe keine Ahnung warum das bei AudioProLinux nicht funzt :(
Hier bei mir läuft alles ohne Probleme...
Das mit den Icons ist ne andere Sache. Da muss man dann selbst konfigurieren.


mfg }-Tux-{

Audio Pro Linux

Beitrag von Audio Pro Linux » 7. Jun 2005, 21:37

}-Tux-{ hat geschrieben:Ich habe keine Ahnung warum das bei AudioProLinux nicht funzt: Hier bei mir läuft alles ohne Probleme...(
Ich denk das liegt an meiner von der Standard-Norm abweichenden Hardware mit g550, ein Treiber der eigentlich inzwischen perfekt unterstützt wird. Aber ein Windowmanager, insbesondere wenn er in einer solchen frühen Version ist wie e, kann da schon Probleme machen. Wahrscheinlich haben die Programmierer einfache keine Hardware um das zu testen. Naja, dann eben /dev/null und noch 2-3 Jahre warten. ;)
}-Tux-{ hat geschrieben: Das mit den Icons ist ne andere Sache. Da muss man dann selbst konfigurieren.
Naja, ich finde hier könnte der Packer schon ein bischen darauf achten was er da baut. Ich kannte zumindest bisher noch nicht einen Windowmanager, wo nicht wenigstens der Pfad zu xterm gestimmt hätte... ich finde das ist mit eine Aufgabe des Packers, immer die Zielplattform vor Augen....Stell dir vor KDE 3.5 erscheint und in dem Build ist keine einzige Verknüpfung richtig.

Klar, wenn um das eingemachte geht muss man schon selbst ran.

e17 ist wohl eher noch nicht für Benutzer geeignet sondern mehr als Machbarkeitsstudie zu verstehen, was die Entwickler ja auch offen zugeben.

Antworten

Wer ist online?

Mitglieder in diesem Forum: Bing [Bot] und 3 Gäste