superkaramba-0.36 (Suse 9.2) libpython2.4.so.1.0

Alles rund um die möglichen Desktopumgebungen wie KDE, Gnome, XFCE usw. die es unter Linux gibt

Moderator: Moderatoren

Antworten
Heart
Hacker
Hacker
Beiträge: 449
Registriert: 10. Jul 2004, 14:37

superkaramba-0.36 (Suse 9.2) libpython2.4.so.1.0

Beitrag von Heart » 30. Mai 2005, 19:56

Hi,

beim Versuch superkaramba-0.36 zu installieren (rpm von http://kde-look.org/content/show.php?content=23802)

bekomme ich folgendes:

Code: Alles auswählen

rpm -Uhv superkaramba-0.36-1.i686.rpm
warning: superkaramba-0.36-1.i686.rpm: V3 DSA signature: NOKEY, key ID 999ac775
error: Failed dependencies:
        libpython2.4.so.1.0 is needed by superkaramba-0.36-1
Wo bekomme ich libpython2.4.so.1.0 für Suse9.2 her?

Danke
P.S.: Installiert ist

Code: Alles auswählen

rpm -qa python*
python-devel-2.3.4-3.1
python-xml-2.3.4-3.1
python-tk-2.3.4-3.1
python-2.3.4-3.2
python-gtk-2.4.1-1.guru.suse92
python-numeric-23.3-2.1
Zuletzt geändert von Heart am 30. Mai 2005, 20:36, insgesamt 3-mal geändert.
Desktop 10/2012

Werbung:
nollsa
Advanced Hacker
Advanced Hacker
Beiträge: 1072
Registriert: 31. Mär 2004, 21:02
Kontaktdaten:

Beitrag von nollsa » 30. Mai 2005, 20:14

Acer Aspire 5610
SuSE 10.3, KDE 3.5.5

Griffin
Guru
Guru
Beiträge: 3235
Registriert: 10. Mai 2005, 14:11
Kontaktdaten:

Beitrag von Griffin » 30. Mai 2005, 20:19

Hast du schon probiert, Superkaramba mit YaST zu installieren?
Ich glaube nämlich, dass libpython2.4.so.1.0 bei Suse 9.3 dabei ist.
Guckst du hier:
http://www.novell.com/products/linuxpac ... ython.html
Im Paket python-2.4-14.i586.rpm soll libpython2.4.so.1.0 drin sein.

Wenn das so ist, installiert YaST es gleich mit.
Versuch es, es wäre der einfachste Weg. :)
"Komm zur dunklen Seite, Luke. Hier gibt es Milch und Kekse!" - Darth Vader

Yoda: "Dunkel die andere Seite ist, Obi Wan"-"Sei still und iss endlich deinen Toast"

Heart
Hacker
Hacker
Beiträge: 449
Registriert: 10. Jul 2004, 14:37

Beitrag von Heart » 30. Mai 2005, 20:38

Oh Mann, sorry....

Ich war so so von der Allianz-Arena-Eröffnung im Fernsehen begeistert, dass ich Suse9.3 geschrieben habe, anstatt 9.2 (welches ich inst. habe)...

Und bei Suse9.2 ist lt. apt mein installiertes python-2.3.4-3.2 das aktuellste :?
Desktop 10/2012

Griffin
Guru
Guru
Beiträge: 3235
Registriert: 10. Mai 2005, 14:11
Kontaktdaten:

Beitrag von Griffin » 30. Mai 2005, 22:32

Schau mal hier:
http://rpmseek.com/rpm/superkaramba-0.3 ... :0:2008913

Wie du bei den Abhängigkeiten unter "Benötigt" lesen kannst, scheint diese Version von Superkaramba mit libpython2.3.so.1.0 auszukommen. Vielleicht läuft das ja bei dir!?
"Komm zur dunklen Seite, Luke. Hier gibt es Milch und Kekse!" - Darth Vader

Yoda: "Dunkel die andere Seite ist, Obi Wan"-"Sei still und iss endlich deinen Toast"

Heart
Hacker
Hacker
Beiträge: 449
Registriert: 10. Jul 2004, 14:37

Beitrag von Heart » 30. Mai 2005, 23:11

Dann gelange ich zu

Code: Alles auswählen

error: Failed dependencies:
        kdelibs3 < 3.3.999 is needed by superkaramba-0.36-1.guru.suse92.kde33
(Ich habe per apt mein KDE vor ein paar Monaten auf 3.4 upgedated, aber scheinbar gibt es kdelibs dafür nicht!?

...und die Datei heißt auch schon suse92.kde33.... :cry: )
Desktop 10/2012

Griffin
Guru
Guru
Beiträge: 3235
Registriert: 10. Mai 2005, 14:11
Kontaktdaten:

Beitrag von Griffin » 31. Mai 2005, 10:57

Doch, die kdelibs gibt es natürlich bei KDE 3.4! Unter KDE 3.4 hast du nur die kdelibs 3.4 dabei. Superkaramba will aber von dir die kdelibs in einer Version kleiner als 3.3.999. Und 3.4 ist halt größer, daher der Konflikt. Vielleicht läuft Superkaramba ja auch mit den kdelibs 3.4, nur wie macht man ihm das klar? :lol:

Wenn du schon apt nutzt, klappt das nicht?:

Code: Alles auswählen

apt-get install superkaramba
Aber da du das vermutlich bereits versucht hast, gibt er dir hier wohl auch irgendwelche unerfüllten Abhängigkeiten aus, oder?

Mein Rat ist daher folgender:
Poste das Problem mit Superkaramba und apt doch einfach mal im APT-Forum hier. Ok2pus hat doch dort eigentlich immer eine Lösung für wirklich alles. :D
"Komm zur dunklen Seite, Luke. Hier gibt es Milch und Kekse!" - Darth Vader

Yoda: "Dunkel die andere Seite ist, Obi Wan"-"Sei still und iss endlich deinen Toast"

Benutzeravatar
Targaman
Newbie
Newbie
Beiträge: 29
Registriert: 23. Apr 2005, 10:20

Beitrag von Targaman » 31. Mai 2005, 19:21

Heart hat geschrieben:Dann gelange ich zu

Code: Alles auswählen

error: Failed dependencies:
        kdelibs3 < 3.3.999 is needed by superkaramba-0.36-1.guru.suse92.kde33
(Ich habe per apt mein KDE vor ein paar Monaten auf 3.4 upgedated, aber scheinbar gibt es kdelibs dafür nicht!?

...und die Datei heißt auch schon suse92.kde33.... :cry: )
habe das gleiche problem! :(

wie könnte man das lösen?

wäre es möglich einfach die suse 9.3 version von superkaramba auf suse 9.2 zu installieren?

oder:

wäre es möglich einfach auf ignorieren zu klicken und es einfach zu testen? oder würde sich die instabilität auch auf mein system auswirken?
Suse 9.3 auf:

ECS N2U400-A | Athlon 2600+ | GeForce 4 TI 4200 | 2x 256 RAM (Dual Channel) | 18 GB Samsung, 80 GB Maxtor | DSL PPPoE...


SuSE Pro Update = SuSE Pro Vollversion! :wink: >> http://www.linux-club.de/viewtopic.php?t=34583

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast