kmail via konsole mails holen lassen

Alles rund um die möglichen Desktopumgebungen wie KDE, Gnome, XFCE usw. die es unter Linux gibt

Moderator: Moderatoren

Antworten
linOS
Member
Member
Beiträge: 203
Registriert: 21. Mai 2004, 18:21
Wohnort: ruhrgebeat
Kontaktdaten:

kmail via konsole mails holen lassen

Beitrag von linOS » 3. Mai 2005, 14:22

hallo

ich bin im urlaub und mein postfach bei web.de quillt wegen maillingliste über. mein rechner zuhause läuft und ich habe ssh-zugang. kann ich kmail dazu bewegen, sämliche post aus allen postfächern abzuholen?

danke
linos
office: kubuntu 6.06, kde 3.5.3 - amd duron 1,2ghz - ram auch... alles =)

Werbung:
Gast

Beitrag von Gast » 3. Mai 2005, 14:27

Code: Alles auswählen

kmail --check
X-Forwarding vorrausgesetzt.

linOS
Member
Member
Beiträge: 203
Registriert: 21. Mai 2004, 18:21
Wohnort: ruhrgebeat
Kontaktdaten:

Beitrag von linOS » 4. Mai 2005, 10:50

macht er nicht. fehler:

ERROR: KUniqueApplication: Can't determine DISPLAY. Aborting.

was ist x-forwarding?
office: kubuntu 6.06, kde 3.5.3 - amd duron 1,2ghz - ram auch... alles =)

Gast

Beitrag von Gast » 4. Mai 2005, 14:15

linOS hat geschrieben: was ist x-forwarding?
Das ist Weiterleitung des X-Servers den du kontaktierst. Das musst du bei ssh natürlich erlauben.

Benutze die Option -X (grosses X.)

siehe:

Code: Alles auswählen

man ssh
-X
Enables X11 forwarding. This can also be specified on a per-host
basis in a configuration file.

X11 forwarding should be enabled with caution. Users with the
ability to bypass file permissions on the remote host (for the
user's X authorization database) can access the local X11 display
through the forwarded connection. An attacker may then be able
to perform activities such as keystroke monitoring.

For this reason, X11 forwarding is subjected X11 SECURITY exten-
sion restrictions by default. Please refer to the ssh -Y option
and the ForwardX11Trusted directive in ssh_config(5) for more
information.

linOS
Member
Member
Beiträge: 203
Registriert: 21. Mai 2004, 18:21
Wohnort: ruhrgebeat
Kontaktdaten:

Beitrag von linOS » 8. Mai 2005, 00:47

also, ich habe in /etc/ssh/sshd_config (oder sö ähnlich, sitze nicht an dem rechner, mit dem ich auf meinen zuhause zugreife) gesehen, das x-forwarding erlaubt ist. ich arbeite von einem windowsrechner aus mit putty. dort kann ich angeben, das dieses forwarding aktiviert wird und ich muß eine displaynummer angeben. habs mit 0 und 1 probiert (logischerweise die zuerst verwendeten meiner meinung) aber so bekomme ich keine verbindung. ohne forwarding komme ich auf den rechner. mit echo $DISPLAY (oder ähnlich...) bekomme ich aber keine ausgabe.
office: kubuntu 6.06, kde 3.5.3 - amd duron 1,2ghz - ram auch... alles =)

Gast

Beitrag von Gast » 8. Mai 2005, 09:20

So muß das mit dem ssh-Zugriff aussehen, um die X-Ausgabe zu dir hinzubekommen. Und natürlich muß der ssh-Server (remote-rechner) das auch erlauben. Dann funzt das auch.

Code: Alles auswählen

ssh -X <user>@<host_oder_IP>
Wenn du das von Windows aus mit Putty (kenn ich nicht, nur mal von gehört) machst, musst du mal in die Docs von Putty schauen ob es da Besonderheiten gibt. Mehr fällt mir dazu nicht ein.
Bei mir funzt das x-forwarding einwandfrei.

Im Klartext:
In der '/etc/ssh/sshd_config' auf deinem Rechner zu Haus muß sich folgender Einrag befinden

Code: Alles auswählen

X11Forwarding yes
für das x-forwarding. Sonst geht das nicht.

Noch 'ne kleine Anmerkung:
Wenn schon Windows und SSH, dann installiere dir mal die Cygwintools und du hast eine komplette Unixumgebung mit der bash, ssh und noch vielles mehr unter Windows..

http://www.cygwin.com/

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 4 Gäste