simply Change / KDE startet nicht

Alles rund um die möglichen Desktopumgebungen wie KDE, Gnome, XFCE usw. die es unter Linux gibt

Moderator: Moderatoren

Antworten
Benutzeravatar
Bär
Newbie
Newbie
Beiträge: 21
Registriert: 24. Apr 2005, 18:43

simply Change / KDE startet nicht

Beitrag von Bär » 24. Apr 2005, 19:18

Hallo zusammen,
ich habe seit vergangenen Donnerstag auch Suse 9.3. Auf meinem einen Desktoprechner kein Problem, jedoch auf meinem zweiten und dem Laptop.

Grub meldet sich noch ganz normal, auch das weitere Laden sieht normal aus, aber auf einmal erschein ein grauer Kasten mit Login und im Hintergrund simply change.
Der Desktop läd nach Eingabe der Login-Daten den KDE Desktop, plus eine Konsole, arbeiten kann man darauf, den Rechner normal runter fahren geht jedoch nicht,nur abmelden.
Habe die Anmerkungen von SUSE ausgeführt und auch die von Warpi, leider keine Veränderung! (vom Laptop will ich garnicht reden, auch wenn alles nach der Installierung einwandfrei lief!)

Hat jemand noch einen Tip, wie man diese Sache wieder normalisieren kann?

Ansonsten finde ich die neue Variante nicht schlecht, das Design erinnert mich jedoch an eine Mischung aus XP und Mac

Gruß Bär

Werbung:
Benutzeravatar
Martin Breidenbach
Ultimate Guru
Ultimate Guru
Beiträge: 5632
Registriert: 26. Mai 2004, 21:33
Wohnort: N 50.17599° E 8.73367°

Re: simply Change / KDE startet nicht

Beitrag von Martin Breidenbach » 24. Apr 2005, 19:45

Bär hat geschrieben:Der Desktop läd nach Eingabe der Login-Daten den KDE Desktop, plus eine Konsole, arbeiten kann man darauf, den Rechner normal runter fahren geht jedoch nicht,nur abmelden.
Was passiert denn wenn Du es versuchst ?

Was passiert bei

Code: Alles auswählen

shutdown -h now
?
Nicht Böse sein ! Der Onkel macht doch nur Spaß !

Benutzeravatar
Bär
Newbie
Newbie
Beiträge: 21
Registriert: 24. Apr 2005, 18:43

Beitrag von Bär » 24. Apr 2005, 20:49

Wenn ich im Hauptmenü auf beenden gehe, gibt er mir nur die Möglichkeit, die aktuelle Sitzung zu beenden und kehrt zum "simply change" Bildschirm zurück.

Den Befehl habe ich noch nicht getestet, werde ich aber umgehend nachholen.

Gruß Bär

Benutzeravatar
Bär
Newbie
Newbie
Beiträge: 21
Registriert: 24. Apr 2005, 18:43

Beitrag von Bär » 24. Apr 2005, 20:58

Hallo Martin,
der Code, den Du mir genannt hast, funktioniert, zumindest von der Shell aus, (aus der Alt +F2 KOnsole nicht).

Gruß Bär

matresi
Newbie
Newbie
Beiträge: 19
Registriert: 27. Aug 2004, 22:09
Wohnort: Visp
Kontaktdaten:

Beitrag von matresi » 24. Apr 2005, 21:42

Hi Bär,
ich hatte das selbe Prob...
Wenn du da runterfahren willst musst du einloggen und in einer konsole mit init 6 runterfahren...

Wenn du deinen KDE zurück willst machst du im grauen Bildschrim ein Terminal auf und gibst da yast2 ein. (oder du loggst dich in den KDE ein und gehst da in den Yast, je nach dem was geht...)
Dann gehst du auf System und dann auf Editor für /etc/sysconfig Dateien

Nun auf Desktop und Displaymanager.
bei Displaymanager kdm auswählen,
bei Displaymanager_KDM_Theme SUSE rauslöschen,
bei WINDOWmanager- bei Default_WM auf kde wechseln..

Dann Neustarten und des funktionierte wieder bei mir...
Ist irgendwie ne erweiterte Version von der Lösung von warpie... :D

Probiers mal...
Bild

Benutzeravatar
Bär
Newbie
Newbie
Beiträge: 21
Registriert: 24. Apr 2005, 18:43

Beitrag von Bär » 25. Apr 2005, 06:52

Hallo Matresi,
jetzt klapps, die xconsole geht zwar weiterhin mit auf, aber ich komme wenigstens wieder in mein normales System.


Vielen Dank


Bär

matresi
Newbie
Newbie
Beiträge: 19
Registriert: 27. Aug 2004, 22:09
Wohnort: Visp
Kontaktdaten:

Beitrag von matresi » 25. Apr 2005, 21:06

Dank nicht mir, danke dem Forum hier...die Marschrichtung habe ich hier gelesen :D
Bild

warpi
Hacker
Hacker
Beiträge: 431
Registriert: 17. Mär 2005, 12:04
Wohnort: augsburg

Beitrag von warpi » 26. Apr 2005, 07:39

Ähm :wink:
Danke für den Hinweis das der Eintrag:
Desktop und Displaymanager.
bei Displaymanager kdm auswählen
fehlt.
Alter Anmeldebildschirm mit Userauswahl:
/etc/opt/kde3/share/config/kdm/kdmrc editieren und UseTheme=true auf UseTheme=false setzen
Jetzt sollte auch die Shell beim starten weg sein.
Hier ist auch beschrieben, in was für Probleme man reinlaufen kann:
http://www.linux-club.de/viewtopic.php?t=31090
Zufriedener 64bit Intel-Quad-Core Benutzer, der darauf nur Linux & sonst nix ran läßt.

Benutzeravatar
Bär
Newbie
Newbie
Beiträge: 21
Registriert: 24. Apr 2005, 18:43

Beitrag von Bär » 26. Apr 2005, 08:25

Hallo warpi,
werde es mir anschauen und korrigieren.

Danke

Gruß

Bär

warpi
Hacker
Hacker
Beiträge: 431
Registriert: 17. Mär 2005, 12:04
Wohnort: augsburg

Beitrag von warpi » 26. Apr 2005, 09:29

Nachtrag
in /etc/opt/kde3/share/config/kdm/kdmrc gibt's auch einen Parameter am Ende (Greeter config for 1st local display) [X-:0-Greeter]
der Parameter
ShowLog=true
ist zwar bei mir gesetzt, aber es kommt trotzdem keine Shell beim Hochfahren.
Bei manchen hat's aber geholfen, den Wert auf false zu setzten.
Zufriedener 64bit Intel-Quad-Core Benutzer, der darauf nur Linux & sonst nix ran läßt.

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste