e17 konfigurieren...

Alles rund um die möglichen Desktopumgebungen wie KDE, Gnome, XFCE usw. die es unter Linux gibt

Moderator: Moderatoren

Antworten
Benutzeravatar
gbolk
Newbie
Newbie
Beiträge: 34
Registriert: 20. Apr 2005, 16:46
Wohnort: Heustreu

e17 konfigurieren...

Beitrag von gbolk » 20. Apr 2005, 16:52

Hi,

ich habe mir soeben mit apt4rpm die aktuellste Version von e17 installiert. Nach dem Start bin ich.....BAFF....;-)....HAMMER, was die Jungs da programmieren.

Nun habe ich aber ein "kleineres" Übel, zu dem ich noch nichts in den weiten des Internets gefunden habe.

Ich kann leider nur Firefox, OO und Terminals öffnen.

Icons bzw. entsprechende Menüeinträge für all die anderen netten Tools welche ich bis dato unter KDE 3.4 nutzen konnte, sind nicht auffindbar bzw. nur durch Terminals zu starten.

Hat jemand sachdienliche Hinweise, wie ich all die Programme nun effizienter (wie unter KDE, XFCE4 bzw. GNOME) starten kann?

Danke

Werbung:
Benutzeravatar
MrShy
Member
Member
Beiträge: 86
Registriert: 14. Feb 2004, 13:55
Wohnort: Nordhessen

Beitrag von MrShy » 10. Mai 2005, 20:19

Hi!

Ich suche schon die ganze Zeit nach einem rpm für e17...
wo hast du das Paket denn gefunden ???

DANKE !!!!!!!!!!!!!!!!!!!!!!!!! :D
CPU: AMD Sempron64 2800+
Arbeitsspeicher: 1280MB RAM
Distribution: Ubuntu 8.04, openSuSE 11.0, KXLight (mit AmigaOS)

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 10. Mai 2005, 21:10

tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

}-Tux-{
Moderator
Moderator
Beiträge: 696
Registriert: 12. Dez 2004, 19:54
Kontaktdaten:

Beitrag von }-Tux-{ » 10. Mai 2005, 21:23

kleine info:
voraussichtlich werden am donnerstag die RPMs vom neuesten Snapshot von http://enlightenment.freedesktop.org/ erscheinen :wink:

mfg }-Tux-{

ps. auf http://www.get-e.org/ gibts noch nen super user-guide!

cero
Moderator
Moderator
Beiträge: 2292
Registriert: 5. Mai 2004, 20:33
Wohnort: nähe Buchholz i.d.N.

Beitrag von cero » 11. Mai 2005, 10:24

Kann ich die RPMs auch unter SuSE 9.3 nutzen oder
lieber nicht?
Wissen, was man weiß,
und wissen, was man nicht weiß,
das ist wahres Wissen.
(Konfuzius)


"Auf der dunklen Seite gibt es keine Kekse, Luke! Bleib lieber hier!" - Obi-Wan Kenobi

}-Tux-{
Moderator
Moderator
Beiträge: 696
Registriert: 12. Dez 2004, 19:54
Kontaktdaten:

Beitrag von }-Tux-{ » 11. Mai 2005, 19:15

cero hat geschrieben:Kann ich die RPMs auch unter SuSE 9.3 nutzen oder
lieber nicht?
hmm ich kann es dir nicht genau sagen... ausprobieren kannst du es, kann dir aber nicht versprechen das es klappt :wink:


mfg }-Tux-{

cero
Moderator
Moderator
Beiträge: 2292
Registriert: 5. Mai 2004, 20:33
Wohnort: nähe Buchholz i.d.N.

Beitrag von cero » 11. Mai 2005, 19:32

}-Tux-{ hat geschrieben:
cero hat geschrieben:Kann ich die RPMs auch unter SuSE 9.3 nutzen oder
lieber nicht?
hmm ich kann es dir nicht genau sagen... ausprobieren kannst du es, kann dir aber nicht versprechen das es klappt :wink:


mfg }-Tux-{
Probieren geht über studieren :-D
Ich werde Dir berichten ob es funktioniert oder Probleme bereitet.
Wissen, was man weiß,
und wissen, was man nicht weiß,
das ist wahres Wissen.
(Konfuzius)


"Auf der dunklen Seite gibt es keine Kekse, Luke! Bleib lieber hier!" - Obi-Wan Kenobi

cero
Moderator
Moderator
Beiträge: 2292
Registriert: 5. Mai 2004, 20:33
Wohnort: nähe Buchholz i.d.N.

Beitrag von cero » 15. Mai 2005, 13:06

Hallo }-Tux-{

Kleiner Bericht über meine "Erfolge" ;-)
Kurz: Ich habe es nicht zum Laufen gebracht.
Zuerst habe ich es unter VMWare probiert um mein Produktivsystem
nich zu zerdengeln - aber da wollte die Installation nicht so wie ich :wink:

Als zweiten Versuch habe ich mich dann doch an mein produktives Linux
gewagt. Ich habe alle Deine RPMs zu meinen eigenen BASE-Repository
hinzugefügt. Dann der Test. Es gabe viele unerfüllte Abhängigkeiten.
Also habe ich diese mal mitgegeben:

Code: Alles auswählen

apt install --test enlightenment libdirectfb-0.9.so.20 libecore_config.so.1 libecore_con.so.1 libecore_evas.so.1 libecore_fb.so.1 libecore_file.so.1 libecore_ipc.so.1 libecore_job.so.1 libecore.so.1 libecore_txt.so.1 libecore_x.so.1 libevas.so.1
Ergebnis:

Code: Alles auswählen

Package libdirectfb-0.9.so.20 has no available version, but exists in the database.
This typically means that the package was mentioned in a dependency and
never uploaded, has been obsoleted or is not available with the contents
of sources.list
E: Paket libdirectfb-0.9.so.20 hat keinen Installationskanditaten
:?: Nun weiß ich nicht weiter. Ideen oder sollte ich es lieber lassen :?:

Edit: Frohe Pfingsten an alle :D
Wissen, was man weiß,
und wissen, was man nicht weiß,
das ist wahres Wissen.
(Konfuzius)


"Auf der dunklen Seite gibt es keine Kekse, Luke! Bleib lieber hier!" - Obi-Wan Kenobi

}-Tux-{
Moderator
Moderator
Beiträge: 696
Registriert: 12. Dez 2004, 19:54
Kontaktdaten:

Beitrag von }-Tux-{ » 15. Mai 2005, 13:32

bevor du enlightenment installieren kannst, musst du die sogenannten EFLs (Enlightenment Foundation Librarys) installieren: das sind folgende:

eet = 0.9.10.007
edb = 1.0.5.003
edje = 0.5.0.007
ecore = 0.9.9.007
embryo = 0.9.1.007
epeg = 0.9.0.003
epsilon = 0.3.0.003
esmart = 0.9.0.003
etox = 0.9.0.003
evas = 0.9.9.007
ewl = 0.0.4.003
emotion = 0.0.1.003
imlib2 >= 1.0.0

lade dir diese dateien, aus meinem repository, packe sie in einen ordner und probiere es erneut
apt install --test /pfad/zu/den/EFLS/*
danach kannst du dann enlightenment installieren bzw. das kannst du dann auch sofort in den ordner packen.

mfg }-Tux-{

cero
Moderator
Moderator
Beiträge: 2292
Registriert: 5. Mai 2004, 20:33
Wohnort: nähe Buchholz i.d.N.

Beitrag von cero » 15. Mai 2005, 13:49

}-Tux-{ hat geschrieben:bevor du enlightenment installieren kannst, musst du die sogenannten EFLs (Enlightenment Foundation Librarys) installieren: das sind folgende:

eet = 0.9.10.007
edb = 1.0.5.003
edje = 0.5.0.007
ecore = 0.9.9.007
embryo = 0.9.1.007
epeg = 0.9.0.003
epsilon = 0.3.0.003
esmart = 0.9.0.003
etox = 0.9.0.003
evas = 0.9.9.007
ewl = 0.0.4.003
emotion = 0.0.1.003
imlib2 >= 1.0.0

lade dir diese dateien, aus meinem repository, packe sie in einen ordner und probiere es erneut
apt install --test /pfad/zu/den/EFLS/*
danach kannst du dann enlightenment installieren bzw. das kannst du dann auch sofort in den ordner packen.

mfg }-Tux-{
Die hatte ich auch schon mit ins Repository gelegt (Habe Dein Verzeichnis komplett von Server gezogen).
Ich versuche mal diese zuerst zu installieren - melde mich wieder.
Danke für deine Hilfe.
Wissen, was man weiß,
und wissen, was man nicht weiß,
das ist wahres Wissen.
(Konfuzius)


"Auf der dunklen Seite gibt es keine Kekse, Luke! Bleib lieber hier!" - Obi-Wan Kenobi

cero
Moderator
Moderator
Beiträge: 2292
Registriert: 5. Mai 2004, 20:33
Wohnort: nähe Buchholz i.d.N.

Beitrag von cero » 15. Mai 2005, 14:18

Habe es jetzt so probiert, wie Du es geschrieben hast.
Ich bekomme leider immer folgende Meldung:

Code: Alles auswählen

Die folgenden Pakete besitzen unerfülte Abhängigkeiten:
  elicit: Hängt ab von: libdirectfb-0.9.so.20 aber es ist nicht installierbar
  entice: Hängt ab von: libdirectfb-0.9.so.20 aber es ist nicht installierbar
  etox: Hängt ab von: libdirectfb-0.9.so.20 aber es ist nicht installierbar
  evas: Hängt ab von: libdirectfb-0.9.so.20 aber es ist nicht installierbar
Ich habe mal nachgesehen. Auf meinem System (SuSE 9.3) ist folgende
Version installiert: libdirectfb-0.9.so.21.
Kann diese neuere Version die Installationsprobleme verursachen?
Wissen, was man weiß,
und wissen, was man nicht weiß,
das ist wahres Wissen.
(Konfuzius)


"Auf der dunklen Seite gibt es keine Kekse, Luke! Bleib lieber hier!" - Obi-Wan Kenobi

}-Tux-{
Moderator
Moderator
Beiträge: 696
Registriert: 12. Dez 2004, 19:54
Kontaktdaten:

Beitrag von }-Tux-{ » 15. Mai 2005, 18:19

ja daran wirds liegen :(

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 15. Mai 2005, 18:31

na dann probiere mal ein virtuelles RPM für diese libdirectfb-0.9.so.20 ...
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

cero
Moderator
Moderator
Beiträge: 2292
Registriert: 5. Mai 2004, 20:33
Wohnort: nähe Buchholz i.d.N.

Beitrag von cero » 15. Mai 2005, 20:22

Hallo }-Tux-{ und oc2pus.

So, ich habe ein virtuelles RPM erstellt (tolles Howto :-)). Danach
konnte ich auch alle Pakete installieren. Habe dann im KDM auf
Enlightenment gewechsel und versucht es zu starten. Es passiert
nicht. Bzw. es wird wohl versucht zu starten, aber das Bild springt nach
einigen Sekunden wieder zum KDM zurück. Danach habe ich einen
Start via Shell probiert:

Code: Alles auswählen

enlightenment: error while loading shared libraries: libdirectfb-0.9.so.20: cannot open shared object file: No such file or directory
Scheint so, als wolle er unbedingt die libdirectfb-0.9.so.20 haben.
Schade. Habt Ihr sonst noch Ideen? Eventuell Checkinstall mit
den Paketen von http://code-monkey.de/e-snapshots/ ? Könnte das etwas werden?
Sonst gebe ich auf ;-)
Wissen, was man weiß,
und wissen, was man nicht weiß,
das ist wahres Wissen.
(Konfuzius)


"Auf der dunklen Seite gibt es keine Kekse, Luke! Bleib lieber hier!" - Obi-Wan Kenobi

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 15. Mai 2005, 20:45

schade, war ein Versuch wert ...

dann probier mal einen symlink zu erstellen für diese lib, der link zeigt dann auf deine lib.so.21 (In der Regel sind lib abwärtskompatibel)

ansonsten bleibt dir wohl nur ein Eigencompile oder }-Tux-{ erstellt ein RPM dafür ;)
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

cero
Moderator
Moderator
Beiträge: 2292
Registriert: 5. Mai 2004, 20:33
Wohnort: nähe Buchholz i.d.N.

Beitrag von cero » 15. Mai 2005, 20:48

oc2pus hat geschrieben:schade, war ein Versuch wert ...

dann probier mal einen symlink zu erstellen für diese lib, der link zeigt dann auf deine lib.so.21 (In der Regel sind lib abwärtskompatibel)

ansonsten bleibt dir wohl nur ein Eigencompile oder }-Tux-{ erstellt ein RPM dafür ;)
Hallo oc2pus,

das mit dem Link habe ich auch gerade mal getestet - Es funktioniert :D :D
Vielen Dank für die Hilfe von Dir und }-Tux-{
Wissen, was man weiß,
und wissen, was man nicht weiß,
das ist wahres Wissen.
(Konfuzius)


"Auf der dunklen Seite gibt es keine Kekse, Luke! Bleib lieber hier!" - Obi-Wan Kenobi

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste