Schriftgröße grottenfalsch

Alles rund um die möglichen Desktopumgebungen wie KDE, Gnome, XFCE usw. die es unter Linux gibt

Moderator: Moderatoren

Antworten
alex0801

Schriftgröße grottenfalsch

Beitrag von alex0801 » 13. Apr 2005, 10:54

Hallo zusammen,
habe hier ein Problem was die Schriftgröße in diversen Programmen betrifft:

ich nutze SuSE 9.2 prof. auf einem Acer Extensa 2902LMI+ mit SXGA+ Display. D.h. 1400x1050 Pixel Auflösung.

In Sax2 habe ich die korrekte Auflösung und die korrekten Displaymaße eingetragen.

Im Kontrollzentrum habe ich die ganzen Schriftarten auf Größe 6 runtergesetzt. Die Standen alle auf 10 oder 12 was für einen solchen Bildschirm extrem Groß ist.

Nun habe ich aber das Problem daß in einigen Anwendungen die Schriftgröße dennoch nicht stimmt. Beispielsweise meine Java IDE Eclipse. Ich kann zwar in Eclipse die Schriftgröße nochmals von Hand runterdrehen, aber die Menüleiste und die ganzen Explorer (Package-Explorer, CVS-Explorer,...) bleiben auf großer Schrift.

Ich hab irgendwo im Netz gelesen daß das an den Einstellungen von GTK liegen soll. Genaueres konnte ich aber nicht rausfinden.

Ich hoffe daß mir jmd. weiterhelfen kann. Denn so macht das Programmieren keinen Spaß.. Is ja was für "fast"-Blinde.

Gruß
Alex

Werbung:
Benutzeravatar
misiu
Moderator
Moderator
Beiträge: 3979
Registriert: 8. Mär 2004, 11:27
Wohnort: bei Schweinfurt

Beitrag von misiu » 13. Apr 2005, 12:27

Programme, die auf KDE-Desktop-Basis laufen, verwenden auch KDE-Schriften, die du schon geändert hast. Programme , wie z.B.
GIMP verwenden GNOME-Desktop (GTK) für die Fensterverziehrungen/Schriften, auch , wenn die unter KDE gestartet
werden. Also must du nochmal im
GNOME-Kontrollzentrum die Schriftgrösse ändern. Dafür meldest du dich im Gnome-Desktop an, oder startest du einfach das Gnome-Kontrollzentrum unter KDE (geht auch).

MfG
misiu

alex0801

Beitrag von alex0801 » 13. Apr 2005, 12:39

Ich werds probieren, danke vielmals,

gruß
Alex

alex0801

Beitrag von alex0801 » 13. Apr 2005, 16:08

Blöde Frage:

gconf ist installiert, aber wie starte ich es ? Muss ich das ganze Gnome-Paket mit installieren ?

Hab bisher ausschließlich mit KDE gearbeitet.

Gruß
Alex

alex0801

Beitrag von alex0801 » 13. Apr 2005, 17:00

So, hab das komplette Gnome-Paket installiert. Beim Login-Bildschirm habe ich Gnome ausgewählt und Gnome gestartet. In Gnome die Schriftart auf Größe 6 korrigiert und schon sieht Eclipse aus wie es aussehen soll. Starte ich danach aber wieder KDE ist es dort immernoch zu groß. Zurück in Gnome stimmts noch. Scheinbar greift KDE auf eine andere Config zu als Gnome. Nur wo schau ich da nach ?

Gruß
Alex

The_Eye
Member
Member
Beiträge: 145
Registriert: 22. Mai 2004, 21:18

Beitrag von The_Eye » 13. Apr 2005, 17:06

Du meinst den gconf-editor. Den startest Du über alt + F2 gconf-editor

Schriften unter KDE werden unter kcontrol eingestellt. Allerdings ist meine Erfahrung, dass sich da GNOME und KDE niemals wirklich identisch werden.

Du benutzt Schriftgrad 6? Also bei mir läuft SuSE bei 1680x1050 und ich habe sowohl unter GNOME als auch unter KDE überall Schriftgrad 10. Bist Du wirklich sicher, dass Du alles richtig konfiguriert hast?

Hast Du unter Sax2 auch einen LCD-Schirm angegeben? SuSE hatte mir da mal ohne dass ich es gemerkt hatte was anderes untergejubelt und da sahen die Schriften auch etwas seltsam aus.
Ubuntu& SuSE -- HP nx7000 & nx9420

alex0801

Beitrag von alex0801 » 14. Apr 2005, 10:24

Hallo,
werde das mit gconf-editor testen.

Im KDE Kontrollzentrum hab ich auch shcon alles angepasst. Aber die besagten Schriftgrößen in Eclipse haben sich dadurch nciht geändert.

Und ja, mit Schriftgrad 6 bin ich mir schon sicher. Habe paralell noch Windows drauf. Um in etwa die gleiche Schriftgröße wie in Windows zu erreichen muss ich auf Schriftgröße 6 bzw 7 stellen.

In Sax2 wurde mein Notebook-TFT korrekt erkannt und eingerichtet.

Seltsam sieht keine der Schriftart aus. Sind alle gestochen scharf, nur eben um einiges zu groß.

Gruß
Alex

The_Eye
Member
Member
Beiträge: 145
Registriert: 22. Mai 2004, 21:18

Beitrag von The_Eye » 14. Apr 2005, 13:49

Trit das Problem eigentlich nur bei Eclipse auf oder auch bei anderen Programmen?

Ach ja, hast Du eigentlich den qt-gtk-engine installiert?
Ubuntu& SuSE -- HP nx7000 & nx9420

Benutzeravatar
panamajo
Guru
Guru
Beiträge: 2582
Registriert: 12. Feb 2005, 22:45

Beitrag von panamajo » 14. Apr 2005, 15:46

alex0801 hat geschrieben:Um in etwa die gleiche Schriftgröße wie in Windows zu erreichen muss ich auf Schriftgröße 6 bzw 7 stellen.
Naja, das ist eher ein Bug von Window$, da die Auflösung des Monitors mit 96 bzw. 120 DPI angenommen wird, was in der Realität kaum erreicht wird. In den Einstellungen der GK lässt sich dies korrigieren, das führt zu besseren Ergebnissen als in den jwlg. Anwendungen die Schriftgröße anzupassen (insbesonders bzg. Schriftgrad).

alex0801

Beitrag von alex0801 » 14. Apr 2005, 19:23

Aha,
und das lässt sich mittels qt-gtk-engine einstellen oder wo mach ich das wenn ich KDE nutzten will (mit Gnome hätt ich das problem gelöst, will aber KDE nutzen) ??!!

Gruß
Alex

Poldibaer
Newbie
Newbie
Beiträge: 25
Registriert: 11. Sep 2004, 20:01

@Alex - gucksu hier

Beitrag von Poldibaer » 17. Apr 2005, 18:19

alex0801 hat geschrieben:Aha,
und das lässt sich mittels qt-gtk-engine einstellen oder wo mach ich das wenn ich KDE nutzten will (mit Gnome hätt ich das problem gelöst, will aber KDE nutzen) ??!!

Gruß
Alex
Hi, Alex,
hier wirds verständlich erklärt:
http://www.linux-club.de/viewtopic.php?t=30960

... und hier gibt es eine kleine Fortsetzung dazu:
http://www.linux-club.de/viewtopic.php?t=31016

HTH,
Gruß,
Poldibär
- Suse Linux 9.2 (Newbie, ich lerne noch) -

alex0801

Beitrag von alex0801 » 18. Apr 2005, 15:22

Hallo zusammen,
bin immernoch nicht wirklich weiter. Hab zwischendurch ausschließlich gnome verwendet weils da 1a funktioniert hat.

Hat mir aber doch keine Ruhe gelassen. Hab mich n bisschen informiert... die Schriftgröße einfach runterdrehen ist scheinbar nicht das gelbe vom Ei. Schriftgröße 10 bzw 12 muss auch bei mir einigermaßen klein aussehen.
Es muss scheinbar an der DPI-Einstellung liegen.

ich habe eine Auflösung von 1400x1050 und eine Bildschirmgröße von 300x230mm. Dies entspricht in etwa einer DPI-Zahl von 118x114.

In der XF86config hab ich DisplaySize schon angegeben, bzw hat Sax2 gemacht, Ein wenig besser wird es wenn ich gnome-control-center gestartet habe und bei Fonts->Details die DPI-Zahl auf rund 64 drehe... Aber das passt ja rechnerisch absolut nicht. Mal davon abgesehen daß nicht alle Schriften sich dran halten, und wenn ich KDE neu starte is alles wieder weg.

Hat denn hier niemand nen Notebook mit selbiger Auflösung mit denselben Problemen ?

Gruß
Alex

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste