Kompilieren von arts: libz... configure: error: not found.

Alles rund um die möglichen Desktopumgebungen wie KDE, Gnome, XFCE usw. die es unter Linux gibt

Moderator: Moderatoren

Antworten
NewRadFan

Kompilieren von arts: libz... configure: error: not found.

Beitrag von NewRadFan » 10. Apr 2005, 17:04

Hallo!

Ich habe unter Suse 9.2 / KDE 3.4 das bekannte Arts-Problem und versuche, arts-1.4.0-8.src.rpm zu kompilieren, aber ich bekomme diese Fehlermeldung:

Code: Alles auswählen

checking for libz... configure: error: not found.
          Possibly configure picks up an outdated version
          installed by XFree86. Remove it from your system.

          Check your installation and look into config.log
error: Bad exit status from /var/tmp/rpm-tmp.3517 (%build)
aus config.log:

Code: Alles auswählen

configure:31958: checking for libz
configure:31993: gcc -o conftest -ansi -W -Wall -Wchar-subscripts -Wshadow -Wpointer-arith -Wmissing-prototypes -Wwrite-strings -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -g3 -fno-inline   -Wformat-security -Wmissing-format-attribute -I/usr/X11R6/include   -D_REENTRANT  conftest.c -L/usr/X11R6/lib    -lz  >&5
conftest.c: In function `main':
conftest.c:89: error: `gzFile' undeclared (first use in this function)
conftest.c:89: error: (Each undeclared identifier is reported only once
conftest.c:89: error: for each function it appears in.)
conftest.c:89: error: parse error before "f"
conftest.c:91: warning: implicit declaration of function `gzgets'
conftest.c:91: error: `f' undeclared (first use in this function)
conftest.c:93: warning: implicit declaration of function `zlibVersion'
conftest.c:93: warning: comparison between pointer and integer
configure:31999: $? = 1
[...]

Code: Alles auswählen

| #define HAVE_SYS_SOUNDCARD_H 1
| /* end confdefs.h.  */
| 
| #include<zlib.h>
| 
| int
| main ()
| {
| 
|   char buf[42];
|   gzFile f = (gzFile) 0;
|   /* this would segfault.. but we only link, don't run */
|   (void) gzgets(f, buf, sizeof(buf));
| 
|   return (zlibVersion() == ZLIB_VERSION);
| 
|   ;
|   return 0;
| }
configure:32041: error: not found.
          Possibly configure picks up an outdated version
          installed by XFree86. Remove it from your system.

          Check your installation and look into config.log
zlib-1.2.1-74 und zlib-devel-1.2.1-74 sind installiert.

Habt ihr einen Tipp?

Werbung:
Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste