Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Gnome taucht nicht im Anmeldefenster auf

Alles rund um die möglichen Desktopumgebungen wie KDE, Gnome, XFCE usw. die es unter Linux gibt

Moderator: Moderatoren

Antworten
Benutzeravatar
manwe23
Member
Member
Beiträge: 57
Registriert: 13. Feb 2005, 17:31
Kontaktdaten:

Gnome taucht nicht im Anmeldefenster auf

Beitrag von manwe23 » 21. Mär 2005, 23:12

Hallo,

Hab mir gerade den ganzen Gnomekrempl installiert aber wenn Ich mich abmelde gibt es bei den Windowmanagern kein Gnome zum auswählen.
Hab dann unter Yast die Optionen für /etc/sysconfig durchprobiert aber auch ohne Erfolg (Autologin natürlich deaktiviert). Gnome bekomm Ich bei mir im Moment nur aus dem Runlevel 3 mit startx gnome zum laufen. Wär zwar auch nicht weiter tragisch aber trotzdem wärs halt praktisch Gnome über das Login Fenster auswählen zu können.

Hier noch meine /etc/syskonfig:

## Path: Desktop/Window manager
## Description:
## Type: string(kde,fvwm,gnome,windowmaker)
## Default: kde
## Config: profiles,kde,susewm
#
# Here you can set the default window manager (kde, fvwm, ...)
# changes here require at least a re-login
DEFAULT_WM="kde"

## Type: yesno
## Default: yes
#
# install the SuSE extension for new users
# (theme and additional functions)
#
INSTALL_DESKTOP_EXTENSIONS="yes"
## Type: string
## Default:
## Path: Desktop
## Description: default mouse cursor theme
#
# Name of mouse cursor theme for X11. Possible themes can be found
# in /usr/X11R6/lib/X11/icons/
#
X_MOUSE_CURSOR="crystalwhite"
## Path: Desktop
## Description: prepare global sycoca database for faster first startup
## Type: list(yes,initial,no)
## Default: initial
#
# building a global sycoca database, which can be used at first user
# login in KDE
#
KDE_BUILD_GLOBAL_SYCOCA="initial"

## Type: yesno
## Default: no
#
# IPv6 support is disabled by default, since too many internet
# servers claim to have IPv6 support, but do not respond.
#
KDE_USE_IPV6="no"
OpenSuse 10.2
ATI Radeon 9600Pro mit fgrlx 8.33.6
AMD 2800+
MSI K8N Neo
nforce3 ultra
1024MB DDR RAM

Werbung:
Benutzeravatar
manwe23
Member
Member
Beiträge: 57
Registriert: 13. Feb 2005, 17:31
Kontaktdaten:

Beitrag von manwe23 » 21. Mär 2005, 23:32

Liegt es vielleicht daran dass Gnome nicht aufaucht weil in der /etc/sysconfig/windowmanager nur Skripte für profiles, kde und susewm stehen?
OpenSuse 10.2
ATI Radeon 9600Pro mit fgrlx 8.33.6
AMD 2800+
MSI K8N Neo
nforce3 ultra
1024MB DDR RAM

Benutzeravatar
manwe23
Member
Member
Beiträge: 57
Registriert: 13. Feb 2005, 17:31
Kontaktdaten:

Gelöst[Gnome taucht nicht im Anmeldefenster auf]

Beitrag von manwe23 » 22. Mär 2005, 02:17

Bei allen wo Gnome nicht im Anmeldefenster bei Benutzung von KDM auftauchen sollte unter Suse 9.2 einfach in folgenden Ordner gehen:
/opt/kde3/share/apps/kdm/sessions
Danach die Datei gnome.desktop öffnen und dort vor gnome-session folgenden Pfad eintragen: /opt/gnome/bin/

Dann sollte das ganze so aussehen:

[Desktop Entry]
Encoding=UTF-8
Type=XSession
Exec=/opt/gnome/bin/gnome-session
TryExec=/opt/gnome/bin/gnome-session
Name=GNOME

Wenn Ihr Gnome wo anders habt, müsst Ihr halt dann den jeweiligen Ordner als Pfad angeben.
OpenSuse 10.2
ATI Radeon 9600Pro mit fgrlx 8.33.6
AMD 2800+
MSI K8N Neo
nforce3 ultra
1024MB DDR RAM

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast