Fehlender Symlink zum Startskript bei KDE 3.4, SuSE 9.2

Alles rund um die möglichen Desktopumgebungen wie KDE, Gnome, XFCE usw. die es unter Linux gibt

Moderator: Moderatoren

Antworten
GroundCon
Newbie
Newbie
Beiträge: 1
Registriert: 18. Mär 2005, 16:22

Fehlender Symlink zum Startskript bei KDE 3.4, SuSE 9.2

Beitrag von GroundCon » 18. Mär 2005, 16:41

Hallo,

ich habe die KDE 3.4 Pakete für SuSE 9.2 manuell vom FTP-Server heruntergeladen und mittels "rpm -Fhv ..." installiert. Das hat auch problemlos geklappt (keine Abhängigkeitskonflikte o.ä.). Allerdings startete KDE bei der Eingabe von startx nicht, sondern Fvwm erschien als Fallback-Alternative.

Eine Untersuchung des Problems brachte zum Vorschein, dass mit dem Update der Symlink

/usr/X11R6/bin/kde

nicht mehr vorhanden war, die Variable $WINDOWMANAGER dennoch diesen Link enthielt. Ein Vergleich der Pakete kdebase3 mittels "rpm -ql" bestätigte, dass in Version 3.4 die o.g. Datei entfernt wurde. Ein manuelles Erzeugen des Symlinks /usr/X11R6/bin/kde -> /opt/kde3/bin/startkde löste das Problem, und KDE 3.4 startete problemlos.

Exakt das gleiche Problem habe ich beim Update auf Qt 3.3.4 erlebt. Auch hier fehlten im Paket qt3-devel plötzlich die Symlinks /usr/bin/qmake etc., so dass sich Qt-Programme nicht mehr kompilieren ließen und der Designer nicht mehr startete.

Mich wundert nur, dass dieses Problem nicht bekannt ist, wo doch die aktualisierten Programme aufgrund offensichtlich fehlender Dateien nicht funktionieren. Bei Google, Novell und diversen Foren war zu diesem Problem jedenfalls nichts zu finden...

Grüße,
GroundCon

Werbung:
Benutzeravatar
panamajo
Guru
Guru
Beiträge: 2583
Registriert: 12. Feb 2005, 22:45

Beitrag von panamajo » 18. Mär 2005, 17:03

Du hast vollkommen recht, der Symlink fehlt und die Variable verweist darauf.

Daß dies noch niemand aufgefallen ist liegt vmtl. darin daß $WINDOWMANAGER in den KDM Scripten unter /opt/kde3/share/config/kdm gar nicht mehr verwendet wird (sondern direkt startkde aufgerufen wird). Wer weiterhin die xdm Startups in /etc/X11/xdm verwendet schaut in die Röhre...

Dummerweise wird derzeit die $HOME/.xsession nicht mehr beachtet, und ich vermisse den dort zu startenden gpg-agent und xim :evil:

micgeb
Newbie
Newbie
Beiträge: 5
Registriert: 16. Feb 2005, 00:00
Kontaktdaten:

Beitrag von micgeb » 18. Mär 2005, 17:32

Mir ist es aufgefallen, guckst du hier:
http://www.linux-club.de/viewtopic.php?t=28660
gruss micgeb

Thomas4000
Member
Member
Beiträge: 178
Registriert: 8. Aug 2004, 20:20
Wohnort: Bayern

Beitrag von Thomas4000 » 19. Mär 2005, 19:53

Mir ist es auch aufgefallen, startx brachte den fvwm.
Der Symlink hats repariert.


Danke für die Lösung!

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste