Probleme mit KDE-Tastaturlayout

Alles rund um die möglichen Desktopumgebungen wie KDE, Gnome, XFCE usw. die es unter Linux gibt

Moderator: Moderatoren

Antworten
Durga
Newbie
Newbie
Beiträge: 3
Registriert: 15. Feb 2005, 15:00

Probleme mit KDE-Tastaturlayout

Beitrag von Durga » 15. Feb 2005, 15:16

Ich habe auf meinem Rechner seit kurzem SuSe 9.2 installiert. Ich habe aber nun das Problem, dass die deutsche Tastatur unter KDE ein "layout -us" hat, also Zeichen wie Raute, Backslash u. Ä. ganz woanders sind als auf der normalen deutschen Tastatur. Wenn ich alles auf "Voreinstellungen" zurückstelle, funktioniert zwar das Meiste wieder ganz normal (also gemäß der deutschen Standard-Tastatur), Buchstaben mit Akzenten (accent aigu, accent grave, usw.) werden dann jedoch nicht mehr erkannt.

Da ich aber öfters auf Ungarisch, manchmal auch auf Französisch schreibe, würde ich diese Sonderzeichen brauchen. Will ich Ungarisch schreiben, kann ich zwar die ungarische Tastatur einrichten, dort sind aber natürlich alle Zeichen (Rufzeichen, Fragezeichen, usw.) woanders, als ich es von der normalen deutschen Tastatur gewohnt bin. (Und so kann ich auch in deutschen Texten keine fremden Sonderzeichen verwenden.)

Meine Frage: gibt es ein deutsches KDE-Tastaturlayout, das so funktioniert, wie jede normale deutsche Tastatur?

Und warum werden Tasturumstellungen manchmal sofort übernommen (z. B. wenn ich in KMail ein Mail schreibe), manchmal aber nicht? Vor allem beim Zurückgehen auf "Voreinstellungen" muss ich den Computer sogar herunterfahren, damit die Änderungen übernommen werden.

Werbung:
Benutzeravatar
panamajo
Guru
Guru
Beiträge: 2581
Registriert: 12. Feb 2005, 22:45

Re: Probleme mit KDE-Tastaturlayout

Beitrag von panamajo » 15. Feb 2005, 16:30

Durga hat geschrieben:Wenn ich alles auf "Voreinstellungen" zurückstelle, funktioniert zwar das Meiste wieder ganz normal (also gemäß der deutschen Standard-Tastatur), Buchstaben mit Akzenten (accent aigu, accent grave, usw.) werden dann jedoch nicht mehr erkannt.
Kommt der Akzent wenn du ihn 2x nacheinander eintippst?
Durga hat geschrieben:Meine Frage: gibt es ein deutsches KDE-Tastaturlayout, das so funktioniert, wie jede normale deutsche Tastatur?
Aus den von dir genannten Gründen halte ich diesen ganzen Tastaturlayout Kram von KDE für Quatsch, denn das ist IMHO Aufgabe des X Servers.

Alle KDE Tastatureinstellungen deaktivieren,
/etc/X11/xorg.conf:

Code: Alles auswählen

Section "InputDevice"
        Identifier      "Keyboard[Cherry_G81]"
        Driver          "kbd"
        Option          "XkbRules"      "xorg"
        Option          "XkbModel"      "pc105"
        Option          "XkbLayout"     "de"
EndSection
Damit hat man ein Layout, bei dem die Beschriftung der Tasten auch dem gesendeten Zeichen entsprechen, inkl. Umlauten etc.
Akzente, die nicht als Taste vorhanden sind gibt man nacheinander ein:
Tilde,n = ñ (Tilde = ~ = AltGr und +)
^,a = â
´,e = é

Optional: anlegen einer .Xmodmap im $HOME mit:

Code: Alles auswählen

keysym Menu = Multi_key
Damit kann man "exotische" Zeichen mit einem intuitiven System eingeben: [Menü]+Akzent eingeben, danach das Zeichen, das den Akzent tragen soll. Bsp.:
[Menü][Shift]7,O = Ø
[Menü][Shift]2,e = ë
etc.
Durga hat geschrieben:Vor allem beim Zurückgehen auf "Voreinstellungen" muss ich den Computer sogar herunterfahren, damit die Änderungen übernommen werden.
Herunterfahren? Ausloggen (Beenden der KDE Sitzung) und Einloggen reicht nicht?

Durga
Newbie
Newbie
Beiträge: 3
Registriert: 15. Feb 2005, 15:00

Re: Probleme mit KDE-Tastaturlayout

Beitrag von Durga » 15. Feb 2005, 23:05

Vielen Dank, werde mal experimentieren.... :D
panamajo hat geschrieben: Kommt der Akzent wenn du ihn 2x nacheinander eintippst?
Nein.
panamajo hat geschrieben: Herunterfahren? Ausloggen (Beenden der KDE Sitzung) und Einloggen reicht nicht?

Wahrscheinlich schon - ich hab's halt immer runtergefahren :roll:

montio
Newbie
Newbie
Beiträge: 31
Registriert: 11. Jun 2004, 18:14

Beitrag von montio » 11. Aug 2005, 09:19

Hallo zusammen,

habe auch Problem mit Suse 9.3 und den Akzenten.
Recherchen und Spielereien mit den Tastaturlayouts haben folgende Möglichkeiten aufgezeigt.
Im Moment funktioniert bei mir ALT + ´ + e für é (anderes entsprechend)
Will man den Akzent ´ einzeln haben, dann doppelt drücken.


Von der Suse Supportdatenbank der Hinweis, dass es mit SHIFT + CTRL/STRG + ´ + e hat mit irgendeiner Tastatureinstellung auch funktioniert, weiß aber nicht mehr mit welcher. Achtung, ich musste immer erst SHIFT und dann CTRL/STRG dazu drücken (nicht anders rum).

Gruß, montio

Grothesk
Ultimate Guru
Ultimate Guru
Beiträge: 14662
Registriert: 26. Okt 2003, 11:52
Wohnort: Köln

Beitrag von Grothesk » 11. Aug 2005, 09:30

Stellt mal in 'sax2' die Tastatur auf 'Deutsch mit toten Tasten' ein.

montio
Newbie
Newbie
Beiträge: 31
Registriert: 11. Jun 2004, 18:14

Beitrag von montio » 13. Aug 2005, 05:44

Hallo Grothesk,
vielen Dank für den Hinweis. Ist wohl die beste Lösung es so zu machen. Habe auf "Basic" gestellt und jetzt läuft es scheinbar alles so wie man es sich vorstellt bzw. gewohnt ist.

Gruß, montio

montio
Newbie
Newbie
Beiträge: 31
Registriert: 11. Jun 2004, 18:14

Beitrag von montio » 16. Aug 2005, 06:10

Guten Morgen Grothesk,

ich hatte ja im vorigen Posting gesagt, dass die Umstellung auf Basic Tastatur in sax2 funktioniert.

Jetzt habe ich leider festgestellt, dass die <>| Zeichen bzw. diese Taste nicht geht. Habe ich was falsch gemacht, oder was kann ich noch einstellen? (im Moment behelfe ich mir, dass ich auf englische tastatur umstelle, aber das ist nicht sehr komfortabel).

Falls du noch einen Hinweis hast, dann schon einmal vielen Dank im Voraus.
Gruß, montio

Lösung: Nachtrag vom 19.8.05:
Ich habe jetzt die Lösung für mich gefunden. Ich habe im Kontrollzentrum - regionale Einstellungen - Tastaturlayout den Tastaturtyp Laptop/Notebook Dell Inspiron 8xxx gefunden und ausgewählt (habe ein Dell Inspiron 6000) und jetzt scheint alles so zu funktionieren, wie ich es mir gewünscht habe. Nochmals vielen Dank.

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast