[gelöst] KDE schaltet Monitor in 'Energiesparmodus'

Alles rund um die möglichen Desktopumgebungen wie KDE, Gnome, XFCE usw. die es unter Linux gibt

Moderator: Moderatoren

Gesperrt
Benutzeravatar
ViktorII
Member
Member
Beiträge: 97
Registriert: 26. Aug 2004, 14:06

[gelöst] KDE schaltet Monitor in 'Energiesparmodus'

Beitrag von ViktorII » 5. Feb 2005, 00:42

Hallo zusammen

wenn ich die Maus und die Tastatur einige Zeit nicht betätigte schaltet KDE den Monitor schwarz. Wie kann ich das verhindern? Habe im Kontrollzentrum nichts gefunden. :?

Vielen Dank
Viktor
Zuletzt geändert von ViktorII am 20. Apr 2005, 15:55, insgesamt 1-mal geändert.
Wenn Fliegen hinter Fliegen fliegen, fliegen Fliegen Fliegen hinterher.

Werbung:
towo
Moderator
Moderator
Beiträge: 3702
Registriert: 15. Feb 2004, 16:42
Wohnort: Nimritz
Kontaktdaten:

Beitrag von towo » 5. Feb 2005, 10:47

Code: Alles auswählen

xset s off
in Deiner ~/.xinitrc sollte Dein Problem beseitigen.
Signatur nach Diktat spazieren gegangen

Bild

OldKid
Hacker
Hacker
Beiträge: 448
Registriert: 2. Aug 2004, 19:37
Wohnort: Sauerland
Kontaktdaten:

Beitrag von OldKid » 5. Feb 2005, 10:50

mmmh ... hast du schon mal im Kontrollznetrum unter Erscheinungsbild geschaut welchen Bildschirmschoner du hast .... hört sich fast so an als wenn du "Leerer Bildschirm" aktiviert hast .
“Regression testing? What's that? If it compiles, it is good, if it boots up it is perfect.”Linus Torvalds
AMD64 X2 4200+ - 4GB RAM - 1,2 TB Disk - GeForce 8400 GS - 2.6.38-ck
Creative Commons Lizenz

Benutzeravatar
ViktorII
Member
Member
Beiträge: 97
Registriert: 26. Aug 2004, 14:06

Beitrag von ViktorII » 6. Feb 2005, 23:13

@ oldkid30

Bildschirmschoner ist deaktiviert. Also daran liegt es nicht.

@ towo2099

Ich habe nur ~/.xinitrc.template gefunden:

Code: Alles auswählen

#!/bin/bash
#
# Sample .xinitrc for SuSE Linux
# This script is called from 'startx' when you start an X session
#

#
# In case everything goes wrong, we at least fall back to a plain xterm
#
failsafe="xterm -ls -T Failsave -geometry 80x24-0-0"
trap "exec $failsafe" EXIT SIGHUP SIGINT SIGPIPE SIGTERM SIGIO

#
# Some bash (1 and 2) settings to avoid trouble on a
# failed program call.
#
test -n "$BASH" && set +o posix
no_exit_on_failed_exec=1
type shopt > /dev/null 2>&1 && shopt -s execfail
set +e > /dev/null 2>&1

#
# This should be the default
#
export TERM=xterm

#
# choose a window manager
#
if test -n "$WINDOWMANAGER" ; then
    WINDOWMANAGER=`type -p $WINDOWMANAGER`
fi
if test -z "$WINDOWMANAGER" ; then
    if test -x /usr/X11R6/bin/kde ; then
        WINDOWMANAGER=/usr/X11R6/bin/kde
    elif test -x /usr/X11R6/bin/startkde ; then
        WINDOWMANAGER=/usr/X11R6/bin/startkde
    elif test -x /usr/X11R6/bin/fvwm2 ; then
        WINDOWMANAGER=/usr/X11R6/bin/fvwm2
    elif test -x /usr/X11R6/bin/wmlist ; then
        for i in `/usr/X11R6/bin/wmlist` ; do
            WINDOWMANAGER=`type -p $i`
            test -n "$WINDOWMANAGER" && break
        done
    elif test -x /usr/X11R6/bin/twm ; then
        WINDOWMANAGER=/usr/X11R6/bin/twm
    fi
fi

if test -z "$WINDOWMANAGER" ; then
    echo "Error: Unable to find a window manager. Please make sure you installed one!"
    echo "Exiting..."
    xmessage -timeout 10 -default okay -center -file - <<-EOF
	Error: Unable to find a window manager. Please make sure you installed one!
	Exiting...
	EOF
    exit 1
fi

#
# Load system and users resources if not already done
# (XSESSION_IS_UP set by xdm in $XLIBDIR/xdm/Xsession)
#
if test "$XSESSION_IS_UP" != "yes" ; then
    XLIBDIR=/usr/X11R6/lib/X11
    test -r $XLIBDIR/Xmodmap    && xmodmap $XLIBDIR/Xmodmap
    test -r $HOME/.Xmodmap      && xmodmap $HOME/.Xmodmap
    test -r $XLIBDIR/Xresources && xrdb -load -retain $XLIBDIR/Xresources
    test -r $HOME/.Xdefaults    && xrdb -I$HOME -merge $HOME/.Xdefaults
    test -r $HOME/.Xresources   && xrdb -I$HOME -merge $HOME/.Xresources
fi

# Start the XIM server
XIMFILE=/etc/X11/xim 
test -r $HOME/.xim   && XIMFILE=$HOME/.xim 
test -r $XIMFILE && source $XIMFILE 

# Enable Numlock if set
test -r /var/run/numlock-on -a -x /usr/X11R6/bin/numlock && /usr/X11R6/bin/numlock

# Disable new Xcursor themes if none is specified resp. located in $HOME
# (use "unset XCURSOR_CORE" to enable them again later)
#if [ "x$XCURSOR_THEME" == "x" -a ! -d $HOME/.icons ]; then 
#  export XCURSOR_CORE=true
#else
#  unset XCURSOR_CORE
#fi

# Prevent keyboard bouncing for Toshiba Notebooks
# Means, disable AccessX
test -r /etc/sysconfig/sax && source /etc/sysconfig/sax
if [ "x$KBD_BOUNCE_FIX" = "xyes" ]; then
	test -x /usr/X11R6/bin/xbounce && /usr/X11R6/bin/xbounce
fi

#
# Uncomment next line to activate asking for ssh passphrase
#
# ssh-add

#
# Add your own lines here...
#

xset s off

# day planer deamon
# pland &

# 
# finally start the window manager
#
exec $WINDOWMANAGER 

# call failsafe
exit 0
Auch nach dem Eintrag und Neustart von KDE ist das Problem nicht behoben. Bin mir auch nicht mehr sicher ob es ein KDE Probelm ist, weil auf Konsole 1 (im Text Modus) schaltet der Bildschirm auch ab? Irgendeine Idee?
Wenn Fliegen hinter Fliegen fliegen, fliegen Fliegen Fliegen hinterher.

Benutzeravatar
spunti
Hacker
Hacker
Beiträge: 598
Registriert: 6. Mai 2004, 10:49

Beitrag von spunti » 6. Feb 2005, 23:18

Notfalls kannst du das auch im BIOS abschalten.

towo
Moderator
Moderator
Beiträge: 3702
Registriert: 15. Feb 2004, 16:42
Wohnort: Nimritz
Kontaktdaten:

Beitrag von towo » 7. Feb 2005, 17:46

@ towo2099

Ich habe nur ~/.xinitrc.template gefunden:
Dann machste aus dieser eine .xinitrc!
Signatur nach Diktat spazieren gegangen

Bild

Benutzeravatar
ViktorII
Member
Member
Beiträge: 97
Registriert: 26. Aug 2004, 14:06

Beitrag von ViktorII » 8. Feb 2005, 19:03

Habe die Datei umbenannt, hat aber keinen Effekt :?:
Wenn Fliegen hinter Fliegen fliegen, fliegen Fliegen Fliegen hinterher.

towo
Moderator
Moderator
Beiträge: 3702
Registriert: 15. Feb 2004, 16:42
Wohnort: Nimritz
Kontaktdaten:

Beitrag von towo » 8. Feb 2005, 19:18

poste mal ein cat ~/.xinitrc
Signatur nach Diktat spazieren gegangen

Bild

Benutzeravatar
ViktorII
Member
Member
Beiträge: 97
Registriert: 26. Aug 2004, 14:06

Beitrag von ViktorII » 8. Feb 2005, 19:32

Code: Alles auswählen

#!/bin/bash
#
# Sample .xinitrc for SuSE Linux
# This script is called from 'startx' when you start an X session
#

#
# In case everything goes wrong, we at least fall back to a plain xterm
#
failsafe="xterm -ls -T Failsave -geometry 80x24-0-0"
trap "exec $failsafe" EXIT SIGHUP SIGINT SIGPIPE SIGTERM SIGIO

#
# Some bash (1 and 2) settings to avoid trouble on a
# failed program call.
#
test -n "$BASH" && set +o posix
no_exit_on_failed_exec=1
type shopt > /dev/null 2>&1 && shopt -s execfail
set +e > /dev/null 2>&1

#
# This should be the default
#
export TERM=xterm

#
# choose a window manager
#
if test -n "$WINDOWMANAGER" ; then
    WINDOWMANAGER=`type -p $WINDOWMANAGER`
fi
if test -z "$WINDOWMANAGER" ; then
    if test -x /usr/X11R6/bin/kde ; then
        WINDOWMANAGER=/usr/X11R6/bin/kde
    elif test -x /usr/X11R6/bin/startkde ; then
        WINDOWMANAGER=/usr/X11R6/bin/startkde
    elif test -x /usr/X11R6/bin/fvwm2 ; then
        WINDOWMANAGER=/usr/X11R6/bin/fvwm2
    elif test -x /usr/X11R6/bin/wmlist ; then
        for i in `/usr/X11R6/bin/wmlist` ; do
            WINDOWMANAGER=`type -p $i`
            test -n "$WINDOWMANAGER" && break
        done
    elif test -x /usr/X11R6/bin/twm ; then
        WINDOWMANAGER=/usr/X11R6/bin/twm
    fi
fi

if test -z "$WINDOWMANAGER" ; then
    echo "Error: Unable to find a window manager. Please make sure you installed one!"
    echo "Exiting..."
    xmessage -timeout 10 -default okay -center -file - <<-EOF
        Error: Unable to find a window manager. Please make sure you installed one!
        Exiting...
        EOF
    exit 1
fi

#
# Load system and users resources if not already done
# (XSESSION_IS_UP set by xdm in $XLIBDIR/xdm/Xsession)
#
if test "$XSESSION_IS_UP" != "yes" ; then
    XLIBDIR=/usr/X11R6/lib/X11
    test -r $XLIBDIR/Xmodmap    && xmodmap $XLIBDIR/Xmodmap
    test -r $HOME/.Xmodmap      && xmodmap $HOME/.Xmodmap
    test -r $XLIBDIR/Xresources && xrdb -load -retain $XLIBDIR/Xresources
    test -r $HOME/.Xdefaults    && xrdb -I$HOME -merge $HOME/.Xdefaults
    test -r $HOME/.Xresources   && xrdb -I$HOME -merge $HOME/.Xresources
fi

# Start the XIM server
XIMFILE=/etc/X11/xim
test -r $HOME/.xim   && XIMFILE=$HOME/.xim
test -r $XIMFILE && source $XIMFILE

# Enable Numlock if set
test -r /var/run/numlock-on -a -x /usr/X11R6/bin/numlock && /usr/X11R6/bin/numlock

# Disable new Xcursor themes if none is specified resp. located in $HOME
# (use "unset XCURSOR_CORE" to enable them again later)
#if [ "x$XCURSOR_THEME" == "x" -a ! -d $HOME/.icons ]; then
#  export XCURSOR_CORE=true
#else
#  unset XCURSOR_CORE
#fi

# Prevent keyboard bouncing for Toshiba Notebooks
# Means, disable AccessX
test -r /etc/sysconfig/sax && source /etc/sysconfig/sax
if [ "x$KBD_BOUNCE_FIX" = "xyes" ]; then
        test -x /usr/X11R6/bin/xbounce && /usr/X11R6/bin/xbounce
fi

#
# Uncomment next line to activate asking for ssh passphrase
#
# ssh-add

#
# Add your own lines here...
#

xset s off

# day planer deamon
# pland &

#
# finally start the window manager
#
exec $WINDOWMANAGER

# call failsafe
exit 0
Wenn Fliegen hinter Fliegen fliegen, fliegen Fliegen Fliegen hinterher.

towo
Moderator
Moderator
Beiträge: 3702
Registriert: 15. Feb 2004, 16:42
Wohnort: Nimritz
Kontaktdaten:

Beitrag von towo » 8. Feb 2005, 19:40

Geht Dein Monitor in Standby, oder schaltet er einfach nur auf "Blank"?
Signatur nach Diktat spazieren gegangen

Bild

Benutzeravatar
ViktorII
Member
Member
Beiträge: 97
Registriert: 26. Aug 2004, 14:06

Beitrag von ViktorII » 8. Feb 2005, 22:32

In Standby scheint er nicht zu gehen. Das Lämpchen am Monitor bleibt grün und wird nicht gelb, so wie es geschieht wenn ich den Rechner ausschalte.
Wenn Fliegen hinter Fliegen fliegen, fliegen Fliegen Fliegen hinterher.

Benutzeravatar
rush hour
Member
Member
Beiträge: 119
Registriert: 19. Jul 2004, 20:39
Wohnort: Bei Ruth
Kontaktdaten:

Beitrag von rush hour » 9. Feb 2005, 00:42

ViktorII hat geschrieben:In Standby scheint er nicht zu gehen. Das Lämpchen am Monitor bleibt grün und wird nicht gelb, so wie es geschieht wenn ich den Rechner ausschalte.
Habe fast dasselbe Problem: erst wird der Bildschirmschoner aktiviert, nach einiger Zeit geht der Bildschirm auf Standby, Lämpchen grün, Bildschirm schwarz, nach ca. 1/2 Std. ist der Bildschirmschoner wieder aktiv... ;-)
openSuSE 42.1 (Leap)/64-bit
ATI HD7950 1 GB GDDR5
MSI Z87-G45
Intel i5-4670K@3400
Soundblaster X-Fi Titanium (PCIe)

alle Linux-Partitionen sind ext4 formatiert
Auf sda(1): Win10/64 Pro, openSuSE/Leap 42.1 auf sdb(2); UEFI-Modus aktiv (wegen Windows)

taki
Advanced Hacker
Advanced Hacker
Beiträge: 974
Registriert: 30. Apr 2004, 17:40
Wohnort: Berlin
Kontaktdaten:

Beitrag von taki » 9. Feb 2005, 09:25

Hallo Leute.
Da auch auf der reinen Konsole das Schwarzschalten eintritt, würde ich erst mal, wie Spunti schon weiter oben erwähnt hatte, im BIOS nachsehen, ob da eine Option zum Schwarzschalten des Monitors gesetzt ist.
Gruß,
Andreas

towo
Moderator
Moderator
Beiträge: 3702
Registriert: 15. Feb 2004, 16:42
Wohnort: Nimritz
Kontaktdaten:

Beitrag von towo » 9. Feb 2005, 16:39

taki hat geschrieben:Hallo Leute.
Da auch auf der reinen Konsole das Schwarzschalten eintritt, würde ich erst mal, wie Spunti schon weiter oben erwähnt hatte, im BIOS nachsehen, ob da eine Option zum Schwarzschalten des Monitors gesetzt ist.
Gruß,
Andreas
Der "Blank" auf der Konsole und der "Blank" auf dem X-Server sind 2 paar Schuhe.

Ich würde unter X zusätzlich noch ein

Code: Alles auswählen

xset s noblank
in die ~/.xinitrc reinschreiben.
Signatur nach Diktat spazieren gegangen

Bild

Dark Wolf
Hacker
Hacker
Beiträge: 466
Registriert: 19. Nov 2004, 22:48
Kontaktdaten:

Beitrag von Dark Wolf » 29. Mär 2005, 22:03

Das Proplem hatte ich auch! Ist ganz einfach! In SAX 2 Bildschirm - Porperies - Expert und Enable DPMS nicht anhaken. Dann schaltet er sich nicht aus.

MfG

Benutzeravatar
ViktorII
Member
Member
Beiträge: 97
Registriert: 26. Aug 2004, 14:06

Beitrag von ViktorII » 2. Apr 2005, 16:57

Jetzt hatte ich schon Hoffung bekommen. Aber zu meinem Entsetzen ist da kein Häckchen und der Monitor schaltet immer noch ab :cry:
Trotzdem danke.
Wenn Fliegen hinter Fliegen fliegen, fliegen Fliegen Fliegen hinterher.

Dark Wolf
Hacker
Hacker
Beiträge: 466
Registriert: 19. Nov 2004, 22:48
Kontaktdaten:

Beitrag von Dark Wolf » 2. Apr 2005, 19:22

Schade... :cry: :cry: :cry:

Benutzeravatar
ViktorII
Member
Member
Beiträge: 97
Registriert: 26. Aug 2004, 14:06

Beitrag von ViktorII » 20. Apr 2005, 15:54

Hab des Rätsels Lösung gefunden: unter Arbeitsfläche einrichten/Anzeige/Energiekontrolle das Häckchen bei 'Energiesparfunktion für Bildschirm einschalten' wegmachen. Peinlich dass ich das nicht früher gesehen habe :oops: :oops: :oops:
Wenn Fliegen hinter Fliegen fliegen, fliegen Fliegen Fliegen hinterher.

Gesperrt

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast