Versionskonflikt nach "apt upgrade" auf KDE 3.3.2

Alles rund um die möglichen Desktopumgebungen wie KDE, Gnome, XFCE usw. die es unter Linux gibt

Moderator: Moderatoren

Antworten
Benutzeravatar
blueshawk
Member
Member
Beiträge: 74
Registriert: 25. Mai 2004, 16:55
Wohnort: Pressbaum/NÖ
Kontaktdaten:

Versionskonflikt nach "apt upgrade" auf KDE 3.3.2

Beitrag von blueshawk » 16. Dez 2004, 18:27

Grüß euch.

Ich hab gestern mittels apt upgrade die KDE von 3.3.0 auf 3.3.2 upgedatet. Heute öffne ich den "Software hinzufügen/entfernen"-Dialog in YaST2 und ich bekomm kiloweise Konfliktmeldungen, dass ich jedes Programm, dass mit der KDE zu tun hat entweder Downgrade auf Version 3.3.0-... oder ein inkonsistentes System riskiere.

Kann mir da jemand Rat geben.

Hier die komplette Liste:

Code: Alles auswählen

#### YaST2 conflicts list - generated 2004-12-16 18:21:36 ####

Konflikt mit arts 1.3.0-11
    Benötigt von:
        arts-devel benötigt arts = 1.3.0-
    Konfliktlösung:
        ( ) arts nicht auf "Geschützt" setzen
        ( ) Alle 3 entsprechenden Pakete löschen
            kdelibs3-devel löschen
            kdebase3-devel löschen
            arts-devel löschen
        ( ) Diesen Konflikt ignorieren und ein inkonsistentes System riskieren
Konflikt mit arts-devel 1.3.0-11
    Kaputte Abhängigkeiten des installierten Pakets:
        arts-devel benötigt arts = 1.3.1-
    Konfliktlösung:
        ( ) Downgrade arts-devel-1.3.1-3 auf Version 1.3.0-11
        ( ) Diesen Konflikt ignorieren und ein inkonsistentes System riskieren
Konflikt mit kdeaccessibility3 3.3.0-5
    Konfliktlösung:
        ( ) Downgrade kdeaccessibility3-3.3.2-3 auf Version 3.3.0-5
        ( ) Diesen Konflikt ignorieren und ein inkonsistentes System riskieren
Konflikt mit kdeadmin3 3.3.0-5
    Konfliktlösung:
        ( ) Downgrade kdeadmin3-3.3.2-3 auf Version 3.3.0-5
        ( ) Diesen Konflikt ignorieren und ein inkonsistentes System riskieren
Konflikt mit kdeartwork3 3.3.0-7
    Konfliktlösung:
        ( ) Downgrade kdeartwork3-3.3.2-4 auf Version 3.3.0-7
        ( ) Diesen Konflikt ignorieren und ein inkonsistentes System riskieren
Konflikt mit kdebase3 3.3.0-29
    Benötigt von:
        kdebase3-devel benötigt kdebase3 = 3.3.0-
    Konfliktlösung:
        ( ) Downgrade kdebase3-3.3.2-7 auf Version 3.3.0-29
        ( ) Entsprechendes Paket löschen
            kdebase3-devel löschen
        ( ) Diesen Konflikt ignorieren und ein inkonsistentes System riskieren
Konflikt mit kdebase3-devel 3.3.0-29
    Konfliktlösung:
        ( ) Downgrade kdebase3-devel-3.3.2-7 auf Version 3.3.0-29
        ( ) Diesen Konflikt ignorieren und ein inkonsistentes System riskieren
Konflikt mit kdeedu3 3.3.0-6
    Konfliktlösung:
        ( ) Downgrade kdeedu3-3.3.2-3 auf Version 3.3.0-6
        ( ) Diesen Konflikt ignorieren und ein inkonsistentes System riskieren
Konflikt mit kdegames3 3.3.0-7
    Konfliktlösung:
        ( ) Downgrade kdegames3-3.3.2-3 auf Version 3.3.0-7
        ( ) Diesen Konflikt ignorieren und ein inkonsistentes System riskieren
Konflikt mit kdegraphics3 3.3.0-13
    Konfliktlösung:
        ( ) Downgrade kdegraphics3-3.3.2-3 auf Version 3.3.0-13
        ( ) Diesen Konflikt ignorieren und ein inkonsistentes System riskieren
Konflikt mit kdelibs3 3.3.0-34
    Benötigt von:
        kdelibs3-devel benötigt kdelibs3 = 3.3.0-
    Konfliktlösung:
        ( ) Downgrade kdelibs3-3.3.2-5 auf Version 3.3.0-34
        ( ) Alle 2 entsprechenden Pakete löschen
            kdebase3-devel löschen
            kdelibs3-devel löschen
        ( ) Diesen Konflikt ignorieren und ein inkonsistentes System riskieren
Konflikt mit kdelibs3-devel 3.3.0-34
    Konfliktlösung:
        ( ) Downgrade kdelibs3-devel-3.3.2-5 auf Version 3.3.0-34
        ( ) Diesen Konflikt ignorieren und ein inkonsistentes System riskieren
Konflikt mit kdemultimedia3 3.3.0-13
    Konfliktlösung:
        ( ) Downgrade kdemultimedia3-3.3.2-3 auf Version 3.3.0-13
        ( ) Diesen Konflikt ignorieren und ein inkonsistentes System riskieren
Konflikt mit kdenetwork3 3.3.0-35
    Konfliktlösung:
        ( ) Downgrade kdenetwork3-3.3.2-7 auf Version 3.3.0-35
        ( ) Diesen Konflikt ignorieren und ein inkonsistentes System riskieren
Konflikt mit kdepim3 3.3.0-32
    Konfliktlösung:
        ( ) Downgrade kdepim3-3.3.2-3 auf Version 3.3.0-32
        ( ) Diesen Konflikt ignorieren und ein inkonsistentes System riskieren
Konflikt mit kdetoys3 3.3.0-5
    Konfliktlösung:
        ( ) Downgrade kdetoys3-3.3.2-3 auf Version 3.3.0-5
        ( ) Diesen Konflikt ignorieren und ein inkonsistentes System riskieren
Konflikt mit kdeutils3 3.3.0-5
    Konfliktlösung:
        ( ) Downgrade kdeutils3-3.3.2-3 auf Version 3.3.0-5
        ( ) Diesen Konflikt ignorieren und ein inkonsistentes System riskieren

#### YaST2 conflicts list END ###

Danke
blueshawk

P.S. ich hab das selbst.kompilierte arts-RPM von misterhsp installiert und bekomme auch wieder sound
OS: SuSE Linux 10.0
Kernel: 2.6.13
KDE: 3.4.2
CPU: Intel Pentium D 820
RAM: 2x 1 GB Kingston HyperX
HDD: 2x 160 GB Maxtor
Display: 2x 19" LG Flatron

Werbung:
Gast

Re: Versionskonflikt nach "apt upgrade" auf KDE 3.

Beitrag von Gast » 16. Dez 2004, 18:50

blueshawk hat geschrieben: ( ) arts nicht auf "Geschützt" setzen
Die Konflikte beruhen arts, so wie ich das im Augenblicke sehe.
Nimm mal den Schutz von arts weg, als erste Lösung. Und das lass apt nochmal laufen.

Ein 'rpm -qa | grep arts' sollte folgendes ergeben, wenn nicht mit apt install ... korregieren.

Code: Alles auswählen

holgi@hsp1~$ rpm -qa | grep arts
arts-gmcop-1.3.2-3
arts-1.3.2-1
arts-devel-1.3.2-3
P.S. ich hab das selbst.kompilierte arts-RPM von misterhsp installiert und bekomme auch wieder sound
Habe das selber installiert und habe genau so mit apt upgedatet. Ich habe bei Yast keine Konflikte.

Gruß Holgi...

Benutzeravatar
blueshawk
Member
Member
Beiträge: 74
Registriert: 25. Mai 2004, 16:55
Wohnort: Pressbaum/NÖ
Kontaktdaten:

Beitrag von blueshawk » 16. Dez 2004, 18:56

bei mir kommt leider was ganz anderes beim befehl "rpm -qa | grep arts" heraus

Code: Alles auswählen

notebook:~ # rpm -qa | grep arts
arts-devel.1.3.1-3
arts-1.3.2-1
ich hab wie geschrieben schon dein arts-RPM eingespielt und es funktioniert auch wunderbar.

blueshawk
OS: SuSE Linux 10.0
Kernel: 2.6.13
KDE: 3.4.2
CPU: Intel Pentium D 820
RAM: 2x 1 GB Kingston HyperX
HDD: 2x 160 GB Maxtor
Display: 2x 19" LG Flatron

Gast

Beitrag von Gast » 16. Dez 2004, 19:02

Die Konflike kommen aber nicht von meinem RPM. Da ist bei dir noch woanders der Hund begraben.
arts-gmcop-1.3.2-3 fehlt bei dir zum Beispiel. Ob das umbedingt brauch, weiß ich nicht.

Benutzeravatar
blueshawk
Member
Member
Beiträge: 74
Registriert: 25. Mai 2004, 16:55
Wohnort: Pressbaum/NÖ
Kontaktdaten:

Beitrag von blueshawk » 16. Dez 2004, 19:09

auch apt spinnt jetzt auf einmal, ich bekom bei apt upgrade folgende Fehlermeldung:
notebook:~ # apt upgrade
Reading Package Lists... Done
Building Dependency Tree... Done
You might want to run `apt-get -f install' to correct these.
The following packages have unmet dependencies:
arts-devel: Depends: arts (= 1.3.1) but 1.3.2-1 is installed
E: Unmet dependencies. Try using -f.
notebook:~ #
kannst du da was daraus erkennen ?!

danke
blueshawk
OS: SuSE Linux 10.0
Kernel: 2.6.13
KDE: 3.4.2
CPU: Intel Pentium D 820
RAM: 2x 1 GB Kingston HyperX
HDD: 2x 160 GB Maxtor
Display: 2x 19" LG Flatron

Gast

Beitrag von Gast » 16. Dez 2004, 19:55

Dann lass noch mal ein

Code: Alles auswählen

apt-get update
laufen, um dein Cache aufzufrischen.

Dann tu das was apt dir da erzählt.

Code: Alles auswählen

apt-get -f install
Dann simuliere mal ein upgrade

Code: Alles auswählen

apt-get -s upgrade
Und wenn das ein konsistentes System ergibt, dann lass das simulieren mal weg und lass nochmal ein

Code: Alles auswählen

apt-get upgrade
laufen.
Ich hoffe dann ist bei dir wieder alles in Butter, bis auf den Sound !?

}-Tux-{
Moderator
Moderator
Beiträge: 696
Registriert: 12. Dez 2004, 19:54
Kontaktdaten:

Beitrag von }-Tux-{ » 17. Dez 2004, 13:24

blueshawk hat geschrieben:
notebook:~ # apt upgrade
Reading Package Lists... Done
Building Dependency Tree... Done
You might want to run `apt-get -f install' to correct these.
The following packages have unmet dependencies:
arts-devel: Depends: arts (= 1.3.1) but 1.3.2-1 is installed
E: Unmet dependencies. Try using -f.
notebook:~ #
du hast arts in der version 1.3.2-1 installiert aber die devel von 1.3.1. Deinstalliere sie und probiere es erneut. Es gab beim upgrade mit sicherheit noch andere zurückgehaltene pakete - kann das sein?

mfg }-Tux-{

Benutzeravatar
blueshawk
Member
Member
Beiträge: 74
Registriert: 25. Mai 2004, 16:55
Wohnort: Pressbaum/NÖ
Kontaktdaten:

Beitrag von blueshawk » 17. Dez 2004, 16:09

wie meinst du zurückgehalten, in bezug auf die arts oder allgemein ?! es steht nur immer dabei, dass gimp und kphone (bin mir nicht sicher ob's so heißt) zurückgehalten worden sind. warum das so ist, weiß ich nicht.

die arts-devel hatte ich schon mal deinstalliert und da hat es auch funktioniert, aber brauch ich die nicht für irgendwas ?!

danke blueshawk
OS: SuSE Linux 10.0
Kernel: 2.6.13
KDE: 3.4.2
CPU: Intel Pentium D 820
RAM: 2x 1 GB Kingston HyperX
HDD: 2x 160 GB Maxtor
Display: 2x 19" LG Flatron

}-Tux-{
Moderator
Moderator
Beiträge: 696
Registriert: 12. Dez 2004, 19:54
Kontaktdaten:

Beitrag von }-Tux-{ » 17. Dez 2004, 22:05

Die devel brauchst du nicht unbedingt, außer wenn du etwas kompilieren willst, was unbedingt die arts-devel benötigt.

mfg }-Tux-{

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast